thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
  Support the forum, shop at newmodeus.com
Our oldest longest advertiser of parts for ThinkPads
Goodbye Lorita, wherever you've gone..

If you've found this forum useful, please consider donating a dollar or two

It is currently Tue Sep 01, 2015 7:18 pm

All times are UTC-05:00




Post new topic  Reply to topic  [ 9 posts ] 
Author Message
PostPosted: Thu Dec 24, 2009 1:56 pm 
Offline
Senior Member
Senior Member

Joined: Fri Mar 13, 2009 2:47 am
Posts: 785
Location: New Alexandria, Pennsylvania
My ThinkPad R40 CMOS battery doesn't want to hold the time/date and have to keep entering bios to adjust it every time I attempt to turn it on. I replaced it with a brand new one and It still isn't holding.

_________________
IBM: 700C,701C,760XD,755CD,770Z,360Cs,600X,560X,560Z,570,310ED,380Z,390X, i1200,i1400,240,850,A22m,A22e,A30,G40, R31,R40,R50,R60,R61i,S30,T20,T23,T30,T40,T60,T61,X21,X30,X41,X41T,X60,X60T,Z60m,TNote,X3200 Server, NetVista M41 6792,M41 6790,X40 Aptiva 2170,ThinkCentre S50,S50 Ultra,A50p,M50,M51,M55e,WorkPad 20X,Z50, ThinkPad T420


Top
   
PostPosted: Thu Dec 24, 2009 2:15 pm 
Offline
Admin
Admin

Joined: Sun Jun 04, 2006 1:26 am
Posts: 9647
Location: San Jose, CA 95120 USA
Verify the following:

- measure the voltage of the battery at the pins on the (tiny) connector; it should be 3V DC or slightly above
- inspect the socket on the motherboard to see if it is loose or damaged
- insure that the connector is firmly pushed into the socket on the motherboard; it's keyed to only go in one way so you should not have to press all that hard

_________________
Ray Kawakami
X22 X24 X31 X41 X41T X60 X60s X61 X61s X200s X300 X301 Z60m Z61t Z61p 560 560Z 600 600E 600X T21 T22 T23 T41 T60p T410 T420 T520 R50 A21p A22p A31 A31p
NOTE: All links to PC-Doctor software hosted by me are dead. Files removed 8/28/12 by manufacturer's demand.


Top
   
PostPosted: Fri Dec 25, 2009 12:49 am 
Offline
Senior ThinkPadder
Senior ThinkPadder

Joined: Sun Feb 25, 2007 11:28 am
Posts: 14392
Location: Albrightsville, Pennsylvania
I don't recall whether that applies to R40, but I do remember that R3x ThinkPads used a different CMOS battery from all the others, probably because they were built by Acer, as was R40.

You may want to verify that you have the correct battery first...

_________________
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

Glorified typewriter collecting SSDI on The FlexView Farm: A31p

Abused daily: T50, T420i

Slaves of my wife & kids: R500F, R60F, T60


Top
   
PostPosted: Sat Feb 20, 2010 7:42 pm 
Offline

Joined: Sat Feb 20, 2010 5:22 pm
Posts: 2
Location: Mississauga, Canada
So did you solve this?

I have the exact problem on the same model machine.

I have replaced the battery.. opened the old one.. just to make sure I was using the same battery.. yep.. no issues.

SO do I have to pull the main board and do some reflow on the battery pins?

James


Top
   
PostPosted: Sat Feb 20, 2010 9:45 pm 
Offline
Senior Member
Senior Member

Joined: Fri Mar 13, 2009 2:47 am
Posts: 785
Location: New Alexandria, Pennsylvania
No I still have to keep my R40 connected to the AC Adapter at all times or I will have to keep entering bios and set time and date every time. Its anyoing. I even replaced the CMOS battery on it.

_________________
IBM: 700C,701C,760XD,755CD,770Z,360Cs,600X,560X,560Z,570,310ED,380Z,390X, i1200,i1400,240,850,A22m,A22e,A30,G40, R31,R40,R50,R60,R61i,S30,T20,T23,T30,T40,T60,T61,X21,X30,X41,X41T,X60,X60T,Z60m,TNote,X3200 Server, NetVista M41 6792,M41 6790,X40 Aptiva 2170,ThinkCentre S50,S50 Ultra,A50p,M50,M51,M55e,WorkPad 20X,Z50, ThinkPad T420


Top
   
PostPosted: Mon Feb 22, 2010 12:46 pm 
Offline

Joined: Sat Feb 20, 2010 5:22 pm
Posts: 2
Location: Mississauga, Canada
Yep, same with this machine, I know the battery is good, I have tested it, the old battery was not good.. I assume it must be a solder joint.. I really dont want to take the board out just for that..

Funny how even a good main battery does not keep the cmos eh? YOu need the AC to keep it. I would have thought that it would draw from the main.. if not hooked up to the ac.

wish there was some kind of circuit test that could be done to see if the pins are connected to what they need to be.

James


Top
   
PostPosted: Mon Aug 02, 2010 12:49 pm 
Offline
Senior Member
Senior Member

Joined: Fri Mar 13, 2009 2:47 am
Posts: 785
Location: New Alexandria, Pennsylvania
I got a brand new main Battery for my ThinkPad R40 and the Battery charge light is amber yellow for charging. The battery Maxi shows 0% and doesn't charge the battery. And the new CMOS battery don't work. Every time I have the laptop off the AC and plug it in. It brings up the Time and Date Error and have to enter the time and date everytime unless I keep it pluged into the AC at all times.

The Same problem goes for my ThinkPad G40 but the CMOS battery is fine. main battery don't charge but shows the amber charge light. and there both new batterys.

_________________
IBM: 700C,701C,760XD,755CD,770Z,360Cs,600X,560X,560Z,570,310ED,380Z,390X, i1200,i1400,240,850,A22m,A22e,A30,G40, R31,R40,R50,R60,R61i,S30,T20,T23,T30,T40,T60,T61,X21,X30,X41,X41T,X60,X60T,Z60m,TNote,X3200 Server, NetVista M41 6792,M41 6790,X40 Aptiva 2170,ThinkCentre S50,S50 Ultra,A50p,M50,M51,M55e,WorkPad 20X,Z50, ThinkPad T420


Top
   
PostPosted: Mon Aug 02, 2010 1:38 pm 
Offline
RBS10000
RBS10000

Joined: Mon Sep 18, 2006 5:17 am
Posts: 14693
Location: Mt. Cobb, PA USA
Are those batteries original IBM/Lenovo stock, or cheap Chinese knock-offs?

_________________
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Board Room for Mods and other Services


Top
   
PostPosted: Tue Aug 03, 2010 10:48 am 
Offline
Senior Member
Senior Member

Joined: Fri Mar 13, 2009 2:47 am
Posts: 785
Location: New Alexandria, Pennsylvania
My R40 is IBM and the G40 is I think an energizer

_________________
IBM: 700C,701C,760XD,755CD,770Z,360Cs,600X,560X,560Z,570,310ED,380Z,390X, i1200,i1400,240,850,A22m,A22e,A30,G40, R31,R40,R50,R60,R61i,S30,T20,T23,T30,T40,T60,T61,X21,X30,X41,X41T,X60,X60T,Z60m,TNote,X3200 Server, NetVista M41 6792,M41 6790,X40 Aptiva 2170,ThinkCentre S50,S50 Ultra,A50p,M50,M51,M55e,WorkPad 20X,Z50, ThinkPad T420


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 9 posts ] 

All times are UTC-05:00


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited