thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
System backups occur about 7:00 am EDT and last about 10 minutes. This will slow performance. RSS feeds have been added to the forum.
Donate if you wish to:
bill at thinkpads dot com

It is currently Fri Jul 25, 2014 6:02 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 13 posts ] 
Author Message
PostPosted: Thu Dec 31, 2009 11:28 am 
Offline
Sophomore Member

Joined: Thu May 06, 2004 11:29 am
Posts: 204
Location: Cancun, Mexico
6459-CTO. Clean install of Win 7 Ultimate, then all drivers downloaded via System Update 4. No errors showing in Device Manager. When I right-click on the Bluetooth icon in the Notification Area, nothing works. I cannot open Settings, I cannot open Show Bluetooth Devices, and Add a Device opens the correct Window, but nothing is discovered (telephone, earphone, etc.) and the computer is not discoverable by other devices.

Details:
Driver for ThinkPad Bluetooth with Enhanced Data Rate
Driver Provider Broadcom
Driver Date 5/9/2008
Driver Version 6.2.0.2600

Microsoft Bluetooth Enumerator
Driver Date: 6/21/2006
Driver Version 6.1.7600.16385

Any ideas would be welcome.

_________________
T520 W7 Pro 8 gig memory
A31/p XP Pro 1 gig memory
A30/p XP Pro 1 gig memory
TP600 Win 2K 288 mb memory
701C Win 98 Don't ask


Top
 Profile  
 
PostPosted: Thu Dec 31, 2009 12:04 pm 
Offline
Senior Member
Senior Member

Joined: Sun Dec 30, 2007 9:52 am
Posts: 616
Location: UK
Is the Bluetooth LED icon in the LCD bezel illuminated? - If not the Bluetooth radio may be off/disabled - check via Fn+F5 - (also check that the Hardware Wireless Radio Switch has been switched on too).

_________________
T60p: T7600, UXGA, ATi FireGL V5200, 3GB RAM, 80GB SSD, BCM94322MC, BDC2.1, DVD-RAM Multi-III, W7Pro, EM770 WWAN (Voice!)
T60F: (Integrated Intel GPU) - [Another T60 FrankenPad!...Different approach]


Last edited by Peak2Peak on Thu Dec 31, 2009 1:33 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Thu Dec 31, 2009 12:58 pm 
Offline
Sophomore Member

Joined: Thu May 06, 2004 11:29 am
Posts: 204
Location: Cancun, Mexico
Peak2Peak wrote:
Is the Bluetooth LED icon in the LCD bezel illuminated? - If not the Bluetooth radio may not be off/disabled - check via Fn+F5 - (also check that the Hardware Wireless Radio Switch has been switched on too).


Thanks for the reply. As I said, no problems are shown in Device Manager. The Bluetooth Enumerator and Radio would not be listed in Device Manager if the radio was off. You can try that yourself by turning the radio off via the Fn+F5 key combo.

The Bluetooth icon in the Notification Area is lit, and the green LED indicator next to the 802.11 LED indicator is lit. Fn+F5 is working, as I can switch the radio on and off, and the Bluetooth icon reflects that change. It's not a hardware problem.

_________________
T520 W7 Pro 8 gig memory
A31/p XP Pro 1 gig memory
A30/p XP Pro 1 gig memory
TP600 Win 2K 288 mb memory
701C Win 98 Don't ask


Top
 Profile  
 
PostPosted: Thu Dec 31, 2009 2:26 pm 
Offline
Sophomore Member

Joined: Fri Feb 10, 2006 2:44 pm
Posts: 164
Location: Lyons, CO
Get and install the Blutetooth package from Lenovo. I don't have the link but you should be able to search the site for:

7zbv12ww.exe

This is a full install and does not require a previous version to be installed. This also gives you access to the higher data rate and more services, e.g., audio.


Top
 Profile  
 
PostPosted: Thu Dec 31, 2009 3:24 pm 
Offline
Sophomore Member

Joined: Thu May 06, 2004 11:29 am
Posts: 204
Location: Cancun, Mexico
tpribors wrote:
Get and install the Blutetooth package from Lenovo. I don't have the link but you should be able to search the site for:

7zbv12ww.exe

This is a full install and does not require a previous version to be installed. This also gives you access to the higher data rate and more services, e.g., audio.


From the download page for 7zbv12ww.exe

Note: Support for the following systems has been dropped.
ThinkPad R60, R60e, R61, R61e, R61i
ThinkPad T60, T60p, T61, T61p
ThinkPad X60, X60s, X60 Tablet, X61, X61s, X61 Tablet
ThinkPad Z60m, Z60t, Z61e, Z61m, Z61p, Z61t
ThinkPad Reserve Edition
For those models listed above, please use the old version, 7vbv05ww (v6.1.0.5100), of this package.

7vbv05ww is the software currently on the machine. If I install 7zbv12ww, will it work, meaning that the text file is just saying Lenovo won't support it, or will it not work at all?

_________________
T520 W7 Pro 8 gig memory
A31/p XP Pro 1 gig memory
A30/p XP Pro 1 gig memory
TP600 Win 2K 288 mb memory
701C Win 98 Don't ask


Top
 Profile  
 
PostPosted: Thu Dec 31, 2009 9:24 pm 
Offline
Admin
Admin

Joined: Thu Sep 01, 2005 10:09 am
Posts: 3836
Location: Sydney, Australia - Best Address on Earth!
mixz1 wrote:
or will it not work at all?

That's it!

Cheers,

Bill B.


Top
 Profile  
 
PostPosted: Thu Dec 31, 2009 11:52 pm 
Offline
Sophomore Member

Joined: Fri Feb 10, 2006 2:44 pm
Posts: 164
Location: Lyons, CO
Well, the version I mentioned does work, but may not be supported. Since I hadn't installed the Bluetooth on the latest install I downloaded and installed the older version.

I discovered that since the driver included with windows is the 6.2* version the 6.1* version included with the package did not get selected. I updated the driver (by letting me choose which one from available drivers) and double clicked on the SECOND driver and it switched it. I deleted all pairings on both the Thinkpad and the Blackberry and paired it again (repaired sounds wrong). Things like file transfer didn't work with the Windows driver but after pairing again it found the audio services and now PIM based file transfers do work. The look and feel of this version isn't as integrated as the XP version - file transfers of unknown PIM types don't go to a default location but the rest of it does work. At least well enough for emergencies when I don't have a USB cable handy.


Top
 Profile  
 
PostPosted: Thu May 13, 2010 7:44 am 
Offline
moderator
moderator

Joined: Wed Mar 23, 2005 3:52 pm
Posts: 4010
Location: Wash., D.C.
FYI, with the current version of the Bluetooth package, support was added back for most of the machines that were previously removed. The current version is 7zbv15ww, below is more info (support for the Z61t/Z61m/Z61e/Z61p models is still missing, but the package works fine with those models, AFAICT);

Quote:
--------------------------------------------------------------------------------
Software Name Bluetooth with Enhanced Data Rate Software II

Support models ThinkPad R400
ThinkPad R500
ThinkPad T400, T400s, T410, T410i, T410s, T410si
ThinkPad T500, T510, T510i
ThinkPad W500, W510
ThinkPad W700, W700ds, W701, W701ds
ThinkPad X100e
ThinkPad X200, X200s, X200 Tablet
ThinkPad X201, X201i, X201s, X201 Tablet
ThinkPad X300(*1), X301

ThinkPad Edge 13", 14", 15"
ThinkPad Edge E30, E40, E50

ThinkPad L410, L412
ThinkPad L510, L512
ThinkPad SL300
ThinkPad SL400, SL400c, SL410
ThinkPad SL500, SL500c, SL510

ThinkPad R60(*1), R60e(*1), R61(*1), R61e(*1), R61i(*1)
ThinkPad T60(*1), T60p(*1), T61(*1), T61p(*1)
ThinkPad X60(*1), X60s(*1), X60 Tablet(*1)
ThinkPad X61(*1), X61s(*1), X61 Tablet(*1)
ThinkPad Reserve Edition(*1)

Operating Systems Microsoft Windows 7 32-bit, 64-bit
Microsoft Windows Vista 32-bit, 64-bit

Refer to marketing materials to find out what computer models
support which Operating Systems.

Version 6.2.1.1400

Support devices ThinkPad Bluetooth with Enhanced Data Rate
ThinkPad Bluetooth 2.1 with Enhanced Data Rate


*1: Does not work as Bluetooth 2.1 (Bluetooth 2.0 + Enhanced Data Rate, 3Mbps),
but works as Bluetooth 1.2 (1Mbps).

_________________
T510, i5-520m, NVidia, HD+, 8GB, 160GB Intel X25-M G2 SSD, Webcam, BT, FPR Home
T410s, i5-560m, Optimus, WXGA+, 8GB, 160GB Intel X18-M G2 SSD, Webcam, BT, FPR Travel
Edge 15 Core i3 | Edge 15 Athlon II X2| Edge 15 Phenom II X4


Top
 Profile  
 
PostPosted: Thu May 13, 2010 8:32 am 
Offline
Junior Member
Junior Member

Joined: Fri Dec 18, 2009 3:58 am
Posts: 429
Location: Honolulu, HI
What works for sure is if you install the Lenovo drivers then go to the Broadcom site and install their update. You can't install the latter until you do the former as it is a pure update. Some kind of licensing thing where you must have an OEM install first. Works like a charm with no issues. Now Lenovo may have subsequently updated the W7 drivers but I do all updates too and from the get go this method worked.

_________________
T61
Aloha!


Top
 Profile  
 
PostPosted: Thu May 13, 2010 2:42 pm 
Offline
Freshman Member

Joined: Mon Jun 29, 2009 2:05 pm
Posts: 97
Location: Warsaw, Poland
check my post here:

http://forum.thinkpads.com/viewtopic.php?f=29&t=86436
I have also 6459CTO . The latest package (7zbv12ww.exe) solved all issues and works smoothly. In my case, Broadcom drivers (package) did not even install due to some compatibility issues displayed...
Jacek

_________________
T61p 6459-CTO Win7 64-bit Prof.
T7500, 4GB RAM, NVIDIA Quadro FX 570M, 320GB HDD WD ScorpioBlack, 15.4 WUXGA, Creative Audigy2 ZS, IBM/Lenovo Advanced Mini Dock 2504, IBM SK-8815 Enhanced Ext. Keyboard, Hyundai V226W Ext. Monitor


Top
 Profile  
 
PostPosted: Sat Sep 10, 2011 3:18 am 
Offline
ThinkPadder
ThinkPadder

Joined: Sat Apr 22, 2006 4:26 pm
Posts: 1511
Location: TX, USA & Bombay, India
Whats the best Bluetooth Stack for X61T / T61 on Windows 7 x 64?

_________________
T61 8892-02U: 14.1"SXGA+/2.2C2D/4G/XP|Adv Mini Dock|30" Gateway XHD3000 WQXGA via Dual-link DVI
X61T 7767-96U: 12.1"SXGA+/1.6C2D/3G/Vista|Ultrabase
W510 4319-2PU: 15.6"FHD/i7-720QM/4G/Win7Pro64 (for dad)
T43 1875-DLU: 14.1"XGA/1.7PM-740/1G/XP (Old)


Top
 Profile  
 
PostPosted: Sat Oct 12, 2013 6:11 pm 
Offline

Joined: Sat Oct 12, 2013 5:56 pm
Posts: 1
Location: Moscow, Russia
I decided to write to this old topic since I faced exactly the same problem: "Open settings" doesn't open any settings and devices can't be found.
I tried to solve it about 2 days and now I know the root of the problem - you have other hidden Bluetooth driver in your system.
1. Start->type "cmd"-> Run as Administrator -> type "set devmgr_show_nonpresent_devices=1" -> Enter
2. type "start devmgmt.msc" -> Enter
3. View -> Show hidden devices
4. Remove old drivers (everything with "bluetooth" string).
5. PROFIT!!!


Top
 Profile  
 
PostPosted: Sun Oct 20, 2013 1:42 am 
Offline
ThinkPadder
ThinkPadder

Joined: Sat Apr 22, 2006 4:26 pm
Posts: 1511
Location: TX, USA & Bombay, India
stepler654 wrote:
I decided to write to this old topic since I faced exactly the same problem: "Open settings" doesn't open any settings and devices can't be found.
I tried to solve it about 2 days and now I know the root of the problem - you have other hidden Bluetooth driver in your system.
1. Start->type "cmd"-> Run as Administrator -> type "set devmgr_show_nonpresent_devices=1" -> Enter
2. type "start devmgmt.msc" -> Enter
3. View -> Show hidden devices
4. Remove old drivers (everything with "bluetooth" string).
5. PROFIT!!!


You are on Win7 x64?

So you removed the old hidden DRIVERs? What driver stack did you put on top?

I am still wondering what is the best "feature rich" stable BT Stack for our Thinkpads that supports All/most BT profiles that Windows used to not support by default.

_________________
T61 8892-02U: 14.1"SXGA+/2.2C2D/4G/XP|Adv Mini Dock|30" Gateway XHD3000 WQXGA via Dual-link DVI
X61T 7767-96U: 12.1"SXGA+/1.6C2D/3G/Vista|Ultrabase
W510 4319-2PU: 15.6"FHD/i7-720QM/4G/Win7Pro64 (for dad)
T43 1875-DLU: 14.1"XGA/1.7PM-740/1G/XP (Old)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group