Page 1 of 1

OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Sat Apr 09, 2016 9:42 pm
by micrex22
====How to install OS/2 Warp 4.52 on a T43/T43p====
#1 create the installation media (I used OS/2 Warp 4.52.086)
N.B. Do not use OS/2 Warp 4.0 as it won't be compatible on the T43 platform out of the box and will be too much of a headache. IBM never supported Warp 4.0 on the T43 anyways.
#3 format the drive, I would advise to formatting it completely with MHDD or Nuke 'n Boot
N.B. I am not sure the maximum size that it can address, I've been using 90 GB drives
N.B. Assuming there is a disk size limit, you can edit the .ISO and the 'virtual diskette' to incorporate Daniela Engert's replacement storage and ATAPI driver, but I've had no luck with getting it to work and it's not necessary for standard SATA drives on a T43.
#2 use the first BOOT CD-ROM and boot into it.
#3 The installation will (most likely) require to create an LVM partition and restart
#4 After the installation loads further, it will ask you to insert the client OS CD-ROM (disc #2), insert it and press enter
#5 continue through the prompts via enter, it will bring you to the LVM manager
#6 press ENTER with the CD-ROM partition highlighted (which will be the only thing in the list), you'll then have an option to create a new partition
#7 create a new partition as bootable
N.B. If you're using HPFS the maximum size is 64 GB, keep in mind the ancient CHKDSK can only do 16 GB. I would just do 16 GB HPFS and then JFS further partitions later.
N.B. If you choose FAT you'll be limited as to what you can install due to lack of long filename support; for instance you won't be able to install the latest WarpZilla package without HPFS/JFS which is a huge drawback.
#8 Change the drive letter to C:
#9 Select the C: volume and change it to INSTALLABLE from the list
N.B. OS/2 can only be installed to C:, any other drive letter it will simply ignore, so your installation volume MUST be C:.
#10 Create another partition if you wish, exist the logical volume manager (it will need to restart)
#11 rinse and repeat with inserting the boot disc and then the client OS disc
#12 you'll finally get to the setup screen, for video you MUST choose *Super VGA* (it's further DOWN in the list), DO NOT choose the default video selection that the installer thinks it wants. Else you'll get a trap error once the installer restarts.
#13 choose all of the options you want, you'll have to specify a password for your account etc.
#14 the installation should restart twice (it may ask to install an optional video utility, you can ignore it) and then you'll be greeted with your brand new IBM (R) OS/2 (TM) Warp (TM) desktop.

====How to install OS/2 Warp DRIVERS on a T43/T43p====
T43/p OS/2 Warp Driver Package Download:

#1 OS/2 TrackPoint driver
Run SMOUSE.EXE and follow the onscreen instructions. It will require a reboot and you will have to manually set the speed to 'lightest touch' and configure the middle button to scrolling. Despite the driver being older, OS/2 features multi-window scrolling (so your cursor simply needs to be over the window to scroll whichever window, and it also does horizontal scrolling). These features would only show up in the very recent drivers for Windows.
N.B. You will most likely have to disable the 'touchpad' portion of the UltraNav since SMOUSE is designed exclusively to work with the TrackPoint. If you don't the touchpad takes precedence over the TrackPoint.

#2 OS/2 SoundMax sound driver
Run INSTALL.CMD and follow the onscreen instructions. It will require a reboot.

#3 OS/2 SciTech SNAP video driver
Run snap-os2-3.1.8 and follow the onscreen instructions. Reboot. Configure the resolution to 1600x1200 @ 16M. Reboot. It should now be working correctly. You will have to run the REGISTER utility and enter in the following to unlock the product so it doesn't expire:
Name: Free OS/2 Code
Code: 9F98-2AB9-9195-CC
[this was a free code that SciTech released after OS/2 became a dead end]
N.B. Don't use the IBM-supplied ATI driver since it is less featureful and potentially more problematic to get working as it's in an unusual distribution package unlike the standard SciTech one.

#4 OS/2 Broadcom ethernet driver
Follow Broadcom's official instructions to add the driver files in MPTS Network Adapters and Protocol Services. Remove the following from OS/2's startup folder: Network Messaging. You will need to manually configure OS/2 to run TCP/IP on DHCP on eth0: TCP/IP Configuration found under system setup.

Below this point is outdated information as I attempted to figure out how to get it installed. There are a handful of errors and incorrect statements (natural byproduct of the troubleshooting process) so take it all with a grain of salt. I'm leaving the errors and troubleshooting steps just for general documentation and in case it may be useful to anyone.
I really want to get OS/2 Warp 4.52 going on one or both of my T43s. XP is an awful OS, Windows 7 can be pushed on a T43 but it's not optimal... so why not have something 'different' (plus Windows 10 is not my preference). IBM did support OS/2, at least marginally on the T43 as per the T43 announcement document (since 98 is listed as well it can be taken on an as-is basis):
Software requirements: The following operating systems
support the ThinkPad T43 computer:
• OS/2 Warp Convenience Package 2 V4.52 Refresh MCP2 Refresh: XR_4503 with FixPak XR_C004, or later, and XR_D003, or later
• OS/2 Warp Convenience Package 1 V4.51 MCP1: XR_4501 with FixPak XR_C004, or later, and XR_D003, or later
• OS/2 Warp Convenience Package 2 V4.52 MCP2: XR_4502 with FixPak XR_C004, or later, and XR_D003, or later

• Windows 98 Second Edition with USB 1.1 support
• Windows 2000 Professional (no service pack, SP1, SP2, SP3, SP4) with USB 2.0 support
• Windows XP Professional (no service pack, SP1, SP1a, SP2) with USB 2.0 support
• Windows XP Home (no service pack, SP1, SP1a, SP2) with USB 2.0 support
• Windows NT 4 (SP6a) with limited USB 1.1 support
For information about support for these operating systems, visit
Note: Previous versions of these operating systems are not supported.
The problem I run into (so far) is thus: the Warp 4.52 installer will start, if there are already partitions on the disk it'll claim it has to reconfigure LVM / on one T43 (the one with a SATA mod), it'll do it endlessly, on the IDE one it'll get past it on a reboot.

But the problem with both of them is that I can't install anything because it can't find the hard disks. I tried forcing the IDE T43 and just ended up with this:
d:\os2/image\disk_2\ format error
Both hard disks don't exceed 100 GB. Does OS/2 require some sort of device driver, or a fix for drives past a certain size in GB?

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Sat Apr 09, 2016 11:21 pm
by micrex22
After reading various webpages, OS/2 doesn't inherently like supporting large disk drives (which is coconuts since Windows 98 does; I wonder which bad blood at IBM had the lack of foresight to realize hard disks increase in space over time).
NOTE: only applies to 4.0 and NOT 4.52. 4.52 is rather competent with disk storage for its age.

Furthermore, to get said device drivers working with OS/2, you have no choice but to use diskettes, as per the readme itself from the OS/2 4.52 disc:
If your system cannot boot from the Warp 4 C-Pak2 Installation CD, or if you need to add device drivers before you begin installation, you must create installation diskettes to start your system and begin the installation process.
NOTE: It is possible to edit the CD-ROM files and not rely on the outdated diskette technique

So with a heavy sigh I pulled out three red JVC diskettes from one of my boxes, an external USB FDD, and got the DANIS506.ADD package. I'll have to check later if the diskettes can be created under something that isn't OS/2. If not I'll have to install OS/2 on a 300GL I have laying around with a 2 GB HDD. Then create the diskettes through that and finally get back to doing it on the T43.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Sun Apr 10, 2016 2:17 pm
by Dekks
Sadly i gave up trying to install OS/2 even on my T21, too many ifs and buts to make it work. So i just run it on a VM in my x201.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Sun Apr 10, 2016 6:22 pm
by micrex22
Dekks wrote:Sadly i gave up trying to install OS/2 even on my T21, too many ifs and buts to make it work. So i just run it on a VM in my x201.
One cannot simply just give up in the wake of Windows 10 and languishing T43s.

After reading from more (ancient) webpages, this is the best avenue for creating the three diskettes. It turns out much of the antiquated information makes you do extra foot work for no reason so we'll skip all of that. There'll be two CD-ROMs for OS/2 Wwarp 4.52, the boot CD-ROM (which is also the one you put in if you want to boot from disc instead of diskette) and the client CD-ROM.
Spoiler: it is possible to modify the CD-ROM boot image and 'cure' it of its antiquated drivers.

You'll want to put in the second 'client' CD-ROM and navigate to the following directory:
(assuming D:\ is your disc drive)

In this folder you'll see three .DSK files (antiquated docs will require you to use XDFCOPY, but just use WinImage since it handles that file format without issue). The three diskette images are as follows:
disk0.DSK - "installation diskette"
dsk1_cd.DSK - "diskette 1"
disk2.DSK - "diskette 2"
NOTE: when referring to 'diskette 1', never assume the installation diskette.

Copy the three images and write them to three diskettes using WinImage
Now it's time for a brief detour and relish in the problem of IDEDASD.EXE. Apparently IBM did update this (which is one of the problems for removeable storage and addressing higher capaities) in 2005. Which, is the same time the T43 came out. Maybe that was deliberate since IBM did offer T43s with OS/2 preinstalled, although I imagine it wasn't a popular option and stock preloads of that are long gone no doubt. Fortunately we're lucky IBM still had the IDEDASD.EXE package for download. Most sites will link the following: ... dedasd.exe
Which of course is long gone. BUT, it's still for download here:

(Really it would be awesome if someone could dump the entire directory, but public viewing is not enabled). IBM probably still has it up for scarce clients that still go to them for OS/2 support. Here's the note about it on eCS regarding IDEDASD.EXE: ... ws&id=1079

However the problem with eCS is that you need a registered license to log in and download the files... so I'm glad IBM kept their old link up. IBM's does seem to be an older 2003 release, but the updated 'OS2DASD.DMD' to fix 'traps' with removable media can be searched for later. At the end of the day if I like OS/2 Warp 4.52 enough, I can always buckle down and buy an eCS license.
In fact, IBM still has a bunch of files and fixes for Warp 4.5: ... /v4.5warp/
(I'm going to dump all of those files later for preservation).
Going back to IDEDASD.EXE, you'll need to fire up a Windows 9x or MS-DOS computer because it's in a 16-bit self-extracting module (I'm going to be uploading the uncompressed IDEDASD files so this step can be evaded in the future). Why'd they even do this? It's not like 100 KB was a big difference in 2003, they could have just used a standard .ZIP instead of using an MS-DOS self extracting module. 2003 was the year when I went from 98 to XP, **so let's say I was actually doing this back then**, I wouldn't have had an MS-DOS computer handy if it failed to extract under XP.
Sidenote: it was utter torture being stuck on XP with no MS-DOS support. The clown interface always bothered me, too.

So the DASD readme has some useful tidbits, including mentioning that SATA is supported (I've had trouble finding this information out since it's not really explicitly mentioned anywhere):
The IBM1S506.ADD driver automatically detects Intel Serial ATA and Parallel ATA controllers described in section 5.1 and enables the highest possible DMA/UDMA modes for all drives.
Well great, T43s with the SATA mod will have no problem then. Although OS/2 Warp 4.52 does detect something even under sata because it attemps to do the dumb LVM thing until you wipe the drive.

Taking a look at what OS/2 Voice had added in regards to IDEDASD.EXE: ... newsf4.htm
Follow the instructions in the IDEDASD.EXE's readme file and copy the patched drivers to disk 1. Missing from the instructions is that OS2CDROM.DMD from the IDEDASD fix needs to be copied to Disk 2. Be sure to copy this new driver to Disk 2.
The IDEDASD readme is already long enough as it is and they forgot to add that? I'm guessing some poor sap in 2003 probably copied the OS2CDROM.DMD to diskette 1 without knowing then (an earlier file of OS2CDROM.DMD is on diskette 2, so that's how you're supposed to know, presumably).

Okay, section 2.1, updating the installation diskettes:
If you are attempting to install Warp on a hard drive greater than 4.3GB, or your are attempting to install Warp Server for e-business on a hard drive greater than 30GB, then the Installation diskettes must be updated.
So here's what we want to copy to diskette 1 (note that's diskette 1 and not the installation diskette):
DASD32.DMD (and rename to OS2DASD.DMD before copying)

And the following needs to be copied to diskette 2:

And we're adding the following line to the top of CONFIG.SYS on diskette 1:
*insert obligatory 'don't copy that floppy' jingle*

Next we need to free up some space on diskette 1 to copy over the extra IDEDASD files. These are the files that I removed off of the diskette (563 KB in total):

And here's the following lines in CONFIG.SYS that need to be removed (you could comment them out but who cares):
(otherwise the COPYFROMFLOPPY=1 will presumably get upset that it can't copy).
But wait-- we're not done yet! The SNOOP list needs to be edited too, so that it doesn't look for the three .SNP files we removed. Comment out the corresponding SNPs under SCSI snoopers:
; SCSI Snoopers
;aha6360.snp <-- bing
;aic7870.snp <-- bang

AIC7770 isn't listed in the snoopers list, so... I guess we can shrug our shoulders since what's not there to begin with cannot be commented out. And if it could, it would break time in the world as we know it, causing a WARP to appear. Suddenly all PC clones would become IBM PCs with OS/2, and every monitor would be converted to 4:3. *gasp*

These are all for Adaptec SCSI cards, so if you need adaptec, copy some different drivers off that you won't need. Rinse and repeat for editing CONFIG.SYS and SNOOP.LST. Don't be a snoop and keep your snoopers in order.

Anyways, once that's done, THEN you can finally overwrite CONFIG.SYS and SNOOP.LST with your new files to diskette 1. Now connect le USB floppy diskette drive to your T43p w/ RBS SATA mod. Pop in the INSTALLATION DISKETTE (not diskette 1, or diskette 2, or OS/2 Warp 4.52 boot or OS/2 Warp 4.52 client). Then it'll ask you to put in diskette 1 and 2 afterwards.

And once you get to diskette 2, you'll get the following error message:
OS/2 is unable to operate your hard disk or diskette drive. The system is stopped. Correct the preceding error and restart the system
That's OS/2-babble for "we cannot find the appropriate driver from the diskette to install to this T43 hard disk". So even a stock IDEDASD.EXE didn't update it to the point where the T43's hard disk could be initiated. Therefore, time to try out the danis506.ADD instead.

So I'm changing basedev=ibm1s506.add to basedev=danis506.add, and I copied the following files to diskette 1:

And soon as it hits diskette 2 like last time, the same OS/2 is unable to operate your hard disk. Investigating the contents of diskette 1, there's CONFIG.X, I'm not sure if this needs to be changed, but I updated it to this as well: basedev=danis506.add
After some other searching yeah, we can make a few more changes.
I commented out 'ibm1s506.snp' on the snoop list (apparently this is only needed for ISA devices). Actually, Dani advises to get rid of all snoopers, so this is the before:
After de-snooping and editing CONFIG.X as well, giving it another shot. Same story.
The issue could be the following of reasons:
#1 soon as it hits diskette 2, the installer fails to recognize the USB floppy drive properly
#2 the danis506 package doesn't work / doesn't support T43s
#3 I'm not doing something correctly
Since IBM *did* have Warp 4.52 installed on T43s, it should theoretically be possible to use exclusive IBM packages for the process, but we'd need the 2005 IDEDASD along with the latest service packs etc.

I investigated the contents of the first boot CD-ROM, it apparently contains the diskette boot images and simply goes through the process like it would the diskette, although with more things obviously (also I've never had the "OS/2 is unable to operate your hard disk or diskette drive" issue with the CD-ROM). Therefore, it is possible to edit the CD-ROM image with the proper boot files and forgo diskettes entirely. So I'm going down this path since the CD-ROM doesn't catastrophically fail like the diskettes, it just doesn't find the hard disks which *should* be resolved with danis506.
Changes need to go to d:\bootimgs\disk_0_1.img on the first Warp 4.52 disc.
I'm using 4.52 .086 instead of .089 due to the fact that the .089 package on winworld reportedly has issues. However, .089 may have some needed changes for the T43 hardware so I am downloading that image to see if some of the files are updated.

I've also read that danis506.add needs to be in '\os2\boot', so I'm guessing the drive should be partitioned prior to OS/2 being installed. My suspicions were correct, .089 has updated boot images versus .086. So let's frankenstein the updated files over.

I took the following updated files from .089:
And as usual added the updated IBM IDEDASD files and the DANIS506 files / and the CDROM one for disk 2. But this time I also moved over the following, because why not, may as well update everything:

Then I use ImgBurn to create two updated disk_0_1 and disk_2 .img files. Then using WinRAR I extracted the Warp 4.52 .086 .ISO, injected the files, rebuilt the .ISO -- burning to a CD-ROM
*fingers crossed*
And we get the following:
Operating system not found
Okay, so it's clearly referring to the disk images we edited (disk_0_1.img and disk_2.img). I didn't use the 2.88 and 1.44 (which seem to be mirroring floppy sizes). So we need to get a bit more clever by using WinImage to assist.
Why did IBM use .IMG for some weird pseudo floppy diskette images anyways? You'll notice there are no .MD5 files as a result...

I had to delete the updated IBM1S506.ADD to make it fit on 2.88, but hopefully it's not calling that file anymore anyways since we removed it entirely from CONFIG.SYS/X and SNOOP.
So we create a 2.88 disk size and flip it to 'all files' so we can actually save in the .IMG extension, and its name of course is disk_0_1.img. Rinse and repeat for disk_2.img. Recompile the ISO, burn another disc, and give it another test.

Aaand, still no dice. The problem appears to be that the disc isn't bootable after the recreation. Because I am too lazy to investigate the cause (I have come across it before if you just extract the contents out of an .ISO and attempt to recreate it it's no longer bootable-- probably needs a special flag or signature), I'm downloading WinISO to edit the original ISO and re-inject the new files, but because we can't go over 500 MB, I'm deleting the Java118 folder. With that done, let's see if THIS works now. This will be CD-ROM #3, good thing I have a massive stash of writable CDs...

Shebam! Editing the .ISO worked and it's booting from the modified disk_0_1 and disk_2 images. However, one step forward, two steps backwards, I get the same error "OS/2 is unable to operate your hard disk or diskette drive". So this problem isn't being corrected by danis506 for some reason (the same error will happen with the IDEDASD package). I'm going to try editing disk_0_1 again and see if I can track down some more drivers and things to help it along.

Once that's done, it can all be edited back to the .ISO and nobody will have to deal with diskettes again.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Mon Apr 11, 2016 12:28 am
by micrex22
Alright this time I decided to try the 'warpdoctor' installation diskettes to see if I could get anywhere different with them. It was a pain extracting the data...

While I did get the same "OS/22 is unable to operate your hard disk or diskette drive.", I got a giant information dump at the top of it, which is as follows (I'm assuming this is because it lacks the danis506 which doesn't dump the info):
IBM Corp. Bus Master IDE Driver for OS/2 Version 4.68
Controller:0 Port:01F0 IRQ:000E Status:OK
Unit:0 Status:OK SMS Enabled LBA Enabled PI04 BIOS
Model:ST910021AS 4.06
Drive has valid Enhanced BIOS extentions Version 48
OS2:log phys BIOS:log BPB:log IDE:loh phys
C 12921 206742 1023 x 206742 16383 avail 195371568
blah blah blah blah
But what we're interested in is the fact it shows: used 100.00%.
So... firing up a 98 boot diskette and will try formatting the HDD. Of course this took awhile because I had to go through a bunch of diskettes before one finally took. But after formatting and making new partitions, it didn't change its mind on this matter.

Digging through some more I tried also adding Daniela's ATAPI filter:

No change. Since we're already on CD-ROM #4, I decided to stop endlessly making dud OS/2 Warp CDs for future generations to discover in 3080 in some landfill (oh, the poor souls to find those).

...back to using the original installer and its files (since it *does* get past diskette 2 and onto the next CD where I can get into the OS/2 Command Interpreter version 4.5). With the warpdoctor installation images, or whenever the danis506 files are used, it doesn't behave like this and I'm not sure why.

I found this forum post on os2world:
...but I press F3 to use the command line to copy the updated drivers (they're at X:\OS2\BOOT where X is the hard disk drive where the OS/2 was installed) and change the CONFIG.SYS FILE properly. Once the updated files where copied at OS2\BOOT I've reboot the system to finish the installation. ... D=914&SID=

I've seen many other places where X:\OS2\BOOT is referenced. But... that filepath does not exist on either the discs, the diskettes, or the disk itself since the installer can't get to a point to deploy partitions and format it. So X:\OS2\BOOT has been a fulcrum of frustration since nobody ever explains it.

Googling it someone mentions this:
We have to perform the following steps: In the directory X:\OS2\BOOT [where X is the boot drive letter] create the counterparts for the main CONFIG.SYS file.

We have to perform the following steps: In the directory X:\OS2\BOOT [where X is the boot drive letter] create the counterparts for the main CONFIG.SYS file. They must have the names of the form CONFIG.Z where Z is any letter or number except 1,2,3,M,V,X. For each of such files, add a line of the form...
Ah, so basically this is just a more roundabout way to reroute to a different CONFIG.SYS file essentially. Which isn't helpful at all because I've already made the necessary changes to CONFIG.SYS and the Dani packages are just not pulling through.

Back to seeing if the OS/2 Command Interpreter version 4.5 can do anything helpful while in the state of getting past the diskette 2 message... I may be able to start the OS/2 installation from this thing. Which means if I dump the OS/2 installer files to the hard disk, I could (theoretically) launch the OS/2 installer that way. However, this still doesn't solve the problem of the IDEDASD.EXE and DANI packages disallowing the installer to continue further (ironically, despite them supposedly solving the issue).

Okay, went back into the Logical Volume Management Tool, and to my surprise the disk is viewable now, and I can create partitions and stuff (this is without any of the extra IBM or Dani software). Huh. Even more curious is that it can 'see' all 90 GB.

So I create a 2048 MB volume and put the bootmanager on it along with making it startable / now the 'system has to be restarted'. Now let's see if it will allow anything to be deployed to it. Doesn't seem to be. Creating multiple 1024 partitions. I still get the following message:
OS/2 Warp requires a minimum volume size of 120 MB. Currently there are no available volumes of at least this size on your hard disk. If you are going to install al the features of OS/2 Warp, you need at least 450 MB of hard disk space.
So it appears the option 'Set the volume installable' is greyed out. I created another 1024 volume, set it to C: (changing the LVM volume to a different letter), was able to set it to installable / was forced to restart again.

OS/2 Warp Version 4 will be installed on:
Volume C
Now it's installing on HPFS (the installer sure is antiquated because it still is technically operates on a diskette system going through multiple diskette folders).

I downloaded a bunch of the T43p OS/2 drivers, hopefully they will work fine once the installation is finished. Well the installation was going so well until:
SYS1201: The device driver C:\OS2\BOOT\COM.SYS specified in the DEVICE statement on line 85 of the CONFIG.SYS file was not installed. Line 85 is ignored.
Press Enter to continue...
See? Now that folder is present (OS2\BOOT) since being installed.

After pressing enter I get this
DOSCALL1.DLL 0002:0000a499
P1=00000001 P2=00000004 P3=XXXXXXXX P4=XXXXXXXX
EAX=0003001a EBX=00000000 ECX=0003000e EDX=afe9000b
ESI=00a40f33 EDI=0000044a
DS=0053 DSACC=d0f3 DSLIM=3fffffff
ES=053 ESACC=d0f3 ESLIM=3ffffffff
FS=150b FSACC=00f3 FSLIM=00000030
GS=0000 GSACC=**** GSLIM=********
CS=EIP=005b:1c-2a42c CSACC=d0df CSLIM=3fffffff
SS:ESP=0053:00030002 SSACC=d0f3 SSLIM=3fffffff
EBP=000300025 FLG=00013212
Which I guess is what's known as a OS/2SOD. Well I'll have to do some research to figure out what's tripping the OS/2SOD, it could be the graphical mode I chose, there were a handful of generic options.

Will the ajkula T43p ever run OS/2 warp? Tune in next time! One nice thing about its boehydis IPS panel is it scales the resolutions perfectly so they're not blurred out. I quite like that.
To be continued...

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Wed Apr 13, 2016 2:01 am
by micrex22
I was about to start editing stuff on the volume, but since it was HPFS I basically shot myself in the foot. Finding anything that handles HPFS is not fun and extra work. So, reinstalling it with FAT and chose a different generic VGA option to see if that changes anything.

Soon as the installer restarts, we're greeted with the following:
SYS201: The device driver C:\OS2\BOOT\COM.SYS specified in the DEVICE statement on line 88 of the CONFIG.SYS file was not installed. Line 88 is ignored. Press Enter to continue...
SYS201: The device driver C:\OS2\BOOT\COM.SYS specified in the DEVICE statement on line 135 of the CONFIG.SYS file was not installed. Line 135 is ignored. Press Enter to continue...

A program in this session encountered a problem and cannot continue.
DOSCALL1.DLL 0003:00009fda
etc etc etc etc
So different lines in CONFIG.SYS are being complained about (The only changes are using a different generic video driver and FAT instead of HPFS).

The trap 0005 is a generic software problem, so it can be anything. Popped the T43 HDD into my T601 with the handy dandy ultrabay (tm) HDD caddy.
Line 135 -- doesn't exist --
So as we can see, OS/2 is pulling numbers from CONFIG.SYS that don't exist. This could be due to the DASD portion puking on itself. So, I did further troubleshooting on the DANI stuff. The Dani ATAPI filename was too long, so I fixed that / but unfortunately I get the same results *bwoh bwoh bowhhhh*

I decided to boot into the files on the disk again, and got an odd message in the slew of errors:
SYS1334: C:\DMISL\BIN\SLDB.DMI allocation error, size adjusted.
After playing with a few settings in the BIOS (such as turning off DEP and security features I'll never use), it didn't change anything. Time to put the OS/2 installation back into my T601 for some analysis. There seem to be a lot of CONFIG.SYS files after the deployment.

Going into C:\OS2\BOOT, we have all of the drivers that it attempts to load. I've decided to give the DANI files another shot, but this time renaming them to what the IBM files were called, in an event to hopefully have it actually operate. Daniella also named the ATAPI file too long (nine characters), so it's not good by default. But just using the equivalent IBM file names and we don't have to worry about that-- assuming the files aren't hardcoded to reference poor names. I also de-snooped a few things. After booting OS/2 with these we end up with even more errors and the same trap. So... it's most likely not a problem with the storage driver and controller.

Moving on, I decided to check Adam Alan Savage's OS/2 pages. Also another thing we can try is RAM reduction, right now the T43 is boosted to 2 GB of memory. Going over Alan's pages, it looks like he has the 2005 version of IBM1S506.ADD (version 10.161) that eCS mentioned that I linked to. Curiously enough it's not in any of the IDEDASD extraction packages, so maybe IBM released it not in one? (which would explain a lot).

So time to revert all of the original IBM files back and not use the Dani ones (which unfortunately still haven't helped thus far). And now I copied over the 2005 IBM1S506.ADD. Following Al's notes, I'm changing the following on CONFIG.X:
SWAPPATH=C:\ 2048 10000
I had to uncheck the file as read-only first, though.
Also adding the following to CONFIG.X and CONFIG.M (odd that it's not CONFIG.SYS anymore):
Apparently that's only useful if you're running the FP13+ kernel, which I'm not sure we are in this instance. We'll assume that we are.

Also removed 1 GB of RAM from the system. Now to test again, aaaaand same problem. At this point I'm convinced the issue could be related to the video drivers if I had to take a shot in the dark (simply because as mentioned prior, depending on which generic VGA driver we choose it changes what CONFIG.SYS errors are generated). Now it should be possible to inject the ATI mobility driver? But I want to try installing a newer version of OS/2 Warp for e-server and see if this changes anything. Just for the sake of troubleshooting.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Wed Apr 13, 2016 4:54 am
by micrex22
First setback, the IBM OS2 Warp 4.52 Server For e-Business ( package on WinWorld is corrupt for the client disc/OS (a problem with the virtual diskette 2 folder). It could easily be fixed via the prior method I used to modify the boot CD-ROMs, but I am too lazy, so we're using the OS disc from IBM OS2 Warp 4.52 Server For e-Business (

After installing the whole thing, we get the exact same problem as the regular desktop version of OS/2. Now, it's worth mentioning the installer loads a form of the OS/2 desktop and that does work, it's just once that's finished and the system reboots does the trap error occur. So if it really were a RAM issue, it shouldn't even be able to start that environment. I threw out all of my 512 MB DDR2 SODIMMs, so I'll have to dig for some to test it with 512 MB. But I guarantee this problem isn't related to the disk or memory. It's most likely something to do with drivers or the chipset.

UNfortunately I have no clue what fixes IBM would have applied to the image prior to deploying to a T43, and it's unlikely any T43s with a factory OS/2 image are still around.
The next avenues will be thus:
A) seeing if I can preinstall an OS/2 environment on a different system or VM, apply the appropriate hot fixes, drivers, etc. Attempt to inject that back onto the T43
B) seeing if the OS/2 T43 recovery media can be found anywhere

I did some more research and the folks on the Japanese OS/2 site do have T43s running OS/2 Warp 4 natively (but no explanation was given as to how this accomplished). Furthermore, after reading elsewhere Dr. Timothy Martin implies a fixpack is needed. So... I'll install it in a VM and apply fixpacks to see if that fixes the problems I am encountering:
Thus, OS/2, with the appropriate updates, should run just fine on the T43.
But to install the appropriate updates (I believe) you need to have OS/2 installed first? Unless you can install the fixpacks to an OS/2 installation without being booted into it (I'll have to review Al Savage's notes).

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Wed Apr 13, 2016 5:38 am
by RealBlackStuff
Following your OS/2 struggles with interest!

IBM supported these T43 under OS/2:
Notice they were all models with ATI graphics.

some OS/2 info: ... enDocument
OS/2 Museum wrote:It appears that the refreshed MCP2 (Merlin Convenience Pack 2) from early 2002 is a must, since previous versions reportedly fail on Pentium 4 systems with more than 512MB RAM.
More info: ... 3-and-t30/

Just in case: I still have some 512MB DDR2

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Wed Apr 13, 2016 6:49 am
by micrex22
RealBlackStuff wrote:Following your OS/2 struggles with interest!

IBM supported these T43 under OS/2:
Notice they were all models with ATI graphics.

some OS/2 info: ... enDocument
OS/2 Museum wrote:It appears that the refreshed MCP2 (Merlin Convenience Pack 2) from early 2002 is a must, since previous versions reportedly fail on Pentium 4 systems with more than 512MB RAM.
More info: ... 3-and-t30/

Just in case: I still have some 512MB DDR2
Unfortunately I believe MCP2 is what upgrades Warp 4.0 to 4.52 (looks like Michal was going from Warp 4.0 to 4.52). Warp Server 4.52.089 definitely has MCP2 in it (and I get the same issue). This also explains why you always see Warp 4.0 retail boxes but never any Warp 4.52 retail boxes. IBM probably had limited distributions of 4.52.

Here's a list of some fix packs for 4.52 while we're on the topic though: ... _Warp_4.52
PJ31319 <-- !trap fix
PJ30659 <-- !trap fix

There are some that fix some trap issues, so once I'm finishing dumping more of the IBM FTP, I'll see if I can do an offline installation of them. Since others have gotten T43s running OS/2 4.52, I'm very curious why more haven't brought up the issues of getting it to install. And I have two T43s I've been testing on this on as I've been going; one of them has the famous noisy fan though, so I should do that spindle mod to fix that.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Thu Apr 14, 2016 9:38 pm
by micrex22
I got OS/2 4.52.086 working in Virtual Box without any hassle whatsoever (I must say that I really like the GUI; you can shut down the system either by the icon in the taskbar, or just rightclick on the desktop and choose shutdown: Microsoft could learn a thing or two from OS/2 *cough* Windows 8 & 10 *cough*). It still spits out some config.sys errors (some of which are still on nonexistent lines, so that'll be the next thing to figure out later). It's most likely due to drivers.

Completely off topic but my T601 didn't have VT-x enabled by default so I had to turn that on. I forgot that you had to completely turn it off and not merely restarting it once enabled. I really ought to upgrade it to the middleton BIOS at some point with an IBM splashscreen.

First things first, I squeezed the lemons dry on finding out what everyone did regarding the following traps that I've been getting:
DOSCALL1.DLL 0003:00009fda
DOSCALL1.DLL 0002:0000a499


OS/2's logical volume manager can cause problems in certain configurations (and this is where some people use the Dani drivers: although in my case the Dani drivers make it impossible to install at all).

So I tried adding REM in all CONFIG.SYS files for: BASEDEV=OS2LVM.DMD
No dice, traps still occur.

Note: Knut Osmundse advises the following:
Knut Osmundse wrote: This is probably caused by an exception in the Ring-3 os2lvm.dmd (or the following driver?) init code. This trap is most likely in the exception handler code in DosCall1 and it is trying to process the init code exception.
Doesn't apply to what I'm troubleshooting, but someone else may find that helpful. At this point we've beaten the storage horse to death so it's nothing to do with ATAPI or LVM.


#2 512 MB RAM limit
I've already tested the latest kernel (4.52.089) which supports more than 512 MB of RAM and it still gets the trap errors. To be double-sure I configured my VM running 4.52.086 *past* 512 MB of RAM and it booted up fine without a problem. For all future readers (and anyone getting into OS/2): going past 512 MB of RAM is only a problem of OS/2 Warp 4.0 and not Warp 4.52.

The ancient troubleshooting guides rarely talk about 4.52 and clarify this, so they're often incorrect since the choice of kernel is 4.52.089: which is also what eCS / upcoming Blue Lion is based on. This includes Al Savage's old pages, WarpDoctor, OS/2Voice, and the multitude of pages that insist you use Daniela Engert's drivers (which were made BEFORE 4.52 came out).

I think this is one of the major contributing factors to OS/2 installation complexity: old sites that fail to state which version of OS/2 they're talking about. As per the previous posts, this caused extra confusion for myself since it was new to me. And then you have forgotten caveats like the 60 GB limit of HPFS. Nobody's going to think to check that since we're all used to allocating space without taking caution of address limitations.
Of course IBM put JFS in OS/2 later on, but it only works for non-bootable volumes: eCS fixed that so you can have the primary OS in JFS)


#3 Video Drivers
One user specified the wrong video drivers (ATI) which was causing the same trap error. So I went ahead and checked the VGA CONFIG.SYS configuration:

It was identical to that of the VM. But we're not done yet... I remember seeing it stated ATI beside generic VGA (which may be that it could detect it's an ATI card but didn't have a driver for it). As mentioned previously I have tried two different generic drivers, but this isn't conclusive enough since it's just the basic CONFIG.SYS.


#4 UNICODE.SYS & filesystem .IFS
Herb Rosenau advised the following:
Herbert Rosenau wrote: As I don't own MCP I can't check it, but look into config.sys on your HD just before you lets boot from:
REM non rem LINES first on top

REM NO parameter allowed on this lines!

I don't quite follow the rest of it (the broken English doesn't help), but it doesn't hurt to give this a shot. I'm guessing Herb means don't REM PROTSHELL=F:\OS2\PMSHELL.EXE / SET COMSPEC=F:\OS2\CMD.EXE.

I've also added REM on the following CONFIG.SYS located in the bootdisk folder:
ifs=hpfs.ifs /c:64

After giving that a shot it changed absolutely nothing, same trap.


#5 ALT + F2
Hitting Alt-F2 before the OS/2 Warp splashcreen shows each stage of what the system is loading (well that's handy).
Soon as we hit C:\OS2\BOOT\COM.SYS is when the line85 error appears.
Soon as we hit C:\IBMCOM\MACS\NULLNDIS.OS2 is when the line 132 error appears. Interesting, I didn't know that's where that was coming from. So VCOM.SYS (in C:\OS2\MDOS\VCOM.SYS) is loading up NULLNDIS.OS2 which causes that problem.
*it continues to go through a bunch.. aaaand*:

That's where it stalls and throws the trap error. So this is a lot more helpful (notice that we didn't hang at OS2LVM.DMD or any of the storage drivers).

Note: apparently having OS/2 launch with ALT + F2 is what one user reported solving the trap error. This is not the case for me; but that was on unrelated hardware and not a T43.


The chase is on.

So, if I'm not mistaken, PMSHELL.EXE is basically OS/2's graphical environment, which leads us back to my initial speculation of it being a video problem. What's going to fail to load the graphical environment? The video driver and/or video card. Furthermore, OS/2 does see the T43's ATI video and VirtualBox's video as being slightly different (it is aware of the difference). Therefore I think we're hot on the tail to the problem.

So there's a few options we can look into:
#1 seeing if offline driver installations can be done
#2 anaylzing the T43 OS/2 drivers in the VM before putting them on real hardware
#3 see about putting the driver in CONFIG.SYS

You can forget doing it by diskettes since the driver is 6 MB (it should be possible to do it by my .ISO method, though: that way the T43/T43p OS/2 installation .ISOs could be unofficially recreated).

After burning an .ISO with the T43 drivers to take a look at, the VM catastrophically combusted since I guess something about it it didn't like. No matter, I just extracted the OS/2 ATI driver from windows 7 instead. Check out what the readme says:
OS/2 ATI Driver Readme wrote: The ATI Special Edition of SciTech SNAP Graphics is a version that ATI has licensed on behalf of its OS/2 customers. The Special Edition contains a subset of the features in the full product, as outlined below:
. Resolutions of 640x480, 800x600, 1024x768, 1280x1024, 1400x1050, 1600x1200
. Support for all color depths
. Refresh rates from 60Hz to 85Hz
. DDC Plug and Play monitor detection
. Full hardware 2D acceleration
. Hardware cursor
*phew* 1600x1200 is supported, I didn't even consider that there was a possibility it wouldn't be (I don't believe the 1600x1200 T43p IPS displays were stock). Apparently this driver is a scitech universal driver that was licensed by ATI. Interesting. But as mentioned before, OS/2 did recognize that it was ATI in some form or fashion.
NOTE: the resolution limitation is exclusive to the package ATI licensed from SciTech. SciTech offered the full suite prior to their demise: it unlocks way more resolutions including wide screen for Z series ThinkPads.

Going through the readme some more, we've hit a bit of a sad, sad crossroad:
OS/2 ATI Driver Readme wrote: This is a list of the various graphics adapters that this Special Edition of SciTech SNAP Graphics supports. This list refers to the actual chips being used, not board-level implementations.
. ATI Radeon 7000/VE, Radeon 9000 Pro, Mobility Radeon, Mobility Radeon 7500
. ATI Mobility Radeon 9000, Mobility Radeon 9600/9700, Mobility Radeon X300
. ATI Mobility Radeon X600
. IBM VGA Compatible
The Mobility Radeon X300 is featured on the 14.1" T43s if I'm not mistaken (which means no 1600x1200 unless you mod in one of those SHARP displays I guess, if it can even be done which it probably can but would be hell). The T43p in question (and my second T43-non-p) has a FireGL V3200 which is not on this list. Does that mean it's not compatible? I'm not sure.
NOTE: the FireGL GPUs are supported and show themselves as X600 to the SciTech driver.

*snort* Lenovo still has IBM's old page on this here (it's nothing but comical seeing Lenovo's new gaudy logo obliviously peering over OS/2 documentation in a forgotten nested location):

But for future reference I'll paraphrase the driver page details here:
Video driver (ATI Mobility Radeon/PCI Express) for OS/2 - ThinkPad T43 (26xx)

This package provides the video display driver for OS/2 users.

The video driver enables or updates the video function of the following IBM systems:
- ThinkPad T43(Machine Type: 26xx)(*1)

- *1: Machine Type 18xx of ThinkPad T43 family are not supported. Please get the additional package for them, and install it, as well.
- This program is language independent and can be used with any language system.
That doesn't clear up anything actually. The 18xx family would be the intel T43s if I'm not mistaken, however 15.1" T43s do fall under 26xx. But of course the driver isn't titled FIRE GL, it's titled Mobility Radeon. Well I need to go sulk for a bit and see if this can still be turned around. Obviously we [can] get the video working especially considering eCS runs on newer video cards, but it's going to take some more work.

The remaining godsend out of this is that the rest of the ATI radeon mobility T43 boards still share major components with their FireGL cousins, so the audio and networking drivers should be fine.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Thu Apr 14, 2016 11:14 pm
by micrex22
Success. You have to specify the 'Super VGA' video option. I added some basic installation instructions to the first post for anyone else wanting to attempt this on their T43/T43p.

Now I have to sort out the drivers (puzzle #2). I'll be updating this thread as I go along with that (I will also be uploading many of these OS/2 files for safekeeping). Much of the OS/2 files and programs are scattered throughout random FTPs and soon-to-die websites so I'll be rescuing that and uploading it for continued public downloads.

I'll take some pictures of the T43p running OS/2 Warp later when I get my camera. Also I will be creating an OS/2 Warp T43 package: some of the OS/2 drivers are hidden on the dark corners of the internet.

The audio driver replicated by is actually corrupt: ... a708ww.exe

Lenovo still has it for download here:

I'm going to see if the lenovo-supplied one is also corrupted. It's the Audio Driver VI which everything from the T30 to the T43 share (so there may be a better audio driver if it's that universal).

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Fri Apr 15, 2016 5:43 am
by RealBlackStuff
ATI FireGL V3200 = ATI Mobility Radeon X600
T43 with Type 26xx = ATI graphics
T43 with Type 18xx = Intel graphics

All T4x mobos are identical in size/mounting and fit in both 14.1" and in 15" (with additional extender/interposer, similar to T60).

You could probably also install OS/2 on an R52 with ATI, and possibly a Z60 with ATI (which is basically a T43 with ex-factory SATA-mod).
But since Z60 are wide-screen, screen resolution might be a killer.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Sun Apr 17, 2016 12:27 am
by micrex22
===Video Driver Attempt #1===
I went ahead and ran the ATI-SciTech setup utility in this manner:
#1 copied the data to c:\SNAP
#2 opened up a windowed OS/2 Commandline
#3 navigated to C:\SNAP, ran the following command as per the readme: SETUP SDD C:
SciTech SNAP readme wrote: 3. At the OS/2 command prompt, type the following command to copy all the
required files to the OS/2 boot drive:
<SrcPath>SETUP xxx [<SrcPath>] [<BootDrive>] [/u]

Where: xxx is one of:
"SDD" - SciTech SNAP Display Driver GRADD
"GEN" - Generic VESA Unaccelerated GRADD
"VGA" - Video Graphics Array (VGA) GRADD
#4 the installer went through, I hit yes to replace whatever
#5 rebooted / the ATI-SciTech text appears, when the OS finally boots I just get a black screen (not even a kernel trap).
So I restarted, hit alt-f1, choose in the recovery options set to generic video / reboot
~ and I get the c0005 trap error like before
Rebooted, went back into alt-f1, chose the fourth option for the recovery installation console (which is bascially the first thing that you go through when installing OS/2): and as it figures, OS/2 stupidly reverted back to Generic VESA Unaccelerated & VGA GRADDs which causes the T43 to trap. So if you use the video reset option in the Alt-F1 menu, you'll be out of luck.
So before I set it back to super VGA, I'm trying Video Graphics Array (VGA) GRADD (which you have to re-insert the OS/2 installation disc since it's like a partial reinstall). Looks like it worked.
--okay so maybe messing with the video drivers before I have tested the other drivers isn't a great idea, so let's get back to that at some point later.

As a side note TCPSTART.CMD is now broken after the reinstallation to fix the video driver (so it prompts each and every time). The installer said it couldn't install the TCP/IP portion due to the file not exisitng... which is probably one of the most ridiculous errors I have ever seen! I have no clue how to fix this so I will probably be reinstalling OS/2 again on this laptop once I have the process for driver installations figured out to a perfected science.

===Audio Driver===
An update regarding the Audio Driver VI for OS/2, even the download from LENOVO.COM seems to be corrupted as per the following message in its entirety:
Self-extracting diskette image processor (OS/2), Version 1.03
Copyright 1995, Sydex, Inc. All Rights Reserved
The image file has been corrupted
It may be wanting a valid diskette drive on A:\ to self extract so I'll try that later when I have a chance. If not I'll have to email some OS/2 people I know if they have an un-corrupted version of the driver. It's probably corrupted because... who the heck installs OS/2 Warp on a T43? No one.
NOTE: the package requires MS-DOS and it self-extracts to A:\ which needs a real diskette drive, OS/2 cannot handle it properly, use DOS to extract the files then transfer them to OS/2.

===TrackPoint driver===
Okay, let's try SMOUSE.EXE (which is 'SingleMouse'), basically it's the enhanced TrackPoint package which has a combo driver for both the TrackPoint and mouse. I have no idea why IBM didn't put it on the T43 drivers page since it is entirely relevant for proper TrackPoint control... I had to dig it out from some random FTP. There were earlier iterations of the OS/2 TrackPoint driver but they're not integrated into the mouse setup. Furthermore, I have no idea how well they will work with the T3x/T4x series. I copied over the files to an extracted location, ran SMOUSE from an OS/2 command prompt, we get:
Installation program is ready to copy files to your system now. Continue with installation ? (Yes/No):
One odd quirk is that they spelled out 'Yes' and 'No' when the response it actually wants is Y or N. Windows/DOS programs usually have it written as: [Y]es/[N]o or Y/N. Whatever. It's installed and wants a reboot so let's go ahead and do that.

After the reboot I opened up the Mouse properties (found under System Setup), the sensitivity tab is available: setting it to the highest possible value for 'light touch' and it's scrolling like how it would with the Windows driver. And what's great is that OS/2 has an identical cursor control to Windows (all unix variants like Linux and OS X handle the cursor in a stupid way that I don't like; I can't explain it but the movement is different somehow). The only minor nitpick I have is that cursor speed on the X axis seems to be faster than it is on the Y axis (this was a common problem of things running in odd resolutions). The video driver could resolve this problem; but if it doesn't, it'll be a minor annoyance. Any operating system should have the X and Y axis moving at the same consistent speed.
NOTE: the cursor axis problem is indeed resolved with the SciTech video drivers.

Moving on to the 'scrolling' tab we have the following:
Choose Scrolling or Magnifying Glass Function:
[ ] Scrolling
[ ] Magnifying Glass
[x] Neither
Of course the stupid installer defaults to 'neither'. Hello IBM, nobody who uses the TrackPoint would set it to 'neither', just default it to Scrolling! Well the scrolling does work on OS/2 windows now, although it doesn't work right at all times sometimes sticking: requiring more pressure causing it to spike over real fast (it does support horizontal scrolling which the windows driver didn't for the longest time). I suppose the SMOUSE driver is the first thing you want to install so you don't have to suffer with awful TrackPoint control. The picture of the TrackPoint mechanism used is the old-style one with the middle scroll at the button instead of being in the centre: but it doesn't matter.

===Ethernet Driver===
Opened up the driver folders: NDIS2 > OS2 > and we have a bunch of files I have no clue what to do with: B57.NIF / B57.OS / PROTOCOLI.INI
The readme doesn't explain much on what to do with these sad files so I'll have to take a look at it later.
NOTE: Broadcom did supply an installation document which I've listed in the install instructions.

===Video Driver Attempt #2===
Going back to the video driver, the following drivers are installed by this package:
SciTech SNAP Display Driver GRADD (SDDGRADD) - SDD
Video Graphics Array GRADD (VGAGRADD) - VGA
Generic VESA Unaccelerated GRADD (GENGRADD) - GEN
And of course this notice
The following steps prepare your computer before installing the SciTech
SNAP Graphics/se GRADD device drivers:

1. Other applications, particularly WIN-OS/2 applications, should be closed
so that the device driver installation can replace the driver files
which an open application might have locked as read only.

2. If you previously installed an SVGA driver, return to VGA resolution
using the procedures in the section of this README entitled "Setting Your
Display to VGA Mode".
Since it was already in VGA (or at least on: Video Graphics Array (VGA) GRADD) I attempted it again.
Same problem, the T43 restarts and goes straight into a black screen. OS/2 is obviously operating since I can hit ctrl+alt+delete and restart the laptop just fine.

Okay, I may have to call it quits because there are some very serious problems I may or may not be able to overcome:
#1 the scitech video driver is NOT working properly with the FireGL (or at least at this point I can't get it to work)
#2 the audio package is corrupt since nobody, probably not even IBM themselves, bothered to verify the package worked or not
#3 the cursor movement (at least in 640x480) has the Y axis moving too slowly versus the faster X axis -- this persists even in emulators
#4 some of the drivers such as the ethernet are not straight forward, and getting warpzilla going is a hellish process
What I mean to say is, getting OS/2 Warp to function beyond a basic installation requires a blood sacrifice (installation difficulties are a façade until you get into the real issue of drivers and applications).

NOTE: all major challenges with the drivers have been overcome.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Sun Apr 17, 2016 8:38 am
by RealBlackStuff
Have you tried this on a "standard" T43 with ATI X300?

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Sun Apr 17, 2016 9:10 am
by ajkula66
RealBlackStuff wrote:Have you tried this on a "standard" T43 with ATI X300?
I honestly don't believe that it would make a difference. Windows and *nix drivers are the same for X300 and V3200, so if a functional driver for OS/2 existed in the first place it would likely work on both cards.

My own experiences with OS/2 on A31p have been quite abysmal and I've shelved that project for the time being, likely until this summer at the earliest.

It's a shame, though. There's a lot about OS/2 that could make it fun to use on older ThinkPads.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Sun Apr 17, 2016 3:15 pm
by micrex22
RealBlackStuff wrote:Have you tried this on a "standard" T43 with ATI X300?
I don't own a standard one anymore unfortunately (it suffered from a GPU issue where the screen would only come on 1 out of every 10th power on). Either the ATI IC had become defective or the BGA chip had bad joints. I tried baking in the oven (mmmmm the smell of baked IBM, way better than baked bread, right, right?? okay not really) but that didn't do a difference as expected because you need something that's hotter with better concentration. SOME of the solder did melt though.

Since I'm calmed down now (and have some music to blast away while I figure this stuff out), let's continue.

Back to the 'Alt-F1' recovery menu, I decided to try both F5 and F6 seeing if disabling or enabling the hardware detection did anything for the SNAP driver:
Select the system configuration file to be used, or enter the option corresponding to the archive desired.
ESC - Continue to boot process using \CONFIG.SYS without changes
F2 - Go to command line, (no files replaced, use original CONFIG.SYS)
F3 - Reset primary video to generic default display and reboot
F4 - Restart the system from the Maintenance Desktop (Selective Install)
F5 - Enable full hardware detection
F6 - Disable hardware detection
It did nothing unfortunately so back to F4 to resetting the graphics driver, and of course we're greeted yet again by the TCP program error:
An error occurred while starting a new session. (\IBMINST\NPCONFIG.EXE): SYS0002: The system canot find the file specified
This time I'm trying SETUP VGA C: (so VGA instead of SDD). If this doesn't work for expanding the options we have we'll try the generic SNAP driver which apparently SciTech left the latest version available for free since it was basically dead later on, as per the document here:
The SciTech SNAP Graphics product is no longer being actively developed, and at least portions of the source code will be made available under an open source license. There will no longer be any future versions of SNAP Graphics available from SciTech. If you would like to use the latest SciTech release on your computer, please use the following free registration code to unlock the product:
Name: Free OS/2 Code
Code: 9F98-2AB9-9195-CC
Please enter the code exactly as shown above (including case).
So a back story about this, SciTech was bought out by Alt Richmond and they're not releasing the source code: but Arcae Noae did license it from them. SciTech initially was planning on making it open source which is why this says 'will be made available under an open source license'.

After restarting with the VGA option we're still stuck with 640 x 480 x 16 (so this did absolutely nothing). Okay, I thought I'd compare what each readme states:

The ATI-licensed readme:
Copyright (C) 1991-2004 SciTech Software, Inc.
All rights reserved.
The actual SciTech product release:
SciTech SNAP Graphics for OS/2
Professional Edition
Copyright (C) 1991-2005 SciTech Software, Inc.
All rights reserved.
Judging by the fact this alternative one says 2005, I'm going to say it's newer. The readme is *considerably* smaller and basically says this for installing it:
To install the translated resources, simply run the setupnlv.cmd script, then reboot your computer when prompted.
At this point I really should get a USB stick configured so I can stop burning hoards of CD-ROMs, but I have no clue how to do that under any OS other than OS/2 since you have to deploy an LVM partition (and nobody could have been bothered to write up a nice guide for that). But, honestly I have no-one to blame but myself. I'll get to that later once we get the important things out of the way first.

Next up dealing with 'Audio Driver VI for OS/2', I downloaded the mirror from Kevin Bowling's mirror (my utmost respect to Kevin as he singlehandedly saved the IBM PCBBS files and had the foreknowledge to realize they wouldn't be there forever), but there's a chance it's also corrupted if the source was. Okay... since that is 99.9% the case, I scoured the archive and found: aftp1ios.exe:
IBM ThinkPad April 27, 2004
Audio Features VI for OS/2
Version 3.1.8 (1IA706WW)
The corrupted one in question is:
IBM ThinkPad January 24, 2005
Audio Driver VI for OS/2
Version 3.1.9 (1IA708WW)
The problem is... version 3.1.9 added support for the T43 so I have no clue if aftp1ios.exe will work, as per:
Released Version
Version 3.0.7a Initial release
Version 3.1.3 Support for T40
Version 3.1.7 Support for T41
Version 3.1.8 Support for T42
Version 3.1.9 Support for T43
UPDATE: I just ran the audio archive on my Windows 98 box and Version 3.1.9 is in fact extracting. So... I'll have the complete audio driver package shortly (I'll be leaving it permanently out of that extracted package so we'll have it without having to worry about silly things like this again).
I'm guessing OS/2 didn't handle the extractor properly or wanted a valid A:\ present (which is stupid since the error doesn't CORRESPOND to that!)

Furthermore, with these dumb self-extracting utilties (which I have never successfully gotten to extract to except A:\), after you extract the contents to a diskette and try to read them with an external USB FDD, *sometimes* depending on the tracks of the FDD, the external diskette drive can't read them. So (in my case) I just then copy them to a USB stick from the actual diskette on my Windows 98 computer. In other words... if you don't have a good 9x computer with USB or network file sharing support, dealing with old IBM self-extractors is a pain.

With that out of the way, let's check out the caveats with the OS/2 SoundMax driver (yeah, apparently this is a bonafide SoundMax OS/2 driver-- can't say I've ever seen anything like it before):
WinOS/2 Audio driver limitations
The Analog SoundMAX driver comes with a WinOS/2 audio driver that supports wave playback and recording in WinOS/2 sessions. It's not possible to use the audio device in OS/2 and WinOS/2 simultaneously. MMPM/2 or WinOS/2 will report errors if you try this.

Known problems
- Master volume adjustments have no effect unless an audio stream is active(OS/2 bug). Use Warpmix instead.
- Mixer changes in Digital Audio App don't show up in Warpmix. This is a limitation of the new mixer subsystem. Close and restart Warpmix to view the new settings.
- Wave volume in Warpmix will reset to full volume when re-opening warpmix. (OS/2 bug). There is no known workaround at this time.
Warpmix... is this where IBM got the name idea for 'Bluemix'?

Burning the drivers to a CD-ROM, let's see if the SciTech will work *now* and if the SoundMax OS/2 driver runs into any problems.

After running INSTALL.CMD, it did run and update CONFIG.SYS, but at the very last second there was a Application Execution Error. Not sure if that matters, rebooting.

Success, the audio works. Interesting 'space shuttle' sounds. Okay, SciTech... ran setupnlv.cmd (in the OS/2 CMD there were two "the system cannot find the file specified" messages. Not sure what it is missing and the readme doesn't expound on it further. Restarting. After the restart we're still stuck with 640 x 480 x 16 and nothing has changed.

I'll need some more time to figure this out (trying different SciTech packages and scouring pages and downloads).

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Mon Apr 18, 2016 2:48 am
by micrex22
Some of the SciTech packges I downloaded previously may have had some issues (there are so many FTPs that don't necessarily always have good files, and they're in a giant mess). I did manage to find snap-os2-3.1.8.exe (which I got from the wayback machine no thanks to any OS/2 FTPs, it actually had downloaded that from the old scitech website). Phew! Basically this whole adventure required getting files from every corner of the internet as nobody thought it meet to have a single location for common builds. In fact I'm surprised there isn't more talk about the T43 and corresponding guides on installing OS/2 on them. No google results showed up for me. Maybe with the advent of Windows 10 there will be more interest now...

I ran the SciTech SNAP installation package (and it doesn't require any command line but uses a rich installation package). Upon reboot they have their own little splash screen unlike the ATI licensed copy. Once OS/2 loads, I have a picture instead of a black screen!

All of these possible resolutions are at my disposal:
(there is also a widescreen option too; so something like the Z series could be used in their proper resolution after all)

The SciTech SNAP utility identifies the chip type as ATI Mobility Radeon X600, Ajkula66 was right. Rebooting to see if I successfully get 1600x1200 @ 16M; and we're in business.
OS/2 is pretty ahead of its time! It automatically scales up the DPI once a higher resolution is detected. Microsoft just introduced this feature in Windows 8...

I've verified that the free code SciTech provided before their demise works (this is entered in the 'register' commandline executable). So there's really no reason to use the watered-down ATI version anyways (even if it did work) since it's so much more crippled than the full edition. Furthermore, this release supports more GPUs (i.e. ajkula's A31p should be able to run its max resolution with this SciTech driver). Unfortunately I couldn't find an ADI OS/2 driver for the A31p :/
(but there may be some universal driver solution, as per when I was going over a bunch of utilities)

So yeah... all of the major drivers are working and accounted for. The only thing left is to set up the networking, but Broadcom does have their instructions there so it should be a piece of cake. I will be including snap-os2-3.1.8.exe in my T43 OS/2 package.

The other things I want to look into are what the best supported mini-PCI WLAN cards are. Getting PCMCIA to work would solely be a bonus (maybe it does work as-is, don't know).

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Mon Apr 18, 2016 4:40 am
by RealBlackStuff
If you forget about Google for a moment, try this: ... &ia=videos
It may bring links Google never heard of...

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Mon Apr 25, 2016 1:54 am
by micrex22
I've been finalizing a T43 system now with everything (had to spend a good few hours researching standard OS/2 software equivalents). Apparently installing the Broadcom network driver according to the instructions isn't as straightforward as one would hope. It has to do with the IBM MPTS Network Adapters and Protocol Services honestly. From hereon "MPTS Network Adapters and Protocol Services" will be known as "MPTSNAPS".

After I install the broadcom networking driver in MPTSNAPS (I left the 'no network adapter' in the list by accident after restarting) I was not able to access any websites with the ancient netscape navigator (haha). So back into the MPTSNAPS and I remove the 'no network adapter', I've already selected the appropriate IBM TCP/IP protocol (I like how IBM prefixed it with IBM TCP/IP, clearly IBM TCP/IP is superior to regular TCP/IP). Okkkkay, after the restart we're greeted with a bunch of NETBEUI complains now, presumably because NetBEUI was part of the 'no network adapter' that was added in during the initial installation.
NET3406: An error occurred while opening network device driver NET1 = NETBEUI$.
SYS1719: The file C:\IBMLAN\NETPROG\NETWKSTA.200 specified in the IFS statement on line 121 of the CONFIG.SYS file does not contain a valid device driver or file system driver. Line 121 is ignored.
Now here's where it gets interesting, the broadcom OS/2 ethernet driver is loaded at this point from CONFIG.SYS:
Broadcom Ethernet OS/2 NDIS2 Driver v9.12 (060822)
Copyright (C) 2002-2006 Broadcom Corporation. All rights reserved.
And then we wait for three minutes before this pops up:
Device - Broadcom NetXtreme Gigabit Ethernet, MAC Address - (censored), LineSpeed -1000 Mbps FullDuplex, IRQ - 11, BusNum - 2, DevNum - 0
Really??? Over THREE minutes? I thought CONFIG.SYS was frozen at first, and I'm sure anyone else would. This may be due to a network misconfiguration as MPTSNAPS does have an 'edit' for TCP/IP option. A better question though, is why this behaviour was started after I removed the 'no network adapter' at the top of the MPTSNAPS stack. Maybe it wasn't fully initializing at first as a result.

After that's done and booted back in I still cannot access anything on netscape, but I'm guessing it's working. While I'm at it I decided to attempt to REM the values in CONFIG.SYS that have incessantly alerting. So the following lines have been REMed, I won't bother mentioning which lines since the amount of lines in CONFIG.SYS constantly changes in OS/2, and usually it mentions lines that are out of bounds anyways:
Reboot and no issues (and no annoying barrage of 'Press Enter / Press Enter / Press Enter'). Launching an OS/2 CMD window, ran netstat -a, got the following:
multicast addrs:

Well, it's definitely not responding to DHCP on the network since it's producing a loopback address! So... I did some quick googling, you need to launch the TCP/IP Configuration Notebook (tcpcfg2). A notebook? OS/2 you're so weird sometimes. Okay it was set to a MANUAL blank address, I flipped lan0 to 'enabled' and to use DHCP. And like Windows 95, OS/2 needs to reboot every time you make a network change. Surprising this persisted up to Merlin CP2. Now to wait for 3 minutes for the Broadcom NIC (I will have to investigate why that is, could be just how the driver operates *sigh*).

Haha, and yep. It's working now. Pulling up looks hilarious being rendered in netscape 4.6 for OS/2. 90% of websites don't work except very basic ones, and even then they look weird because there's no CSS support, no transparent PNG support, etc. Unfortunately and cause netscape to catastrophically crash. But that's fine, we'll want to get WarpZilla set up soon.

I am getting this now:
Network Messaging: LNM0038: Either Network Messaging or the Netpopup service is already running. Network Messaging cannot be run if either of these are already running.
This makes sense since it's some IBM P2P networking program that always starts up (you'll see the OS/2 CMD always launching it on a fresh install). We don't want the Network Messaging program. The 'startup' folder is located on the main OS/2 System folder. Go in there and delete Network Messaging. I've confirmed this removes that message.

So now I want to deal with the excruciating delay with the Broadcom driver. Going back into MPTSNAPS editing the 'broadcom ethernet' object. Here are the settings I used:
PCI Bus Number: 2
PCI Device Number: 0
PCI Function Number: [left blank]
Line Speed: 100
Duplex Mode: FULL
Locally Administered Address: [left blank]
Turn Off Check Sum Fix: [left blank]
It wouldn't let me type 1000, only 100! So OS/2 Warp internally does not operate at gigabit. At least I haven't looked into how to get past this; if I had to guess some sort of editing has to be done to MPTSNAPS. Saved and rebooting... *fingers crossed*
No dice, I'll have to look into it further later.

Actually I take that back, after the Broadcom driver loaded after the three minute mark, it showed it operating in 10/100 with forced full duplex. So it was operating at gigabit afterall. MPTSNAPS just doesn't allow you to manually specify gigabit I guess?

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Wed May 18, 2016 7:27 am
by karotlopj
Dekks wrote:Sadly i gave up trying to install OS/2 even on my T21, too many ifs and buts to make it work. So i just run it on a VM in my x201.
I have an X21 with OS/2 running on it.

I'd suggest getting a PATA Thinkpad Ultra Bay like this:- ... d+ultrabay

Get OS/2 installed on another ThinkPad then simply swap the hard disk.

You will probably need to make a few changes to CONFIG.SYS but it should work - it did for me anyway.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Tue Aug 16, 2016 3:09 am
by lukee
Hello, I have got a T43p (with T43 ATI X300 GPU) and UXGA FlexView LCD. It is very late T43(p) with only Lenovo logos on it. Is it possible to run OS/2 on it? How fast is the OS/2 performing on this laptop? I have an experience with multiple Linux distributions on it but all seem to me a bit slow. Now I am trying Windows 2000 on it and it seems it works pretty well. Thanks.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Wed Aug 17, 2016 2:12 am
by lukee
I have been trying yesterday. The first CD disk created LVM and requested me to restart the ThinkPad. After the restart, installation program started and I went through few of the screens to the format window where I have selected 'Complete format' (sector by sector), but when the formatting started, HDD LED was not working. Today morning I checked the ThinkPad and there was still the message that the installation program is formatting the volume. It seems to me that the installation program somehow got stuck on that screen. In some previous screen, installation utility recognized HDD properly (80GB Fujitsu - original IBM FRU by the way) and offered HPFS file system for the volume. Should I select fast format instead during my next attempt?

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Wed Aug 17, 2016 3:09 pm
by lukee
I finally made the installation finished - the problem with formatting was caused by large partition (over 64GB) I used before. Now I am using 60GB partition and it formats well. After the first restart, I am getting the same error as micrex was getting (that one with COM.SYS), after hitting Enter, there is a screen of death with the same message:

Code: Select all

DOSCALL1.DLL 0002:0000a499
I need to say that I was careful during the installation and that I've selected 'Super VGA' from the list of available graphics modes in the installer.
Making REM before DEVICE command in CONFIG.SYS which deals with COM.SYS has no effect; I can't see the error now but the boot process still throws the DOSCALL1.DLL error.

Mobo: T43 with ATI X300
LCD: UXGA from T43p

Any idea?

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Sat Aug 20, 2016 11:32 pm
by micrex22
lukee wrote:I finally made the installation finished - the problem with formatting was caused by large partition (over 64GB) I used before. Now I am using 60GB partition and it formats well. After the first restart, I am getting the same error as micrex was getting (that one with COM.SYS), after hitting Enter, there is a screen of death with the same message:

Code: Select all

DOSCALL1.DLL 0002:0000a499
I need to say that I was careful during the installation and that I've selected 'Super VGA' from the list of available graphics modes in the installer.
Making REM before DEVICE command in CONFIG.SYS which deals with COM.SYS has no effect; I can't see the error now but the boot process still throws the DOSCALL1.DLL error.

Mobo: T43 with ATI X300
LCD: UXGA from T43p

Any idea?
If it's the same error I got it's related to the display driver. Try a different generic option and see what happens (you'll need to format and reinstall everything).

Also (as per the the notes), I would advise making the primary partition 16 GB and not 60 GB -- because you won't be able to run chkdsk. You can always make another larger JFS partition for data later.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Tue Mar 21, 2017 4:33 pm
by rgvgeek
micrex22, Thanks SOOO much for this write-up. It helped me so much trying to get OS/2 on my T43

One note, I was getting Trap errors 000D on boot up for both OS2 4.52 and eCS 1.2, finally figured out from another post elsewhere that it had to do with the APM drivers, I REM'd them out and no more problems there.

But did you ever solve the Broadcom Ethernet 3 minute delay issue? I have that now and it's annoying, but still glad it all works :)

Thanks Again!

:banana: :bow: :D

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Wed Mar 22, 2017 11:02 am
by micrex22
rgvgeek wrote:micrex22, Thanks SOOO much for this write-up. It helped me so much trying to get OS/2 on my T43

One note, I was getting Trap errors 000D on boot up for both OS2 4.52 and eCS 1.2, finally figured out from another post elsewhere that it had to do with the APM drivers, I REM'd them out and no more problems there.

But did you ever solve the Broadcom Ethernet 3 minute delay issue? I have that now and it's annoying, but still glad it all works :)

Thanks Again!

:banana: :bow: :D
I haven't had a chance to revisit the OS/2 Network management and Broadcom driver so I have not yet resolved that problem. The issue is that it's given too much time to do its resolution. Maybe it's possible to edit these values somewhere?

The guys at OS/2 World actually already knew all of the above before I spent a week figuring all of that out on my own (with the exception of a consolidated driver package for the T43, OS/2 files are scattered all over the place and it actually bothers me a bit)--they could even know about the Broadcom delay on start up or provide better troubleshooting. Feel free to make a post asking for assistance on it:

EDIT: It's worth noting that IBM would have shipped some 'CTO' T43s with OS/2 Warp and there must have been OS/2 T43 recovery media. But it's probably in the void of forgetfulness where all lost IBM software languishes.

Re: OS/2 Warp 4.52 on a ThinkPad T43 / T43p

Posted: Sat Oct 07, 2017 1:12 pm
by micrex22
There was something I just happened to see in the T43 manual:
If you are using OS/2 in the default format, HPFS, you cannot create a hibernation file. If you want to use hibernation mode, you will need to reinstall OS/2 with FAT format.
And it's true, I wasn't able to get the T43 to properly 'hibernate' with OS/2-HPFS. I'm guessing ArcaOS solves this issue--so... it may be a better option to go that route--unless you don't want to pay for an ArcaOS license.