Page 1 of 1

Browser not loading many websites with Windows 95 installed.

Posted: Fri May 24, 2019 7:38 pm
by MaxVCad
So I've successfully installed a wireless card into my 365XD that has Windows 95B on it. Some websites load but very few, and only the most basic. Like even these forums don't load, it just says 'Page Cannot Be Displayed.' I have IE 5.5 SP2 as well as some version of Netscape. I've also tried installing the most recent versions of Java I could for Win95. Are there any other extensions that I can install to make it load more stuff or am I pretty much out of luck?

Re: Browser not loading many websites with Windows 95 installed.

Posted: Fri May 24, 2019 8:02 pm
by theterminator93
What you're running into is the fact that the web has evolved well beyond the capabilities of IE5.5. The simplest explanation is probably that few modern web servers will accept the outdated security protocols IE5.5 supports (e.g. SSL 2.0), and simply terminate the connection when no cipher handshake can be negotiated.

With most sites migrating to HTTPS in lieu of HTTP, the list of sites that can be accessed is growing shorter by the day. Sites that do load, expect browsers that support the elaborate JavaScript and HTML5 those sites were written in. Also something that has left IE5.5 behind.

Re: Browser not loading many websites with Windows 95 installed.

Posted: Fri May 24, 2019 8:12 pm
by MaxVCad
That's pretty much what I figured. Too bad there's not a website that converts webpages into crappier versions of themselves. I'll browse and make some bookmarks of cool sites I can access, that'll make me happy enough. It's pretty cool using WiFi on a laptop from 1996.