T42p's battery won't charge while the laptop is turned off

T4x series specific matters only
Post Reply
Message
Author
maxcreations
Posts: 13
Joined: Sat Nov 18, 2017 3:33 am
Location: Yekaterinburg, Russia

T42p's battery won't charge while the laptop is turned off

#1 Post by maxcreations » Wed Nov 22, 2017 1:20 pm

I have T42p, working new battery, working charger.
The issue is that the laptop won't charge the battery while it's turned off and the battery indicator on the screen panel does not shows up.
But as soon as I turn on the laptop, battery start charging and indicator shows up.
Also the battery runs out in this laptop about 2hrs, and at this time this battery works about 4hrs in the R50e (with almost identical specs).
Does anybody knows how to fix that? Thanks!

maxcreations
Posts: 13
Joined: Sat Nov 18, 2017 3:33 am
Location: Yekaterinburg, Russia

Re: T42p's battery won't charge while the laptop is turned off

#2 Post by maxcreations » Thu Nov 30, 2017 4:00 pm

So, I dismounted the motherboard but can't locate any blown fuses or other fired up components.
Can anybody help to locate the problem?

Here are the images (about 2 Mb for each)
Back 1
Back 2
Back 3
Back 4
Front 1
Front 2
Last edited by maxcreations on Sun Dec 10, 2017 2:03 pm, edited 1 time in total.

Mac-Chatter
Posts: 9
Joined: Sat Feb 04, 2017 7:15 am
Location: Berlin, Germany

Re: T42p's battery won't charge while the laptop is turned off

#3 Post by Mac-Chatter » Sat Dec 02, 2017 5:51 am

This is only a guess:
I suspect your charger may not supply the proper voltage and a possible Thinkpad's Z-Diode blocks the current. Only if you feel safe for electrical testing you may measure the charger's output voltage on the plug you insert into the Laptop. Be carefull, that you do not short plus> and <minus> and irreversible damage your charger. Look at your charger"s imprint for the voltage output. If you try a different charger be aware that many of them deliver a 3V higher voltage (19V) then the IBM charger (16V).

For a workaround, try charging while suspend to RAM (stand-by) and give uspend to disk (hibernate) a try too.

Enjoy vintage computing, Mac-Chatter
Working Vintage Stuff:
ASUS X72N, WinVista-32; DualCore 2,5Ghz; RAM 6GB; SSD (SATA): 480GB; Gavotte RAMDISK: ~2,5GB (PAE) for pagefile
IBM T41; XP-Pro; RAM: 2GB; SSD (IDE=>SATA):128GB; RAMDISK: 760MB pagefile
Medion 95400; XP-Home; P-1,7GHz; RAM: 2GB; SSD (IDE): 64GB; RAMDISK: 760MB pagefile

RealBlackStuff
Admin
Admin
Posts: 18263
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: T42p's battery won't charge while the laptop is turned off

#4 Post by RealBlackStuff » Sat Dec 02, 2017 7:38 am

Cannot see any of those pictures!
(Using PaleMoon browser 27.6.1)
Google

403. That’s an error.

Your client does not have permission to get URL /gi9e1ZS-8QI76sqytDT14hEEEh1dhbyxMGq7JvgvZauodu36pEzCaZmOjMkrgPJpiFNO6ic-zvHOLFdq43u3=w1920-h873-rw from this server. (Client IP address: xx.xx.xx.xx)

Forbidden That’s all we know.
Happens regularly, that's why I advise to use the likes of Imgur instead.

Callahan
Posts: 44
Joined: Fri Nov 25, 2016 7:37 am
Location: Alexandria, PA

Re: T42p's battery won't charge while the laptop is turned off

#5 Post by Callahan » Sun Dec 10, 2017 5:44 am

RBS ... thanks for clearing things up about the images. I also see the same google message. I was wondering if it was my browser or still using WinXP.
...

maxcreations
Posts: 13
Joined: Sat Nov 18, 2017 3:33 am
Location: Yekaterinburg, Russia

Re: T42p's battery won't charge while the laptop is turned off

#6 Post by maxcreations » Sun Dec 10, 2017 2:02 pm

RealBlackStuff wrote:
Sat Dec 02, 2017 7:38 am
Cannot see any of those pictures!
(Using PaleMoon browser 27.6.1)
Google

403. That’s an error.

Your client does not have permission to get URL /gi9e1ZS-8QI76sqytDT14hEEEh1dhbyxMGq7JvgvZauodu36pEzCaZmOjMkrgPJpiFNO6ic-zvHOLFdq43u3=w1920-h873-rw from this server. (Client IP address: xx.xx.xx.xx)

Forbidden That’s all we know.
Happens regularly, that's why I advise to use the likes of Imgur instead.
Sorry, here is the new link with all images https://imgur.com/a/bBidl (also updated links at the top)
I have 2 original 16V 4.5A IBM chargers and both are fine.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T4x Series”

Who is online

Users browsing this forum: No registered users and 6 guests