Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T43 Success with mSATA to IDE Adapter

T4x series specific matters only
Post Reply
Message
Author
LowRes
Posts: 11
Joined: Mon Sep 02, 2019 2:01 pm
Location: Lindsay, ON Canada

T43 Success with mSATA to IDE Adapter

#1 Post by LowRes » Mon Sep 16, 2019 6:06 pm

Just wanted to share my experience tonight and maybe help somebody else out that may be searching if this actually works. IT DOES

System:
T43 (Type 2686DHU)
15” XGA 1024x768
Pentium M 740 1.73GHz
2GB DDR2 533MHz PC2-4200
Ati Mobility Radeon X300 64MB

Adapter:
kuroutoshikou KRHK-mSATA/19
mSATA SSD:
Kingston 120GB (ssdNOW Series)

I installed windows 7, all the drivers, and even testing out some games. All working good

I’ve done a lot of research and reading the sticky on the topic and people’s comments and it seems like there’s a lot of confusion if this actually works so hopefully this helps somebody.

It’s pretty snappy and fast, nothing like doing the SSD mod but I’m perfectly happy to use this instead of the old IDE drive.
T43p
15” UXGA FFS, Pentium M 760 2.0GHz, 2GB Ram, ATI FireGL V3200 128MB, mSATA SSD
T61p
15.4” WUXGA, Core 2 Duo 2.4GHz, 4GB Ram, Nvidia Quadro FX 570M 256MB, OCZ Vertex 4 SSD

H-Atkinson
Freshman Member
Posts: 83
Joined: Tue Sep 10, 2019 10:27 pm
Location: Glendale, CA

Re: T43 Success with mSATA to IDE Adapter

#2 Post by H-Atkinson » Tue Oct 29, 2019 3:55 pm

Had similar success with a 250 gb Samsung SSD and the same adapter on my T43p.
T43p, T61p, T601p, T601 (dead), T601, T60p (Prototype), X230, P53, T480 (In the process of rebuilding)

MiddlePath360
Posts: 3
Joined: Tue Feb 04, 2020 2:22 pm
Location: Redding, CA

Re: T43 Success with mSATA to IDE Adapter

#3 Post by MiddlePath360 » Tue Feb 04, 2020 3:16 pm

H-Atkinson,

I'm attempting a similar upgrade on my T43, but the system only sees 123GB of my Kingston 240GB mSATA drive. The BIOS was already updated to version 1.29.
Specs:
T43 15” Type 2687-D4U
• BIOS version 1.29 (1YET65WW)
• BIOS Date 2006-08-21
• Embedded Controller Version 1.06
• Pentium M 1.86GHz CPU
• RAM: 2GB
• FlexView 1400x1050 display
• OS: Windows XP Pro SP 3

HDD: Ableconn IIDE-MSAT mSATA SSD to 2.5-Inch IDE Adapter Converter (Marvell 88SA8052 chipset) with 150 MB/s capacity

Kingston UV500 mSATA 240GB SATA III 3D TLC SUV500MS/240G

Not sure what I'm missing. Any Suggestions?

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20803
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T43 Success with mSATA to IDE Adapter

#4 Post by RealBlackStuff » Wed Feb 05, 2020 2:51 am

Yeah, do a SATA-mod instead.
Remove the SATA-chip from the motherboard and replace the IDE- with a SATA-connector.
See the T43p SATA Guide thread at the top of this Forum.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

"Computers don't lie, but liars can compute." (Terry Hayes)

MiddlePath360
Posts: 3
Joined: Tue Feb 04, 2020 2:22 pm
Location: Redding, CA

Re: T43 Success with mSATA to IDE Adapter

#5 Post by MiddlePath360 » Thu Feb 06, 2020 4:32 pm

Suggestion appreciated, but I already have an IDE-to-mSATA adapter card and a Kingston mSATA card. It functions, I just can't get the T43 to fully read the 240GB capacity.
As others have reported their systems recognizing more than the 123GB space being seen by my T43, I want to explore all current options before going down a different storage path.

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20803
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T43 Success with mSATA to IDE Adapter

#6 Post by RealBlackStuff » Fri Feb 07, 2020 2:59 am

Install TTAV134 modded BIOS from here: viewtopic.php?t=126293
Maybe your machine needs the No-2010 error removed without showing it.

MiddlePath360
Posts: 3
Joined: Tue Feb 04, 2020 2:22 pm
Location: Redding, CA

Re: T43 Success with mSATA to IDE Adapter

#7 Post by MiddlePath360 » Sat Feb 08, 2020 5:44 pm

Thanks for the Link! I'll try the BIOS update to see if it fixes the issue and post my results. The T43 details page from the post you suggested is also an excellent source of T43 info.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T4x Series”

Who is online

Users browsing this forum: No registered users and 11 guests