Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Trouble With Updated Fingerprint Reader Software T43

T4x series specific matters only
Post Reply
Message
Author
Shay
Posts: 11
Joined: Sun Dec 04, 2005 2:40 pm

Trouble With Updated Fingerprint Reader Software T43

#1 Post by Shay » Mon Feb 13, 2006 10:41 pm

I updated the Fingerprint software today. Now I do not get the IBM login screen with the fingerprint. I get the normal XP login. This is a T43.

Thanks in advance.

christopher_wolf
Special Member
Posts: 5741
Joined: Sat Oct 08, 2005 1:24 pm
Location: UC Berkeley, California
Contact:

#2 Post by christopher_wolf » Tue Feb 14, 2006 12:25 am

Then you have to change the setting in the FPR ThinkVantage program to Logon with the FPR; ThinkVantage>Control Center>Settings

There, you can choose whether or not you want to logon using the Fingerprint Reader.

HTH :)
IBM ThinkPad T43 Model 2668-72U 14.1" SXGA+ 1GB |IBM 701c

~o/
I met someone who looks a lot like you.
She does the things you do.
But she is an IBM.
/~o ---ELO from "Yours Truly 2059"

davidspalding
ThinkPadder
ThinkPadder
Posts: 1593
Joined: Mon Nov 14, 2005 2:39 pm
Location: Durham, NC
Contact:

#3 Post by davidspalding » Tue Feb 14, 2006 9:18 am

Same happened to me. Go to Client Security, Advanced, and "Change how Windows logs on" or some such.

The update disables the fingerprint logon method.

It also re-enabled that goofy "Welcome Screen." I think that setting is in Control Panel - Users ... "How windows start up" or some such.
2668-75U T43, 2GB RAM, 2nd hand NMB kybd, Dock II, spare Mini-Dock, and spare Port Replicators. Wacom BT tablet. Ultrabay 2nd HDD.
2672-KBU X32, 1.5GB RAM, 7200 rpm TravelStar HDD.

Shay
Posts: 11
Joined: Sun Dec 04, 2005 2:40 pm

#4 Post by Shay » Tue Feb 14, 2006 2:13 pm

David. Thanks for the help, but the weird thing is client security is missing from thinkvantage menu. I will have to figure how to reinstall it.

Nick Y
Junior Member
Junior Member
Posts: 438
Joined: Tue Feb 14, 2006 2:17 pm
Location: Bucks., UK

Fingerprint Error Msg

#5 Post by Nick Y » Tue Feb 14, 2006 2:34 pm

I too have a problem with the new fingerprint s/w (version 5.4)

Since installing, I get an error message shortly after starting up (-approx 20 secs after using fingerprint reader on the T43/ 2668F5G to log-in.)

The message is as follows:
Title Bar: Fingerprint Software Error
Beneath title bar: Failed to initialize the application.
The system cannot find the path specified.

Code/ Description Box: (under 'details<<' button)
Failed to initialize the application.
3 The system cannot find the path specified.

Any suggestions? I tried uninstalling the ThinkVantage s/w (excl. the passport info) but no change in error msg.

Nick

TimWang
Sophomore Member
Posts: 133
Joined: Sat Jan 15, 2005 2:56 am
Location: Toronto, Ontario, Canada

#6 Post by TimWang » Tue Feb 14, 2006 6:04 pm

Hey, that happened to my T43 as well. I'll try to follow the steps that other people recommended and see if it fixes the problem.

TimWang
Sophomore Member
Posts: 133
Joined: Sat Jan 15, 2005 2:56 am
Location: Toronto, Ontario, Canada

#7 Post by TimWang » Tue Feb 14, 2006 6:23 pm

I tried following the instructions but for some reason I do no have Client Security or the ThinkVantage Control Center. Does this have anything to do with the fact that I am still using Access IBM?

Shay
Posts: 11
Joined: Sun Dec 04, 2005 2:40 pm

#8 Post by Shay » Wed Feb 15, 2006 10:20 am

I reinstalled rescue and recovery and now it works again. Weird that you have to use rescue and recovery to install client security solution. Thanks for you help.

TimWang
Sophomore Member
Posts: 133
Joined: Sat Jan 15, 2005 2:56 am
Location: Toronto, Ontario, Canada

#9 Post by TimWang » Wed Feb 15, 2006 7:09 pm

I tried fixing this problem and I still can't seem to get the fingerprint reader to be used during Start up or a resume from sleep mode. Does anyone have any other tips on how to fix this. Should I try to reinstall the fingerprint software?

anliume
Posts: 1
Joined: Fri Dec 23, 2005 2:54 am

#10 Post by anliume » Thu Feb 16, 2006 3:15 am

I have the same problem as Nick Y. I've uninstalled all fingerprint software and rebooted...and the error was gone. Then I reinstalled the fingerprint software and the problem is back. After login XP takes very long time to boot when Fingerprint is installed..maybe looking for the Fingerprint Software which is not found after upgrade generating the error-message mentioned above.

//A
T43, 2668-4NG

Nick Y
Junior Member
Junior Member
Posts: 438
Joined: Tue Feb 14, 2006 2:17 pm
Location: Bucks., UK

#11 Post by Nick Y » Thu Feb 16, 2006 4:13 am

anliume: At least I am not the only one with this problem!

I have looked at the event viewer and it flags an error loading ati2evxx.exe, which does not appear to be installed, although copies are in various backup areas on the laptop. I am currently checking to see where it goes (by trial error probably.)

What seems strange, to me anyway, is that the Fingerprint s/w should flag an error 'long' after successful log-in and when most other activities (e.g. network connection, various 'bug'scans have completed or are well underway. I would have thought that, by then, the fingerprint activities would have been finished with, but then I am only starting to understand the XP system...

Nick
IBM ThinkPad T43-2668-F5G,
T41p-2373-GEG & a T61-6466-9YG

Doltan
Freshman Member
Posts: 71
Joined: Tue Mar 22, 2005 9:35 am
Location: Singapore

#12 Post by Doltan » Thu Feb 16, 2006 11:03 am

I updated the Fingerprint software today. Now I do not get the IBM login screen with the fingerprint. I get the normal XP login. This is a T43.

Thanks in advance.

Had the same problem initially. Seems like it resets some setting back to default. I went into Control panel -> Other Control Panel Options -> IBM Embedded Security Subsystem -> Configure Application Support and Policy, and check "Enable Windows Logon Replacement" and select "Use Fingerprint Logon Only", then apply.

I think you also have to set it properly in the Control Center for the fingerprint software, but main thing to get it working for me was the above.
Laptop: 2668-H3A T43p

TimWang
Sophomore Member
Posts: 133
Joined: Sat Jan 15, 2005 2:56 am
Location: Toronto, Ontario, Canada

#13 Post by TimWang » Thu Feb 16, 2006 11:59 pm

I have a T43 but I do not see the IBM Embedded Security Subsystem in my control panel. Do I have to install something to get that?

Doltan
Freshman Member
Posts: 71
Joined: Tue Mar 22, 2005 9:35 am
Location: Singapore

#14 Post by Doltan » Fri Feb 17, 2006 1:10 pm

Yes, I had to install and activate it quite some time back. Was working fine all the while until the latest update. In fact, I though you would need this in order to use fingerprint to logon to windows?

Anyway, did you click on the "Other Control Panel Options" at the side to find it?
Laptop: 2668-H3A T43p

TimWang
Sophomore Member
Posts: 133
Joined: Sat Jan 15, 2005 2:56 am
Location: Toronto, Ontario, Canada

#15 Post by TimWang » Sat Feb 18, 2006 12:17 am

Yea, but I did not see the IBM Embedded Security Subsystem. I don't know why this happened... everything was fine before I updated.

davidspalding
ThinkPadder
ThinkPadder
Posts: 1593
Joined: Mon Nov 14, 2005 2:39 pm
Location: Durham, NC
Contact:

#16 Post by davidspalding » Sat Feb 18, 2006 8:52 am

Seems clear from everyone's experience that the update disables some security settings, but doesn't restore them consistently. Probably a safe path, as trying to update, possibly failing, and leaving the user potentially locked out of the system, requiring a service call, could be disastrous for the "easy update" initiative.

Word to the wise: check your security settings before updating CSS, Fingerprint Software, et al, before letting Software Installer rip-snort new updates for any security/login-related components.
2668-75U T43, 2GB RAM, 2nd hand NMB kybd, Dock II, spare Mini-Dock, and spare Port Replicators. Wacom BT tablet. Ultrabay 2nd HDD.
2672-KBU X32, 1.5GB RAM, 7200 rpm TravelStar HDD.

nishnt
Posts: 2
Joined: Wed Nov 30, 2005 3:16 pm

troubles with updated finger print reader - solution

#17 Post by nishnt » Sat Feb 18, 2006 3:06 pm

To fix the fingerprint update issue , follow these steps

1. Uninstall old fingerprint software and Client security software.
2. Download the new fingerprint software and install.
3. Download the new Client security software from the link below and install
( just google IBM client security if link doesnt work)

http://www-307.ibm.com/pc/support/site. ... MIGR-46391

The new fingerprint software seems to have some conflict with older versions of client Security software.

From what I have seen , the new finger print software seems to be much better at recognising fingerprints.

christopher_wolf
Special Member
Posts: 5741
Joined: Sat Oct 08, 2005 1:24 pm
Location: UC Berkeley, California
Contact:

Re: troubles with updated finger print reader - solution

#18 Post by christopher_wolf » Sat Feb 18, 2006 3:25 pm

nishnt wrote:To fix the fingerprint update issue , follow these steps

1. Uninstall old fingerprint software and Client security software.
2. Download the new fingerprint software and install.
3. Download the new Client security software from the link below and install
( just google IBM client security if link doesnt work)

http://www-307.ibm.com/pc/support/site. ... MIGR-46391

The new fingerprint software seems to have some conflict with older versions of client Security software.

From what I have seen , the new finger print software seems to be much better at recognising fingerprints.
It is indeed better than the previous one in terms of recognizing fingerprints; I have noticed that in certain areas, the fingerprint reader has slight difficulty picking up the fingerprint and analyzing it. I don't know what influences it, although I do know that the FPR uses fringe-capacitance.
IBM ThinkPad T43 Model 2668-72U 14.1" SXGA+ 1GB |IBM 701c

~o/
I met someone who looks a lot like you.
She does the things you do.
But she is an IBM.
/~o ---ELO from "Yours Truly 2059"

DIGITALgimpus
Senior Member
Senior Member
Posts: 774
Joined: Sat Aug 20, 2005 1:01 pm

#19 Post by DIGITALgimpus » Sat Feb 18, 2006 4:24 pm

Anyone else find the banner displayed on the top during login ugly in the new version?
T43 (2687-DUU) - 1.86GHz, 1.5GB RAM, 100GB 5400 (non IBM-firmware Hitachi 5k100) HD, Fingerprint Scanner, 802.11abg/Bluetooth, ATI x300

Nick Y
Junior Member
Junior Member
Posts: 438
Joined: Tue Feb 14, 2006 2:17 pm
Location: Bucks., UK

Re: troubles with updated finger print reader - solution

#20 Post by Nick Y » Sun Feb 19, 2006 3:42 pm

nishnt wrote:To fix the fingerprint update issue , follow these steps

1. Uninstall old fingerprint software and Client security software.
...
I tried the above steps, but I still get the error message shortly after starting up as mentioned earlier in this topic.

(I investigated ati2evxx.exe but it is no longer reqired, as far as I can see.)

Has anyone had the error message problem and been able to find both cause and cure?

Nick
IBM ThinkPad T43-2668-F5G,
T41p-2373-GEG & a T61-6466-9YG

alant
Posts: 20
Joined: Thu Apr 14, 2005 12:04 am
Location: Sydney, Australia

#21 Post by alant » Mon Feb 20, 2006 4:11 am

I have had problems with this release. After the update, my X41 fails to recognise my external IBM/Lenovo USB fingerprint-scanning keyboard attached to the X4 ultrabase. The scanner built into my X41 works fine, but not the one on the external keyboard.


I had to restore from backup to get things working again ...


Regards - Alan.
---

Alan.T

Nick Y
Junior Member
Junior Member
Posts: 438
Joined: Tue Feb 14, 2006 2:17 pm
Location: Bucks., UK

re:Fingerprint Error Msg

#22 Post by Nick Y » Mon Feb 20, 2006 5:40 pm

I think that I have solved problem using a process of elimination -i.e. disabling seemingly relevant start-up items one by one, in MSconfig, until I stopped getting the FingerPrint error message.

Problem seems to be to do with trying to start up ctlcntr.exe.

I looked for ctlcntr.exe" /startup in the registry and deleted the path entry listed below and all seems OK now.

"C:\Program Files\ThinkVantage Fingerprint Software\ctlcntr.exe" /startup

Nick
IBM ThinkPad T43-2668-F5G,
T41p-2373-GEG & a T61-6466-9YG

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T4x Series”

Who is online

Users browsing this forum: No registered users and 14 guests