Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T40 Battery Not Charging but runs fine from AC

T4x series specific matters only
Post Reply
Message
Author
billymm
Posts: 13
Joined: Tue Oct 16, 2007 9:05 pm
Location: Melbourne, Australia

T40 Battery Not Charging but runs fine from AC

#1 Post by billymm » Wed Oct 17, 2007 3:31 pm

Hi all,

I stumbled across this forum when looking for some technical data & I think its a great idea. I have a T40/p which up until a few days ago was working / charging fine.

The problem I am having is that as soon as I insert the battery into it the Battery Status light turns orange & stays on until I remove the battery. It does this without the AC connected.

So I connect the AC & look at the Battery Information in XP & both the current & wattage is 0 & the voltage is 12.39V. I have tested the battery & charger on another T40 & they are both working ok

I suspect the charging circuit on the motherboard. I saw a post that said the charge circuit was based around a MAX1901 low noise power supply controller. Is this correct?

Does any one have any schematics, componants I should be looking at on the m/b or any ideas on how I can fix this please? Id prefer to try & fix motherboard rather than replace.

Thanx in advance, billy
T40/P 2373 G1M

richk
Moderator
Moderator
Posts: 2913
Joined: Sun Jan 01, 2006 3:29 pm
Location: San Francisco, CA

#2 Post by richk » Sat Oct 20, 2007 11:23 am

Before you start "fixing" the motherboard, it's possible your charger isn't putting out enough current. 3.5 amp chargers act like that in T4x machines. They will work if the machine has 256MB memory, but won't charge with 2GB.

billymm
Posts: 13
Joined: Tue Oct 16, 2007 9:05 pm
Location: Melbourne, Australia

#3 Post by billymm » Tue Oct 23, 2007 2:53 am

I dont think its the charger as I have 3 of them & the charge light does the same with all. All 3 chargers charge up another T40 ok & the battery light (on the other unit) doesnt stay on when the AC adapter is not connected.

I originally had 2GB memory & have removed 1GB. This in my case hasnt changed not being able to charge.
T40/P 2373 G1M

billymm
Posts: 13
Joined: Tue Oct 16, 2007 9:05 pm
Location: Melbourne, Australia

#4 Post by billymm » Tue Oct 23, 2007 2:57 am

...any info on motherboard repair or motherboard troubleshooting would be greatly appreciated
T40/P 2373 G1M

billymm
Posts: 13
Joined: Tue Oct 16, 2007 9:05 pm
Location: Melbourne, Australia

#5 Post by billymm » Thu Apr 17, 2008 8:19 am

........after a lot of searching I found out that the charging circuit is basically a couple of mosfets (TPC8109 & TPC8014) & a battery charger ic (ADP3806)

I hope this helps others who are looking for this info

Does anyone know where to buy either of these components as I was told the adp3806 is out of manufacture...... any help appreciated in getting these parts
T40/P 2373 G1M

sjthinkpader
Senior ThinkPadder
Senior ThinkPadder
Posts: 2908
Joined: Tue Jan 22, 2008 8:29 pm
Location: San Jose, CA

#6 Post by sjthinkpader » Thu Apr 17, 2008 9:39 am

Check the fuse first, it is a white color large fuse located close to the battery connector.
T60p 2623-DDU/UXGA IPS/ATI V5200
T60 2623-DCU/SXGA+ IPS/ATI X1400
T43p 2668-H8U/UXGA IPS/ATI V3200
R50p 1832-NU1/UXGA IPS/ATI FireGL T2
X61t 7762-B6U dual touch IPS/64GB SSD
X32 2673-BU6/32GB SSD
755CDV 9545-GBK Transmissive Projection LCD

billymm
Posts: 13
Joined: Tue Oct 16, 2007 9:05 pm
Location: Melbourne, Australia

#7 Post by billymm » Thu Apr 17, 2008 10:02 am

Hi, thanx for the help.

Do you mean the 2 directly behind the battery connector (on the top of the pcb) or the one with "10" written on it on the underside of the pcb?
T40/P 2373 G1M

billymm
Posts: 13
Joined: Tue Oct 16, 2007 9:05 pm
Location: Melbourne, Australia

#8 Post by billymm » Thu Apr 17, 2008 10:09 am

I checked all 3 & they arent blown
T40/P 2373 G1M

lagoausente
Posts: 40
Joined: Thu Apr 03, 2008 1:27 pm
Location: CORUÑA, SPAIN

#9 Post by lagoausente » Fri Apr 18, 2008 6:28 am

billymm wrote:........after a lot of searching I found out that the charging circuit is basically a couple of mosfets (TPC8109 & TPC8014) & a battery charger ic (ADP3806)

I hope this helps others who are looking for this info

Does anyone know where to buy either of these components as I was told the adp3806 is out of manufacture...... any help appreciated in getting these parts
I have the same problem in a T40 mainboard. would be nice to find the equivalente to the obsolete ADP 3806. Anyone have experience?

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T4x Series”

Who is online

Users browsing this forum: Bing [Bot] and 12 guests