Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

GUIDE: Reflow GPU fix - 56K WARNING!!!

T4x series specific matters only
Post Reply
Message
Author
zakia
Posts: 3
Joined: Sat Feb 28, 2009 11:49 am
Location: Newark, DE

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#121 Post by zakia » Tue Mar 03, 2009 10:28 am

Phant0m`` wrote:Can someone please tell me what type of 1500 Heat gun they successfully used? And if it wasn't simple Dual speeds 1500 Heat Gun, could Dual speeds 1500 Heat Gun possibly could work?
I picked a $25 Wagner heat gun from Lowes, 1200W dual speed 750 and 1000F and it works fine.
Since I don't have infrared thermometer, I first tested with meat thermometer ( :mrgreen: ) and found that distance of around 15" - 18" will raise temp about 10-20C per minute, on high speed setting. Well I got impatience and sometime push it to 12" away. But at the end my T40 works again. :)

Phant0m``
Posts: 4
Joined: Wed Feb 25, 2009 5:01 pm
Location: Halifax, Nova Scotia, Canada

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#122 Post by Phant0m`` » Wed Mar 04, 2009 10:36 am

Thanks zakia, and It's nice to see you had success with it. :)

I noticed in the first post, one of the images with the heat gun shown, the gun off a little to one side of the motherboard and the nose tilted down a little towards the GPU chip. I'm assuming having the heat gun nose directly downwards over the GPU chip isn't very smart? The positioning shown in the picture, does the gun stay there at the fixed position for the whole entire process? or do I need to slowly have the gun cycling at the fixed distance away from the chip to spread the heat more evenly?

I also noticed the table used seemed to have many holes where the motherboard sits, I guess this indicates we shouldn't have the bottom of the motherboard collect any heat?

philosoraptor
Posts: 1
Joined: Thu Mar 05, 2009 1:34 pm
Location: New York, NY

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#123 Post by philosoraptor » Thu Mar 05, 2009 3:20 pm

Thanks for the guide. I successfully brought my notebook back to life and I was super excited when it worked. I couldnt stop grinning.

My concern is that the problem will recur. It seems the reason most gpu's fail on laptops is a tendency to overheat and crack the connections. If that is the case, it seems its only a matter of time before this happens again...

For those of you experienced with this type of issue, how have your laptops performed since the reflow? If the problem returns, is it possible to reflow the machine once more?

Also, it seems that even after reconnecting the MB battery, the computer time and date is reset every time i shut down. What could be the problem here?

Thanks again for this awesome guide.

Beaver
Sophomore Member
Posts: 171
Joined: Sat Oct 25, 2008 1:40 pm
Location: Brno, Czech Republic

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#124 Post by Beaver » Thu Mar 05, 2009 6:41 pm

Well, the good question is: Does the reball companies use the better solder than original one ? As there were some rumors about the fact that GPU/USB problems are caused by the fragile solder compliant with RoHS standards.
IBM T40p 2373-CG6, Pentium M 1.5 GHz, 1024 MB RAM, 40GB HDD, 14.1" TFT, ATI FireGL 9000 64 MB
Dual boot WinXP + Fedora Core 10

poshgeordie
ThinkPadder
ThinkPadder
Posts: 1101
Joined: Sat Feb 09, 2008 6:19 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#125 Post by poshgeordie » Fri Mar 06, 2009 7:41 am

philosoraptor wrote: Also, it seems that even after reconnecting the MB battery, the computer time and date is reset every time i shut down. What could be the problem here?
Congratulations on doing it - it IS hugely satisfying when you manage it yourself.

Re the date time reset every time, it sounds like your CMOS battery is flat.
Do you have access to a multimeter to check the battery volts?

In any case they're so cheap to replace that I'd suggest getting one via Marketplace or via eBay.

Nameless
Freshman Member
Posts: 93
Joined: Thu Sep 11, 2008 2:51 pm
Location: Austin, Texas

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#126 Post by Nameless » Fri Mar 06, 2009 1:45 pm

Seller "wibony" on ebay has cmos batteries (supposedly genuine Lenovo) for ~$5.

Fnurga
Posts: 12
Joined: Sat Feb 28, 2009 3:36 pm
Location: Umeå, Sweden

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#127 Post by Fnurga » Tue Mar 10, 2009 4:35 pm

I just tried to reflow my T42.
But i failed :(

I didn't have a thermometer, but instead i had a hot air gun where i could set the output temp digitally.

Maybe i set it to low?

Step one: 50c for 1 min 30 sec.
Step two: 150c for 1 min 30 sec.
Step Three: 260c for 4 min 30 sec.
Step four: 350c for 15 sec.
Step five: from 260 to 50 in 2 min.
Step six: let it cool down by itsel for 30 min.

Anyone have an idea what went wrong?

Regards

poshgeordie
ThinkPadder
ThinkPadder
Posts: 1101
Joined: Sat Feb 09, 2008 6:19 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#128 Post by poshgeordie » Tue Mar 10, 2009 7:09 pm

Fnurga wrote:I just tried to reflow my T42.
But i failed :(

I didn't have a thermometer, but instead i had a hot air gun where i could set the output temp digitally.

Maybe i set it to low?

Step one: 50c for 1 min 30 sec.
Step two: 150c for 1 min 30 sec.
Step Three: 260c for 4 min 30 sec.
Step four: 350c for 15 sec.
Step five: from 260 to 50 in 2 min.
Step six: let it cool down by itsel for 30 min.

Anyone have an idea what went wrong?

Regards
When you say it failed, if you press on the GPU do you still get a display on the screen? If you do then you've not used a high enough temperature. If this is the case I would recommend having it professionally reflowed.
If there's nothing at all then either the GPU's not resoldered or it's burnt out.

Using a hot air gun which measures the temperature of the air - yes the air coming out of it is that temperature, but the temperature of the air hitting the GPU will cause the chip to heat up much higher than that measured temperature.

When doing this work (I use infrared reflowing equipment) I monitor the temperature of the chip surface to make sure it reaches the correct temperature.

Unfortunately it's difficult to say if you used too much heat or not enough because there are too many variables.

Fnurga
Posts: 12
Joined: Sat Feb 28, 2009 3:36 pm
Location: Umeå, Sweden

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#129 Post by Fnurga » Wed Mar 11, 2009 6:34 am

poshgeordie wrote:
When you say it failed, if you press on the GPU do you still get a display on the screen? If you do then you've not used a high enough temperature. If this is the case I would recommend having it professionally reflowed.
If there's nothing at all then either the GPU's not resoldered or it's burnt out.

Using a hot air gun which measures the temperature of the air - yes the air coming out of it is that temperature, but the temperature of the air hitting the GPU will cause the chip to heat up much higher than that measured temperature.

When doing this work (I use infrared reflowing equipment) I monitor the temperature of the chip surface to make sure it reaches the correct temperature.

Unfortunately it's difficult to say if you used too much heat or not enough because there are too many variables.

No, i don't get display on the screen if i press on the GPU, and didn't get that before i tried to reflow either.

How come that the temp of the GPU will be higher than the air from the heat gun?

Can it be possible that i have another problems with the motherboard? I may have done this for no use?

Regards

poshgeordie
ThinkPadder
ThinkPadder
Posts: 1101
Joined: Sat Feb 09, 2008 6:19 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#130 Post by poshgeordie » Wed Mar 11, 2009 7:41 am

This is PG's first-law-of-applying-heat-onto-a-GPU-using-a-heat-gun (!):

At any point in time, heat applied to the GPU will dissipate (heat will be lost) causing a lowering of the temperature.

However because you are continuing to apply heat, the rate of heat loss will be less than the heat being applied by the hot air gun causing an overall rise in heat.

Reading some of the hot air gun how to's, they suggest using a temperature probe to measure the surface temperature of the GPU so that it rises to the correct temperature but does not exceed it. The measurements need to be made when hot air is not being blown onto the GPU.

Going back to your original problem; what happened to make you think you have a GPU problem?

Does the TP work on an external monitor?

Are you sure you do not have a faulty display, or video cable - check both ends are connected properly.

If you have a test meter go to the T4x Fuse Information document in my signature and check the fuses.

Fnurga
Posts: 12
Joined: Sat Feb 28, 2009 3:36 pm
Location: Umeå, Sweden

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#131 Post by Fnurga » Wed Mar 11, 2009 12:29 pm

poshgeordie wrote:This is PG's first-law-of-applying-heat-onto-a-GPU-using-a-heat-gun (!):

At any point in time, heat applied to the GPU will dissipate (heat will be lost) causing a lowering of the temperature.

However because you are continuing to apply heat, the rate of heat loss will be less than the heat being applied by the hot air gun causing an overall rise in heat.

Reading some of the hot air gun how to's, they suggest using a temperature probe to measure the surface temperature of the GPU so that it rises to the correct temperature but does not exceed it. The measurements need to be made when hot air is not being blown onto the GPU.

Going back to your original problem; what happened to make you think you have a GPU problem?

Does the TP work on an external monitor?

Are you sure you do not have a faulty display, or video cable - check both ends are connected properly.

If you have a test meter go to the T4x Fuse Information document in my signature and check the fuses.
No, an external monitor doesn'n work either.

I am pretty sure that the video cable isn't faulty.


If a T4x have the gpu-problem, does it beep in the start? Mine is completly silent exept for the cpu fan (hard drive is not in the computer)

Oh, fuses. Why didn't i think about that! Thats the next thing im going to check :)

Edit: The link for fuses don't work. "The page cannot be found" :(

Regards

poshgeordie
ThinkPadder
ThinkPadder
Posts: 1101
Joined: Sat Feb 09, 2008 6:19 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#132 Post by poshgeordie » Wed Mar 11, 2009 12:52 pm

Beeps - sometimes you get four (I think) beeps saying there's a system board fault.

Sound's stupid but is there a beep when a TP normally starts??!! Feel stupid asking and can't be bothered to shut down and restart!!

Link to fuses in my sig is sorted - thanks for mentioning it BTW.

Also can be reached here

Fnurga
Posts: 12
Joined: Sat Feb 28, 2009 3:36 pm
Location: Umeå, Sweden

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#133 Post by Fnurga » Wed Mar 11, 2009 1:09 pm

poshgeordie wrote:Beeps - sometimes you get four (I think) beeps saying there's a system board fault.

Sound's stupid but is there a beep when a TP normally starts??!! Feel stupid asking and can't be bothered to shut down and restart!!

Link to fuses in my sig is sorted - thanks for mentioning it BTW.

Also can be reached here

Strange that mine isn't beeping at all then. :?

Im going to check the fuses within a couple of hours, and will report back here later :)
It would be a real pity if i burnt the gpu for a broken fuse :/

Regards

Fnurga
Posts: 12
Joined: Sat Feb 28, 2009 3:36 pm
Location: Umeå, Sweden

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#134 Post by Fnurga » Wed Mar 11, 2009 2:40 pm

Ok, thanks for the Fuse guide PG!

Unfortunatly the fuses don't seem to be the problem for me.

Anything i can do exept get a new motherboard or try to reflow it once again?

Regards

poshgeordie
ThinkPadder
ThinkPadder
Posts: 1101
Joined: Sat Feb 09, 2008 6:19 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#135 Post by poshgeordie » Wed Mar 11, 2009 3:03 pm

You have nothing to lose by trying again.

I haven't mentioned it before but my business is GPU reflowing. For further details click on the blue reflowing banner at the top of the page!

What I can offer you is to do a reflow on the chip and if it doesn't work then all you pay is carriage to me and back to you again.

A further option - if the motherboard is faulty I can find a replacement board and fit it for you.

PM or email me if you're interested.

Fnurga
Posts: 12
Joined: Sat Feb 28, 2009 3:36 pm
Location: Umeå, Sweden

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#136 Post by Fnurga » Thu Mar 12, 2009 1:32 pm

poshgeordie wrote:You have nothing to lose by trying again.

I haven't mentioned it before but my business is GPU reflowing. For further details click on the blue reflowing banner at the top of the page!

What I can offer you is to do a reflow on the chip and if it doesn't work then all you pay is carriage to me and back to you again.

A further option - if the motherboard is faulty I can find a replacement board and fit it for you.

PM or email me if you're interested.
Thanks for the offer. But i feel like it would be an expensive risk to ship it from Sweden to UK, at least for now.
Eventually i may get on different toughts :)

You've got PM ;)

Regards

utahvw
Posts: 1
Joined: Fri Mar 13, 2009 4:27 am
Location: Portland, OR

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#137 Post by utahvw » Fri Mar 13, 2009 5:01 am

Can you say AWESOME?!!!!

I just followed the guide instructions to the letter and I am posting this from my resurrected T41p. For anyone who is hesitant to try this let me say this....I have never attempted any repair at this level before and it worked perfectly! I am still grinning from ear to ear just as i have been for the past hours since I put it back together and it booted up first time and has been running for 6 hours now with no complaint.

Make sure to cut the square out in the tin foil exactly to size and weight the foil on two of the sides to keep the heated air from lifting the foil. ( I used a tuning fork and a pair of hemostats which held the foil down nicely). Go SLOW....check the temperature often...I check every 30 seconds to get a good idea of the rate of temperature change.

Many thanks to the author of this guide! This is easily the most useful repair information I have ever found. Thank you so much!!

Rich

visionviper
Contributing Member
Contributing Member
Posts: 528
Joined: Sat Oct 13, 2007 9:47 pm
Location: Pullman, WA
Contact:

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#138 Post by visionviper » Fri Mar 13, 2009 5:44 pm

I'm glad a few more people have brought their laptops back from the dead.

As a note to those who end up with non-working boards: No, do not attempt a second reflow - just buy a new motherboard.
7mm SSD list
Guide to fixing T4x GPU problems via reflow

Current: T420s
Former: X301, X61t, T40

VFR_firefly
Posts: 49
Joined: Wed Aug 02, 2006 4:45 pm
Location: Chicago mostly
Contact:

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#139 Post by VFR_firefly » Fri Mar 20, 2009 11:42 am

2 expensive coasters. I followed the procedures exactly. I guess nothing is guaranteed.

YMMV. I'm going to try superior re-ball next time or find an R51 Mobo.

Fool me twice...
Molon Labe

-Jim

Fnurga
Posts: 12
Joined: Sat Feb 28, 2009 3:36 pm
Location: Umeå, Sweden

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#140 Post by Fnurga » Fri Mar 20, 2009 7:44 pm

Hi,

i have now done two reflows without any luck..

i think there multiple things thats broke on my mobo.
I may have damaged something myself, i belive that the lcd backlight worked before i tried to reflow, now it seems to be broke.
All the fuses are good.

Regards

deforest
Freshman Member
Posts: 98
Joined: Thu Feb 09, 2006 8:47 pm

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#141 Post by deforest » Tue Mar 24, 2009 10:43 am

Just got back a t40p that I sent to superior reball, I was chicken to try to do the reflow myself. Before I sent it in, I had to press and hold down the palm rest to boot up, i.e. classic gpu failure symptom. When I got it back, all I had to do was push the power button and sit back and watch. Total of 2 week turn around, which includes the shipping time.

murray1
Freshman Member
Posts: 51
Joined: Fri Feb 23, 2007 2:27 pm
Location: Spruce Grove, Alberta

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#142 Post by murray1 » Thu Apr 23, 2009 6:18 pm

Cool, just did this with my T40 and it worked. Thanks a lot for the information. My father is having similar problems with his too and I will probably try to fix his too.

beeblebrox
**SENIOR** Member
**SENIOR** Member
Posts: 760
Joined: Thu Nov 11, 2004 3:22 pm
Location: No location is OK - BillM

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#143 Post by beeblebrox » Fri Apr 24, 2009 11:58 am

I am having serious problems.

I have two boards with a Radeon 9600 chip and one with a 7500 chip. Both notebooks could boot when I pressed the palmrest, and when moving they go dead. Typical flexing error.

When they are running ok, I try the Lenovo System tools and the video burn in test. The graphics chips heat up and the thinkpad goes black.
Ok, flexing.

I have repaired 5 Thinkpads with a heat gun without problems. But here it comes: the Radeon 9600 (128MB) chip just went dead, the notebook starts, no beep, no screen, just the DVD spins up and reads something. Fan is running. The Thinklight does not work anymore.
I am dead sure I did not overheat the chip with the heat gun. I tried reflowing twice.
Do you have any idea what was wrong?

On the Radeon 7500 I had an extremely strange experience. When I heated it up to just barely 230C, suddenly little balls of tin appear next to the graphics ram chips, out of nowhere, squeezed out from a virtual hole in the sealing of the graphics ram on top of the chip. I have never seen this before! The chips don't work anymore. Has anyone seen this as well?

poshgeordie
ThinkPadder
ThinkPadder
Posts: 1101
Joined: Sat Feb 09, 2008 6:19 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#144 Post by poshgeordie » Fri Apr 24, 2009 5:31 pm

Sounds like you've had a lot of success but I think you're beginning to run into some of the limitations of using this method.
beeblebrox wrote:the Radeon 9600 (128MB) chip just went dead, the notebook starts, no beep, no screen, just the DVD spins up and reads something. Fan is running. The Thinklight does not work anymore.
I am dead sure I did not overheat the chip with the heat gun. I tried reflowing twice.
Do you have any idea what was wrong?
I'd suggest checking fuses - go to my sig, download my 'Docs and How To's List', and have a look at the T4x fuses location doc listed.

Other than that, I'd say the motherboard is damaged elsewhere.
beeblebrox wrote:On the Radeon 7500 I had an extremely strange experience. When I heated it up to just barely 230C, suddenly little balls of tin appear next to the graphics ram chips, out of nowhere, squeezed out from a virtual hole in the sealing of the graphics ram on top of the chip. I have never seen this before! The chips don't work anymore. Has anyone seen this as well?
This is due to too much heat being applied to the top of the chip and has damaged one of the GPU memory chip BGA's (ball grid arrays - the individual tiny solder joints on the chip), and is not uncommon if too much top heat is applied like this. What's needed is to remove that memory chip and reball it, but AFAIK no one does it, so it's a new graphics chip.

One of the reasons why infrared reflowing employs bottom heat as well as top heat is to precisely avoid too much heat from one source, and instead applies a certain percentage from below and so much from above.
The resultant combination of heat sources then just melts the BGA enough to allow the solder to just turn into a liquid state without it starting to run all over the place as has happened to you.

Regarding attempting to measure the temperature whilst applying heat, it is not actually possible to meaningfully measure the heat being applied to the chip whilst applying top heat from any source since too much intense heat being applied to one area which will heat up far more quickly than the thermocouple probe can track. If relying on this method inevitably the chip will be overheated.

I appreciate that it's not practical from a price point of view, but when reflowing subminiature high magnification devices are employed which enables the user to actually observe the BGA in real time and see when the solder melts.
This is the one of the most reliable methods and is far and away better than trying to guess at the surface temperature.

Hope that helps - maybe in future think about applying heat a lot more gently - or if you're in the States send the boards off to Superior Reballing or Arndt Computer Services - both owners are active members here too.

beeblebrox
**SENIOR** Member
**SENIOR** Member
Posts: 760
Joined: Thu Nov 11, 2004 3:22 pm
Location: No location is OK - BillM

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#145 Post by beeblebrox » Sat Apr 25, 2009 12:39 am

Hello poshgeordie,

yes, the correct heat ist critical. You are absolutely right. The strange thing is, the graphics RAM on that Radeon 7500 was sealed on all sides.
I usually put a little piece of solder on top of the chip to JUST BARELY melt it and then keep the heater at the same distance for 1 Minute. That's how I easily and reliably fixed all the other boards. However, the other boards had graphics RAM open on the sides, so you could see the little BGA balls on the carrier.

In this case, there must have been a tiny hole in the glue sealing and the heat pressure squeezed out the solder balls out from nowhere. The notebook was dead.

NOW: I simply reflowed again, more solder balls popping from the sides. But the notebook is starting again, however with the typical lines and blurred screen. And it is reading the CD and HDD and booting up. I am really puzzled...
I am getting me an infrared thermometer now, because I am curious what exactly is going on.

poshgeordie
ThinkPadder
ThinkPadder
Posts: 1101
Joined: Sat Feb 09, 2008 6:19 pm
Location: Newcastle upon Tyne, UK
Contact:

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#146 Post by poshgeordie » Sat Apr 25, 2009 3:49 am

The solder idea is good - I assume you mean that you keep the heat on until the solder melts and then remove the heat. I would say that if you keep the heat on for a minute after it melts then there's a big chance the balls will run into each other.
If you think about it, when the solder melts then the balls underneath are going to be very close to melting as well, and I'd suggest removing the heat at that point and allowing residual heat to penetrate to fully melt the BGA. When using a heat gun with it's powerful heat source I'd say there'd be more than enough residual heat left.

When reflowing, the bottom heat is left on for around 10 seconds after the top heat is removed for just this reason - to somplete the melting action on the BGA.

Getting an IR thermometer would be interesting but may not advance things any more. In IR reflowing, when top heat is applied, all temperature probes are moved away because their readings become meaningless whilst heat is being applied.

The bottom line is that sufficient heat has to be applied to just cause the solder to flow freely enough to stick the chip to the motherboard, no more, no less.

Re the solder popping out through solid black gunge, I do wonder if when heat is applied in these circumstance, that because there's no 'vent' hole around the gunge, pressure inside the chip builds up and then 'blows' like a volcano with bits of solder as the 'lava' (wow I'm on a creative roll here - could we sell this to Stephen Speilburg and call it 'Graphics and Thinkpad' - [like Wallace and Grommit]!!).

erik21
Posts: 15
Joined: Sat Nov 22, 2008 8:18 pm
Location: Buffalo, New York

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#147 Post by erik21 » Sat May 16, 2009 6:24 pm

A question to someone who has done this successfully: what temperature setting did you use when you reflowed?
A T40 and a T42.

distant0
Posts: 1
Joined: Tue May 19, 2009 6:56 pm
Location: Melbourne, Australia

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#148 Post by distant0 » Wed May 20, 2009 5:27 pm

I think my T40 is also developing this problem.. can't you re-solder the GPU?? why reflow??

bajaman61
Posts: 24
Joined: Fri Nov 07, 2008 5:04 pm
Location: Ensenada, Baja California, Mexico

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#149 Post by bajaman61 » Thu May 21, 2009 1:42 pm

distant0 wrote:I think my T40 is also developing this problem.. can't you re-solder the GPU?? why reflow??
Short Answer: The GPU has what is known as a Ball Grid Assembly and the fix is not a simple soldering operation. (Search for "BGA" on a search engine to learn more.) High heat "reflows" the BGA by bringing its more complicated solder array to a "flow" or liquid state -- but still contains the solder and so, on cooling, reattaches the GPU.

Check out the FAQs page for an alternative "wedge" solution: http://forum.thinkpads.com/viewtopic.php?f=31&t=74366

For a wedge I use a plastic container from a CF card and removed two of the container's corners so it only sits on the GPU to test the T4Xs that "act up". Forum Member poshgeordie has a pdf document that makes quick work of disassembling your T4X to the extent necessary to insert the wedge fix described above.

It is a good way to confirm the problem as the wedge fix will make the problem disappear completely. Then you have a confirmed diagnosis and can decide if you want to perform more extensive surgery.
Here to learn about IBM Thinkpads and running them on LINUX

carlisle_united
Freshman Member
Posts: 50
Joined: Sun Apr 19, 2009 9:19 am
Location: Bålsta, Sweden

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#150 Post by carlisle_united » Sat May 23, 2009 5:03 pm

So....
It looks like my "new" T43 als has a bad GPU...
Im thinking of doing the reflow, BUT...
Does it work on a T43? I havent read anything about the T43...
My T43 has a metalic "cover" over the GPU thats connected to the fan...
Will this cause a problem for the reflow?

Im hoping that I can fix this problem since I really like the feel of the T43.
-----------
IBM ThinkPad T23
IBM ThinkPad A22m
IBM ThinkPad T40

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T4x Series”

Who is online

Users browsing this forum: Bing [Bot] and 18 guests