Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

GUIDE: Reflow GPU fix - 56K WARNING!!!

T4x series specific matters only
Post Reply
Message
Author
usernotabuser
Freshman Member
Posts: 52
Joined: Fri Oct 17, 2008 8:43 pm
Location: Tallahassee, FL

#91 Post by usernotabuser » Fri Nov 07, 2008 9:02 pm

Wow, seeing the mixed results from the people that have tried this, I think I'll end up sending the T42 I purchased off to be repaired "professionally" if this issue ever rears its ugly head.

Great concept and props to the tutorial maker.

Here's a relevant side note:

My perfectly fine, newly acquired T42: Should I epoxy something to help prevent this problem? Or should I take some other action to help prevent this problem from occurring (besides proper methods for pickup and moving of the laptop)?

It seems like the epoxy (preventative) measure would make any further action, (if the issue did develop) to repair the issue, impossible.
Simple is as simple does.

ajkula66
SuperUserGeorge
SuperUserGeorge
Posts: 16814
Joined: Sun Feb 25, 2007 11:28 am
Location: Brodheadsville, Pennsylvania, USA

#92 Post by ajkula66 » Fri Nov 07, 2008 9:51 pm

usernotabuser wrote:
My perfectly fine, newly acquired T42: Should I epoxy something to help prevent this problem? Or should I take some other action to help prevent this problem from occurring (besides proper methods for pickup and moving of the laptop)?

It seems like the epoxy (preventative) measure would make any further action, (if the issue did develop) to repair the issue, impossible.
Don't fix what's not broken. And, yes, "preventive measures" used on late T42/p as well as on all ATi-based T43/p machines actually make repairing these boards (which are far less likely to fail in the first place) more difficult. The same would apply to what you have in mind.

What you can do:

a) Install the "long fan" if your T42 doesn't already have it.
b) Try to minimize the number of heating/cooling cycles...keep the laptop on as much as possible, turning the LCD off when not in use to protect the backlight.

My $0.02 only...
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your grouchy retired FlexView farmer)

FlexView AARP club members:A31p, T43pSF

Abused daily: T520, X200s


PMs requesting personal tech support will be ignored.

usernotabuser
Freshman Member
Posts: 52
Joined: Fri Oct 17, 2008 8:43 pm
Location: Tallahassee, FL

#93 Post by usernotabuser » Fri Nov 07, 2008 9:57 pm

I do both of these things by default. Thanks for the input.

Edit: By that I mean I have the long fan, and do the other.

Curse you beer for making me look silly when I post comments on an internet forum!
Simple is as simple does.

zrequir
Posts: 4
Joined: Wed Nov 12, 2008 2:58 pm
Location: Oakland, CA

Heat gun

#94 Post by zrequir » Wed Dec 24, 2008 3:35 pm

Can my wife's hair dryer be substituted for the heat gun?
Elis

MelVic
Posts: 8
Joined: Sat Dec 27, 2008 4:19 pm
Location: Melbourne, Australia

#95 Post by MelVic » Sat Dec 27, 2008 7:56 pm

Hello to all, ive had this problem for ages, i got the t40 for nothing though i did have to get a new keyboard for it, but this gpu fix should give a nice cheap laptop as i only need it for movies, anyhow the question, ive got everything bar the infrared thermometer, is there another way of getting the temp right eg: time ?

Mark

Nameless
Freshman Member
Posts: 93
Joined: Thu Sep 11, 2008 2:51 pm
Location: Austin, Texas

Re: Heat gun

#96 Post by Nameless » Mon Dec 29, 2008 2:28 pm

zrequir wrote:Can my wife's hair dryer be substituted for the heat gun?
Unless her hair dryer is hot enough to catch her hair on fire, sorry no. :lol: Hair dryers don't put out nearly enough heat to reach 200+ deg C. That's ~400 deg F! You'll need a real heat gun.

MelVic
Posts: 8
Joined: Sat Dec 27, 2008 4:19 pm
Location: Melbourne, Australia

#97 Post by MelVic » Fri Jan 02, 2009 2:56 pm

Hi guy's, i gave up and got a infrared thermometer, followed the instructions and i have to say it worked like a bomb, its been going for these past days without a glitch. ive given it bit of a hard time also by flexing the mobo and its still going.

So thanks for this fix :D

Mark

Rick Aguinaldo
Sophomore Member
Posts: 126
Joined: Tue Apr 27, 2004 2:52 pm
Location: Dhahran, Saudi Arabia

#98 Post by Rick Aguinaldo » Fri Jan 02, 2009 4:43 pm

Feeling very lucky last night - three (two T41 and one R51) successful GPU reflow fixes. Two layers of aluminum foil were wrapped around the first work piece, a T41 board stripped of all removable parts. A window was cut on the aluminum foil to expose the GPU, following its outline on the foil as as they did with a BGA chip in this video. Some steel screw nuts were placed around the window to keep the foil pressed against the board so that the possibility of hot air flowing underneath the foil is minimized. The tip of the thermocouple probe was placed on top the GPU chip. Preheat on the chip is two minutes at 150C-180C. Reflow is at 260C for four minutes. The first test on the reflow job was a success! :D.

Encouraged by the results, I proceeded with the second T41 board, a bare bottom half (minus the keyboard, optical and hard drives) using the same heat shielding technique. The success on the second board made me proceed aggressively on the the third one, an R51 board which was an eBay acquisition to replace the first board. It too exhibited the GPU problem a couple of days after it was transplanted into the T41. Noting the performance of the double layer heat shield, this time only the keyboard was removed. The third one was also a bingo!

Thanks and more feathers to the chaps who did the pioneering work on this GPU fix. :D

rkawakami
Admin
Admin
Posts: 10137
Joined: Sun Jun 04, 2006 1:26 am
Location: San Jose, CA 95120 USA
Contact:

#99 Post by rkawakami » Fri Jan 02, 2009 5:01 pm

Rick,

I would have thought that you'd simply leave the boards out in the sun for a couple of minutes during the summer :) . I guess you couldn't wait that long :lol: . Nice results!
Ray Kawakami
X22 X24 X31 X41 X41T X60 X60s X61 X61s X200 X200s X300 X301 Z60m Z61t Z61p 560 560Z 600 600E 600X T21 T22 T23 T41 T60p T410 T420 T520 W500 W520 R50 A21p A22p A31 A31p
NOTE: All links to PC-Doctor software hosted by me are dead. Files removed 8/28/12 by manufacturer's demand.

limbus
Posts: 1
Joined: Tue Jan 13, 2009 5:57 pm
Location: College Station, TX

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#100 Post by limbus » Tue Jan 13, 2009 7:02 pm

I was doing some background reading about the assembly/disassembly process. The maintenance manual (Pg.105, fan assembly installation) advises using thermal grease.
Do you use thermal grease when putting the system back together or are those instructions applicable only when installing a brand new fan? And if it is necessary, what kind of thermal grease is needed and where can it be purchased?

madkat
Junior Member
Junior Member
Posts: 326
Joined: Wed Jun 18, 2008 1:21 am
Location: Bucharest, Romania

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#101 Post by madkat » Thu Jan 15, 2009 4:45 pm

it's way off topic - but:
you ALWAYS use fresh thermal paste when removing/putting back the heatsink
Arctic Silver 5 gives fairly good results
ex: T30, TR451, TR453, R51, R52, X40, X60, R61, T400
X200 - P8600 2.66Ghz, 3G, 250G
G50-70 - 3558U 2.4Ghz, 4G, 1T

Beaver
Sophomore Member
Posts: 171
Joined: Sat Oct 25, 2008 1:40 pm
Location: Brno, Czech Republic

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#102 Post by Beaver » Mon Jan 19, 2009 5:19 pm

So my friends, it looks like I am starting to catch the GPU problem as well. Yesterday I got a black screen while the laptop was running graphical demanding application. Pressing on the area on the right side of touchpad helped. I made a system shutdown and pushed on the area over the GPU for several minutes (yes, I know that temp. emitted by GPU itself is not enough to melt down the solder, but just for sure...) and the problem went away with the next system startup. Anyway the GPU detach monster is crowling around my laptop and it will try to take my soul and GPU. I am starting to search for company able to do reball on the BGA chips (in Czech Republic or somewhere nearby if possible).

Just inform you - today I removed the keyboard and observed if everything is OK and I was little bit surprised that my laptop has a long fan. So long fan itself will not save you :( In the time the issue happend the laptop was sitting on the table with my hands on keyboard - no flex, no stress, no moving.
IBM T40p 2373-CG6, Pentium M 1.5 GHz, 1024 MB RAM, 40GB HDD, 14.1" TFT, ATI FireGL 9000 64 MB
Dual boot WinXP + Fedora Core 10

greg025
Posts: 31
Joined: Tue Apr 27, 2004 8:12 pm
Location: Rockville, MD
Contact:

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#103 Post by greg025 » Wed Jan 21, 2009 3:12 pm

I also have the dreaded no video issue on my T42P. In this thread I noticed that there was reference to somebody who was providing a service to do the repair (apart from the reference on eBay).

Is this true and if so who was it please?

Thank You,

Greg
A22P, T40P (1.6/2Gig/100Gig), T42P (2.1/2/100)

Ralf Hutter
Posts: 49
Joined: Fri Aug 22, 2008 3:34 pm
Location: East Arcadia California

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#104 Post by Ralf Hutter » Thu Jan 22, 2009 4:52 pm

greg025 wrote:I also have the dreaded no video issue on my T42P. In this thread I noticed that there was reference to somebody who was providing a service to do the repair (apart from the reference on eBay).

Is this true and if so who was it please?

Thank You,

Greg
Here:

http://forum.thinkpads.com/viewtopic.php?f=11&t=48458

astryx
Posts: 1
Joined: Thu Jan 22, 2009 1:05 pm
Location: Milpitas, CA

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#105 Post by astryx » Thu Jan 22, 2009 7:41 pm

Hi,
I just want to thank you for posting your solution. I did pretty much the same think you did and it fixed the problem instantly and hopefully permanently. But it's too soon to say, for it's been only a couple of days. Since I know that this motherboard is sensitive to flexing, I'll handle this laptop more carefully from now on. I wrapped a 1" thick layer of wall type fiberglass insulation before wrapping the aluminum foils to help slowing down the heat transfer and prevent thermal stress buildup. I also used an inverted funnel made by cutting the same exact square opening with return lips, from an aluminum cap for 4x4 posts, that I got from the Home Depot. I used an exacto knife and plier to do so. I thought it would help concentrating the heat only to that spot. It actually worked so well that I'm pretty sure a hair dryer can be used instead of the 1500 Watt heat gun! Indeed, as long as heat is added constantly, and the motherboard is well insulated from the ambient temperature, the GPU will keep getting hotter. As to the infrared thermometer, well ...I borrowed it... Now, I you think that if it's either too hard or expensive to get, you may try to cut a scrap piece of printed circuit board that has a surface mounted device on it and position it as vertically on top of the GPU to monitor the temperature. Here you'll need to use your imagination...cut, bend and make a little roof out of it, or hold it on a small slotted block that can take this heat. Once the IC of this scrap board starts to slide down you know you've reached the required reflow temperature and you will need lifting up your dryer about 6 inches to start the cooling phase. Remember that you need to build or remove heat gradually! So plunge or withdraw your heater intermittently shooting away from the opening in short 10 second cycles at most.
By the way, I noticed that my USB 2.0 port never worked since I got my laptop. This problem is notorious with the early T40 models. I bet that the problem and solutions are identical to the GPU's as one guy in this forum http://forum.thinkpads.com/viewtopic.ph ... 67&start=0 . I'll have to try this one, but I don't have any idea where the Southbridge USB controller is located on the motherboard. So if you know a link that has a picture of its location, post it here. That could start a new active thread.

Good luck

jeffbl
Posts: 35
Joined: Wed Jun 23, 2004 10:12 am
Location: Montreal, QC, Canada
Contact:

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#106 Post by jeffbl » Fri Jan 23, 2009 10:51 pm

Holy cow. I had a T42 with this problem, and I sold it for scrap. Then my beloved X31 started showing symptoms mid 2008, and got worse and worse until it would freeze if I just looked at it funny. It was completely unusable. I got an IR thermometer and heat gun, and tried this the other night. It was a disaster. I carefully wrapped in two layers of foil, and heated it up to 230, held it there, and the smoke alarm went off at 11pm. Had to go deal with that, came back and tried to cool it down as best I could according to the instructions. Waited, took of the foil, and notices some huge plastic blobs, one by the hinge that had melted all over a detached capacitor near the hinge, and another blob over by the CF slot. Pulled that all off, and the capacitor came off entirely. Despair. Fortunately, my wife is an expert with a soldering iron, and said, "no problem." She soldered the capacitor back on today. I just got everything reassembled - but i had to break off a melted piece of the CF eject mechanism that was preventing the motherboard from seating in the shell properly.

And...

IT BOOTS. Unbelievable. And it is rock solid - I've been picking it up, torquing on the edges, no problems. I'm amazed. I'm calling it the resurrection-pad now. We'll see if it lasts...or if some of the ports are hosed...or if the magic smoke comes out suddenly when I pick it up again.

bangadrum
Posts: 10
Joined: Mon Dec 15, 2008 10:55 am
Location: Derby, UK

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#107 Post by bangadrum » Thu Jan 29, 2009 12:38 pm

Just reflowed mine.
Despite checking all round I managed to miss some tape that had been put on the underside of the board for some reason.

The heat contracted the tape and pulled several surface mount components off the board, not going to be fixable without new components and an SMA/BGA reflow station.

BUGGER! :oops: :x

New motherboard ordered. Ouch.

erik21
Posts: 15
Joined: Sat Nov 22, 2008 8:18 pm
Location: Buffalo, New York

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#108 Post by erik21 » Thu Jan 29, 2009 12:41 pm

Can someone who was successful in reflowing recommend a heat gun? Will a 1300W one do?

Thanks,
erik
A T40 and a T42.

Spiracle
Posts: 3
Joined: Fri Jan 30, 2009 9:08 am
Location: Cambridge, UK

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#109 Post by Spiracle » Fri Jan 30, 2009 11:37 am

After following your instructions my T41 now works perfectly (now two weeks and counting). Thanks.

Our IR thermometer had gone missing so seat of the pants guesswork was necessary but it all seemed to come out OK.

Of course I had two screws left over after re-assembly. :lol:

Rick Aguinaldo
Sophomore Member
Posts: 126
Joined: Tue Apr 27, 2004 2:52 pm
Location: Dhahran, Saudi Arabia

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#110 Post by Rick Aguinaldo » Sat Jan 31, 2009 3:12 pm

erik21 wrote:Can someone who was successful in reflowing recommend a heat gun? Will a 1300W one do?

Thanks,
erik
I used an Alpha Wire Corp Model HG1R1 heat gun. It takes 14 amps at 120V so it has a higher wattage than what you are contemplating. I guess the 1300w heat gun would do the job because I had to keep the blower at distance from the work piece to keep the temperature at 260C-280C. The one they used in the youtube video I referenced earlier is even smaller but they have the air stream concentrated by using a small-diameter blower.

erikill
Posts: 18
Joined: Wed May 10, 2006 11:10 am
Location: USA
Contact:

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#111 Post by erikill » Thu Feb 12, 2009 2:41 pm

I attempted the re-flow and was unsucessful. I used the IR thermometer and my friend and I gradually raised and cooled it. I think maybe the heat shield didnt work since some of the plastic connectors melted some. Put it back to together somewhat, the batt light would flicker for 2ms and the screen flicker as well and that was it. Tried re-flow again, still no dice. I checked the underside of the board and saw some soldier through the little holes under the VC. Oh well....ordering a replacement mobo!
T42 - 2378-FZU replaced with T41 mobo.
T43p - 2668-H8U

--
Previous T20 Frankenstein

skydreamer
Posts: 9
Joined: Sun Oct 21, 2007 2:44 am
Location: Moycullen, Ireland

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#112 Post by skydreamer » Sat Feb 14, 2009 9:21 am

:D Worked for me!!

I have got a top class Heat Gun from Bosch for this job, which can be set to any temperature in steps of 10C over eBay and together with a Fluke infra probe the whole heating and cooling process was simple.

Your nose is the best indicator!

When I hit 220C there was a distinct change in smell of the vapour emitted by the hot graphics chip, suddenly I could sense melting flux. So 10C more and I started cooling the tormented motherboard.

Long live T40. :banana:
Rescued T23, 1GB RAM, PIII 1.13GHz, 80GB 5400 rpm HDD, Mini-PCI WiFi, internal bluetooth module, LCD 1400x1050. Dual Boot XP Pro & Fedora Core 7.

MikeB
Posts: 1
Joined: Thu Feb 12, 2009 8:27 am
Location: Ewing, New Jersey, USA

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#113 Post by MikeB » Thu Feb 19, 2009 3:07 pm

Regarding home re-flowing of GPU, I just came across a listing for a professional company that does re-flowing and it looks like they are into doing repairs on IBM T4x computers. You can send them your computer, they will take it apart, professionally re-flow( with special equipment, not hot air guns)the BGA , xray the connection, test it and put it back together, test, and send it back for $75.00. Not bad! The link is http://cgi.ebay.com/IBM-Motherboard-rep ... 1|294%3A50

I have a call into them to go over this and most likely I will send in my t41 for repair.

horacelau
Posts: 11
Joined: Sat Jun 11, 2005 11:14 pm

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#114 Post by horacelau » Thu Feb 19, 2009 5:21 pm

Looks like that is Superior Reball. Do a search for them on this board and you can read about other people's experiences. In summary, if your Thinkpad is fixed after reflow, you will get it back in reasonable amount of time. If reflow fails to fix it, forget about seeing your Thinkpad again. They have had mine since August and I still don't have it back. Lots of excuses about why it hasn't been returned, emails and phone calls ignored. Case has been filed with BBB.

karentvchick
Posts: 1
Joined: Tue Feb 24, 2009 1:35 pm
Location: New York, NY

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#115 Post by karentvchick » Tue Feb 24, 2009 2:18 pm

Hi all,

Fascinating reading here, even if I understand very little. I stumbled across this site while looking for a fix for my beloved T40. While on a work trip, my GPU failed (I didn't know what it was at the time) while attempting to send some files from the Duluth airport. After much research, I've determined the GPU solder is what I *think* is wrong with my computer. Right now I have the small post it notes under the touchpad pressing down on the GPU and I use the mouse & on screen keyboard so I don't have to touch the machine.

I am not as crazy to think I could attempt this repair myself, so my question is, would you recommend James Arndt/Arndt computer? Or someone else who has done this repair? I definitely want this computer back, and in working condition. The ebay guy doesn't sound like a good idea.

Please give me your honest answers.

Thanks!
Karen

Phant0m``
Posts: 4
Joined: Wed Feb 25, 2009 5:01 pm
Location: Halifax, Nova Scotia, Canada

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#116 Post by Phant0m`` » Wed Feb 25, 2009 5:54 pm

Hi folks,

Not until I came across this topic, that I actually known what is wrong with my IBM T40. .. All I knew it had to be an loose connection with a cable or a chip. Basically the symptoms I experienced is the LCD screen usually don't come on, unless Laptop is jarred, and even then it may have good picture for a little time but then the picture becomes dirty / distorted .. especially when the Laptop gets just a little jarred. And applying pressure just above where the GPU is located brings the picture back for as long as the pressure exists...

.. I guess it has already been said, this seems to be a famous problem with the IBM T40s.

I have read carefully the first post, I have some questions, sorry for my ignorance and I hope I didn't miss anything afterwards that may be of some answers here...

- For requirements an 1500W Heat Gun was listed, nothing was said about it needing to be VARI TEMP. I know in the details it was talking about gradually bringing the temperature up, I'm only guessing we need an 1500 Heat Gun with variable temperature ... like the one shown here http://parts.digikey.com/1/parts/986651 ... 1802e.html.

Is it impossible to use safely an 1500W Heat Gun instead with like maximum two temperature variables like the Black & Deckers - http://www.blackanddecker.com/ProductGu ... uctID=2747 ?

... And is there any place that shows how to fix GPU using simply an Soldering Iron - http://en.wikipedia.org/wiki/Soldering_iron ?

- Was the Aluminium foil tucked under the motherboard just a tad? or was it just hanging over the side of the motherboard ... All four sides?

- Was the heat gun always at an fixed location and pointing directly on the GPU chip or off on the side of it just a little? , was the gun height always the same and what height would this be? And was there an circular rotation like seen used on the youtube video?

- I noticed the image in the first post, it shows the heat gun slightly tilted, and not directly over-top pointing directly downwards. Hence one of the reasons for my previous question.

Again, I do apologize for my ignorance, and something I may have missed on this lengthly topic, I'm just somewhat worried, and with questions to be asked.


Much appreciate any assistance on this matter.


Regards,
Phant0m``

zakia
Posts: 3
Joined: Sat Feb 28, 2009 11:49 am
Location: Newark, DE

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#117 Post by zakia » Sat Feb 28, 2009 3:15 pm

Hi guys, I'm new here. :)

My T40 video just went bad a couple days ago and now looks like this: http://img514.imageshack.us/img514/6676/img0202a.jpg.

Will this reflow GPU method help fix the problem? Please advise. Thanks!

Phant0m``
Posts: 4
Joined: Wed Feb 25, 2009 5:01 pm
Location: Halifax, Nova Scotia, Canada

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#118 Post by Phant0m`` » Sat Feb 28, 2009 9:58 pm

Only 1500w heat guns I see on eBay are those with just Dual speeds... so much for "heat the GPU SLOWLY" ... :wink:

zakia
Posts: 3
Joined: Sat Feb 28, 2009 11:49 am
Location: Newark, DE

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#119 Post by zakia » Tue Mar 03, 2009 2:29 am

zakia wrote:Hi guys, I'm new here. :)

My T40 video just went bad a couple days ago and now looks like this: http://img514.imageshack.us/img514/6676/img0202a.jpg.

Will this reflow GPU method help fix the problem? Please advise. Thanks!
Well, I did reflow last night and the video is now good again. :)
I use the method explained here btw (not the youtube).
Many thanks to the OP who made this possible!

Phant0m``
Posts: 4
Joined: Wed Feb 25, 2009 5:01 pm
Location: Halifax, Nova Scotia, Canada

Re: GUIDE: Reflow GPU fix - 56K WARNING!!!

#120 Post by Phant0m`` » Tue Mar 03, 2009 5:40 am

Can someone please tell me what type of 1500 Heat gun they successfully used? And if it wasn't simple Dual speeds 1500 Heat Gun, could Dual speeds 1500 Heat Gun possibly could work?

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T4x Series”

Who is online

Users browsing this forum: No registered users and 16 guests