Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Hitachi website - 7K100, 100 GB PATA HD is unavailable

T40/T41/T42/T43 series specific matters only
Message
Author
cmarti
ThinkPadder
ThinkPadder
Posts: 1939
Joined: Sun Feb 12, 2006 1:26 am
Location: Orlando, Florida
Contact:

#31 Post by cmarti » Sat Jan 03, 2009 2:16 pm

This comes from the seller:
I purchased these drives on ebay and selling them because they are not compatible in lenovo thinkpad T43 units but will be fine in other models and other brands of laptops.
Strange because my T43p came with one from factory and it worked perfectly :roll:
X32/2.0GHZ/2GB/ENGENIUS EMP-8602+S 600mw mini pci/WD 250GB
X60/1.83GHZ/2GB/Atheros/7K100

sjthinkpader
Senior ThinkPadder
Senior ThinkPadder
Posts: 2908
Joined: Tue Jan 22, 2008 8:29 pm
Location: San Jose, CA

#32 Post by sjthinkpader » Sat Jan 03, 2009 2:32 pm

The factory drives have different ID in the firmware.
T60p 2623-DDU/UXGA IPS/ATI V5200
T60 2623-DCU/SXGA+ IPS/ATI X1400
T43p 2668-H8U/UXGA IPS/ATI V3200
R50p 1832-NU1/UXGA IPS/ATI FireGL T2
X61t 7762-B6U dual touch IPS/64GB SSD
X32 2673-BU6/32GB SSD
755CDV 9545-GBK Transmissive Projection LCD

cmarti
ThinkPadder
ThinkPadder
Posts: 1939
Joined: Sun Feb 12, 2006 1:26 am
Location: Orlando, Florida
Contact:

#33 Post by cmarti » Sat Jan 03, 2009 6:15 pm

Oh well, Thanks!
X32/2.0GHZ/2GB/ENGENIUS EMP-8602+S 600mw mini pci/WD 250GB
X60/1.83GHZ/2GB/Atheros/7K100

davidspalding
ThinkPadder
ThinkPadder
Posts: 1593
Joined: Mon Nov 14, 2005 2:39 pm
Location: Durham, NC
Contact:

Re: Hitachi website - 7K100, 100 GB PATA HD is unavailable

#34 Post by davidspalding » Tue Apr 21, 2009 3:45 pm

Sorry I missed this thread last year ... though my T43's original 5400 RPM (I think) 80 GB drive is doing fine, I had bought a 7K100 100 GB in 2006 for a second drive (UltraBay Slim 2nd HDD adapter) for video/Photoshop work.

Though it gives the 2010 error in the T43 as a primary drive (I was trying to wipe it to a factory install in the T43 as a caddy), I'm using it in a late-2005 X32 with ear-to-ear-grin inducing performance. The 5400 RPM 60GB drive that came out of the X32 just started dying in the T43's UltraBay Slim adapter this weekend. So I'm shopping for a compatible drive to use as a second in the T43 ... or maybe upgrade the T43 when I wipe it to reinstall and refresh in May.

Any tips on where the HD FW "white list" of drives that could be flashed to clear the 2010 error is?
2668-75U T43, 2GB RAM, 2nd hand NMB kybd, Dock II, spare Mini-Dock, and spare Port Replicators. Wacom BT tablet. Ultrabay 2nd HDD.
2672-KBU X32, 1.5GB RAM, 7200 rpm TravelStar HDD.

closersource
Freshman Member
Posts: 86
Joined: Fri Jun 16, 2006 9:01 pm
Location: New York, New York

Re: Hitachi website - 7K100, 100 GB PATA HD is unavailable

#35 Post by closersource » Tue Apr 21, 2009 4:15 pm

The complete list as of 1/2009 is here. Unfortunately, as discovered earlier by several forum members, for all non-IBM/Lenovo branded Hitachi drives the firmware update is useless as the memory PROM is read-only and thus are non-flash-able. You are welcome to try and report back.
WORK: X250
TRAVEL: X220T
PAST: T42P / T61P / X61T / T400 / T410S / W520 / T430

XCoalMiner
Sophomore Member
Posts: 245
Joined: Sun May 30, 2004 11:01 am
Location: SE PA (USA)

Re: Hitachi website - 7K100, 100 GB PATA HD is unavailable

#36 Post by XCoalMiner » Tue Apr 21, 2009 7:13 pm

closersource wrote:The complete list as of 1/2009 is here.
Where exactly is "here"?

davidspalding
ThinkPadder
ThinkPadder
Posts: 1593
Joined: Mon Nov 14, 2005 2:39 pm
Location: Durham, NC
Contact:

Re: Hitachi website - 7K100, 100 GB PATA HD is unavailable

#37 Post by davidspalding » Wed Apr 22, 2009 8:42 am

I couldnt' find it either. Please be specific (thread topic, sticky, FAQ, or...?).

closersource
Freshman Member
Posts: 86
Joined: Fri Jun 16, 2006 9:01 pm
Location: New York, New York

Re: Hitachi website - 7K100, 100 GB PATA HD is unavailable

#38 Post by closersource » Wed Apr 22, 2009 1:07 pm

WORK: X250
TRAVEL: X220T
PAST: T42P / T61P / X61T / T400 / T410S / W520 / T430

davidspalding
ThinkPadder
ThinkPadder
Posts: 1593
Joined: Mon Nov 14, 2005 2:39 pm
Location: Durham, NC
Contact:

Re: Hitachi website - 7K100, 100 GB PATA HD is unavailable

#39 Post by davidspalding » Wed Apr 22, 2009 3:06 pm

A-ha!!! :bow: Thank you sir. I had never really delved into this as I preferred my 7200 rpm drive as a second, data drive. I think I'd tried that firmware update on my 5400 rpm original drive, but never thought to try it on the second drive .... 7K100 HTS721010G9AT00!

So I can probably get a new <strike> 7200 rpm PATA drive </strike>, larger 5400 RPM PATA drive for my X32 to work with, and use the older 7200 in my T43 when I wipe it this summer, with no 2010 error. Good news for me. :banana:

Thanks for helping me connect the dots.
Last edited by davidspalding on Thu Apr 23, 2009 6:29 am, edited 1 time in total.

XCoalMiner
Sophomore Member
Posts: 245
Joined: Sun May 30, 2004 11:01 am
Location: SE PA (USA)

Re: Hitachi website - 7K100, 100 GB PATA HD is unavailable

#40 Post by XCoalMiner » Wed Apr 22, 2009 8:06 pm

davidspalding wrote:...
So I can probably get a new 7200 rpm PATA drive for my X32 to work with,
...
As I learned after starting this thread, new 7200 rpm PATA notebook drives are nowhere to be found. That is because they are not manufactured any longer.

5400 rpm PATAs are readily available.

closersource
Freshman Member
Posts: 86
Joined: Fri Jun 16, 2006 9:01 pm
Location: New York, New York

Re: Hitachi website - 7K100, 100 GB PATA HD is unavailable

#41 Post by closersource » Wed Apr 22, 2009 8:30 pm

You can find the 7200 drives on EBAY. They are out of production, but so are all the firmware-upgradeable drives on the list. Any new 5400 drive will exhibit the 2010 error.
WORK: X250
TRAVEL: X220T
PAST: T42P / T61P / X61T / T400 / T410S / W520 / T430

schen
Moderator Emeritus
Moderator Emeritus
Posts: 1554
Joined: Thu May 06, 2004 11:01 am
Location: Terrell, Texas

Re: Hitachi website - 7K100, 100 GB PATA HD is unavailable

#42 Post by schen » Wed Apr 22, 2009 9:21 pm

closersource wrote:You can find the 7200 drives on EBAY. They are out of production, but so are all the firmware-upgradeable drives on the list. Any new 5400 drive will exhibit the 2010 error.
Which is why I keep a few NOS Hitachi and Fujitsu 5400rpm drives in the closet for a rainy day. As an aside, what I ended up doing to to run my 80Gb/7200rpm drive as a main drive and use one of those UltraBay Slim SATA adapters from China with a Hitachi 7200rpm drive for a data drive. :banana:
Family Daily Drivers- T430s, T450s
Work- Sadly, the ThinkPads have gone away...... and replaced by HP ProDesk SFF drone machines :( Projects- T540p
Historic Retired ThinkPads- Z61m (Titanium), X20, A31p, 701c, 760XD, WorkPad C505

davidspalding
ThinkPadder
ThinkPadder
Posts: 1593
Joined: Mon Nov 14, 2005 2:39 pm
Location: Durham, NC
Contact:

Re: Hitachi website - 7K100, 100 GB PATA HD is unavailable

#43 Post by davidspalding » Thu Apr 23, 2009 6:37 am

Corrected above. Obviously I'm still confused.

I can see the 7200 RPM drives on eBay, most of them used ... :P ... but it seems that the WD Scorpio drives are the best bargains at the moment. 250 GB or so for < $100? At that size, they ought to be as fast as an old 7200. "More than a match for poor [X32]," as Khan said.
2668-75U T43, 2GB RAM, 2nd hand NMB kybd, Dock II, spare Mini-Dock, and spare Port Replicators. Wacom BT tablet. Ultrabay 2nd HDD.
2672-KBU X32, 1.5GB RAM, 7200 rpm TravelStar HDD.

LegendaryKA8
Junior Member
Junior Member
Posts: 395
Joined: Wed Sep 05, 2007 3:46 am
Location: Colo. Springs, CO
Contact:

Re: Hitachi website - 7K100, 100 GB PATA HD is unavailable

#44 Post by LegendaryKA8 » Thu Apr 23, 2009 10:53 am

Wow.... to be honest, I didn't know what I was sitting on all this time... and now I know why my 100GB 7200RPM drive was about $200 when I bought it new in '07. I only used it for a few months and now it's happily churning away in my T41. Guess I should look for a spare.

IIRC, I remember seeing a discussion on the T2x/T3x forum about a specific 160GB 5400RPM drive that handily outperformed any 7200RPM unit... anyone have any info on that?
ThinkPads:T21(retired), X200(retired), T500(busted) T400(retiring), T430(upcoming)
Other: Dell Precision M6700(desk hog)

closersource
Freshman Member
Posts: 86
Joined: Fri Jun 16, 2006 9:01 pm
Location: New York, New York

Re: Hitachi website - 7K100, 100 GB PATA HD is unavailable

#45 Post by closersource » Thu Apr 23, 2009 1:46 pm

As for "speed" it depends on what metric you are referring to. For sequential transfers the 5400 drives are more than a match for the 7200 drives because of higher density. Unfortunately the 7200 still comes up faster on random access and that is by far how "responsiveness" can best be gauged by the average user.

The drives on EBAY are indeed almost all used, but if you choose the right seller with the later date codes (post 2006) you can still get a very reliable drive. After all, new drives fail all the time. So in the end it depends on how much you need the speed. Then again there is always PATA SSD.
WORK: X250
TRAVEL: X220T
PAST: T42P / T61P / X61T / T400 / T410S / W520 / T430

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T40/T41/T42/T43 Series”

Who is online

Users browsing this forum: No registered users and 22 guests