T61p bios hack for ICH8M SATA-II 3Gbps (+history)

Work/comment area for scripts and utilities like TP Fan, 2-finger scrolling, etc
Message
Author
nando4
Posts: 13
Joined: Wed Aug 19, 2009 12:36 am
Location: Sydney, Australia

T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#1 Post by nando4 » Sun Feb 14, 2010 3:13 am

7-22-10 PROBLEM SOLVED!! Patched T61/X61 sata-II bios available here.
______________________________________________________________________________________________

Problem

Current-gen Indilinx, Samsung and Intel SSDs are seeing their SATA-II ~260MB/s sequential read/writes capped to SATA-I 1.5Gbps 130MB/s. The high performance Intel X25M G2 also sees multithreaded 4kb reads being capped from it's SATA-II 162MB/s level to 130MB/s SATA-I as shown here and here.

Affected Systems

All Santa Rosa based Lenovo Thinkpads using ICH8M I/O chipset are bios capped to 1.5Gbps link speed. Lenovo's reason being 'standardising' 1.5Gbps operation for ultrabay compatibility explained here.

The Solution

1. T61p's ICH8M I/O chipset's sata controller is capped to 1.5Gbps mode by the bios setting CAP.ISS to 1.5Gbps mode as shown here.

2. Request Lenovo community attempt to hack the bios byte(s) to change CAP.ISS to the 3Gbps setting. A previous request went out months ago on MydigitalLife here, a premier bios hacking community, with no useful response.

History

i. Lenovo advertised SATA-II capability with the T61p in the tabook shown here.

ii. Intel advertised ICH8M I/O chipset's SATA-II 3GBps performance as a key benefit of upgrading from ICH7M.

iii. Many are running the ultrabays with the Marvell 88SA8040 sata-to-pata chip with 3Gbps HDDs without any problems shown here and here.

iv. Same-gen HP 8510W also with the ICH8M I/O controller and FX570M graphics has SATA-II capability. Does this mean the 8510W bios would work on the T61P?

Note: I am not a T61P owner, just someone who was asked by T61P owners to investigate this problem.

Related: T61/X61 SATA II 1.5 GB/s cap - willing to pay for a solution NBR thread.
Last edited by nando4 on Thu Jul 22, 2010 8:50 am, edited 9 times in total.
Now: 12.1" HP 2510P U7600@1.5 2GB 128GB K3VLAR SSD + 500GB/caddy + GTX470/3dmark.vant=P5561 | Win7/64 XP.sp3 Ubuntu9.10
Next (2010): 12" 32nm + expresscard 2.0+GTX580/3dmark06=23k | X200 SSD+HDD | DIY ViDock

Harryc
Moderator Emeritus
Moderator Emeritus
Posts: 13228
Joined: Thu Apr 12, 2007 8:23 am
Location: Upstate New York

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#2 Post by Harryc » Sun Feb 14, 2010 3:25 am

Oh no, not the T61 SATA 1.5G cap discussion again ;-). If you do a forum search you'll see a couple of heated discussions from the past that led nowhere. This will most likely end up in the same bucket ... that is if an Admin doesn't lock it or delete it first.

nando4
Posts: 13
Joined: Wed Aug 19, 2009 12:36 am
Location: Sydney, Australia

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#3 Post by nando4 » Sun Feb 14, 2010 3:34 am

Harryc wrote:Oh no, not the T61 SATA 1.5G cap discussion again ;-). If you do a forum search you'll see a couple of heated discussions from the past that led nowhere. This will most likely end up in the same bucket ... that is if an Admin doesn't lock it or delete it first.
This thread is a straightforward technical request of the Lenovo community. Hopefully a Lenovo lover with bios hacking/disassembly ability will develop a solution. Linked ICH8M I/O chipset details show exactly what needs to be done.
Now: 12.1" HP 2510P U7600@1.5 2GB 128GB K3VLAR SSD + 500GB/caddy + GTX470/3dmark.vant=P5561 | Win7/64 XP.sp3 Ubuntu9.10
Next (2010): 12" 32nm + expresscard 2.0+GTX580/3dmark06=23k | X200 SSD+HDD | DIY ViDock

Harryc
Moderator Emeritus
Moderator Emeritus
Posts: 13228
Joined: Thu Apr 12, 2007 8:23 am
Location: Upstate New York

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#4 Post by Harryc » Sun Feb 14, 2010 3:38 am

Yeah, good luck with that.

JaneL
Admin
Admin
Posts: 4996
Joined: Thu Apr 15, 2004 4:40 am
Location: Greenville SC

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#5 Post by JaneL » Sun Feb 14, 2010 10:52 am

Harry, Nando4 asked if he could post this, and Bill and I decided he could under some strict limits which he has adhered to. It's just going to be an effort to work on a community-developed BIOS hack. If the thread strays off into territory that has already been beaten to death, Nando4 knows it will be locked, so the rest of you, please stay within the guidelines.

Thanks - Jane
Jane
2015 X1 Carbon, ThinkPad Slate, T410s, X301, X300, X200 Tablet, T60p, HP TouchPad, iPad Air 2, iPhone 5S, IdeaTab A2107A, Yoga 3 Pro
Bill Morrow's thinkpads.com Facebook group
I'm on Twitter

I do NOT respond to PM or e-mail requests for personal tech support.

andykrej
Freshman Member
Posts: 101
Joined: Tue Mar 31, 2009 4:28 am
Location: Copenhagen, Denmark

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#6 Post by andykrej » Sat Mar 13, 2010 5:39 pm

So does any one now if there has ever been an atempt on modifying the BIOS?

I found the CAP registers on my X61s using BAR-edit, and yes, they are set to 01h. As I expected, changing them to 00h or 02h doesn't work. The first instance at ABAR offset 00h bits 20:23 changes itself back to 01h , but the second instance at +22Ch can be changed, but that doesn't help us as the speed has to be renegotiated.

I'm not that familiar with BIOS tools, but I can't see why it should be that difficult to change the CAP.ISS register at boot up.
X62s / SXGA+ Xiphmont / i7-5500u / Samsung 840 pro/ 16GB
T61 / QXGA IPS / 2.4GHz / 8GB

nando4
Posts: 13
Joined: Wed Aug 19, 2009 12:36 am
Location: Sydney, Australia

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#7 Post by nando4 » Sun Jul 18, 2010 6:39 pm

Modded T61p bios for SATA-II 3.0Gbps now exists

middleton has posted on NBR that he has a modded bios to give T61P full 3.0Gbps SATA-II capability. See here.
Now: 12.1" HP 2510P U7600@1.5 2GB 128GB K3VLAR SSD + 500GB/caddy + GTX470/3dmark.vant=P5561 | Win7/64 XP.sp3 Ubuntu9.10
Next (2010): 12" 32nm + expresscard 2.0+GTX580/3dmark06=23k | X200 SSD+HDD | DIY ViDock

crashnburn
ThinkPadder
ThinkPadder
Posts: 1643
Joined: Sat Apr 22, 2006 4:26 pm
Location: TX, USA & Bombay, India

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#8 Post by crashnburn » Mon Jul 19, 2010 11:38 am

nando4 wrote:Modded T61p bios for SATA-II 3.0Gbps now exists

middleton has posted on NBR that he has a modded bios to give T61P full 3.0Gbps SATA-II capability. See here.
Interesting. Anyone else here tried it out?
T61 8892-02U: 14.1"SXGA+/2.2C2D/4G/XP|Adv Mini Dock|30" Gateway XHD3000 WQXGA via Dual-link DVI
X61T 7767-96U: 12.1"SXGA+/1.6C2D/3G/Vista|Ultrabase
W510 4319-2PU: 15.6"FHD/i7-720QM/4G/Win7Pro64 (for dad)
T43 1875-DLU: 14.1"XGA/1.7PM-740/1G/XP (Old)

jketzetera
Sophomore Member
Posts: 215
Joined: Tue Oct 30, 2007 11:29 pm
Location: Sydney Australia

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#9 Post by jketzetera » Tue Jul 20, 2010 8:36 pm

I have and it works.

crashnburn
ThinkPadder
ThinkPadder
Posts: 1643
Joined: Sat Apr 22, 2006 4:26 pm
Location: TX, USA & Bombay, India

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#10 Post by crashnburn » Wed Jul 21, 2010 10:27 am

jketzetera wrote:I have and it works.
Care to share :)
T61 8892-02U: 14.1"SXGA+/2.2C2D/4G/XP|Adv Mini Dock|30" Gateway XHD3000 WQXGA via Dual-link DVI
X61T 7767-96U: 12.1"SXGA+/1.6C2D/3G/Vista|Ultrabase
W510 4319-2PU: 15.6"FHD/i7-720QM/4G/Win7Pro64 (for dad)
T43 1875-DLU: 14.1"XGA/1.7PM-740/1G/XP (Old)

jketzetera
Sophomore Member
Posts: 215
Joined: Tue Oct 30, 2007 11:29 pm
Location: Sydney Australia

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#11 Post by jketzetera » Thu Jul 22, 2010 11:05 pm

The author has published the patched BIOS in the thread referenced by Nando4 in his first post.

crashnburn
ThinkPadder
ThinkPadder
Posts: 1643
Joined: Sat Apr 22, 2006 4:26 pm
Location: TX, USA & Bombay, India

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#12 Post by crashnburn » Fri Jul 23, 2010 7:11 am

jketzetera wrote:I have and it works.
Which T61 and what hardware are you using it on?
T61 8892-02U: 14.1"SXGA+/2.2C2D/4G/XP|Adv Mini Dock|30" Gateway XHD3000 WQXGA via Dual-link DVI
X61T 7767-96U: 12.1"SXGA+/1.6C2D/3G/Vista|Ultrabase
W510 4319-2PU: 15.6"FHD/i7-720QM/4G/Win7Pro64 (for dad)
T43 1875-DLU: 14.1"XGA/1.7PM-740/1G/XP (Old)

koray
Posts: 22
Joined: Tue Aug 11, 2009 12:55 pm

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#13 Post by koray » Tue Aug 10, 2010 10:54 am

I can confirm it works with X61 Tablet, too.

K.
X61T SXGA+ IPS Intel X25-M 80GB, X60s, T60

j_bravo14
Posts: 3
Joined: Fri Aug 13, 2010 8:02 pm
Location: Atlanta, GA

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#14 Post by j_bravo14 » Mon Aug 16, 2010 7:22 am

I have it also on my T61 7662 and it works. Using an OCZ vertex 60gb @ 230 mbps :)

Radioguy
ThinkPadder
ThinkPadder
Posts: 1101
Joined: Fri Feb 29, 2008 2:45 pm
Location: Brooklyn, New York

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#15 Post by Radioguy » Tue Aug 17, 2010 5:05 am

Hmm...this looks as if it includes the whitelist hack Zender offers. If you have a T61, wouldn't it be preferable to choose this hacked bios over his?
  • T61 - 6465CTO - T9500 - 15.4" LG WSXGA+ - 8GB OCZ- 120GB EVO 850 SSD - X3100 - Win 8.1 Pro 64-bit
    X301 - 2774W8Q - U9400 - 13.3" BOEHYDIS WXGA - 8GB Elpida - 128GB C400 mSATA SSD - 4500MHD - Win 10 Pro 64-Bit

crashnburn
ThinkPadder
ThinkPadder
Posts: 1643
Joined: Sat Apr 22, 2006 4:26 pm
Location: TX, USA & Bombay, India

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#16 Post by crashnburn » Wed Aug 18, 2010 8:38 pm

Radioguy wrote:Hmm...this looks as if it includes the whitelist hack Zender offers. If you have a T61, wouldn't it be preferable to choose this hacked bios over his?
Thats what I am thinking. It clears several stupid "locks" by Lenovo.
T61 8892-02U: 14.1"SXGA+/2.2C2D/4G/XP|Adv Mini Dock|30" Gateway XHD3000 WQXGA via Dual-link DVI
X61T 7767-96U: 12.1"SXGA+/1.6C2D/3G/Vista|Ultrabase
W510 4319-2PU: 15.6"FHD/i7-720QM/4G/Win7Pro64 (for dad)
T43 1875-DLU: 14.1"XGA/1.7PM-740/1G/XP (Old)

Radioguy
ThinkPadder
ThinkPadder
Posts: 1101
Joined: Fri Feb 29, 2008 2:45 pm
Location: Brooklyn, New York

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#17 Post by Radioguy » Wed Aug 18, 2010 10:52 pm

Yes, I have less reason than most to flash right now (No SSD, and have a Lenovo approved WLAN card), but as it becomes more encompassing, and the reports of successful flashes continue, I feel more tempted (Though I doubt I will, unless I upgrade one of the key components).

However, if this hack could also uncripple the audio, there would be dancing in the streets.
  • T61 - 6465CTO - T9500 - 15.4" LG WSXGA+ - 8GB OCZ- 120GB EVO 850 SSD - X3100 - Win 8.1 Pro 64-bit
    X301 - 2774W8Q - U9400 - 13.3" BOEHYDIS WXGA - 8GB Elpida - 128GB C400 mSATA SSD - 4500MHD - Win 10 Pro 64-Bit

Kamika007z
Junior Member
Junior Member
Posts: 353
Joined: Fri Apr 07, 2006 9:04 am
Location: NJ
Contact:

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#18 Post by Kamika007z » Thu Aug 19, 2010 8:30 am

When you say audio, do you mean SPDIF?

Installed and running perfectly fine.

While I have a Lenovo/IBM approved WLAN card, and have a board that accepts Penryn-based CPUs, I do have a Momentus XT hdd that runs at SATA-II well.

I believe Zender started it all with understanding and breaking down the BIOS, so without his efforts, we would not make it this far - so thank you Zender!

I would recommend this BIOS over Zender's since its a newer version (2.27), and it may seem that he stopped updating his, includes the WLAN mod, as well as additional ones (SLIC v2, Thermal, and of course SATA-II).

Hope this helps!
T61p [8891-CTO]: Intel X9000 (2.8GHz) CPU, 8GB RAM, 128GB OCZ Vertex 2 SSD, 14.1in 1400x1050 (4:3) Modified Symmetrical LCD cover & bezel, nVidia FX 570M, DVDRW, Intel 6300 WiFi, BT, FR, Windows 7, SLIC2.1, Unlocked SATA II middleton BIOS, WLAN Whitelist Modified. Mint Condition.

Radioguy
ThinkPadder
ThinkPadder
Posts: 1101
Joined: Fri Feb 29, 2008 2:45 pm
Location: Brooklyn, New York

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#19 Post by Radioguy » Sat Aug 21, 2010 5:07 am

Kamika007z wrote:When you say audio, do you mean SPDIF?
No, Stereo Mix. There's a big thread about it here:

http://forum.thinkpads.com/viewtopic.php?f=18&t=52527

Of course, it's not a BIOS issue, which is what would make this such an amazing fix if included. :mrgreen:
  • T61 - 6465CTO - T9500 - 15.4" LG WSXGA+ - 8GB OCZ- 120GB EVO 850 SSD - X3100 - Win 8.1 Pro 64-bit
    X301 - 2774W8Q - U9400 - 13.3" BOEHYDIS WXGA - 8GB Elpida - 128GB C400 mSATA SSD - 4500MHD - Win 10 Pro 64-Bit

eyeland
Sophomore Member
Posts: 178
Joined: Mon Sep 07, 2009 11:02 am
Location: Copenhagen, Denmark

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#20 Post by eyeland » Mon Sep 06, 2010 7:55 am

So with this modded bios, will I be able to use an intel x25-m or v alongside a seagate momentus in the ultrabay at full speeds?
W530 FHD - 32GB Ram - K2000m - >1TBSSD |
Modded T61| Scarlet Saffire 6i6-Phillips IPS | Win10x64
---
daybreak broke me loose and brought me back...

crashnburn
ThinkPadder
ThinkPadder
Posts: 1643
Joined: Sat Apr 22, 2006 4:26 pm
Location: TX, USA & Bombay, India

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#21 Post by crashnburn » Tue Sep 07, 2010 9:33 am

Whats wrong with this picture?

Crystal HD Report:

-----------------------------------------------------------------------
CrystalDiskMark 3.0 (C) 2007-2010 hiyohiyo
Crystal Dew World : http://crystalmark.info/
-----------------------------------------------------------------------
* MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]

Sequential Read : 57.056 MB/s
Sequential Write : 55.061 MB/s
Random Read 512KB : 19.149 MB/s
Random Write 512KB : 18.755 MB/s
Random Read 4KB (QD=1) : 0.305 MB/s [ 74.5 IOPS]
Random Write 4KB (QD=1) : 0.895 MB/s [ 218.6 IOPS]
Random Read 4KB (QD=32) : 0.692 MB/s [ 168.9 IOPS]
Random Write 4KB (QD=32) : 0.897 MB/s [ 218.9 IOPS]

Test : 1000 MB [C: 35.0% (98.1/280.3 GB)] (x5)
Date : 2010/09/07 20:01:00
OS : Windows XP Professional SP3 [5.1 Build 2600] (x86)
T61 8892-02U: 14.1"SXGA+/2.2C2D/4G/XP|Adv Mini Dock|30" Gateway XHD3000 WQXGA via Dual-link DVI
X61T 7767-96U: 12.1"SXGA+/1.6C2D/3G/Vista|Ultrabase
W510 4319-2PU: 15.6"FHD/i7-720QM/4G/Win7Pro64 (for dad)
T43 1875-DLU: 14.1"XGA/1.7PM-740/1G/XP (Old)

frankiepankie
Junior Member
Junior Member
Posts: 448
Joined: Mon Apr 09, 2007 11:50 am
Location: The Netherlands

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#22 Post by frankiepankie » Wed Oct 27, 2010 6:46 am

This is one kickass mod :eek:

I am very enthousiast to try this on my T61, because i have a 40GB Intel SSD installed, and i am currently not getting the full performance out of it because of the SATA-I barrier.

But i still have a few questions:
  • Will this work with my T61 (7665-Y4F)
  • Am i able to 'downgrade' back to the original Lenovo BIOS if i am not happy with the modded BIOS ?
  • Does it have any negative side effects on the 320GB WD HDD that i have installed in my Ultrabay ?
Okay, i was too enthousiastic to wait :lol: , so i tried it and it works!
For some comparison screenshots:

HD Tune
http://tweakers.net/ext/f/ePWZKSAQOUC9i ... J/full.jpg

CrystalDiskMark:
http://tweakers.net/ext/f/JNOeNXAduwj81 ... L/full.jpg

Intel Rapid Storage Technology:
http://tweakers.net/ext/f/25FTCbECIe859 ... T/full.jpg


The only problem i am facing is that the Ultrabay is on very slow speed, compared to before applying the modified BIOS.

Before the modified BIOS my WD3200BEVT that is in the Ultrabay would have 64MB/sec read speed, now only 13MB/sec :cry:
I guess something is going wrong with DMA / PIO
Okay, the Ultrabay problem was fixed by resetting the BIOS to defaults. Now all is working very good, and at very high speed :twisted:
Lenovo ThinkPad T410

eyeland
Sophomore Member
Posts: 178
Joined: Mon Sep 07, 2009 11:02 am
Location: Copenhagen, Denmark

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#23 Post by eyeland » Fri Nov 12, 2010 10:19 am

Great work by those involved!
Any new experiences? Is this being treated in another thread here?(seems odd with such few replis if it finally works with no negative experiences unsolved?)
My fingers are itching to order an SSD and try this mod, but atm my t61 is my only machine so I remain cautious...
Furthermore, this may be a silly question but I am running Win7x64U alongside Ubuntustudio using Grub - anything to be aware of in that regard if I choose to go ahead with the hack?
Thanks and thanks :)
W530 FHD - 32GB Ram - K2000m - >1TBSSD |
Modded T61| Scarlet Saffire 6i6-Phillips IPS | Win10x64
---
daybreak broke me loose and brought me back...

Turboqueef
Freshman Member
Posts: 109
Joined: Sun Nov 12, 2006 5:54 pm
Location: Otsego, Michigan
Contact:

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#24 Post by Turboqueef » Sat Nov 13, 2010 10:34 am

Is anyone working on a bios hack for the T60 series?

Thanks,
Jeff B
W510 4318-CTO i7 720QM, Win7 64, SSD, Passmark Rating: 1338 & 1398 (OC graphics)
SOLD>>>T60p 2623-DDU, T7600, Win7 64, SSD, Passmark Rating: 835.5
05 STi 11.44 @ 123.6

frankiepankie
Junior Member
Junior Member
Posts: 448
Joined: Mon Apr 09, 2007 11:50 am
Location: The Netherlands

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#25 Post by frankiepankie » Sat Nov 13, 2010 10:54 am

T60 isn't able to run at SATA-II mode, the controller hasn't got support for SATA-II.

In T61 the controller is able to run at SATA-II, but Lenovo has disabled it to ensure maximum compatibility with Ultrabay devices.
Lenovo ThinkPad T410

eyeland
Sophomore Member
Posts: 178
Joined: Mon Sep 07, 2009 11:02 am
Location: Copenhagen, Denmark

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#26 Post by eyeland » Thu Nov 18, 2010 11:59 am

Any of the people involved in this project still following this thread?
W530 FHD - 32GB Ram - K2000m - >1TBSSD |
Modded T61| Scarlet Saffire 6i6-Phillips IPS | Win10x64
---
daybreak broke me loose and brought me back...

carthikv12
Posts: 5
Joined: Wed Mar 24, 2010 3:42 am
Location: Chennai, India

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#27 Post by carthikv12 » Fri Dec 17, 2010 3:55 pm

SSD firmware update utility - launched on 12th November 2010

http://www-307.ibm.com/pc/support/site. ... MIGR-69806

So what exactly is this update?
Is it unlocking SATA II officially?
Or is it just to better support SSD features, disable defragment etc?

frankiepankie
Junior Member
Junior Member
Posts: 448
Joined: Mon Apr 09, 2007 11:50 am
Location: The Netherlands

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#28 Post by frankiepankie » Fri Dec 17, 2010 6:36 pm

It is an update for the firmware of the SSD, not of the system unfortunately.

If you look in the changelog that came with the SSD: http://download.lenovo.com/ibmdl/pub/pc ... ss20en.txt you will see that they state the modelnumbers of the SSD that the update supports.

I guess it is for ThinkPads that came with an SSD out of the factory.


By the way, the BIOS hack where this topic is all about is still working fine on my T61 8) I haven't experienced any problems, and my Intel X25-V is working at a high speed 8)
Lenovo ThinkPad T410

carthikv12
Posts: 5
Joined: Wed Mar 24, 2010 3:42 am
Location: Chennai, India

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#29 Post by carthikv12 » Sat Dec 18, 2010 1:24 am

Ok thanks a lot! that clears stuff up...

Good to know that your T61 is still running strong Frankie, I'm curious, what change did you have to make to the bios exactly? I mean to allow the ultrabay to run at full speed?

You said you had to set it to default to make it work, so did you tweak some settings originally?? and revert back to default on the bios? What i mean is if i will have to do something in addition to a straightforward bios flash to have full speed primary as well as ultrabays...

Thanks again!
Carthik


PS: Anyone with this bios flashed on T61P have any feedback??

frankiepankie
Junior Member
Junior Member
Posts: 448
Joined: Mon Apr 09, 2007 11:50 am
Location: The Netherlands

Re: T61p bios hack for ICH8M SATA-II 3Gbps (+history)

#30 Post by frankiepankie » Sat Dec 18, 2010 9:35 am

I just flashed it, and then entered the bios and picked the option "Load setup defaults" and after that, changed the BIOS settings that i had changed before the flash (things like disable Recovery partition etc).
Lenovo ThinkPad T410

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad Utility Work Area”

Who is online

Users browsing this forum: No registered users and 1 guest