Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Post content not saved on back-forward

Got a question or suggestion about the forum? Ask or comment here, or
PM an admin or moderator.
Post Reply
Message
Author
dr_st
Moderator
Moderator
Posts: 7494
Joined: Sat Oct 29, 2005 6:20 am

Post content not saved on back-forward

#1 Post by dr_st » Wed Jan 11, 2017 8:41 am

One of the nice features of phpBB forums such as this one is that if you are in the middle of preparing a post, and hit 'back' (intentionally or accidentally), then 'forward' again, to go back to the reply page, the content entered in the reply form is saved. This works automatically, at least in Mozilla-based browsers, such as Firefox and Pale Moon, without any extensions installed.

I noticed a few days ago that this no longer works for me. If I hit back-forward, I am greeted with an empty post. I use Pale Moon 27.0.3, but I do not think it is a browser issue, since the same feature still works for me in other phpBB-based forums, such as VOGONS. The issue is also not limited to a single machine / OS.

Has anything changed recently in the forum software? Does it still work for other members?
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG, X61 7673-V2V
T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 19442
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: Post content not saved on back-forward

#2 Post by RealBlackStuff » Wed Jan 11, 2017 9:08 am

The accidental "back" happened to me this morning, and I also noticed that my post-text had "magically" disappeared.
I was using the previous PaleMoon 27.0.2.
I just updated to 27.0.3 while making this post, restarted PaleMoon while still making this post, and then went back and forth a few times, and it kept the text!
Posted it, then went back to check making changes.
Weird, the altered text disappeared with <= / =>, but the 'old' text remained.

rkawakami
Admin
Admin
Posts: 10135
Joined: Sun Jun 04, 2006 1:26 am
Location: San Jose, CA 95120 USA
Contact:

Re: Post content not saved on back-forward

#3 Post by rkawakami » Wed Jan 11, 2017 3:55 pm

Noticed this a little while ago and I attributed it to the recent upgrade of the forum server. I now make sure that I copy the contents of my posting, if it's more than a few lines long, every few minutes just in case I hit the wrong key.
Ray Kawakami
X22 X24 X31 X41 X41T X60 X60s X61 X61s X200 X200s X300 X301 Z60m Z61t Z61p 560 560Z 600 600E 600X T21 T22 T23 T41 T60p T410 T420 T520 W500 W520 R50 A21p A22p A31 A31p
NOTE: All links to PC-Doctor software hosted by me are dead. Files removed 8/28/12 by manufacturer's demand.

dr_st
Moderator
Moderator
Posts: 7494
Joined: Sat Oct 29, 2005 6:20 am

Re: Post content not saved on back-forward

#4 Post by dr_st » Sun Dec 24, 2017 1:37 pm

It appears that the problem of losing post content persists on both Pale Moon and Firefox, but seems to be working fine in Chrome.

Is there any way this can be investigated and fixed?
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG, X61 7673-V2V
T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

Thinkpad4by3
ThinkPadder
ThinkPadder
Posts: 1923
Joined: Sun Aug 09, 2015 9:25 am
Location: N. Bellmore, ny

Re: Post content not saved on back-forward

#5 Post by Thinkpad4by3 » Tue Jan 30, 2018 7:53 am

dr_st wrote:
Sun Dec 24, 2017 1:37 pm
It appears that the problem of losing post content persists on both Pale Moon and Firefox, but seems to be working fine in Chrome.

Is there any way this can be investigated and fixed?
I think that is because Chrome and Firefox save textboxes automatically and hog every bit of memory you have in the process.
Thinkpad4by3's Law of the Universe.

The efficiency of two screens equally sized with equal numbers if pixels are equal. The time spent by a 4:3 user complaining about 16:9 is proportional to the inefficiency working with a 16:9 display, therefore the amount of useful work extracted is equal.

dr_st
Moderator
Moderator
Posts: 7494
Joined: Sat Oct 29, 2005 6:20 am

Re: Post content not saved on back-forward

#6 Post by dr_st » Tue Jan 30, 2018 8:09 am

Thinkpad4by3 wrote:
Tue Jan 30, 2018 7:53 am
I think that is because Chrome and Firefox save textboxes automatically and hog every bit of memory you have in the process.
Pale Moon (like old Firefox) saves some kind of fields automatically. It used to do it here too, but not after the last upgrade.

What happens is that with time different implementations of text fields are added, and the browsers have to adjust their capabilities to keep up. Pale Moon is based on rather old Firefox code, and it seems lately that more and more things slip through the cracks, and the small development team cannot keep up.

On a broader sense, it seems that Chrome is winning the web. Chrome is the new Internet Explorer. 10-15 years ago the entire web was basically developed to work on IE first, and everything else was optional. Now Chrome is in the same position. The only reason Firefox still manages to sort-of keep up is because it works very hard to copy everything Chrome does.

In this particular case, I was hoping that something that can be adjusted in the forum software to allow old browsers to still be able to auto-save content, but apparently it isn't really possible (or there is no sufficient expertise). Oh well.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG, X61 7673-V2V
T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 19442
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: Post content not saved on back-forward

#7 Post by RealBlackStuff » Tue Jan 30, 2018 9:05 am

I have now gone so far, that I opened up my mouse (M$ Intellimouse Explorer 3.0) and blocked the "page forward" and "page backward" buttons on the left side of that mouse.
Those buttons turned out to be my problem
Hurray, no more loss of post content! :banana:

Thinkpad4by3
ThinkPadder
ThinkPadder
Posts: 1923
Joined: Sun Aug 09, 2015 9:25 am
Location: N. Bellmore, ny

Re: Post content not saved on back-forward

#8 Post by Thinkpad4by3 » Tue Jan 30, 2018 10:05 am

RealBlackStuff wrote:
Tue Jan 30, 2018 9:05 am
I have now gone so far, that I opened up my mouse (M$ Intellimouse Explorer 3.0) and blocked the "page forward" and "page backward" buttons on the left side of that mouse.
Those buttons turned out to be my problem
Hurray, no more loss of post content! :banana:
How can I do that on the classic keyboard? Too many times I hit the back key aiming for one of the others.
Thinkpad4by3's Law of the Universe.

The efficiency of two screens equally sized with equal numbers if pixels are equal. The time spent by a 4:3 user complaining about 16:9 is proportional to the inefficiency working with a 16:9 display, therefore the amount of useful work extracted is equal.

jaspen-meyer
Senior Member
Senior Member
Posts: 829
Joined: Wed May 19, 2010 11:21 pm
Location: Pardubice, Czech Republic
Contact:

Re: Post content not saved on back-forward

#9 Post by jaspen-meyer » Tue Jan 30, 2018 11:06 am

There are ways to recover posts. Easiest is with a browser plugin.

edit:
I tested the following on my sites and it worked. I'm not sure if it'd work here, with this site's javascript. The solution is autocomplete="on". Here is a mock-up of the updated phpBB code:

<form action="./posting.php..." method="post" name="postform" autocomplete="on">

<textarea name=asdf value=''>

</form>
T420 i7 3612QM seabios; T420 i7 3630QM; T400 Q9100 seabios; T61 P9600; T60 libreboot; x62; x60s libreboot, led; x24 xiphmont led

Post Reply

Return to “Forum Notices, Questions and Suggestions”

Who is online

Users browsing this forum: No registered users and 1 guest