Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Sysprepbackup Accessory Package? Do I need to install it?

Work/comment area for scripts and utilities like TP Fan, 2-finger scrolling, etc
Post Reply
Message
Author
barrywohl
Junior Member
Junior Member
Posts: 445
Joined: Tue Mar 06, 2007 8:01 am
Location: Sheridan, WY
Contact:

Sysprepbackup Accessory Package? Do I need to install it?

#1 Post by barrywohl » Mon Nov 21, 2011 7:56 pm

I just upgraded from Rescue and Recovery 4.31 to 4.50 on my X201t which came with Win 7 Pro x64 and R&R 4.3 or earlier. I did the upgrade due to R&R 4.31 getting stuck at "gathering data...".

The 4.50 download page suggests I might need to run the Sysprepbackup Accessory Package, but I can't figure out whether I do or not. After the upgrade to 4.50 the Thinkvantage button worked normally during the boot up "ThinkPad" flast screen and launched R&R 4.50.

This is the paragraph I have found mystifying:

"•The Sysprepbackup operation changes in the Windows 7 operating system because a new version of Windows Recovery Environment (Windows RE) is built in the Windows 7 operating system. When you run the System Preparation Tool (Sysprep) and use the /generalize option, the Sysprep operation disables Windows RE by removing the Boot Configuration Data (BCD) entry to the Rescue and Recovery Pre Desktop Area (PDA). To make the Rescue and Recovery program work with Sysprepbackup in the Windows 7 operating system, you must download and install the Sysprepbackup accessory package."
from: http://support.lenovo.com/en_US/detail. ... IGR-4Q2QAK

Am I good to go without running the Sysprepbackup Accessory Package or should I run it even though nothing seems broken now?

Barry in Sheridan Wyoming
First Thinkpad 755CX in 1995. First IBM: PC 1982 8088 w 64K RAM, dual floppy. Currently in use:
X230T with Win8Pro x64, i7, 500gb ssd; W700 WUXGA RAID 1 Blu-Ray W7Pro x64, occasionally a T61p with Win7Pro x64

Scott_Y
Posts: 1
Joined: Wed Dec 14, 2011 10:42 am
Location: Boulder, Colorado

#2 Post by Scott_Y » Wed Dec 14, 2011 11:27 am

Did you ever find an answer to your question, Barry? I'm in the same situation, and that paragraph about sysprepbackup is confusing to me too. Quite obscure. I've searched around on the Web, but I haven't found a clear explanation. My feeling is it is not needed if one is simply upgrading an existing Rescue and Recovery -- but that's mostly a guess.

It would be helpful if someone could explain when running the Sysprepbackup Accessory Package is needed, and when not.

Specifically, is it needed when upgrading from Rescue and Recovery 4.3x to 4.5 (Win7 x64)?

barrywohl
Junior Member
Junior Member
Posts: 445
Joined: Tue Mar 06, 2007 8:01 am
Location: Sheridan, WY
Contact:

Re: Sysprepbackup Accessory Package? Do I need to install it?

#3 Post by barrywohl » Wed Dec 14, 2011 12:25 pm

I did not do the Sysprep... installation. My X201T has been fine. When I boot into the R&R utilities instead of Windows 7 Pro, it shows I'm running the upgraded R&R.

Barry
First Thinkpad 755CX in 1995. First IBM: PC 1982 8088 w 64K RAM, dual floppy. Currently in use:
X230T with Win8Pro x64, i7, 500gb ssd; W700 WUXGA RAID 1 Blu-Ray W7Pro x64, occasionally a T61p with Win7Pro x64

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad Utility Work Area”

Who is online

Users browsing this forum: No registered users and 2 guests