Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Not charging battery in T23

T20-T23 Series and T30 specific matters only. NOT for T25-Retro.
Message
Author
kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1662
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: Not charging battery in T23

#31 Post by kfzhu1229 » Wed Sep 16, 2020 4:26 pm

b1ack0p wrote:
Wed Sep 16, 2020 2:25 pm
So motherboard is good right? Problem is the battery? So can i assemble back the T23 now? :)
If you have it torn down to bits, try plugging the main battery in the Ultrabay battery connector. The connector for these (and in fact, T4x batteries as well) are exactly the same, just the size of each battery determines everything, so no need to worry about burning out anything.
If it charges just fine in the Ultrabay battery connector, then clearly something is wrong with the motherboard. Otherwise, you are looking at replacing the battery.
Dell Lat CP MMX-233 64mb 40gb W2k
600 PII-266 416mb 40gb WXP
T23 PIII 1.13ghz 1gb W7
Lat D830 X9000 8gb 128gb WSXGA+ Ultrasharp fp W10
T530i 15.6" i7 16gb fp W10
UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10 (Sharp)
Lat C840 P4-2.5 2gb 60gb W7 (Ultrasharp)

cadillacmike68
ThinkPadder
ThinkPadder
Posts: 1154
Joined: Fri May 27, 2011 9:19 pm
Location: Florida

Re: Not charging battery in T23

#32 Post by cadillacmike68 » Thu Sep 17, 2020 11:55 am

This is why I have more than one of any series. I can swap out known good items to see where the problem goes or stays.
600, 600X
760LD FUBARd
T21 2647 T22 2647 1@ 1GHz SXGA+ 4 more; T23 2647 1@ 1.2GHz SXGA+ 3 more
T30 2366-88U 2GHz; 2366-83U 1.8G; 5@ 2366-LU0/66U; 2367-KU6 FUBARd
T41 T42 T43
T61 8897 2.4GHz SXGA+; 8898 2.4Ghz; 6463 2@ WSXGA+; 7658 2.5GHz; T61p; 6 more T61s
T500 2
T530 W530

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1662
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: Not charging battery in T23

#33 Post by kfzhu1229 » Thu Sep 17, 2020 4:23 pm

cadillacmike68 wrote:
Thu Sep 17, 2020 11:55 am
This is why I have more than one of any series. I can swap out known good items to see where the problem goes or stays.
Well I have testbench bare motherboards for this purpose. While a T2x battery does not physically fit into a A3x chassis for example, it does fit and work just fine on a bare motherboard. Same thing is true for the Dells. I have a A30 motherboard with a failed video chip so for charging purposes it does the job just fine, and I have spare inverter and a crap 14.1" XGA cable so that the battery LED can be displayed
Dell Lat CP MMX-233 64mb 40gb W2k
600 PII-266 416mb 40gb WXP
T23 PIII 1.13ghz 1gb W7
Lat D830 X9000 8gb 128gb WSXGA+ Ultrasharp fp W10
T530i 15.6" i7 16gb fp W10
UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10 (Sharp)
Lat C840 P4-2.5 2gb 60gb W7 (Ultrasharp)

b1ack0p
Posts: 33
Joined: Sun Aug 18, 2019 4:48 pm
Location: Istanbul, Turkey

Re: Not charging battery in T23

#34 Post by b1ack0p » Fri Sep 18, 2020 1:55 pm

i tested same battery on a spare T22 then after a while it charged up to %1 only. left for hours and no more charge.
my ThinkCollection: X20, X31, X40, X601s, X61, X230, T23, T42, T60

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1662
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: Not charging battery in T23

#35 Post by kfzhu1229 » Fri Sep 18, 2020 2:29 pm

b1ack0p wrote:
Fri Sep 18, 2020 1:55 pm
i tested same battery on a spare T22 then after a while it charged up to %1 only. left for hours and no more charge.
Try leaving the battery on the charge for like 30 mins - 1 hour and then disconnect and then reconnect. Repeat this for like 5 times.
If the battery still doesn't charge more than 1%, then I think what was happening was that the battery is trying to charge up but it can't because two or more of the cells have died due to overdischarging.
Dell Lat CP MMX-233 64mb 40gb W2k
600 PII-266 416mb 40gb WXP
T23 PIII 1.13ghz 1gb W7
Lat D830 X9000 8gb 128gb WSXGA+ Ultrasharp fp W10
T530i 15.6" i7 16gb fp W10
UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10 (Sharp)
Lat C840 P4-2.5 2gb 60gb W7 (Ultrasharp)

b1ack0p
Posts: 33
Joined: Sun Aug 18, 2019 4:48 pm
Location: Istanbul, Turkey

Re: Not charging battery in T23

#36 Post by b1ack0p » Fri Sep 18, 2020 7:06 pm

i had another T23 but non-working. fan spins, Z indicator light turns on on the keyboard but no display. so i plugged the battery on it and left it charging for about 40-45 mins. then i plugged it back to working T23, and battery showed 1% on IBM battery maximiser's gauge. then again i plugged the battery to non-working T23, battery indicator turned permanent orange light and after few seconds it turned to green light, and then it turned back to orange-blinking light.

What are these values below meaning at IBM Battery Maximiser software at Battery status section?

Battery 1 - Charging
Current : 0.00A
Voltage : 9.12V (probably because of 1% charge)
Wattage : 0.00W

Battery health shows - Green - The battery is in good condition ;

Device Chemistry : Li-ion
Full Charge Capacity : 25.96Wh
Design Capacity : 38.88Wh
Cycle Count : 304
First Used Date : 2001-11
my ThinkCollection: X20, X31, X40, X601s, X61, X230, T23, T42, T60

b1ack0p
Posts: 33
Joined: Sun Aug 18, 2019 4:48 pm
Location: Istanbul, Turkey

Re: Not charging battery in T23

#37 Post by b1ack0p » Sat Sep 19, 2020 8:35 am

i left the battery on charge during night on the working T23 while it was charged to 1% on another non-working T23 but in morning battery charge percentage was 0% again.. i still suspect that working-T23 mobo might have an issue.. i wonder why it didnt hold the 1% charge and let it drain to 0%.. this time Voltage decreased to 8.32V.

additional info; i tested hardware with PC Doctor v5 and all passed without issue..
my ThinkCollection: X20, X31, X40, X601s, X61, X230, T23, T42, T60

kfzhu1229
ThinkPadder
ThinkPadder
Posts: 1662
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: Not charging battery in T23

#38 Post by kfzhu1229 » Sat Sep 19, 2020 10:14 am

b1ack0p wrote:
Sat Sep 19, 2020 8:35 am
i wonder why it didnt hold the 1% charge and let it drain to 0%.. this time Voltage decreased to 8.32V.
This is for sure an issue with the battery and not the motherboard.
When a battery suffered from severe overdischarging, the remaining amount of capacity left inside the battery cells that the battery can charge up to is low enough that it can't even pass over the threshold of critical discharge voltage (which is the voltage that your battery would display as 0% charge remaining).
So a normal battery cell (18650) charges up to like 4.2V when it is declared as full, but for one of your overdischarged cells it might only charge up to like 2V instead, and then the capacity it has left is low enough that the tiny amounts of current drawn by the battery controller board is enough to drain it back down in no time. That's why in this case the battery's overall percentage can't go over like 1% and it doesn't hold 1% very well either.
In this case, either open up the battery and re-cell the battery before the battery controller declares the battery as totally dead, or just replace the battery.
Dell Lat CP MMX-233 64mb 40gb W2k
600 PII-266 416mb 40gb WXP
T23 PIII 1.13ghz 1gb W7
Lat D830 X9000 8gb 128gb WSXGA+ Ultrasharp fp W10
T530i 15.6" i7 16gb fp W10
UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10 (Sharp)
Lat C840 P4-2.5 2gb 60gb W7 (Ultrasharp)

b1ack0p
Posts: 33
Joined: Sun Aug 18, 2019 4:48 pm
Location: Istanbul, Turkey

Re: Not charging battery in T23

#39 Post by b1ack0p » Sat Sep 19, 2020 10:27 am

Thank you kfzhu1229

Then i can relax that motherboard is fine.
my ThinkCollection: X20, X31, X40, X601s, X61, X230, T23, T42, T60

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T20-T23 & T30 Series. NOT for T25-Retro”

Who is online

Users browsing this forum: No registered users and 31 guests