Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Dead T30 - powers on, no post, no beeps. Any ideas?

T20-T23 Series and T30. NOT for T25-Retro.
Post Reply
Message
Author
astral
Posts: 31
Joined: Mon Apr 25, 2022 4:51 pm
Location: Cleveland, Ohio

Dead T30 - powers on, no post, no beeps. Any ideas?

#1 Post by astral » Thu Aug 25, 2022 3:20 pm

Picked up a super cheap untested T30 and surprise surprise, it’s dead. It powers on, the fan begins to spin, and the power light stays on, but it never posts and never beeps. I already tried reflowing both RAM slots but no luck. Any ideas before I part it out?

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 23103
Joined: Mon Sep 18, 2006 5:17 am
Location: Loch Garman, Éire
Contact:

Re: Dead T30 - powers on, no post, no beeps. Any ideas?

#2 Post by RealBlackStuff » Fri Aug 26, 2022 12:30 am

Tried an external monitor?
Take out battery and wifi?
Lovely day for a Guinness! (The Real Black Stuff)
Lenovo: X240, X250, T440p, M900 Tiny (all with W7/SP1)

astral
Posts: 31
Joined: Mon Apr 25, 2022 4:51 pm
Location: Cleveland, Ohio

Re: Dead T30 - powers on, no post, no beeps. Any ideas?

#3 Post by astral » Fri Aug 26, 2022 9:02 am

Tried all that but still no luck. No external monitor output at all, stays off. If it was just a video issue I’d expect to still here a post beep, but oh well. I also managed to bridge some pins on the lower RAM slot, higher up on the plastic part and I kind of melted it a bit fixing them, so even if I could get the board working I’d likely only have one working slot. The bridge happened on a second attempt at reflowing though, and it still didn’t start after I tested it the first time.

It’s also missing the hard drive if that matters.

solidpro
Sophomore Member
Posts: 222
Joined: Thu Jun 11, 2020 11:46 am
Location: Milton Keynes, GB

Re: Dead T30 - powers on, no post, no beeps. Any ideas?

#4 Post by solidpro » Sat Aug 27, 2022 10:46 am

Isn't this one of those machines where the solder joints on the RAM cracks?
WANTED: 130, 220, 300 ,240Z, 235, 300C, 310x, 315D, 320, 330x, 345x, 350x, 355x, 360x, 365x, 385x, 390X,
ANY 5xx Series, 700, 700C, 701CS, 720, 720C, 730TE, 750, 750C, 750P, 755x, 760x, 765x, 770x
ANY 8xx Series, A20P, A21p, A22p, A30p, A31p, R30, R50, R50p, R52, T40p, X2x, X3x, X40

astral
Posts: 31
Joined: Mon Apr 25, 2022 4:51 pm
Location: Cleveland, Ohio

Re: Dead T30 - powers on, no post, no beeps. Any ideas?

#5 Post by astral » Sat Aug 27, 2022 2:45 pm

managed to get it to POST. I damaged the bottom slot though so only 1GB of RAM, but it's better than nothing. Not sure what fixed it.

kfzhu1229
Senior ThinkPadder
Senior ThinkPadder
Posts: 2340
Joined: Tue Sep 22, 2015 10:59 pm
Location: Toronto, Canada

Re: Dead T30 - powers on, no post, no beeps. Any ideas?

#6 Post by kfzhu1229 » Sat Aug 27, 2022 3:46 pm

astral wrote:
Sat Aug 27, 2022 2:45 pm
managed to get it to POST. I damaged the bottom slot though so only 1GB of RAM, but it's better than nothing. Not sure what fixed it.
The annoyance with this thing is that if one slot is cracked enough with the solder joints, even if you leave the slot blank you'd still get a power on and no POST no beep situation. You'd have to push that slot in just to hear the no RAM beeps
Dell Lat CP MMX-233 64mb 40gb W2k
600 PII-266 416mb 40gb WXP
T23 PIII 1.13ghz 1gb W7
Precision M4300 X9000 8gb 160gb WUXGA Ultrasharp fp W10
T530i 15.6" i7 16gb fp W10
UXGA:
A30p PIII 1.2 1gb W7 (IDTech)
T43p 2.26 2gb fp W10 (Sharp)
Lat C840 P4-2.5 2gb 60gb W7 (Ultrasharp)

astral
Posts: 31
Joined: Mon Apr 25, 2022 4:51 pm
Location: Cleveland, Ohio

Re: Dead T30 - powers on, no post, no beeps. Any ideas?

#7 Post by astral » Sat Aug 27, 2022 10:04 pm

luckily that hasn't happened with mine. If it quits booting in the future I can always reflow it again, but I'm not going to mess with it for the time being. 1GB is honestly plenty for my uses for the T30, and it's been a pretty nice and snappy system so far. The problem is that I bridged some pins on the lower slot with solder (on the plastic area) and trying to unbridge them melted the slot slightly. RAM still fits fine but isn't recognized. It's possible that something is still shorted, not making contact or needs to be reflowed but I'm not pushing it when I've already gotten this lucky. At least for now.

solidpro
Sophomore Member
Posts: 222
Joined: Thu Jun 11, 2020 11:46 am
Location: Milton Keynes, GB

Re: Dead T30 - powers on, no post, no beeps. Any ideas?

#8 Post by solidpro » Thu Sep 01, 2022 1:13 pm

I reflowed one once. It was a bit unnerving, but the trick is to try and do a single, clean sweep and don't go back for more...
WANTED: 130, 220, 300 ,240Z, 235, 300C, 310x, 315D, 320, 330x, 345x, 350x, 355x, 360x, 365x, 385x, 390X,
ANY 5xx Series, 700, 700C, 701CS, 720, 720C, 730TE, 750, 750C, 750P, 755x, 760x, 765x, 770x
ANY 8xx Series, A20P, A21p, A22p, A30p, A31p, R30, R50, R50p, R52, T40p, X2x, X3x, X40

astral
Posts: 31
Joined: Mon Apr 25, 2022 4:51 pm
Location: Cleveland, Ohio

Re: Dead T30 - powers on, no post, no beeps. Any ideas?

#9 Post by astral » Sun Sep 25, 2022 2:42 pm

1 month Update: Since it randomly began working, it has continued to, and not once failed to start. The second RAM slot may not work but I'm more than satisfied with what I got out of it for how cheap it was. 1GB is plenty and it's nice and fast.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T20-T23 & T30 Series. NOT for T25-Retro”

Who is online

Users browsing this forum: No registered users and 2 guests