Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

ThinkPad won't boot to Post

T20-T23 Series and T30 specific matters only. NOT for T25-Retro.
Post Reply
Message
Author
SEGA_Genesis
Posts: 9
Joined: Sun Mar 03, 2019 2:38 pm
Location: United States of America

ThinkPad won't boot to Post

#1 Post by SEGA_Genesis » Thu Jun 27, 2019 3:40 pm

I did something really stupid and reckless when messing with my ThinkPad T30...


I was messing around with the backlight inverter (which was messing up) with the power on. Yeah, stupid I know. Anyhow, I accidentally disconnected the cable going to the screen, and the one providing the inverter power was still in. I got a really weird "eeeerrrr" noise, and the inverter got hot and smelled burnt.

I pulled the power, then tried to boot back up. Nothing. The fan spins, but it doesn't boot to post. I checked with a flashlight to see if it was just because the inverter was blown and also tried using an external display to no avail. I tried pressing a bunch of keys, hitting the audio buttons, but no beeps, nothing. The only sign of life is the CPU fan.

I'm assuming that it's the motherboard, but I don't know where to look.

Yeah I know it was really stupid, I'm pee'd at myself as it is. Any help is appreciated.
Devices: IBM ThinkPad t30, IBM WorkPad (Palm III),
I am currently pursuing an IT degree, and I love toying around with hardwere, both classic and modern.
Discord:SEGA_Genesis#9816

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T2x & T3x Series. NOT for T25-Retro”

Who is online

Users browsing this forum: No registered users and 2 guests