Page 1 of 1

T61,Windows XP, after Middleton bios update wireless not working

Posted: Wed Aug 07, 2019 7:26 am
by HikerLT
Did the middleton bios upgrade on my T61, then installed a new 240Gb SSD, and reloaded the windows XP operating system.

Boots and runs a lot faster....BUT....

Problem -> can't get the wireless working.

Doing the my computer>properties>device manager - the network devices only show 1384 net adapter

Other devices show Unknown device "ACPI\IBM0068\5&2890D699&0

Any help and advice is appreciated

Re: T61,Windows XP, after Middleton bios update wireless not working

Posted: Wed Aug 07, 2019 12:42 pm
by TinkerMan
HikerLT wrote:
Wed Aug 07, 2019 7:26 am
Did the middleton bios upgrade on my T61, then installed a new 240Gb SSD, and reloaded the windows XP operating system.

Boots and runs a lot faster....BUT....

Problem -> can't get the wireless working.

Doing the my computer>properties>device manager - the network devices only show 1384 net adapter

Other devices show Unknown device "ACPI\IBM0068\5&2890D699&0

Any help and advice is appreciated
is that win xp 64 bit or 32 bit ?
if its the 32 bit , i dont understand why you did the Middleton, its wasting the T61 with a 32 bit XP
I also have an XP machine, but its a T60, which is a perfect match since the T60 cant use more then 3 gigs of ram

also it would help us to know what wireless card you have.

Re: T61,Windows XP, after Middleton bios update wireless not working

Posted: Wed Aug 07, 2019 1:06 pm
by ajkula66
Welcome to the forum!
HikerLT wrote:
Wed Aug 07, 2019 7:26 am
Did the middleton bios upgrade on my T61, then installed a new 240Gb SSD, and reloaded the windows XP operating system.

Boots and runs a lot faster....BUT....

Problem -> can't get the wireless working.

Doing the my computer>properties>device manager - the network devices only show 1384 net adapter

Other devices show Unknown device "ACPI\IBM0068\5&2890D699&0

Any help and advice is appreciated
That device doesn't seem to be your wireless card.

Is the wireless switch on ? Is the card enabled in BIOS ?
TinkerMan wrote:
Wed Aug 07, 2019 12:42 pm
is that win xp 64 bit or 32 bit ?
if its the 32 bit , i dont understand why you did the Middleton, its wasting the T61 with a 32 bit XP
Middleton's BIOS has absolutely nothing to do with one running a 32-bit vs. 64-bit OS. It is an excellent idea regardless of the OS. Why wouldn't one want SATA II transfer speeds and/or whitelists removed ?

Re: T61,Windows XP, after Middleton bios update wireless not working

Posted: Wed Aug 07, 2019 1:32 pm
by HikerLT
my T61 model is 7661-BF3

I donloaded and installed the wireless driver :

Intel Wireless LAN (abgn, abg, bg) for Windows XP - ThinkPad
Version
: 13.04.0000

Now I show wireless connectivity, but can not connect to any websites in Internet Explorer.

Running the Internet Explorer TOOLS > Diagnose Connection problems

result :

Windows cannot connect to the Internet using HTTP, HTTPS, or FTP. This is probably caused by firewall settings on this computer.

Check the firewall settings for the HTTP port (80), HTTPS port (443) and FTP port (21)



How do I check these settings ?

Thanks for the advice and help !

Re: T61,Windows XP, after Middleton bios update wireless not working

Posted: Wed Aug 07, 2019 2:16 pm
by TinkerMan
ajkula66 wrote:
Wed Aug 07, 2019 1:06 pm
TinkerMan wrote:
Wed Aug 07, 2019 12:42 pm
is that win xp 64 bit or 32 bit ?
if its the 32 bit , i dont understand why you did the Middleton, its wasting the T61 with a 32 bit XP
Middleton's BIOS has absolutely nothing to do with one running a 32-bit vs. 64-bit OS. It is an excellent idea regardless of the OS. Why wouldn't one want SATA II transfer speeds and/or whitelists removed ?
I never said that middleton bios has anything to do with 32 bit or 64 bit, you misread my comment,
I was saying that if he is using 32 bit it wont matter much, since he can only use 3 gigs of ram instead of 8 gigs.
that and also XP has several other limitations, which might be ok on an older T60, but using xp on a t61 is a waste.

Re: T61,Windows XP, after Middleton bios update wireless not working

Posted: Wed Aug 07, 2019 2:28 pm
by ajkula66
TinkerMan wrote:
Wed Aug 07, 2019 2:16 pm
I never said that middleton bios has anything to do with 32 bit or 64 bit, you misread my comment,
You said, emphasis mine:
if its the 32 bit , i dont understand why you did the Middleton, its wasting the T61 with a 32 bit XP
I was saying that if he is using 32 bit it wont matter much, since he can only use 3 gigs of ram instead of 8 gigs.
that and also XP has several other limitations, which might be ok on an older T60, but using xp on a t61 is a waste.
Regarding XP as an OS, that's your opinion which you're most certainly entitled to. However, the improvement in performance after applying Middleton's BIOS is not a matter of opinion, it's a proven fact. Nothing wasted there.
HikerLT wrote:
Wed Aug 07, 2019 1:32 pm
my T61 model is 7661-BF3

I donloaded and installed the wireless driver :

Intel Wireless LAN (abgn, abg, bg) for Windows XP - ThinkPad
Version
: 13.04.0000

Now I show wireless connectivity, but can not connect to any websites in Internet Explorer.
Try a different browser to begin with.

Should that fail, connect via wired LAN and verify whether you can get online.

Good luck.

Re: T61,Windows XP, after Middleton bios update wireless not working

Posted: Wed Aug 07, 2019 2:58 pm
by TinkerMan
ajkula66 wrote:
Wed Aug 07, 2019 2:28 pm
TinkerMan wrote:
Wed Aug 07, 2019 2:16 pm
I never said that middleton bios has anything to do with 32 bit or 64 bit, you misread my comment,
You said, emphasis mine:
if its the 32 bit , i dont understand why you did the Middleton, its wasting the T61 with a 32 bit XP
I was saying that if he is using 32 bit it wont matter much, since he can only use 3 gigs of ram instead of 8 gigs.
that and also XP has several other limitations, which might be ok on an older T60, but using xp on a t61 is a waste.
Regarding XP as an OS, that's your opinion which you're most certainly entitled to. However, the improvement in performance after applying Middleton's BIOS is not a matter of opinion, it's a proven fact. Nothing wasted there.
I agree that the M bios adds several improvements beyond the RAM, but I hope you would also agree that at this point its the win XP which is the biggest limiting factor for his machine.

Re: T61,Windows XP, after Middleton bios update wireless not working

Posted: Thu Aug 08, 2019 5:23 am
by TinkerMan
to the original poster, did you check to see if the wireless antenna wires are well connected to the wireless card?

Re: T61,Windows XP, after Middleton bios update wireless not working

Posted: Tue Aug 13, 2019 12:55 pm
by onespeedbiker
I did a search of "ACPI\IBM0068\5&2890D699&0" which turns out to be the IBM power management device; this should be the driver for it. https://support.lenovo.com/us/en/downloads/ds015022 As far as your wireless card, was this an existing card or was it added after the bios change? If it was the existing card, did it show in the Device Manager prior to the BIOS change?