Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Replaced CCFL but now the video cable is bad?

T60/T61 series specific matters only
Post Reply
Message
Author
fefrie
Junior Member
Junior Member
Posts: 476
Joined: Wed Jan 24, 2007 3:29 am
Location: Vancouver, Canada

Replaced CCFL but now the video cable is bad?

#1 Post by fefrie » Wed Sep 11, 2019 9:41 pm

Have a T60 with bluetooth, and the bluetooth ribbon part ripped, which may or may not be a red herring, as when I replaced the CCFL the first time, it worked with no problems for a year.

It burnt out a year later, so I went on to replace the ccfl again, and the light would only come on for a blip, then turn off and never come on again.

I have another non BT T60 and ran both inverters on it, with the new CCFL, and it worked.

So the CCFL is good, the two inverters are still good, the only thing different between the two are the video cable and the panel itself.

Question, do video cables go bad? and can I use an XGA, non BT video cable on a SXGA panel? I lose BT functionality of course, but can different spec panels share the same video cable?

Still baffled that the cable can go bad. Should I check something else out?
IBM Thinkpad T23 1.13 2647-9LU 640MB Ram 40GB hard drive SOLD!
T42 SXGA 1.7 64mb xp

fefrie
Junior Member
Junior Member
Posts: 476
Joined: Wed Jan 24, 2007 3:29 am
Location: Vancouver, Canada

Re: Replaced CCFL but now the video cable is bad?

#2 Post by fefrie » Thu Sep 19, 2019 9:45 pm

Weird condition.

Test 1

If I disconnect the video cable from the panel, but still leave the ccfl plugged in, and turn on the laptop with the panel with it flat on the keyboard,

It turns on and stays on. The panel is connected via the ccfl plug and it stays reliably lit.

I move the video cable (not attached to panel, and flick the inverter, and the panel stays lit.

I even shake the panel and it stays lit but if I put the panel vertical, the light turns off, and stays off no matter if I retry plugging it back in and out.

If I reset the laptop (via remote desktop), the panel lights up reliably again. Flat on the keyboard, no probems.

Right now I've got the laptop set for an 'always on' profile to keep the CCFL running, and hopefully 'burn in' any issues away.

My next step is to either buy another CCFL from a more reliable seller (any suggestions) or go with the assumption that the CCFL is good? and pull the non bluetooth T60 cable from the other T60 that I have, that is XGA.
IBM Thinkpad T23 1.13 2647-9LU 640MB Ram 40GB hard drive SOLD!
T42 SXGA 1.7 64mb xp

tfflivemb2
Moderator Emeritus
Moderator Emeritus
Posts: 5548
Joined: Thu Sep 01, 2005 1:17 pm
Location: Wisconsin
Contact:

Re: Replaced CCFL but now the video cable is bad?

#3 Post by tfflivemb2 » Fri Sep 20, 2019 3:20 pm

Have you inspected the wires that attach to the CCFL? It sounds like it might be trying to short out, with just the right angle...if I am reading your post right.

fefrie
Junior Member
Junior Member
Posts: 476
Joined: Wed Jan 24, 2007 3:29 am
Location: Vancouver, Canada

Re: Replaced CCFL but now the video cable is bad?

#4 Post by fefrie » Fri Sep 20, 2019 3:40 pm

Yes.

With the panel laying on the keyboard, I've banged around the ccfl wire into the inverter. It's pretty robust, however if I were to tap on it where it goes into the panel, it does change light output.

Which gives me thought, that I might be able to use the old plug and wires and solder them into the new ccfl and see if that works.

Overall, this process is pretty annoying, but for the hour or so I had it back, it was super nice to play on it again in a nice bright new screen.

I've been Remote Desktoping into it via a 7 inch tablet using a lenovo BT keyboard and mouse, and while that tiny piece of technology is amazing in it's own right, the T60 just feels nicer to use on a desk.
IBM Thinkpad T23 1.13 2647-9LU 640MB Ram 40GB hard drive SOLD!
T42 SXGA 1.7 64mb xp

tfflivemb2
Moderator Emeritus
Moderator Emeritus
Posts: 5548
Joined: Thu Sep 01, 2005 1:17 pm
Location: Wisconsin
Contact:

Re: Replaced CCFL but now the video cable is bad?

#5 Post by tfflivemb2 » Fri Sep 20, 2019 4:43 pm

I guess I was maybe picturing the wires being pinched, like I've seen on some other brand laptops.

At this point, it might be worth checking out the possibility of swapping the LCD altogether, if the CCFL is causing this many problems. I've seen a lot of "dead" T60s and T61s, so I am sure that you can pick up a machine and strip the LCD for a little more than the cost of another CCFL.

fefrie
Junior Member
Junior Member
Posts: 476
Joined: Wed Jan 24, 2007 3:29 am
Location: Vancouver, Canada

Re: Replaced CCFL but now the video cable is bad?

#6 Post by fefrie » Fri Sep 20, 2019 4:56 pm

Given that a thought. However SXGA panels are rare, and people selling on ebay know that. And there really aren't ones to be found.
IBM Thinkpad T23 1.13 2647-9LU 640MB Ram 40GB hard drive SOLD!
T42 SXGA 1.7 64mb xp

tfflivemb2
Moderator Emeritus
Moderator Emeritus
Posts: 5548
Joined: Thu Sep 01, 2005 1:17 pm
Location: Wisconsin
Contact:

Re: Replaced CCFL but now the video cable is bad?

#7 Post by tfflivemb2 » Fri Sep 20, 2019 8:12 pm

fefrie wrote:
Fri Sep 20, 2019 4:56 pm
Given that a thought. However SXGA panels are rare, and people selling on ebay know that. And there really aren't ones to be found.
What about SXGA+? And is yours a 14" or a 15"? 4:3?
Last edited by tfflivemb2 on Fri Sep 20, 2019 8:15 pm, edited 1 time in total.

fefrie
Junior Member
Junior Member
Posts: 476
Joined: Wed Jan 24, 2007 3:29 am
Location: Vancouver, Canada

Re: Replaced CCFL but now the video cable is bad?

#8 Post by fefrie » Fri Sep 20, 2019 8:15 pm

tfflivemb2 wrote:
Fri Sep 20, 2019 8:12 pm
fefrie wrote:
Fri Sep 20, 2019 4:56 pm
Given that a thought. However SXGA panels are rare, and people selling on ebay know that. And there really aren't ones to be found.
What about SXGA+?
Whatever 1400x1050 res is out there, I can't find it. All 1024x768 for a 14" panel
IBM Thinkpad T23 1.13 2647-9LU 640MB Ram 40GB hard drive SOLD!
T42 SXGA 1.7 64mb xp

tfflivemb2
Moderator Emeritus
Moderator Emeritus
Posts: 5548
Joined: Thu Sep 01, 2005 1:17 pm
Location: Wisconsin
Contact:

Re: Replaced CCFL but now the video cable is bad?

#9 Post by tfflivemb2 » Fri Sep 20, 2019 8:19 pm

ok, so that answers the edit to my post. You have a 14". I was going to say I have a 2623-D3U, that won't boot, but it has a 15" 1400x1050, with Bluetooth.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T6x Series”

Who is online

Users browsing this forum: No registered users and 16 guests