Page 1 of 1

Replaced CCFL but now the video cable is bad?

Posted: Wed Sep 11, 2019 9:41 pm
by fefrie
Have a T60 with bluetooth, and the bluetooth ribbon part ripped, which may or may not be a red herring, as when I replaced the CCFL the first time, it worked with no problems for a year.

It burnt out a year later, so I went on to replace the ccfl again, and the light would only come on for a blip, then turn off and never come on again.

I have another non BT T60 and ran both inverters on it, with the new CCFL, and it worked.

So the CCFL is good, the two inverters are still good, the only thing different between the two are the video cable and the panel itself.

Question, do video cables go bad? and can I use an XGA, non BT video cable on a SXGA panel? I lose BT functionality of course, but can different spec panels share the same video cable?

Still baffled that the cable can go bad. Should I check something else out?

Re: Replaced CCFL but now the video cable is bad?

Posted: Thu Sep 19, 2019 9:45 pm
by fefrie
Weird condition.

Test 1

If I disconnect the video cable from the panel, but still leave the ccfl plugged in, and turn on the laptop with the panel with it flat on the keyboard,

It turns on and stays on. The panel is connected via the ccfl plug and it stays reliably lit.

I move the video cable (not attached to panel, and flick the inverter, and the panel stays lit.

I even shake the panel and it stays lit but if I put the panel vertical, the light turns off, and stays off no matter if I retry plugging it back in and out.

If I reset the laptop (via remote desktop), the panel lights up reliably again. Flat on the keyboard, no probems.

Right now I've got the laptop set for an 'always on' profile to keep the CCFL running, and hopefully 'burn in' any issues away.

My next step is to either buy another CCFL from a more reliable seller (any suggestions) or go with the assumption that the CCFL is good? and pull the non bluetooth T60 cable from the other T60 that I have, that is XGA.

Re: Replaced CCFL but now the video cable is bad?

Posted: Fri Sep 20, 2019 3:20 pm
by tfflivemb2
Have you inspected the wires that attach to the CCFL? It sounds like it might be trying to short out, with just the right angle...if I am reading your post right.

Re: Replaced CCFL but now the video cable is bad?

Posted: Fri Sep 20, 2019 3:40 pm
by fefrie
Yes.

With the panel laying on the keyboard, I've banged around the ccfl wire into the inverter. It's pretty robust, however if I were to tap on it where it goes into the panel, it does change light output.

Which gives me thought, that I might be able to use the old plug and wires and solder them into the new ccfl and see if that works.

Overall, this process is pretty annoying, but for the hour or so I had it back, it was super nice to play on it again in a nice bright new screen.

I've been Remote Desktoping into it via a 7 inch tablet using a lenovo BT keyboard and mouse, and while that tiny piece of technology is amazing in it's own right, the T60 just feels nicer to use on a desk.

Re: Replaced CCFL but now the video cable is bad?

Posted: Fri Sep 20, 2019 4:43 pm
by tfflivemb2
I guess I was maybe picturing the wires being pinched, like I've seen on some other brand laptops.

At this point, it might be worth checking out the possibility of swapping the LCD altogether, if the CCFL is causing this many problems. I've seen a lot of "dead" T60s and T61s, so I am sure that you can pick up a machine and strip the LCD for a little more than the cost of another CCFL.

Re: Replaced CCFL but now the video cable is bad?

Posted: Fri Sep 20, 2019 4:56 pm
by fefrie
Given that a thought. However SXGA panels are rare, and people selling on ebay know that. And there really aren't ones to be found.

Re: Replaced CCFL but now the video cable is bad?

Posted: Fri Sep 20, 2019 8:12 pm
by tfflivemb2
fefrie wrote:
Fri Sep 20, 2019 4:56 pm
Given that a thought. However SXGA panels are rare, and people selling on ebay know that. And there really aren't ones to be found.
What about SXGA+? And is yours a 14" or a 15"? 4:3?

Re: Replaced CCFL but now the video cable is bad?

Posted: Fri Sep 20, 2019 8:15 pm
by fefrie
tfflivemb2 wrote:
Fri Sep 20, 2019 8:12 pm
fefrie wrote:
Fri Sep 20, 2019 4:56 pm
Given that a thought. However SXGA panels are rare, and people selling on ebay know that. And there really aren't ones to be found.
What about SXGA+?
Whatever 1400x1050 res is out there, I can't find it. All 1024x768 for a 14" panel

Re: Replaced CCFL but now the video cable is bad?

Posted: Fri Sep 20, 2019 8:19 pm
by tfflivemb2
ok, so that answers the edit to my post. You have a 14". I was going to say I have a 2623-D3U, that won't boot, but it has a 15" 1400x1050, with Bluetooth.