Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

T60/T61 series specific matters only
Post Reply
Message
Author
128MB
Posts: 35
Joined: Thu May 17, 2018 8:37 am
Location: Overpelt, Belgium

T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#1 Post by 128MB » Mon Apr 27, 2020 1:08 pm

I just spend 3 days getting the 2503 dock and gt1030 gpu working with my T60P and the results are amazing.
But now today i tried my Prodikeys DM PS/2 keyboard together with my generic logitech USB mouse and it didn't work.
And now all USB ports are dead, both dock and the laptop itself, plugged in the dock or not.

I can use the trackpad and the laptop keyboard but plug anything USB is not detected and the usb mouse optical led does not light up.
If i plug anything PS/2 in the dock it works fine same as any other port.

dr_st
Moderator
Moderator
Posts: 8430
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#2 Post by dr_st » Mon Apr 27, 2020 2:02 pm

See if you can make it come alive by undocking the laptop, turning it off completely, unplugging the battery, waiting a bit, then reconnecting the battery and booting without the dock.

Also, while doing the above check whether USB devices are detected in the BIOS.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

128MB
Posts: 35
Joined: Thu May 17, 2018 8:37 am
Location: Overpelt, Belgium

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#3 Post by 128MB » Tue Apr 28, 2020 12:33 pm

yeah now i get code 53 on all usb controllers. tried windows update and lenovo system update no luck, imma try and find the old driver again.
edit
I did get the original driver, removed all usb controllers in device manager, reinstalled and it gives the same code 53.
edit
system restore worked, now to go step by step and see where it goes wrong.
edit

I rebooted ONCE inside the dock without changing anything and back to square one.

dr_st
Moderator
Moderator
Posts: 8430
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#4 Post by dr_st » Tue Apr 28, 2020 2:01 pm

Code 53?
https://support.microsoft.com/en-us/hel ... in-windows
"This device has been reserved for use by the Windows kernel debugger"???

That's a weird thing to see.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

128MB
Posts: 35
Joined: Thu May 17, 2018 8:37 am
Location: Overpelt, Belgium

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#5 Post by 128MB » Tue Apr 28, 2020 2:07 pm

52

my bad

thats why i couldnt find anything on google ... silly me

dr_st
Moderator
Moderator
Posts: 8430
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#6 Post by dr_st » Tue Apr 28, 2020 3:37 pm

Code 52 is a digital signature error. Maybe some files got corrupted? Try running sfc /scannow from the command prompt.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

128MB
Posts: 35
Joined: Thu May 17, 2018 8:37 am
Location: Overpelt, Belgium

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#7 Post by 128MB » Wed Apr 29, 2020 12:48 am

ill try when i have some time tonight. funny thing is it happens when i boot inside the dock.

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21173
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#8 Post by RealBlackStuff » Wed Apr 29, 2020 1:14 am

What OS are you using?
T60p shouldn't have anything newer than W7.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

128MB
Posts: 35
Joined: Thu May 17, 2018 8:37 am
Location: Overpelt, Belgium

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#9 Post by 128MB » Wed Apr 29, 2020 4:04 am

W7 pro 64 bit
4gb ram
120gb kingston ssd
1gb seagate hdd in the drive slot and the dock has the dvd drive.

zoltan87
Sophomore Member
Posts: 216
Joined: Mon Oct 24, 2016 12:16 pm
Location: Plymouth, United Kingdom

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#10 Post by zoltan87 » Wed Apr 29, 2020 7:45 am

RealBlackStuff wrote:
Wed Apr 29, 2020 1:14 am
What OS are you using?
T60p shouldn't have anything newer than W7.
I use my T60 in a 2503 dock with Nvidia GT1030 running Windows 8.1 64 bit, and after the initial setup I have had zero issues using it as my main computer. Had to disable fast boot up, installed power manager in Windows 7 compatibility mode, and had to use an older version of onscreen display driver for brightness, volume etc. control icons to be displayed on the screen properly when I adjust them. But Win 8.1 really works perfectly fine after that. Unfortunately I have no idea how to solve the thread poster's usb issue, I just thought I will mention this so that people will know that Win 8.1 is still a compatible OS for the T60.
Thinkpad T60, 15" Flexview, with mods (Xiphmont's LED mod, T500 heatsink, cpu undervolt, reinforced frame)
Thinkpad T601, 15" Flexview, with mods (Xiphmont's LED mod, T500 heatsink, cpu pin mod for FSB change and undervolt, reinforced frame)
Thinkpad X32
Thinkpad A21e
NEC ProSpeed SX/20

128MB
Posts: 35
Joined: Thu May 17, 2018 8:37 am
Location: Overpelt, Belgium

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#11 Post by 128MB » Thu Apr 30, 2020 11:16 am

-system restore now fails to fix anything
-tried disabling the check for signed drivers: did not work
-tried removing the registry keys for upper and lower filter: not present
-removed the devices now i can't install them at all
-enabled windows update and tried updating the windows installation but it fails everytime and throws numerous error codes
-had one weird bluescreen for no reason i can think of...

so time to reinstall completely i guess

trying to boot from cd or getting into the bios gives me a blank screen ...

and windows setup can't find a harddisk ... even at default bios settings.

WTF seriously is this thing crumbling into pieces or what ?

dr_st
Moderator
Moderator
Posts: 8430
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#12 Post by dr_st » Thu Apr 30, 2020 1:25 pm

I hope you are trying all this without the dock.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

128MB
Posts: 35
Joined: Thu May 17, 2018 8:37 am
Location: Overpelt, Belgium

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#13 Post by 128MB » Thu Apr 30, 2020 1:35 pm

dr_st wrote:
Thu Apr 30, 2020 1:25 pm
I hope you are trying all this without the dock.
i am ...

dr_st
Moderator
Moderator
Posts: 8430
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#14 Post by dr_st » Thu Apr 30, 2020 2:24 pm

Given that it has started with USB glitches, check that the external USB ports are physically OK, and have no bent / broken connectors. Sometimes these cause shorts that can lead to POST failures.

Can you sometimes enter the BIOS? If so, is the hard drive visible in the BIOS boot order?
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

Dreadtafarian
Posts: 3
Joined: Thu Apr 30, 2020 4:40 pm
Location: Ljubljana, Slovenia

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#15 Post by Dreadtafarian » Thu Apr 30, 2020 5:30 pm

I have T60P 2007-93 G, T7400, 4gb ram 1600x1200 running windows 7. Used to be dead for a couple of years(one long two short beeps no boot) but I reheated the GPU and its working again. Installed the W500 fan and got the temps under load down by 25 degrees celsius. So that got me hyped up again, got an ssd installed and its killing it.

Also I have the advanced docking station with the 6570 inside. The issue is that the machine freezes randomly if I touch keyboard while testing the old games I used to play. The touchpad is freezing the machine even without the docking station so its disabled in bios. The v5200 fire gl is quite laggy and it doesnt have the drivers installed, so I believe that all these issues have something to do with the windows 7 drivers,but I am not sure about it. Will try to get a dead TP60/61 and replace the keyboard and the touchpad to see if it will change anything.

By the way did anyone try replacing the fan inside the docking because that thing is really annoying? I mean the GPU fan is at 15% and this guy is working as if its full load.
T60P 2007-93G T7400, 4GB RAM, Fire Gl V5200 SSD 120GB Win 7 Advanced dock + mini dock
W520 4284-CN2 I7-2760, 8GB RAM, Nvidia Quadro 1000 320 GB Win 7

128MB
Posts: 35
Joined: Thu May 17, 2018 8:37 am
Location: Overpelt, Belgium

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#16 Post by 128MB » Fri May 01, 2020 1:47 am

dr_st wrote:
Thu Apr 30, 2020 2:24 pm
Given that it has started with USB glitches, check that the external USB ports are physically OK, and have no bent / broken connectors. Sometimes these cause shorts that can lead to POST failures.

Can you sometimes enter the BIOS? If so, is the hard drive visible in the BIOS boot order?
i get in the bios sometimes and it always discovers usb devices like mouse and keyboard on post.
i now tried another iso of win7 and installing as we speak.

edit

installed win 7 pro 32 bit and cannot install anything or use windows update

error 0x800b0109 pops up everywhere

update troubleshooter does not work, that gives the same error.
manually downloading updating packets give the same error

another day has passed, no more time am i wasting on this can't afford it. im binning it
bye

N33dF0rSp33dFan
Posts: 21
Joined: Sat Oct 28, 2017 11:18 am
Location: Galati, Romania

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#17 Post by N33dF0rSp33dFan » Fri May 01, 2020 9:49 am

Dreadtafarian wrote:
Thu Apr 30, 2020 5:30 pm
By the way did anyone try replacing the fan inside the docking because that thing is really annoying? I mean the GPU fan is at 15% and this guy is working as if its full load.
When I had my 2503, I had to replace the fan to save what was left of my ears, but it isn't easy to take apart. A (almost) full teardown is required, there are loads of clips, different sizes of screws, and some springs that like to come out. I've heard of people running it without any fan and didn't complain about the heat coming from the PSU, but I personally wouldn't suggest it.
Current ThinkPads: none
Owned ThinkPads : T61 (6457-6PG), X61 (7674-4NG), W500 (4061-38U) + 2503 Advanced Dock w/ RX 550, X41 (2525-63G)

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21173
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#18 Post by RealBlackStuff » Fri May 01, 2020 10:38 am

Wouldn't it be easier to just find the power wires to the fan, and cut one or both of those?
And leave the fan in.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

Dreadtafarian
Posts: 3
Joined: Thu Apr 30, 2020 4:40 pm
Location: Ljubljana, Slovenia

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#19 Post by Dreadtafarian » Fri May 01, 2020 6:33 pm

Already opened it up. Was thinking of making a short PDF with pics and maybe some tips about opening it. I took the cover off, then the metal lid and instead of going all the way, I decided to take a shorter route. I simply drilled 3 holes(cobalt ate through plastic on the back with ease), then made holes a bit wider to be able to get the screws out through the back and that was it.Not 100% centered but i didn't mark it prior to drilling just estimated but it turned out OK in the end.

There it is on the shelf at the moment waiting for the replacement fan. Did I mention that my dock is IBM branded not Lenovo so probably older version. So the fan choice is next, original is Sunon 12v 60x60x15mm 1.8 w. Found Sunon fan in the local electric store for 3 eur it has a little less power consumption 1.5 i think but 36 db of noise. Based on the bad experience with the original I would rather opt for whatever will do the trick at the moment. In the future it would be nice to get a fan with the led light, if it wouldn't require an additional connector. Id say an 18 thick fan would also fit but the plastic screw holes would have to be drilled a bit just for the screw head to sit in. The 20 mm fan hardly maybe with some heavy heavy modding and lot of sanding, would have to be adapted to the shape of the plastic net.
T60P 2007-93G T7400, 4GB RAM, Fire Gl V5200 SSD 120GB Win 7 Advanced dock + mini dock
W520 4284-CN2 I7-2760, 8GB RAM, Nvidia Quadro 1000 320 GB Win 7

Dreadtafarian
Posts: 3
Joined: Thu Apr 30, 2020 4:40 pm
Location: Ljubljana, Slovenia

Re: T60P + 2503 Dock + GT1030 heaven BUT NOW ...USB IS DEAD

#20 Post by Dreadtafarian » Wed May 06, 2020 4:02 pm

Finally got the fan. Akasa 1.6w 12v and it seems a bit quieter but still irritates. I think that it should be a fan that doesn't allow the rpm change, not sure anymore about it all. Maybe its better to simply muffle it somehow without disrupting the airflow.

Also it seems that when the pci sensor shows over 50c my T60p freezes randomly so that's my main issue at the moment. It can work for hours at time but sometimes it freezes
T60P 2007-93G T7400, 4GB RAM, Fire Gl V5200 SSD 120GB Win 7 Advanced dock + mini dock
W520 4284-CN2 I7-2760, 8GB RAM, Nvidia Quadro 1000 320 GB Win 7

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T6x Series”

Who is online

Users browsing this forum: No registered users and 20 guests