Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

T60/T61 series specific matters only
Post Reply
Message
Author
Think43p
Freshman Member
Posts: 92
Joined: Mon Apr 26, 2010 3:49 pm
Location: Stuttgart, DE

T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#1 Post by Think43p » Thu Oct 15, 2020 2:29 pm

Hi All,

About my T60p below (Win 10 32-bit, 4Gb ram), for the display, I have the Microsoft Basic Display Adapter driver and usage was just about ok for daily browsing and MS office applications (however sluggish with VLC videos), but when I installed the driver for the ATI FireGL V5200 (79d533ww) the laptop was terrible to use. The laptop turned extremely sluggish, the desktop background color and the taskbar color turned the same and even basic things like right clicking on the desktop and trying to change the resolution were impossible, lots of flickering etc so I uninstalled that driver and went back to the MS basic driver.

The reason I would like to get the ATI driver is there are some advantages to using that over the basic driver so am I missing anything to successfully install the ATU FireGL driver and have a sanely performing T60p?

ThinkPad T60p 2007-WUK (also says 2007-CTO)
BIOS - 2.20 79ETE0WW
T2600(2.16GHz)
15in 1600x1200 LCD
256MB ATI FireGL V5200
Win 10 32-bit, 4Gb ram
Samsung 860 EVO 250GB SSD

ATI FireGL Driver downloaded from:
https://support.lenovo.com/be/en/downloads/ds004138
T400
T60p 2007-WUK

ChrisJ9876
Posts: 16
Joined: Tue Jun 12, 2007 6:11 pm
Location: Endicott NY

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#2 Post by ChrisJ9876 » Mon Oct 19, 2020 10:16 pm

I have a T60p with that same driver (79d533ww) and it's working just fine for me. Win10 Pro, 32bit, 3g ram, T2600 cpu, ATI V5200, Crucial MX300 SSD, 14.1" 1400x1050 (but running at 1024x768 'cause its easier on the eyes). But I notice that you are not at the latest BIOS level, which is 2.27.
I also have 2 T60's with near-identical specs, except they have ATI x1400, but use the same driver, also with no problems.

Think43p
Freshman Member
Posts: 92
Joined: Mon Apr 26, 2010 3:49 pm
Location: Stuttgart, DE

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#3 Post by Think43p » Tue Oct 20, 2020 4:19 am

My bad. I mustve updated the BIOS after I had this info written down. I just checked and I do have the latest driver 2.27 (79ETE7WW) installed. So hitting a wall again.
T400
T60p 2007-WUK

dr_st
Moderator
Moderator
Posts: 8659
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#4 Post by dr_st » Tue Oct 20, 2020 4:21 am

It's possible that your GPU is failing. The Microsoft basic driver does not enable various advanced features of the GPU, which often helps mask hardware issues.
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

Think43p
Freshman Member
Posts: 92
Joined: Mon Apr 26, 2010 3:49 pm
Location: Stuttgart, DE

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#5 Post by Think43p » Tue Oct 20, 2020 5:24 am

Not really sure if the GPU is failing since it runs exceptionally well with Win 7 and the ATI driver so its something to do with Win10.
T400
T60p 2007-WUK

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 21591
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#6 Post by RealBlackStuff » Tue Oct 20, 2020 5:37 am

Time to put a 14.1" 4:3 T61 motherboard in it and turn it into a T601F FrankenPad.
SATA II speed, up to 8GB RAM, 64-bit OS, etc.
More info here.
NOT a great day for a Guinness! (the Real Black Stuff).
Ireland is on FULL lockdown till December 2020!
Covid-19: Mask it or Casket!
Check out The Boardroom for Mods and Other Services.

dr_st
Moderator
Moderator
Posts: 8659
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#7 Post by dr_st » Tue Oct 20, 2020 6:20 am

Think43p wrote:
Tue Oct 20, 2020 5:24 am
Not really sure if the GPU is failing since it runs exceptionally well with Win 7 and the ATI driver so its something to do with Win10.
This does give some certainty that the HW is fine.

When you install the driver on Win10 - did you install just the driver or the Catalyst Control Center as well? Did you change any settings from default? Finally, do you have the Lenovo Power Management driver installed (if so, which version), and any Power Management software?
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

Think43p
Freshman Member
Posts: 92
Joined: Mon Apr 26, 2010 3:49 pm
Location: Stuttgart, DE

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#8 Post by Think43p » Tue Oct 20, 2020 7:03 am

did you install just the driver or the Catalyst Control Center as well?
Both. I just ran setup of 79d533ww and it installed the driver and the CCC as well.

Did you change any settings from default?
No

Finally, do you have the Lenovo Power Management driver installed (if so, which version), and any Power Management software?
No. No.
T400
T60p 2007-WUK

dr_st
Moderator
Moderator
Posts: 8659
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#9 Post by dr_st » Tue Oct 20, 2020 7:15 am

You may want to try to install the driver only (unpack it then run update driver from Device Manager).

Also I recommend the Power Management driver is installed, maybe the one here:
https://thinkpads.com/support/Thinkpad- ... ku09ww.exe
Thinkpad 25 (20K7), T490 (20N3), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

Think43p
Freshman Member
Posts: 92
Joined: Mon Apr 26, 2010 3:49 pm
Location: Stuttgart, DE

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#10 Post by Think43p » Tue Oct 20, 2020 7:37 am

Thanks.

So I installed gtku09ww and uninstalled only the CCC from Programs while keeping the ATI driver intact but still the same issue. Seems the problem lies with an incompatibility with the ATI driver and Win10 on this laptop. Im back on the basic driver which works just about ok for basic browsing not for videos however. So back to square one.

I'm going to upgrade the CPU on this from T2600 to the T7600 very soon and was thinking of replacing the HS using one from a W500/T500/T61p but idle temp right now hovers around 52 degC which is acceptable so don't think i'll do that.
T400
T60p 2007-WUK

Think43p
Freshman Member
Posts: 92
Joined: Mon Apr 26, 2010 3:49 pm
Location: Stuttgart, DE

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#11 Post by Think43p » Thu Oct 22, 2020 3:35 am

RealBlackStuff wrote:
Tue Oct 20, 2020 5:37 am
Time to put a 14.1" 4:3 T61 motherboard in it and turn it into a T601F FrankenPad.
SATA II speed, up to 8GB RAM, 64-bit OS, etc.
More info here.
Thanks RBS but as my usage is pretty much browsing and office apps, the laptop in its current state is pretty acceptable. Once I change the CPU, Im hoping it will be slightly better than what it is now.
T400
T60p 2007-WUK

andy2000
Freshman Member
Posts: 62
Joined: Thu Feb 01, 2007 12:17 am
Location: Austin, TX

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#12 Post by andy2000 » Thu Oct 29, 2020 11:49 am

I ran into the same issue when installing Windows 10 2004 on a T60p with ATI graphics. After doing some research, I found that there seems to be an incompatibility with 2004 and the ATI video driver. 1909 works fine on the same T60 with ATI graphics. I haven't tried the newly released 20H2 version yet.

Think43p
Freshman Member
Posts: 92
Joined: Mon Apr 26, 2010 3:49 pm
Location: Stuttgart, DE

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#13 Post by Think43p » Fri Oct 30, 2020 6:43 am

Update:

Finally replaced the T2600 with a T7600. It was a simple straight off swap. Put it some Titan thermal paste while still keeping the original thermal pads over the GPU.

Laptop's running slightly faster than before so that's :banana: Also idle temp reduced slightly - hovering around 48-52 deg C from 52-54 deg C earlier.
T400
T60p 2007-WUK

Think43p
Freshman Member
Posts: 92
Joined: Mon Apr 26, 2010 3:49 pm
Location: Stuttgart, DE

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#14 Post by Think43p » Fri Oct 30, 2020 7:32 am

andy2000 wrote:
Thu Oct 29, 2020 11:49 am
I ran into the same issue when installing Windows 10 2004 on a T60p with ATI graphics. After doing some research, I found that there seems to be an incompatibility with 2004 and the ATI video driver. 1909 works fine on the same T60 with ATI graphics. I haven't tried the newly released 20H2 version yet.
Thanks Andy, Sort of relieved to know that it wasn't just my laptop acting up. But hopefully the upcoming releases fix the underlying issues with such older hardware.
T400
T60p 2007-WUK

EDMAC
Posts: 1
Joined: Fri Oct 30, 2020 8:41 pm
Location: San Diego, CA

Re: T60p - Problem installing ATI FireGL V5200 driver - Win10 32bit

#15 Post by EDMAC » Fri Oct 30, 2020 9:10 pm

Hi,
Hope this might help people who have had their video become unusable after "upgrading" from Windows 10-1909 to 2004 (or 20H2). Turn off transparency Effects (Personalization/Colors). This worked for me on my T60p with FireGL5250. It also works on 2 other T60p's with FireGL 5200 chips. All of my T60 and T60p laptops are using ATI driver 8.383.1.100 for X1300/FireGL 5200/FireGL 5250 and Win XP/7/various versions of 10 up through 20H2. As an aside, I have to disable the ATI GPU for a few of my older games (2000-2005 vintage) and use the Microsoft Basic Display Adapter setting. However I don't have to do this if I play games in Win10-32 bit version 1511.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T60/T61 Series”

Who is online

Users browsing this forum: No registered users and 49 guests