Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T60p power mgmt bug drastically reduces graphics performance

T60/T61 series specific matters only
Post Reply
Message
Author
WPWoodJr
Junior Member
Junior Member
Posts: 399
Joined: Wed Nov 08, 2006 7:45 pm
Contact:

T60p power mgmt bug drastically reduces graphics performance

#1 Post by WPWoodJr » Tue Mar 18, 2008 10:14 am

Jan 1, 2011 edit:
Amazingly this bug is fixed. I just tested the latest TP power manager and you can now set "Optimize Fan Control" to "Balance all parameters" without putting the graphics card into a persistent battery-saving mode:
http://www-307.ibm.com/pc/support/site. ... MIGR-70602

Previous post:
Just found this bug on my two T60p's with ATI FireGL graphics cards. It may apply to other systems too.

In Thinkpad Power Manager, if you set "Optimize Fan Control" to "Balanced", then when you switch back and forth between Battery and AC power, the graphics card will enter a battery-saving mode and never leave it. This reduces the graphics card performance to 1/4 to 1/3 of its potential.

I'm using the latest Power Manager V1.30b and the latest Lenovo ATI driver 8.442.3-080103a1-057754C-Lenovo. I tested the graphics card's performance using http://www.ozone3d.net/benchmarks/fur/.

The solution is to never set "Optimize Fan Control" to "Balanced" in the Thinkpad Power Management scheme settings; always run with it at "Maximize Performance". You will also need to ensure that the ATI Catalyst settings are correct if you have ever used a "Balanced" setting. Launch the ATI Catalyst control center and go to the "Advanced" mode, "PowerPlay" settings. Click "Defaults" which should set "Enable Power Play" and "Allow refresh rate reduction". "Plugged in" should now be set to "Optimal Performance", and "High Battery" and "Low Battery" should now be set to "Optimal Battery Life". Click OK.

To reproduce this bug, plug the system in to AC then edit the current power management scheme (you may have to create a new one if you are using one of the IBM default ones) and set "Optimize Fan Control" to "Balanced" while under Battery power. Set it to "Balanced" or "Maximize Performance" under AC. Then launch the ATI Catalyst control center and go to the "Advanced" mode, "PowerPlay" settings. Click "Defaults" which should set "Enable Power Play" and "Allow refresh rate reduction". "Plugged in" should now be set to "Optimal Performance", and "High Battery" and "Low Battery" should now be set to "Optimal Battery Life". Click OK.

Then remove the AC plug. The screen should blink and reduce in intensity. The blink is your cue that the ATI card is entering the "Optimal Battery Life" mode using ATI's "Powerplay". Now plug the system back in to AC power. The screen will not blink, as it should when switching back to the "Optimal Performance" mode. At this point, if you run ATI Catalyst, you should see that "Optimal Performance" is actually selected, but that the "Apply" and "Discard" buttons are enabled. If you press "Discard" then the "Plugged In" setting will revert to "Optimal Battery Life" - its as if the power mode switch from battery to AC had only partially succeeded - in fact, even though the system is under AC power, the graphics card is still running in "Optimal Battery Life" mode.

I'd be interested in other's experience with this bug - is it just these drivers, does it occur on T61p's, etc. Also, how does one submit a bug like this to Lenovo?
Last edited by WPWoodJr on Sat Jan 01, 2011 12:32 pm, edited 2 times in total.
T60p 2613-CTO, 2.33GHz, 3GB ram, Intel 80gb G2 SSD, H7K 200GB/7200rpm, LG Flexview IPS SXGA+ screen, ATI FireGL V5250
Essential TP Hotfixes and Tweaks

Marie-Anne
Freshman Member
Posts: 110
Joined: Mon Aug 13, 2007 10:50 am
Location: Amsterdam, Netherlands

#2 Post by Marie-Anne » Tue Mar 18, 2008 11:28 am

Is this on VISTA or XP or both?
T60, 2008ZWA: T5600 CPU, 15" SXGA+ 1400x1050 IPS (LG) LCD Panel, ATI X1400 128 MB, 2x2 GB DDR2 RAM, 240 GB SSD OCZ Vertex 2, bluetooth, IR-port, Intel 3940 wireless 802.11 abg, Intel 1000 PL LAN card, NO fingerprint reader, Windows 7 Enterprise 32-Bit

WPWoodJr
Junior Member
Junior Member
Posts: 399
Joined: Wed Nov 08, 2006 7:45 pm
Contact:

#3 Post by WPWoodJr » Tue Mar 18, 2008 12:32 pm

I experienced it on XP SP2. Can you test Vista?
T60p 2613-CTO, 2.33GHz, 3GB ram, Intel 80gb G2 SSD, H7K 200GB/7200rpm, LG Flexview IPS SXGA+ screen, ATI FireGL V5250
Essential TP Hotfixes and Tweaks

meekus
Freshman Member
Posts: 61
Joined: Tue Dec 18, 2007 12:03 am

#4 Post by meekus » Tue Mar 18, 2008 1:36 pm

Turn off the "Lower display refresh rate" option (i.e. set it to "Never"). That's what I've done with my T60 w/ ATI X1400 video and my problems were solved.

FWIW I saw no reduction in power dissipation and battery life with the variable display refresh rate at either 40- or 50-Hz and the constant screen blanking caused by changing between 40- (50-) and 60-Hz was just freaking annoying IMHO.

WPWoodJr
Junior Member
Junior Member
Posts: 399
Joined: Wed Nov 08, 2006 7:45 pm
Contact:

#5 Post by WPWoodJr » Tue Mar 18, 2008 2:44 pm

meekus wrote:Turn off the "Lower display refresh rate" option (i.e. set it to "Never"). That's what I've done with my T60 w/ ATI X1400 video and my problems were solved.

FWIW I saw no reduction in power dissipation and battery life with the variable display refresh rate at either 40- or 50-Hz and the constant screen blanking caused by changing between 40- (50-) and 60-Hz was just freaking annoying IMHO.
You're talking about a completely different issue. My issue was not screen blanking, it was a 60-75% drop in video card performance.
T60p 2613-CTO, 2.33GHz, 3GB ram, Intel 80gb G2 SSD, H7K 200GB/7200rpm, LG Flexview IPS SXGA+ screen, ATI FireGL V5250
Essential TP Hotfixes and Tweaks

Truthfinder
Junior Member
Junior Member
Posts: 311
Joined: Sun Nov 12, 2006 12:24 am
Location: Jersey by the Sea

Poor Video Performance

#6 Post by Truthfinder » Thu Mar 20, 2008 7:29 pm

Good evening:

I just tried to duplicated the problem with my T60, however, it has the X1400 video card. The issue doesn't appear to take place with the X1400 Graphics card.

Anyone else try this ?


Best to one and all :D
ThinkPad T-60 2623D7U, 4GB Kingston HyperX / ThinkPad T-60P 2008-83U , 4GB Kingston HyperX.
Running Windows 7 on both units. Dedicated ThinkPad user for about 18 years.

quickie
Posts: 19
Joined: Thu Dec 22, 2005 6:15 pm
Location: Ulm, Germany
Contact:

#7 Post by quickie » Sun Mar 30, 2008 5:41 pm

Same problem here, (t60 x1400 graphics adapter) .

WPWoodJr
Junior Member
Junior Member
Posts: 399
Joined: Wed Nov 08, 2006 7:45 pm
Contact:

#8 Post by WPWoodJr » Mon Mar 31, 2008 8:34 am

quickie wrote:Same problem here, (t60 x1400 graphics adapter) .
You duplicated the problem (graphics card enters battery-saving mode and never leaves it)?
T60p 2613-CTO, 2.33GHz, 3GB ram, Intel 80gb G2 SSD, H7K 200GB/7200rpm, LG Flexview IPS SXGA+ screen, ATI FireGL V5250
Essential TP Hotfixes and Tweaks

san
Posts: 49
Joined: Fri Mar 16, 2007 6:37 pm
Location: Store Heddinge Denmark

#9 Post by san » Mon Mar 31, 2008 10:07 am

Problem reproduced (actually, it was in effect...) and solved with your guide. Thanks for sharing.
pri: W700 WUXGA, Qx9300 @2.53 GHz, FX3700, 8GB Kingston HyperX, 2 x 160GB X25-m G2 Raid0, Blueray, Wacom, Pantone
sec: T60p UXGA Flexview, 80GB X25-m G1, T2600, 4GB
other: T61p WSXGA+, T500 WSXGA+
wishlist: Tablet
prev: T61p WUXGA, R500, T60, T42, T40, A21p, 770, 760
fav: 770, A series, T60p, W700

WPWoodJr
Junior Member
Junior Member
Posts: 399
Joined: Wed Nov 08, 2006 7:45 pm
Contact:

#10 Post by WPWoodJr » Mon Mar 31, 2008 10:40 am

Another solution is just to disable Powerplay. I've recently decided to do that, I was getting blue screens from a driver called ati2dvag.dll and so far disabling Powerplay seems to have prevented those blue screens, as well as preventing the slow graphics performance reported here.
T60p 2613-CTO, 2.33GHz, 3GB ram, Intel 80gb G2 SSD, H7K 200GB/7200rpm, LG Flexview IPS SXGA+ screen, ATI FireGL V5250
Essential TP Hotfixes and Tweaks

3DD
Posts: 8
Joined: Mon Apr 21, 2008 1:47 pm
Location: Los Angeles, CA

#11 Post by 3DD » Mon Apr 21, 2008 8:50 pm

WPWoodJr, good work. I also noticed the ATI PowerPly settings don't stick, but I didn't relate it to the Lenovo Power Manager Fan Control. You should submit a bug to Lenovo.

WPWoodJr
Junior Member
Junior Member
Posts: 399
Joined: Wed Nov 08, 2006 7:45 pm
Contact:

#12 Post by WPWoodJr » Mon Apr 21, 2008 9:46 pm

WPWoodJr wrote:Another solution is just to disable Powerplay. I've recently decided to do that, I was getting blue screens from a driver called ati2dvag.dll and so far disabling Powerplay seems to have prevented those blue screens, as well as preventing the slow graphics performance reported here.
Followup: I'm still getting the occasional blue screen every week or two from ati2dvag.dll - this seems to be a common problem with no consensus solution that has plagued ATI cards/drivers for 3-4 years at least, although I only see it on one of my T60ps so it may be hardware-related.
T60p 2613-CTO, 2.33GHz, 3GB ram, Intel 80gb G2 SSD, H7K 200GB/7200rpm, LG Flexview IPS SXGA+ screen, ATI FireGL V5250
Essential TP Hotfixes and Tweaks

blynch
Posts: 49
Joined: Mon Sep 25, 2006 12:34 am
Location: Notre Dame, IN

#13 Post by blynch » Tue Apr 22, 2008 1:45 am

I do not see this problem with my T60p running Vista ultimate. My thinkvantage updates tells me my power manager is version 1.43 though. Catalyst is Version 2007.0621.1715.28924

Kaz
Posts: 40
Joined: Tue Jul 01, 2008 11:43 am
Location: Plano, TX

#14 Post by Kaz » Tue Jul 01, 2008 1:57 pm

Reviewed WPWOODJr's post and was not able to duplicate issue with T60 and x1400. Am attempting to troubleshoot why ATI CCC's PowerPlay setting for 'Plugged In' changes automatically from 'Optimal Performance' to 'Optimal Battery'. Running latest driver from Lenovo, 8.442. Have attempted to roll back to previous version without success so back to latest version. CCC is set to default settings. Just changed Power Manager (V. 1.30b) so that Battery Settings running with Max Performance vs. Balanced to determine if this prevents ATI CCC from making automatic changes to the PowerPlay settings.

Interested in feedback as to others experiencing same issue. Concerned about this since I am troubleshooting Black Screen of Death when using Windows Media Players 10 or 11 and playing videos downloaded from websites. Only recourse in to press power button and hard boot T60 laptop as only NumLock and F-PgUp (LED Light) will work. There are no entries in the event log when this happens. Timeframe between crashes can be sporatic. Have only encountered this issue with Windows Media Player and playing videos downloaded from Internet in real time. Cannot recall whether I have issues playing videos already on disk as I rarely play videos unless viewing them from a website (news, etc.).
T60, 8744-5BU: 2.0 GHz T7200, 2GB RAM, 15.4" WSXGA+ 1680x1050 ATI Mobility Radeon X1400, Win XP Pro SP3

seeplus
Sophomore Member
Posts: 164
Joined: Sun Aug 20, 2006 12:53 pm
Location: easton.ct.us

Re: T60p power mgmt bug drastically reduces graphics perform

#15 Post by seeplus » Wed Jul 02, 2008 9:39 pm

WPWoodJr wrote:Just found this bug on my two T60p's with ATI FireGL graphics cards. It may apply to other systems too.
...
- in fact, even though the system is under AC power, the graphics card is still running in "Optimal Battery Life" mode.

I'd be interested in other's experience with this bug - is it just these drivers, does it occur on T61p's, etc. Also, how does one submit a bug like this to Lenovo?
I noticed this a while back; PowerPlay is flaky. Settings never stuck on my 2613-cto T60p w/ ATi v5250. I've just disabled it unless I'm somewhere without access to a plug (pretty much just an airplane or on the couch/in bed.) Even then I usually don't bother. :)

I don't like Catalyst at all; it's bloated and slow (because it's based on .NET, I think. Correct me if I'm wrong, please.) I had it disabled for a while, but it is very handy for arranging the order of multiple displays.
- Chris

2613-CTO

gpvillamil
Sophomore Member
Posts: 170
Joined: Tue May 25, 2004 10:47 am
Location: New York, NY
Contact:

Re: T60p power mgmt bug drastically reduces graphics perform

#16 Post by gpvillamil » Thu Jul 03, 2008 3:46 pm

What were your results from the FurMark benchmark?

I'm getting min fps = 2, avg = 3, max = 7 for a total score of 132 (1680 x 1050 fullscreen), which seems incredibly lame.
WPWoodJr wrote:Just found this bug on my two T60p's with ATI FireGL graphics cards. It may apply to other systems too.

In Thinkpad Power Manager, if you set "Optimize Fan Control" to "Balanced", then when you switch back and forth between Battery and AC power, the graphics card will enter a battery-saving mode and never leave it. This reduces the graphics card performance to 1/4 to 1/3 of its potential.

I'm using the latest Power Manager V1.30b and the latest Lenovo ATI driver 8.442.3-080103a1-057754C-Lenovo. I tested the graphics card's performance using http://www.ozone3d.net/benchmarks/fur/.

The solution is to never set "Optimize Fan Control" to "Balanced" in the Thinkpad Power Management scheme settings; always run with it at "Maximize Performance". You will also need to ensure that the ATI Catalyst settings are correct if you have ever used a "Balanced" setting. Launch the ATI Catalyst control center and go to the "Advanced" mode, "PowerPlay" settings. Click "Defaults" which should set "Enable Power Play" and "Allow refresh rate reduction". "Plugged in" should now be set to "Optimal Performance", and "High Battery" and "Low Battery" should now be set to "Optimal Battery Life". Click OK.

To reproduce this bug, plug the system in to AC then edit the current power management scheme (you may have to create a new one if you are using one of the IBM default ones) and set "Optimize Fan Control" to "Balanced" while under Battery power. Set it to "Balanced" or "Maximize Performance" under AC. Then launch the ATI Catalyst control center and go to the "Advanced" mode, "PowerPlay" settings. Click "Defaults" which should set "Enable Power Play" and "Allow refresh rate reduction". "Plugged in" should now be set to "Optimal Performance", and "High Battery" and "Low Battery" should now be set to "Optimal Battery Life". Click OK.

Then remove the AC plug. The screen should blink and reduce in intensity. The blink is your cue that the ATI card is entering the "Optimal Battery Life" mode using ATI's "Powerplay". Now plug the system back in to AC power. The screen will not blink, as it should when switching back to the "Optimal Performance" mode. At this point, if you run ATI Catalyst, you should see that "Optimal Performance" is actually selected, but that the "Apply" and "Discard" buttons are enabled. If you press "Discard" then the "Plugged In" setting will revert to "Optimal Battery Life" - its as if the power mode switch from battery to AC had only partially succeeded - in fact, even though the system is under AC power, the graphics card is still running in "Optimal Battery Life" mode.

I'd be interested in other's experience with this bug - is it just these drivers, does it occur on T61p's, etc. Also, how does one submit a bug like this to Lenovo?

WPWoodJr
Junior Member
Junior Member
Posts: 399
Joined: Wed Nov 08, 2006 7:45 pm
Contact:

Re: T60p power mgmt bug drastically reduces graphics perform

#17 Post by WPWoodJr » Sat Jul 05, 2008 3:06 pm

gpvillamil wrote:What were your results from the FurMark benchmark?

I'm getting min fps = 2, avg = 3, max = 7 for a total score of 132 (1680 x 1050 fullscreen), which seems incredibly lame.
I can't run at 1680 x1050 - do you have an external monitor hooked up?

I get 10fps average on my T60p. Furmark running at 1024x768, fullscreen for 60 secs. What do you get at those settings?
T60p 2613-CTO, 2.33GHz, 3GB ram, Intel 80gb G2 SSD, H7K 200GB/7200rpm, LG Flexview IPS SXGA+ screen, ATI FireGL V5250
Essential TP Hotfixes and Tweaks

WPWoodJr
Junior Member
Junior Member
Posts: 399
Joined: Wed Nov 08, 2006 7:45 pm
Contact:

Re: T60p power mgmt bug drastically reduces graphics perform

#18 Post by WPWoodJr » Sat Jul 05, 2008 3:09 pm

WPWoodJr wrote:
gpvillamil wrote:What were your results from the FurMark benchmark?

I'm getting min fps = 2, avg = 3, max = 7 for a total score of 132 (1680 x 1050 fullscreen), which seems incredibly lame.
I can't run at 1680 x1050 - do you have an external monitor hooked up?

I get 10fps average on my T60p. Furmark running at 1024x768, fullscreen for 60 secs. What do you get at those settings?
Sorry I take it back - it will do the 1680x1050 benchmark.

327 o3marks, 5 fps avg
T60p 2613-CTO, 2.33GHz, 3GB ram, Intel 80gb G2 SSD, H7K 200GB/7200rpm, LG Flexview IPS SXGA+ screen, ATI FireGL V5250
Essential TP Hotfixes and Tweaks

sg2002
Posts: 3
Joined: Mon Aug 11, 2008 2:35 pm
Location: Toronto, Canada

#19 Post by sg2002 » Mon Aug 11, 2008 6:48 pm

I had the same issue on R60 with x1400 video card. Disabling PowerPlay is not working for me, because every time you change from one fan control mode to another it just enables PowerPlay again.

WPWoodJr
Junior Member
Junior Member
Posts: 399
Joined: Wed Nov 08, 2006 7:45 pm
Contact:

Re: T60p power mgmt bug drastically reduces graphics performance

#20 Post by WPWoodJr » Sat Jan 01, 2011 12:28 pm

Amazingly, this bug is fixed! I just tried the latest TP power manager here and the bug is gone:
http://www-307.ibm.com/pc/support/site. ... MIGR-70602
T60p 2613-CTO, 2.33GHz, 3GB ram, Intel 80gb G2 SSD, H7K 200GB/7200rpm, LG Flexview IPS SXGA+ screen, ATI FireGL V5250
Essential TP Hotfixes and Tweaks

mrybczyn
Posts: 17
Joined: Fri Jun 04, 2010 3:26 pm
Location: Waterloo, Canada

Re: T60p power mgmt bug drastically reduces graphics performance

#21 Post by mrybczyn » Wed Jan 05, 2011 9:36 pm

Sweet find! This was bothering me for the longest time, I just assumed it was some sort of poor coding on the part of the game I played, but now its running much smoother.

Sticky this :-)
T60p 1600x1200 flexview, intel G2 SSD, cooling mods, Ubuntu 9.10 undervolted

JayNYC
Freshman Member
Posts: 61
Joined: Thu Mar 20, 2008 8:15 am
Location: Brooklyn, NY

Re: T60p power mgmt bug drastically reduces graphics performance

#22 Post by JayNYC » Thu Jan 06, 2011 12:10 pm

does this issue exist for Win 7 32bit?

sg2002
Posts: 3
Joined: Mon Aug 11, 2008 2:35 pm
Location: Toronto, Canada

Re: T60p power mgmt bug drastically reduces graphics performance

#23 Post by sg2002 » Fri Jan 07, 2011 12:07 pm

Are you sure it was fixed? For me it's still not working, even with latest Power Manager. Does your monitor blinks for a second when you switch from default to max performance?

WPWoodJr
Junior Member
Junior Member
Posts: 399
Joined: Wed Nov 08, 2006 7:45 pm
Contact:

Re: T60p power mgmt bug drastically reduces graphics performance

#24 Post by WPWoodJr » Fri Jan 07, 2011 12:38 pm

Under Windows XP, I tested before installing the latest power manager and after. My monitor now blinks when I remove or apply power. Before it would blink only the first time power was removed. The settings in Catalyst are correct too.

You have an R60 with X1400 graphics card, not a T60p like me, correct?
T60p 2613-CTO, 2.33GHz, 3GB ram, Intel 80gb G2 SSD, H7K 200GB/7200rpm, LG Flexview IPS SXGA+ screen, ATI FireGL V5250
Essential TP Hotfixes and Tweaks

sg2002
Posts: 3
Joined: Mon Aug 11, 2008 2:35 pm
Location: Toronto, Canada

Re: T60p power mgmt bug drastically reduces graphics performance

#25 Post by sg2002 » Tue Jan 11, 2011 10:17 am

Basically your PM should switch PowerPlay settings every time when you switch Optimize Fan Control setting. And when you switch PowerPlay settings your screen should blink.

Yes, I have r60. But the bug is somewhere within Power Manager, since even modded x1400 drivers work fine with Power Manager 1.48.

WPWoodJr
Junior Member
Junior Member
Posts: 399
Joined: Wed Nov 08, 2006 7:45 pm
Contact:

Re: T60p power mgmt bug drastically reduces graphics performance

#26 Post by WPWoodJr » Tue Jan 11, 2011 8:12 pm

The power manager I have is at 1.89 now. For the T60p, this bug is fixed.
T60p 2613-CTO, 2.33GHz, 3GB ram, Intel 80gb G2 SSD, H7K 200GB/7200rpm, LG Flexview IPS SXGA+ screen, ATI FireGL V5250
Essential TP Hotfixes and Tweaks

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T6x Series”

Who is online

Users browsing this forum: Bing [Bot] and 39 guests