Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T60 - No AC Power. Motherboard issue?

T60/T61 series specific matters only
Post Reply
Message
Author
laboye
Freshman Member
Posts: 53
Joined: Thu Apr 23, 2009 11:27 pm
Location: Hollywood, FL
Contact:

T60 - No AC Power. Motherboard issue?

#1 Post by laboye » Fri Dec 11, 2009 9:28 pm

Hi all. One of my T60s had a complete motherboard failure and would not power up. I installed a working motherboard, which I tested a few times, and powered it up with AC power. All worked fine; I popped in a battery and let it charge. A few hours later, I unplugged it and powered it on. I decided to restore an image down to it so I did so on battery power in another room. It was taking longer than usual to restore, so I brought the AC adapter over and plugged it in. I didn't hear the power control beep, the LCD brightness stayed the same and the AC power LED on the system panel did not come on! I tried another outlet, AC adapter and DC jack and still no dice. The machine works great under battery power, though.

Its a 14" T60 1951-44U (new motherboard) with an upgraded T2500 2GHz CPU. The original base and motherboard did not have a model-type sticker.

Any suggestions?
Personal: T42 2373-K3U (General Purpose);X21 2662-6MU with 2361 dock (Media Handler);Transnote 2675-21U (Um...Transnote!)
Past Personal and Serviced: 240, 570, 600E, A20m, T20, T21, 3x T30, 12xT4x, T43p (I miss it! :(), X20, X24
Current Workbench: X40, 2xX41, 2xT40, 3xT42, 5xiSeries,9x600/E/X

TTA
Junior Member
Junior Member
Posts: 353
Joined: Mon Nov 27, 2006 4:42 am
Location: Sterling Heights, Mi
Contact:

Re: T60 - No AC Power. Motherboard issue?

#2 Post by TTA » Fri Dec 11, 2009 10:19 pm

laboye wrote:Hi all. One of my T60s had a complete motherboard failure and would not power up. I installed a working motherboard, which I tested a few times, and powered it up with AC power. All worked fine; I popped in a battery and let it charge. A few hours later, I unplugged it and powered it on. I decided to restore an image down to it so I did so on battery power in another room. It was taking longer than usual to restore, so I brought the AC adapter over and plugged it in. I didn't hear the power control beep, the LCD brightness stayed the same and the AC power LED on the system panel did not come on! I tried another outlet, AC adapter and DC jack and still no dice. The machine works great under battery power, though.

Its a 14" T60 1951-44U (new motherboard) with an upgraded T2500 2GHz CPU. The original base and motherboard did not have a model-type sticker.

Any suggestions?
One. Do you have the right fan? If you had a fan from a Intel graphics board and your new board has ATI I could see somthing frying in short order.
T60p/x32/t42p/a31p and about 100 more 8)
Jim

laboye
Freshman Member
Posts: 53
Joined: Thu Apr 23, 2009 11:27 pm
Location: Hollywood, FL
Contact:

Re: T60 - No AC Power. Motherboard issue?

#3 Post by laboye » Fri Dec 11, 2009 10:26 pm

I noted that when I saw that the original fried T60 board had a nice beefy ATI card and extended fan plating. Fortunately, the new board (1951-44U) has the Intel 950 Integrated Graphics. I managed to get the fan from another broken T60 I have (1953-D8U) which also has the Intel graphics.

The only difference is the upgrade from the T2400 1.83GHz to the T2500 2GHz CPU. I also checked the BIOS update log, but there doesn't seem to be any reference to a CPU compatibility update; I assumed it was compatible based on specs.
Personal: T42 2373-K3U (General Purpose);X21 2662-6MU with 2361 dock (Media Handler);Transnote 2675-21U (Um...Transnote!)
Past Personal and Serviced: 240, 570, 600E, A20m, T20, T21, 3x T30, 12xT4x, T43p (I miss it! :(), X20, X24
Current Workbench: X40, 2xX41, 2xT40, 3xT42, 5xiSeries,9x600/E/X

TTA
Junior Member
Junior Member
Posts: 353
Joined: Mon Nov 27, 2006 4:42 am
Location: Sterling Heights, Mi
Contact:

Re: T60 - No AC Power. Motherboard issue?

#4 Post by TTA » Fri Dec 11, 2009 10:46 pm

laboye wrote:I noted that when I saw that the original fried T60 board had a nice beefy ATI card and extended fan plating. Fortunately, the new board (1951-44U) has the Intel 950 Integrated Graphics. I managed to get the fan from another broken T60 I have (1953-D8U) which also has the Intel graphics.

The only difference is the upgrade from the T2400 1.83GHz to the T2500 2GHz CPU. I also checked the BIOS update log, but there doesn't seem to be any reference to a CPU compatibility update; I assumed it was compatible based on specs.
Maybe the battery shorted somthing out. Maybe you're just unlucky.
I'm not much of a fan tracing circuts or looking for blown fuses...
Wanna buy a working intel T60 board? FRU:42T0120
T60p/x32/t42p/a31p and about 100 more 8)
Jim

phlo
Posts: 5
Joined: Tue May 04, 2010 4:18 pm
Location: Vallorbe, Switzerland

Re: T60 - No AC Power. Motherboard issue?

#5 Post by phlo » Tue May 04, 2010 4:40 pm

Hey there,
did you figure out anything further? I have a similar issue with a 2007-FUG T60. Worked perfectly fine for a couple of years, until I had to swap the fan assembly. A couple of hours after that (and while on AC power), it suddenly un-detected the (still plugged in) AC source and continued to run from battery. I checked the adapter with a multimeter (seemed okay) and even made sure using another one -- no response.
Runs flawlessly off battery, though.

laboye
Freshman Member
Posts: 53
Joined: Thu Apr 23, 2009 11:27 pm
Location: Hollywood, FL
Contact:

Re: T60 - No AC Power. Motherboard issue?

#6 Post by laboye » Wed May 05, 2010 3:56 pm

Alas, no. I ended up selling the motherboard for parts. Let me know if you run into anything though, as I've been working on more T60s.

-Eddie
Personal: T42 2373-K3U (General Purpose);X21 2662-6MU with 2361 dock (Media Handler);Transnote 2675-21U (Um...Transnote!)
Past Personal and Serviced: 240, 570, 600E, A20m, T20, T21, 3x T30, 12xT4x, T43p (I miss it! :(), X20, X24
Current Workbench: X40, 2xX41, 2xT40, 3xT42, 5xiSeries,9x600/E/X

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T6x Series”

Who is online

Users browsing this forum: No registered users and 20 guests