Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X32 for W98SE AND W7 ?

X2/X3/X4x series specific matters only
Post Reply
Message
Author
Jefferson
Posts: 40
Joined: Fri Dec 03, 2010 6:05 pm
Location: Denver, CO

X32 for W98SE AND W7 ?

#1 Post by Jefferson » Tue Sep 10, 2019 1:50 am

Does X32 support both W98SE AND W7?

Officially, NO as W98SE support ended with X31 and the oldest model that supports W7 is X6x series.

But I noticed that the difference between X31 and X32 is the CPU and CPU only; the Video and Sound systems are identical, which

led me to believe that I may be able to install the official drivers of W98SE for X31 on X32. Is that correct?

As for the W7, my X32 came with W7 Starters edition installed, and it seems running fine but the video driver seems to behave funny.

It wouldn't run Windows Index Test, for example. I read it somewhere that one can use the official XP driver on W7.

Has anyone tried the XP driver on X32 running W7?

Thanks
:banana:
With the original box and documentation : 600, 380XD, 385XD, X24, X30(10th Anniv), T42p, T43, R52, W700ds
Without : 385XD, 600X, 770X, W701, T420, T430, T520, X230
Not working & for parts : At least a dozen
Other laptops : Dell, Alienware, Lenovo
:banana:

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2317
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: X32 for W98SE AND W7 ?

#2 Post by axur-delmeria » Tue Sep 10, 2019 2:00 am

Windows 7 --> have you checked if audio works? IIRC Win 7 doesn't have drivers for AC97-based sound chips.
Daily driver: X220 4291-C91 i7-2620M

Backup: X601 Core 2 Duo T8100
Toy: X60F Core Solo U1300
On loan: X220 4291-P79 i5-2520M
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

Jefferson
Posts: 40
Joined: Fri Dec 03, 2010 6:05 pm
Location: Denver, CO

Re: X32 for W98SE AND W7 ?

#3 Post by Jefferson » Tue Sep 10, 2019 2:08 am

axur-delmeria wrote:
Tue Sep 10, 2019 2:00 am
Windows 7 --> have you checked if audio works? IIRC Win 7 doesn't have drivers for AC97-based sound chips.
yes, it worked fine. in fact, i was able to watch youtube just fine, with 140p :)

while video quality leaves much to be desired, the audio playback quality seemed flawless.

as i said, it came with W7 Starters edition and i'm pretty sure the audio driver was the default microsoft one.
:banana:
With the original box and documentation : 600, 380XD, 385XD, X24, X30(10th Anniv), T42p, T43, R52, W700ds
Without : 385XD, 600X, 770X, W701, T420, T430, T520, X230
Not working & for parts : At least a dozen
Other laptops : Dell, Alienware, Lenovo
:banana:

dr_st
Moderator
Moderator
Posts: 8017
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: X32 for W98SE AND W7 ?

#4 Post by dr_st » Tue Sep 10, 2019 1:42 pm

Jefferson wrote:
Tue Sep 10, 2019 1:50 am
But I noticed that the difference between X31 and X32 is the CPU and CPU only; the Video and Sound systems are identical, which led me to believe that I may be able to install the official drivers of W98SE for X31 on X32. Is that correct?
Yes, the machines are exactly the same other than the CPU.

Jefferson wrote:
Tue Sep 10, 2019 1:50 am
As for the W7, my X32 came with W7 Starters edition installed, and it seems running fine but the video driver seems to behave funny.
Yes. There is no official good working video driver for Win7 for the ATI Radeon M6 in the X31/X32. You can get by with XP driver or half-arsed Vista driver, or some Omega driver, but I never got it to work as good as it worked on XP. Multi-monitor schemes are a pain, and most of the time don't work right, for example.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

Jefferson
Posts: 40
Joined: Fri Dec 03, 2010 6:05 pm
Location: Denver, CO

Re: X32 for W98SE AND W7 ?

#5 Post by Jefferson » Tue Sep 10, 2019 4:02 pm

dr_st wrote:
Tue Sep 10, 2019 1:42 pm
Yes. There is no official good working video driver for Win7 for the ATI Radeon M6 in the X31/X32. You can get by with XP driver or half-arsed Vista driver, or some Omega driver, but I never got it to work as good as it worked on XP. Multi-monitor schemes are a pain, and most of the time don't work right, for example.
Thanks for your comment. At least whatever driver that came with my X32 W7 was good enough to run Chrome and Youtube ok. Once I tried to get the modern browser working on Windows XP and it was just a pain in the... anyhow, so I figured W7, albeit with less-than-perfect W7 video driver, is an easy choice for the internet purpose while W98 will take care of my gaming needs. Also thought it's kinda cool to run W98 and W7 on the same machine since those two OSs are released at least 15 years apart...
:banana:
With the original box and documentation : 600, 380XD, 385XD, X24, X30(10th Anniv), T42p, T43, R52, W700ds
Without : 385XD, 600X, 770X, W701, T420, T430, T520, X230
Not working & for parts : At least a dozen
Other laptops : Dell, Alienware, Lenovo
:banana:

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X2/X3/X4x Series incl. X41 Tablet”

Who is online

Users browsing this forum: No registered users and 4 guests