Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

[SOLVED] X41 SSD "works" but won't boot - next steps?

X2/X3/X4x series specific matters only
Post Reply
Message
Author
brancusi
Posts: 1
Joined: Sat Jul 11, 2020 3:49 pm
Location: Seattle, WA

[SOLVED] X41 SSD "works" but won't boot - next steps?

#1 Post by brancusi » Sat Jul 11, 2020 4:21 pm

UPDATE: It dawned on me that using the drive via the USB -> PATA adapter meant the drive wasn't actually a USB drive as the icon was for a regular IDE drive, so I tried again with the SSD mounted in the X41. Same problem, didn't work - BUT now I took it OUT of the plastic case that was supplied and tried again - SAME problem - but I noticed that the LED lights on the SSD were not on, so wondered if this was just an alignment problem - and YES, after taking some more care to insert it naked into the chassis, the lights came on and everything now works as expected!! Basically the tolerance of the plastic case were far enough out to push the pins to one side leading it not to connect properly at all. Guess I'm lucky this didn't fry anything - but all is now working and leaving this here in case it helps others using the same adapter set. :P

Greetings

I hate being defeated by a computer, but I'm out of options and not sure what my next course of action should be. I've been reading the forum posts here about SSD adventures and have tried various options, but I'm now officially stuck :-(

I'm trying to upgrade the HDD on my Thinkpad X41 running windows XP pro. I've upgraded the BIOS to the latest version 2.09 and also the embedded controller to version 1.02. I'm using a PATA -> mSata adapter from https://www.ebay.com/itm/mSATA-SSD-to-h ... 1762518210 (switched to 3.3V when in the laptop, switched to 5V when using in a USB -> PATA adapter) and the mSata drive I'm using is the 60GB version of https://www.amazon.com/gp/product/B07JPKDHT5/. The USB adapter that I have is [url]https://www.amazon.com/gp/product/B01E7EPKUO/ and that just lets me mount a collection of PATA drives that I have as I've been going through upgrading multiple other computers (with varying success).

FIRST ATTEMPTS

I have a clone of the HDD I made with Clonezilla on a USB stick but when I tried to restore it to the SSD fitted internally to the laptop, the SSD wasn't being recognized, Clonezilla would complain about "ata1: SRST failed (errno=-16)" on booting from the CD and when trying to do the restore it wouldn't find the SSD at all.

SECOND ATTEMPTS

This time I've connected the SSD to my USB adapter and re-cloned the HDD using Macrium reflect. The SSD is clearly working fine with this adapter, I can clone to it, mount it on different computers and everything looks OK, but I can't persuade the X41 to boot from it as a USB mounted drive (wanted to get this working first in case it was a pin connection problem when I swap out the actual HDD). I've enabled USB boot in the bios of course and when I reboot and hit F12 for boot options, I see the HDD and the USB drive listed. If I select the HDD it works as expected, if I select the USB mounted SSD, I get a blank screen with a flashing cursor and no error message.

1) I have used a disk hex editor to inspect the MBR on both drives and they are identical except for the disk signature bytes.
2) I have tried using MBRFix to generate a new MBR for Windows XP, exactly the same problem on boot

Does anyone have thoughts on how I could proceed or what the problem might be? I don't mind buying new adapters etc if it's proven to be working on an X41 but I'm reluctant to give up as the hardware seems to all be working in a different configuration and this smells like a silly config issue that I can't track down.

Help appreciated!
Thanks,

Roger

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X2/X3/X4x Series incl. X41 Tablet”

Who is online

Users browsing this forum: No registered users and 10 guests