Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Odd Problem with my X40...

X2/X3/X4x series specific matters only
Post Reply
Message
Author
Digitalhorizons
Freshman Member
Posts: 56
Joined: Mon Mar 26, 2012 4:51 am
Location: Chesapeake, VA

Odd Problem with my X40...

#1 Post by Digitalhorizons » Thu Apr 19, 2012 9:33 pm

Hi, I got a x40 laptop from a friend, I was getting it for my grandmother due to it's robustness and light weight, but I started having a problem a few days after using it, the backlight would go out on it's on and the longer it was allowed the run the quicker it would turn off, so I ordered a replacement, it worked fine for about a day then started doing the same thing, I then noticed after trying to use the USB ports that they didn't work, so I ordered a replacement MB cheap off ebay too, hoping this would fix both problems I was having, it only fixed one, I'm still having the backlight issue but now all the LED status lights won't work, on either inverter board I have, what is going on??? Do I need to replace the whole screen? Any advice would be appreciated.

Digitalhorizons
Freshman Member
Posts: 56
Joined: Mon Mar 26, 2012 4:51 am
Location: Chesapeake, VA

Re: Odd Problem with my X40...

#2 Post by Digitalhorizons » Thu Apr 19, 2012 10:25 pm

Ok, apparently it's the MB, I swapped it out for the old MB with the defective USB ports and the status lights work. This is really driving me bonkers cause the backlight keeps going out with both inverters, did I just happend to have bad luck and got two bad inverters or is the screen really the culprit?

Raceboy
Senior Member
Senior Member
Posts: 779
Joined: Sun Feb 10, 2008 7:17 am
Location: Tartu, Estonia

Re: Odd Problem with my X40...

#3 Post by Raceboy » Fri Apr 20, 2012 2:30 am

Check the fuses near the LCD connector.
X61s:L7500,4GB,128GB SSD,IPS
X32s:PM 758 LV CPU mod,2GB,64GB microSATA SSD,COM mod,IPS
701c,240,380,X60s,560X,570E,600/E,T20,T21,T30,TR451,T42p
Past:560/E/Z,600E,R30,T21,T23,T30,T40,TR451,T40p,T41,T41p,T42,T42p,T43,X20,X22,X23,X24,X31,X40,X41,X60/T,X61/s,X201,T60,T60p,T61,T400,T601p

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20266
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: Odd Problem with my X40...

#4 Post by RealBlackStuff » Fri Apr 20, 2012 5:47 am

A bad or broken CCFL will show the same symptoms: work for a while, then when the CCFL heats up, it will conk out.
Either replace the CCFL, or the LCD (or the whole lid).
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

Digitalhorizons
Freshman Member
Posts: 56
Joined: Mon Mar 26, 2012 4:51 am
Location: Chesapeake, VA

Re: Odd Problem with my X40...

#5 Post by Digitalhorizons » Fri Apr 20, 2012 5:50 am

Thanks, I assume when you say check the fuses near the LCD connector you're talking about the LCD connector at the MB? l guess those going out cause the status LEDs to not light up?

Raceboy
Senior Member
Senior Member
Posts: 779
Joined: Sun Feb 10, 2008 7:17 am
Location: Tartu, Estonia

Re: Odd Problem with my X40...

#6 Post by Raceboy » Fri Apr 20, 2012 7:18 am

Digitalhorizons wrote:Thanks, I assume when you say check the fuses near the LCD connector you're talking about the LCD connector at the MB? l guess those going out cause the status LEDs to not light up?

Yes, the LCD connector on the MB.
X61s:L7500,4GB,128GB SSD,IPS
X32s:PM 758 LV CPU mod,2GB,64GB microSATA SSD,COM mod,IPS
701c,240,380,X60s,560X,570E,600/E,T20,T21,T30,TR451,T42p
Past:560/E/Z,600E,R30,T21,T23,T30,T40,TR451,T40p,T41,T41p,T42,T42p,T43,X20,X22,X23,X24,X31,X40,X41,X60/T,X61/s,X201,T60,T60p,T61,T400,T601p

sjthinkpader
Senior ThinkPadder
Senior ThinkPadder
Posts: 2908
Joined: Tue Jan 22, 2008 8:29 pm
Location: San Jose, CA

Re: Odd Problem with my X40...

#7 Post by sjthinkpader » Sat Apr 21, 2012 10:19 am

If the B/L turns on at all, it won't be the fuse. Like RBS said, it'll be the CCFL.
T60p 2623-DDU/UXGA IPS/ATI V5200
T60 2623-DCU/SXGA+ IPS/ATI X1400
T43p 2668-H8U/UXGA IPS/ATI V3200
R50p 1832-NU1/UXGA IPS/ATI FireGL T2
X61t 7762-B6U dual touch IPS/64GB SSD
X32 2673-BU6/32GB SSD
755CDV 9545-GBK Transmissive Projection LCD

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X2/X3/X4x Series incl. X41 Tablet”

Who is online

Users browsing this forum: No registered users and 5 guests