X40 - USB Blues

X2/X3/X4x series specific matters only
Post Reply
Message
Author
sicelo
Posts: 3
Joined: Tue Jul 05, 2016 5:23 pm
Location: Johannesburg, South Africa
Contact:

X40 - USB Blues

#1 Post by sicelo » Wed Jul 06, 2016 12:05 pm

Hi
I have received an X40 as a gift. Unfortunately, the USB ports are not working, which appears to have been a common problem with the X40.

What I wish to find out is - if i purchase a cardbus USB card, can the X40 boot off it to install an operating system? I know for example it cannot boot off the SD card (which works).

Or does the BIOS handle PCMCIA USB differently, and therefore be unable to boot from it?

Neil
Senior ThinkPadder
Senior ThinkPadder
Posts: 2926
Joined: Sun Aug 07, 2005 5:41 pm
Location: Paragould AR USA

Re: X40 - USB Blues

#2 Post by Neil » Wed Jul 06, 2016 5:21 pm

USB is dead in my X40 too so I use a PCMCIA card. No..try as I might, it won't boot from the add on card.
Collection = T500 - R400 - X300 - X200 - T61 (14" WXGA+) - T61 (14.1" SXGA+) - T60 (15" SXGA+) - X40 - T43p - T43 - T42p - A30P - 600E

dr_st
Senior ThinkPadder
Senior ThinkPadder
Posts: 6836
Joined: Sat Oct 29, 2005 6:20 am

Re: X40 - USB Blues

#3 Post by dr_st » Thu Jul 07, 2016 8:43 am

CardBus! You're using CardBus! (PCMCIA is the old slow 16-bit variant of the same form factor). :D

And no, it won't boot from that. You have to add special support in the BIOS for each individual controller to be able to boot from it. I haven't seen a Thinkpad that had BIOS support for booting from anything CardBus.
Current: X220 4291-4BG, T410 2537-R46, T60 1952-F76, T60 2007-QPG, T42 2373-F7G
Collectibles: T430s (IPS FHD + Classic Keyboard), X32 (IPS Screen)
Retired: X61 7673-V2V, A31p w/ Ultrabay Numpad
Past: Z61t 9440-A23, T60 2623-D3U, X32 2884-M5U

axur-delmeria
ThinkPadder
ThinkPadder
Posts: 1424
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: X40 - USB Blues

#4 Post by axur-delmeria » Thu Jul 07, 2016 10:32 am

Plop Boot Manager states that it supports booting from Cardbus USB cards: https://www.plop.at/en/bootmanager/pcmcia.html.

Note that I haven't tried this, so I don't know if it will work or not.
Daily driver: X220 4291-P79 i5-2520M

In reserve: X61 T7500, X60 T2300
In pieces: X60s CS U1300 [board only], two retired but working X61Ts
RIP: 760XD 9546-U9E

sicelo
Posts: 3
Joined: Tue Jul 05, 2016 5:23 pm
Location: Johannesburg, South Africa
Contact:

Re: X40 - USB Blues

#5 Post by sicelo » Thu Jul 07, 2016 11:30 am

Thank you all for your replies.
I will buy the card for regular USB usage, and install Linux in another way (e.g. TFTP or move HDD across)

sicelo
Posts: 3
Joined: Tue Jul 05, 2016 5:23 pm
Location: Johannesburg, South Africa
Contact:

Re: X40 - USB Blues

#6 Post by sicelo » Sat Jul 23, 2016 2:53 pm

Just as a follow-up:
- I did get the add-on USB Cardbus card for general USB use. Works very well
- Took out the 60GB SSD in the X40 hoping to install Linux on it while connected to an adapter. Eventually scrapped this plan as I was not too sure about voltage levels of the SSD (3.3V?) and the adapter (5V?)
- Decided to set up TFTP boot, and this worked awesomely.

So the X40 currently runs Debian 8/Jessie. Gnome3 works just well on it, although there is one nasty bug (Debian Bug #770130 & 776911) which can be work-arounded. KDE4 also works fine and is what I'm currently on.

teamde78
Freshman Member
Posts: 96
Joined: Sat Jul 18, 2015 5:18 pm
Location: Amherst, MA

Re: X40 - USB Blues

#7 Post by teamde78 » Fri Jul 29, 2016 7:17 am

sicelo wrote:Just as a follow-up:
- I did get the add-on USB Cardbus card for general USB use. Works very well
- Took out the 60GB SSD in the X40 hoping to install Linux on it while connected to an adapter. Eventually scrapped this plan as I was not too sure about voltage levels of the SSD (3.3V?) and the adapter (5V?)
- Decided to set up TFTP boot, and this worked awesomely.

So the X40 currently runs Debian 8/Jessie. Gnome3 works just well on it, although there is one nasty bug (Debian Bug #770130 & 776911) which can be work-arounded. KDE4 also works fine and is what I'm currently on.
Glad it is working for you. My X40 had similar issues last year, and I ended up not trying to fix it. I may just try to now and see if I can get a work around to those pesky USB problems.
Thinkpads: T430 (daily Driver), T60, Z61, T410, T410s, W500, W510.
Other: Macbook Pro Retina 2015, Macbook Pro 2012.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X2/X3/X4x Series incl. X41 Tablet”

Who is online

Users browsing this forum: No registered users and 4 guests