Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X40 with non-working USB ports

X2/X3/X4x series specific matters only
Post Reply
Message
Author
Lockheed
Sophomore Member
Posts: 182
Joined: Tue Jun 24, 2008 11:16 am
Location: France (most of the time)

X40 with non-working USB ports

#1 Post by Lockheed » Sat Dec 10, 2016 4:16 am

I got two X40s with latest bios. The problem is, that one of them behaves like it has no USB ports at all. They cannot be selected as boot device in BIOS when there is a USB stick or ThinkPad USB DVD drive plugged in, neither do they function within OS. Linux lists 4 ports, but no device is being detected with lsusb when plugged in. The same is true for Windows XP.

What's more, even if I put this X40 in a docking station, its USB ports are equally ignored.

Is this a faulty motherboard, or could there be some arcane ThinkPad setting that is causing this? I think I went through every setting in BIOS, but I read there is some windows software called something like "ThinkPad Configuration utility" - could someone disable USBs within it in WIndows, and now they are off?
T420s - i7, 16GB RAM, Samsung 850 EVO + 1TB Hitachi 9.5mm, Nvidia, Oleh Bios.
W500 - C2D P9500, 8GB RAM, Samsung 830 SSD + 750GB Hitachi HDD, Intel+ATI GPU, bright WUXGA, FP-reader
Arch Linux, BTRFS+ZFS on LUKS

Neil
Senior ThinkPadder
Senior ThinkPadder
Posts: 2944
Joined: Sun Aug 07, 2005 5:41 pm
Location: Paragould AR USA

Re: X40 with non-working USB ports

#2 Post by Neil » Sat Dec 10, 2016 8:21 am

Yes, it's a faulty system board. Likely the USB controller chip has failed. My X40 is in the same condition, and it's fairly common failing, though certainly does not affect all X40 systems.

My solution, for a few years now, has been to put a USB adapter in the CardBus slot. But, one cannot boot from such an adapter. For boot options I am fortune to have an Ultra Base with optical drive.
Collection = T500 - R400 - X300 - X200 - T61 (14" WXGA+) - T61 (14.1" SXGA+) - T60 (15" SXGA+) - X40 - T43p - T43 - T42p - A30P

axur-delmeria
ThinkPadder
ThinkPadder
Posts: 1725
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: X40 with non-working USB ports

#3 Post by axur-delmeria » Sat Dec 10, 2016 1:15 pm

Thinkwiki article regarding this issue.
Daily driver: X220 4291-C91 i7-2620M

Backup: X220 4291-P79 i5-2520M
Toy: X60/s Frankenpad Core Solo U1300
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E, X61 T7500
:cry:

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X2/X3/X4x Series incl. X41 Tablet”

Who is online

Users browsing this forum: No registered users and 5 guests