Compact Flash Card in X41 - XP Installation Failure Solved

X2/X3/X4x series specific matters only
Post Reply
Message
Author
michael8554
Posts: 6
Joined: Sat Mar 04, 2017 7:37 pm
Location: Wiltshire, UK

Compact Flash Card in X41 - XP Installation Failure Solved

#1 Post by michael8554 » Sat Mar 04, 2017 8:23 pm

Read all 37 pages of this excellent thread and decided to buy an X41 without a hard drive, but including a dock with CD drive.
Tried a Transcend 133x 4GB card for "proof of concept", using an XP Pro nLite CD installation (about 3GB).
The installation went without a hitch - the card was formatted FAT32 beforehand in a PC but without any boot added.
Performance was a bit slow but not unusable.
Based on that success I bought a Hama 30GB 200x 30MB/s card, but I failed to get XP to install.
Thinking it was the "Fixed" problem I tried many formatting programmes and even formatting in Linux, but no go.
So then I bought a SwissBit 8GB Industrial card, assuming this was Fixed, but XP installation failed on this too.
Then tried another identical Transcend 133x 4GB to note the steps to succesfull installation - but this failed!
Gets to the part of XP installation where it automatically reboots for the first time, but the CF doesn't boot and the CD starts re-installing XP from scratch.
Now there should be a message saying "hit any key to boot from CD", but I wasn't seeing that, and I wasn't hitting any key either.
Went round the loop a couple of times until, on a whim, I ejected the XP CD as it was shutting down.
The CF card booted into XP !!
The BIOS was set to boot from CD which is the correct setting, but I can't explain why it carried on booting after Windows was installed, has never happened to me on several other XP installations on other machines.
Now have the Industrial CF running XP Pro at very acceptable speed in a PA-CF18H IDE adapter.
Also installed 2GB RAM card on top of the 0.5GB which only gives a useable 2GB not 2.5GB.
Michael

michael8554
Posts: 6
Joined: Sat Mar 04, 2017 7:37 pm
Location: Wiltshire, UK

Re: Compact Flash Card in X41 - XP Installation Failure Solved

#2 Post by michael8554 » Sun Mar 05, 2017 7:24 am

I forgot to mention, after the first successful install on Transcend 133x, I got rid of the hard drive Error 2010 message with the BIOS update - any bearing?
Michael

Insulator_King
Posts: 18
Joined: Sat Jan 15, 2005 8:01 pm
Location: West Central Mountains of New Mexico

Re: Compact Flash Card in X41 - XP Installation Failure Solved

#3 Post by Insulator_King » Wed Aug 16, 2017 8:51 pm

re; RAM

The sytem can only recognize up to 2GB. But it is the best you can do with the hardware.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X2/X3/X4x Series incl. X41 Tablet”

Who is online

Users browsing this forum: No registered users and 5 guests