Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

[solved] Bluetooth mouse reconnect problem

X20/X30/X40 Series specific matters only
Post Reply
Message
Author
omero72
Posts: 37
Joined: Fri Nov 18, 2011 7:04 pm
Location: Marmara, Anatolia

[solved] Bluetooth mouse reconnect problem

#1 Post by omero72 » Wed May 20, 2020 9:04 am

One or two years ago I removed or arranged some software from my X41 to clean up the disk space and as far as I can remember I tinkered with bluetooth software too. Then Microsoft Bluetooth Mouse 5000 (2007 model) which was functioning perfectly then started to malfunction. I installed the BT sofware from scratch using the Lenovo official X41 Bluetooth driver suite (named 7jba10ww.exe about 100.1 MB)
https://thinkpads.com/support/Thinkpad- ... m/X41.html
but the mouse still had problems. I can add it using the "Add a Bluetooth Device" at the system tray BT icon, and it gets added fine but if I turn the mouse off and then on , it doesn't reconnect. If I reboot Windows XP (SP3) and then turn the BT mouse on, it still doesn't connect. I have to go through the "Add a Bluetooth Device" to connect it.

I have another mouse, Trust Bluetooth Mouse (trust.com/20403) and "Add a Bluetooth Device" doesn't even add it, the cursor just keeps rolling until I have to cancel the Add operation so it may be the Lenovo's BT driver software causing all this stuff. But I don't know which other software is compatible.

Also, when I turn the BT Card off using the Fn+F5 , the Windows sounds twice which gives the impression that 2 seperate hardware is being turned off. When I press Fn+F5 again to turn on the BT Card, it sounds once, as expected.

Lastly, when I turn off and on the mouse, sometimes it manages to reconnect but that happens very rarely, 1 out of 20 times, I'd say.
Any comment is appreciated.

omero72
Posts: 37
Joined: Fri Nov 18, 2011 7:04 pm
Location: Marmara, Anatolia

Re: [solved] Bluetooth mouse reconnect problem

#2 Post by omero72 » Mon May 25, 2020 6:12 am

Today I've solved the problem.

First, I removed the Bluetooth card which is BMDC-3 (FRU 39T0026) and installed BMDC200 (27R1880) which I detached from my R51. On R51 this BMDC200 was working super perfectly,picking up each and every mouse instantly. So I reckoned that it should perfect on X41 too. It came up as IBM Integrated bluetooth III on driver installation dialog and its drivers were installed flawlessly. However, no Bluetooth icon on the system tray came up so I have installed the bluetooth III software named as 'bthwxp1o.exe' (20MB) but the Bluetooth icon still didn't come up so I concluded that this card wouldn't work on X41 and I removed it and installed the BMDC-3 card again. It asked for drivers and I selected the drivers from the '52bm01ww.exe' (100MB) but no Bluetooth icon appeared on system tray. So I've installed all the software contained in 52bm01ww.exe. Nonetheless, I have not selected the unneeded Bluetooth services such as Bluetooth imaging, PIM synchronisation, Bluetooth serial port, etc. After the installation , the Bluetooth icon appeared on system tray and to my surprise, it started to function perfectly. I managed to connect the Trust Bluetooth Mouse , which previously didn't connect at all. And then I turned the mouse off and on, it reconnected again in a second. It's working like it was the year before.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X20/X30/X40 Series incl. Tablets”

Who is online

Users browsing this forum: No registered users and 15 guests