Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Need help: X61 bricked from BIOS and ECP version mismatch

X60/X61 and X60t/X61t Series
Post Reply
Posts: 5
Joined: Wed Dec 07, 2022 3:30 am
Location: Seattle, WA

Need help: X61 bricked from BIOS and ECP version mismatch

#1 Post by error_checking_coder » Mon Mar 20, 2023 1:49 am

While I was trying to downgrade from Middleton 2.22 BIOS, I accidentally flashed the official 1.10 BIOS without downgrading the ECP to 1.02. The flash went OK while I was in Windows 7, but when I reboot it, the screen remained black, the power light is on, the fan is on, but there is no other responses. Did I just brick it? I feel especially painful because it is a somewhat high-end T8300 model.

Additional context/questions:
- I was trying to switch from regular Middleton to SXGA+ Middleton, for LCD upgrade. I tried directly flashing the SXGA+ Middleton but the new LCD won't light up, so I thought a downgrade followed by another Middleton flash might work.
- When I tried downgrade, I first used WINUPTP.EXE (instead of WinPhlash.exe) to install 1.10 BIOS + 1.02 ECP. It used to work but today it says my system is incompatible. That's why I switched to WinPhlash.EXE. It appears that WINUPTP.EXE will correctly match ECP with BIOS version during flashing, while WinPhlash doesn't care about ECP. I still have no clue why it used to work but not this time.
- I have a separate working X61. I plugged that X61's LCD into the bricked system board, same issue. I plugged the bricked LCD into that X61's system board, it works. So, the issue is definitely in the system board.
- I read about Phoenix bios crisis tool: https://www.bios-mods.com/bios-recovery ... -recovery/ I'm not sure if X61 is phoenix but I tried it anyway. I couldn't get it to work. I also tried it on my other working X61. Fn+R or Fn+B does not activate the BIOS recover mode. So, I manually boot into the recover USB, the screen says Remove and USB and Press any key. I did that and nothing happened. The system continued to boot. I wonder if the tool even works for X61?
- I tried CMOS battery drain, power drain, memory reinstall. No effect.
- The HDD light no longer lights up or flashes. I doubt the system ever reaches POST.

Anything helps. Thank you!

Admin Emeritus
Admin Emeritus
Posts: 23385
Joined: Mon Sep 18, 2006 5:17 am
Location: Loch Garman, Éire

Re: Need help: X61 bricked from BIOS and ECP version mismatch

#2 Post by RealBlackStuff » Mon Mar 20, 2023 10:08 am

How about trying to boot from an external CD/DVD or the X6x-dock instead of USB (or v.v.)?
As a last resort, see if this helps: https://w3ask.com/guide-flash-bios-spi- ... rogrammer/
Lovely day for a Guinness! (The Real Black Stuff)
Lenovo: X240, X250, T440p, T480, M900 Tiny.

Junior Member
Junior Member
Posts: 315
Joined: Fri Sep 04, 2015 7:41 pm
Location: Oxford, UK

Re: Need help: X61 bricked from BIOS and ECP version mismatch

#3 Post by unixed » Mon Mar 20, 2023 11:37 am

It is not enough to flash Middleton's SXGA+ BIOS. If you then just put in the SXGA+ screen you could brick your planar, the pimout is different and you require an adapter of one form or another (check the pinouts to confirm). If that's what you've done flashing the BIOS won't help.

Post Reply
  • Similar Topics
    Last post

Return to “Thinkpad X60/X61 Series incl. Tablets”

Who is online

Users browsing this forum: No registered users and 48 guests