Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X61 Bluetooth issue

X60/X61 series specific matters only.
Post Reply
Message
Author
b1ack0p
Posts: 24
Joined: Sun Aug 18, 2019 4:48 pm
Location: Istanbul, Turkey

X61 Bluetooth issue

#1 Post by b1ack0p » Sun Aug 18, 2019 5:00 pm

Hi,

this is my first post. first of all i would like to say that i follow this forum for long time without registration and solutions to issues i faced on my thinkpads in this forum which came up with google searches helped me a lot! thanks for Thinkpads forum and i am glad there is such a place like here.

recently i have got a used X61 arrived with bluetooth on it but system doesnt detect bluetooth. i checked BIOS and there is no bluetooth setting to enable/disable there in Security or I/O Ports. i tried to turn on/off wifi switch button but still no luck. i also tried to install ThinkPad bluetooth driver data rate II but it didnt install by warning no BT detected.. i installed ubuntu, checked usb and pci devices with lsusb and lspci commands but no bluetooth again.

i disassembled to check if BT card is not plugged properly but it was plugged.. i cleaned the little socket and LCD flex cable with isopropyl alcohol but still no BT. i hope it is not mobo or flex cable faulty because it s hard to find parts from my location.

could you please give me advice what could be the problem? some may consider BT is not important but i sometimes need it while using BT mouse/keyboard and speakers.

thanks in advance.
my ThinkInventory: X20, X31, X40, X601s, X61,X230, T23, T42, T60

olex126
Junior Member
Junior Member
Posts: 330
Joined: Tue May 29, 2007 3:46 pm
Location: St.Thomas, Ontario, CANADA

Re: X61 Bluetooth issue

#2 Post by olex126 » Sun Aug 18, 2019 9:39 pm

Does Function+F5 bring up a Wireless/Bluetooth menu?

Dave
Previous & Collection Thinkpads: 701C A22m A30/A31p T23p x2 T30 T41 X31 various 750's 760's & 390's.

DD's & Test Benches: X41T, X60T & X61T's, various T42p-T43p's, x200 x201 x220T x230 T520 W530 T601F LED (X9000/8Gb/250SSD/W7 U)


"Life Is A Journey...Enjoy The Ride!"

b1ack0p
Posts: 24
Joined: Sun Aug 18, 2019 4:48 pm
Location: Istanbul, Turkey

Re: X61 Bluetooth issue

#3 Post by b1ack0p » Mon Aug 19, 2019 2:17 am

Thanks for reply. I just tried on Windows 7 - 64bit, installed Hotkey features v3.81 first and v3.89 later but volume keys and non of the Fn-keys bringing menu.
my ThinkInventory: X20, X31, X40, X601s, X61,X230, T23, T42, T60

b1ack0p
Posts: 24
Joined: Sun Aug 18, 2019 4:48 pm
Location: Istanbul, Turkey

Re: X61 Bluetooth issue

#4 Post by b1ack0p » Mon Aug 19, 2019 6:13 am

Hi again. i installed hotkey features and i could access Fn-5 menu but it doesnt show Bluetooth there. Shows only two , 1-Aairplane mode 2- 802.11 Wireless Radio

i tried another lcd (same BT card, same motherboard but different LCD flex cable) it didnt work..
my ThinkInventory: X20, X31, X40, X601s, X61,X230, T23, T42, T60

wileE
Sophomore Member
Posts: 216
Joined: Sun May 26, 2013 5:20 am
Location: Seligenstadt, Germany

Re: X61 Bluetooth issue

#5 Post by wileE » Mon Aug 19, 2019 10:40 am

Try this:
install tpfc v 062 https://thinkwiki.de/TPFanControl belongs on a X61 anyway
right click on the temperature icon that shows up in the task bar
second menu item is for switching bluetooth

b1ack0p
Posts: 24
Joined: Sun Aug 18, 2019 4:48 pm
Location: Istanbul, Turkey

Re: X61 Bluetooth issue

#6 Post by b1ack0p » Mon Aug 19, 2019 1:52 pm

Hi,
@wileE thanks for the reply. i installed as you adviced even i enabled Bluetooth at right click of TPfanControl no bluetooth detected :(
Screenshot here: https://i.postimg.cc/J73KxNbN/2019-08-19-20-33-09.png
my ThinkInventory: X20, X31, X40, X601s, X61,X230, T23, T42, T60

wileE
Sophomore Member
Posts: 216
Joined: Sun May 26, 2013 5:20 am
Location: Seligenstadt, Germany

Re: X61 Bluetooth issue

#7 Post by wileE » Mon Aug 19, 2019 2:13 pm

Most likely your bluetooth module is broken then.
If you buy a new one, X61 also works with the bluetooth 4.0 modules from the x230. Although you need the Middleton Bios for that.

b1ack0p
Posts: 24
Joined: Sun Aug 18, 2019 4:48 pm
Location: Istanbul, Turkey

Re: X61 Bluetooth issue

#8 Post by b1ack0p » Mon Aug 19, 2019 2:31 pm

i tried X61 BT module on T400 and it works. do you think something else with motherboard?
my ThinkInventory: X20, X31, X40, X601s, X61,X230, T23, T42, T60

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2655
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: X61 Bluetooth issue

#9 Post by axur-delmeria » Mon Aug 19, 2019 11:09 pm

So you already tried a different LCD cable, but it still didn't work? If yes, then it's likely that the issue is with the system board-- either it's not delivering power to the BT card, or the USB port it's wired to is defective/malfunctioning.
Daily driver: X220 4291-C91 i7-2620M

Backup: X601 Core 2 Duo T8100
Toy: X60F Core Solo U1300
On loan: X220 4291-P79 i5-2520M
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

b1ack0p
Posts: 24
Joined: Sun Aug 18, 2019 4:48 pm
Location: Istanbul, Turkey

Re: X61 Bluetooth issue

#10 Post by b1ack0p » Tue Aug 20, 2019 11:57 am

Hi finally problem fixed. i tried 2 flex cable didnt work. finally today i received another x61 (bad condition with good screen) i just replaced screen and flex cable worked with the card. so problem was bad lcd cable. replacement fixed the issue.

thanks all for replies and advices.
my ThinkInventory: X20, X31, X40, X601s, X61,X230, T23, T42, T60

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2655
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: X61 Bluetooth issue

#11 Post by axur-delmeria » Tue Aug 20, 2019 12:02 pm

So even the 2nd cable was defective? Awful luck. Good thing you found a replacement part.
Daily driver: X220 4291-C91 i7-2620M

Backup: X601 Core 2 Duo T8100
Toy: X60F Core Solo U1300
On loan: X220 4291-P79 i5-2520M
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

b1ack0p
Posts: 24
Joined: Sun Aug 18, 2019 4:48 pm
Location: Istanbul, Turkey

Re: X61 Bluetooth issue

#12 Post by b1ack0p » Wed Aug 21, 2019 12:29 pm

Yes it seems 2 cables were bad.
my ThinkInventory: X20, X31, X40, X601s, X61,X230, T23, T42, T60

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Thinkpad X60/X61 Series incl. Tablets”

Who is online

Users browsing this forum: No registered users and 26 guests