Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

X60/X61 series specific matters only.
Post Reply
Message
Author
iamdmc
Senior Member
Senior Member
Posts: 686
Joined: Fri Sep 21, 2007 11:37 pm
Location: Downtown Toronto, Canada

Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

#1 Post by iamdmc » Wed Mar 11, 2020 1:37 pm

I bought an HV121P01-100/101 from Aliexpress (Kevin trade shop - a supposedly reputable seller)
with the SXGA+ cable mod from the same seller and one from a ThinkPads forum member

I waited 6 weeks to get it from China, and naturally I was a bit excited to receive it today! Except when I plugged it into either one of my 2 X61s laptops (2 different motherboards, 2 different LCD cables) it powered on but had weird lines all over it and the image was not synchronised (see photos). I also tried 2 different SXGA+ mod cables (one from aliexpress, one from forum member) with the same result. Both motherboards are flashed with middleton's bios, and otherwise work fine. The original XGA screen works fine.

Images and video here https://imgur.com/a/GKFMwby

xiphmont posted a while back about another problem with the HV121P01 screens from aliexpress (tube vision) which was fixed by tweaking VR1. I tried this but to no effect. https://xiphmont.dreamwidth.org/tag/hv121p01

Can anyone lend their advice? Does someone know how to fix the problem? I really want to upgrade my X61s to SXGA+! Your thoughts are greatly appreciated

Panel https://www.aliexpress.com/item/32358449669.html
Cable https://www.aliexpress.com/item/1400-10 ... 32900.html
ThinkPad T480s
i7-8550u | 16+8GB RAM | 500GB Samsung 970 2280 M.2 M-key PCIe x4 | FHDtoQHD upgrade | 2242 M.2 B-key PCIe x2 @WWAN slot | Intel AX200

The X61 is dead... long live the X61

Past IBM ThinkPads: T450s, X250, X230, X220, X300, T410, X61s, T60p, T41, X31, T23, A21m

iamdmc
Senior Member
Senior Member
Posts: 686
Joined: Fri Sep 21, 2007 11:37 pm
Location: Downtown Toronto, Canada

Re: Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

#2 Post by iamdmc » Wed Mar 11, 2020 1:56 pm

Could it be a bad video scaler? Something on the LCD panel control board? It looks from one of my videos that the left-most 1/8th of the panel works fine but the rest of it has image doubling, lines, and jumping

Obvious things I've rules out:

* original LVDS cable from X61 (used 2 different ones to the same effect)

* bad motherboard connection (used 2 different X61 motherboards, both with middleton bios)

* bad bios settings (loaded defaults, toyed around with other settings - no change)

* bad SXGA+ cable mod (bought 2, used each one on both motherboards/both LVDS cables to the same effect)

I tried toying around with VR1 as per xiphmont's link, but that didn't change anything either...

in the end, is it defective or can something be done to fix it?
ThinkPad T480s
i7-8550u | 16+8GB RAM | 500GB Samsung 970 2280 M.2 M-key PCIe x4 | FHDtoQHD upgrade | 2242 M.2 B-key PCIe x2 @WWAN slot | Intel AX200

The X61 is dead... long live the X61

Past IBM ThinkPads: T450s, X250, X230, X220, X300, T410, X61s, T60p, T41, X31, T23, A21m

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2549
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

#3 Post by axur-delmeria » Wed Mar 11, 2020 8:58 pm

Have you flashed the SXGA+ BIOS ?
Daily driver: X220 4291-C91 i7-2620M

Backup: X601 Core 2 Duo T8100
Toy: X60F Core Solo U1300
On loan: X220 4291-P79 i5-2520M
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20988
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

#4 Post by RealBlackStuff » Thu Mar 12, 2020 1:43 am

+1 for SXGA+ BIOS (Middleton).
Any chance the screen displays at 50Hz instead of 60Hz, or v.v.?

Check all 30 cable-wires at both ends/connectors for continuity.
One bad soldering can screw up the functionality tremendously (been there, done that in my FrankenPad LED-mods).
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

"Computers don't lie, but liars can compute." (Terry Hayes's I Am Pilgrim)

iamdmc
Senior Member
Senior Member
Posts: 686
Joined: Fri Sep 21, 2007 11:37 pm
Location: Downtown Toronto, Canada

Re: Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

#5 Post by iamdmc » Thu Mar 12, 2020 7:10 am

Ahhha I got it working! Turns out that the Middleton bios I flashed was the non sxga+ version. I booted into ubuntu from usb and for some reason ubuntu fixes the display mess even without flashing sxga+ bios but windows 10 doesn't. Installed win10 32bit, reflashed bios, now working perfectly! Thanks so much! I feel like a fool but also happy because it works

Thanks everyone for your help!! Does anyone still have any LED backlight upgrade kit for the sxga+ screen?
ThinkPad T480s
i7-8550u | 16+8GB RAM | 500GB Samsung 970 2280 M.2 M-key PCIe x4 | FHDtoQHD upgrade | 2242 M.2 B-key PCIe x2 @WWAN slot | Intel AX200

The X61 is dead... long live the X61

Past IBM ThinkPads: T450s, X250, X230, X220, X300, T410, X61s, T60p, T41, X31, T23, A21m

axur-delmeria
Senior ThinkPadder
Senior ThinkPadder
Posts: 2549
Joined: Mon May 28, 2012 5:49 am
Location: Metro Manila, Philippines

Re: Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

#6 Post by axur-delmeria » Thu Mar 12, 2020 9:22 am

Glad you got it working.

BTW, can you post a link to where you bought your LCD adapter cable from? I'm thinking of transplanting the Samsung XGA PVA screen from one of my X61T's to my non-Tablet X61. :D
Daily driver: X220 4291-C91 i7-2620M

Backup: X601 Core 2 Duo T8100
Toy: X60F Core Solo U1300
On loan: X220 4291-P79 i5-2520M
In pieces: two retired but working X61Ts
RIP: 760XD 9546-U9E; X61 7676-A24; and a BOE-Hydis HV121P01-100 in failed SXGA+ mod
:cry:

iamdmc
Senior Member
Senior Member
Posts: 686
Joined: Fri Sep 21, 2007 11:37 pm
Location: Downtown Toronto, Canada

Re: Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

#7 Post by iamdmc » Thu Mar 12, 2020 9:45 am

Yep here you go:

I also bought one off a kind forum member with all-white cables which worked as well. I have a second X61s I want to get an SXGA+ screen for so I might keep that one for myself (or for spares in case they stop making these) https://www.aliexpress.com/item/32685632900.html
ThinkPad T480s
i7-8550u | 16+8GB RAM | 500GB Samsung 970 2280 M.2 M-key PCIe x4 | FHDtoQHD upgrade | 2242 M.2 B-key PCIe x2 @WWAN slot | Intel AX200

The X61 is dead... long live the X61

Past IBM ThinkPads: T450s, X250, X230, X220, X300, T410, X61s, T60p, T41, X31, T23, A21m

Libre_ME
Posts: 37
Joined: Wed Aug 01, 2018 1:03 pm
Location: Columbus, OH

Re: Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

#8 Post by Libre_ME » Thu Mar 12, 2020 6:21 pm

Glad that you figured this out. I'd like to get one of these screens, as well. I had Xiphmont make me a daylight_led-kit, but it's for the XGA tablet screen (1024 x 768.) I've never opened the package yet. I don't think it will work for SXGA+. I got around to installing this screen finally, about a month or so ago. i was going to install the daylight-led-kit, but when I tested the screen it was brighter than any of my other thinkpad's screens. I installed that screen in an x61. Two days later a line started forming in the top right corner, about 1/8" from the right side of screen. Over next several days it finally reached the bottom of the screen. I think that I pressed too hard trying to get the bezel to snap into place. this was my first screen mod ever. I have to do it again. Do you have a link to Aliexpress SXGA+ screen, or is it in your first message?

iamdmc
Senior Member
Senior Member
Posts: 686
Joined: Fri Sep 21, 2007 11:37 pm
Location: Downtown Toronto, Canada

Re: Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

#9 Post by iamdmc » Thu Mar 12, 2020 6:52 pm

Libre_ME wrote:
Thu Mar 12, 2020 6:21 pm
Glad that you figured this out. I'd like to get one of these screens, as well. I had Xiphmont make me a daylight_led-kit, but it's for the XGA tablet screen (1024 x 768.) I've never opened the package yet. I don't think it will work for SXGA+. I got around to installing this screen finally, about a month or so ago. i was going to install the daylight-led-kit, but when I tested the screen it was brighter than any of my other thinkpad's screens. I installed that screen in an x61. Two days later a line started forming in the top right corner, about 1/8" from the right side of screen. Over next several days it finally reached the bottom of the screen. I think that I pressed too hard trying to get the bezel to snap into place. this was my first screen mod ever. I have to do it again. Do you have a link to Aliexpress SXGA+ screen, or is it in your first message?
Yep here you go (link to screen): https://www.aliexpress.com/item/32358449669.html

Sorry to hear about your mod. Because I was frustrated with the SXGA+ mod not working last night, I swapped the CCFL backlight in my original XGA screen to a cheapo generic 12" LED strip and re-used the CCFL inverter to power it. I also snapped the CCFL tube while trying to remove it (oops, slightly dangerous). The LED strip is a bit brighter than the CCFL that was there before it, but not significantly so. I suspect it's because I'm not using the LED driver that came with it just the stock CCFL inverter, as I didn't want to desolder the CCFL component / resolder the LED driver to the LED indicator board just yet (me being lazy). Anyway it made me feel better about the SXGA+ mod not working last night, then I got it to work this morning, so 2 success stories!

If you decide not to go for the SXGA+ screen or just decide against doing the backlight mod/want to sell it please PM me! Otherwise good luck :) !

I still have to remove the plastic/metal 'ears' from the SXGA+ panel with my dremel cutting tool... wish me luck
ThinkPad T480s
i7-8550u | 16+8GB RAM | 500GB Samsung 970 2280 M.2 M-key PCIe x4 | FHDtoQHD upgrade | 2242 M.2 B-key PCIe x2 @WWAN slot | Intel AX200

The X61 is dead... long live the X61

Past IBM ThinkPads: T450s, X250, X230, X220, X300, T410, X61s, T60p, T41, X31, T23, A21m

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20988
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

#10 Post by RealBlackStuff » Fri Mar 13, 2020 2:30 am

I've never done an X6x LED-conversion, but I worked on plenty T601 Frankenpads with LED-backlit screens.
What I eventually figured out, was to remove the transformer from the original inverter once it is used with a LED-backlit screen.
See here what I did and why: https://www.theboardroom.info/trafo.html
One would assume that the same applies to the X6x inverters.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

"Computers don't lie, but liars can compute." (Terry Hayes's I Am Pilgrim)

iamdmc
Senior Member
Senior Member
Posts: 686
Joined: Fri Sep 21, 2007 11:37 pm
Location: Downtown Toronto, Canada

Re: Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

#11 Post by iamdmc » Fri Mar 13, 2020 3:44 am

RealBlackStuff wrote:
Fri Mar 13, 2020 2:30 am
I've never done an X6x LED-conversion, but I worked on plenty T601 Frankenpads with LED-backlit screens.
What I eventually figured out, was to remove the transformer from the original inverter once it is used with a LED-backlit screen.
See here what I did and why: https://www.theboardroom.info/trafo.html
One would assume that the same applies to the X6x inverters.
Thanks! Did that affect brightness at all?
ThinkPad T480s
i7-8550u | 16+8GB RAM | 500GB Samsung 970 2280 M.2 M-key PCIe x4 | FHDtoQHD upgrade | 2242 M.2 B-key PCIe x2 @WWAN slot | Intel AX200

The X61 is dead... long live the X61

Past IBM ThinkPads: T450s, X250, X230, X220, X300, T410, X61s, T60p, T41, X31, T23, A21m

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20988
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: Help! SXGA+ mod on X61 with lines on screen - broken? fixable?

#12 Post by RealBlackStuff » Fri Mar 13, 2020 7:34 am

Nope.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Thinkpad X6x Series incl. X6x Tablet”

Who is online

Users browsing this forum: No registered users and 15 guests