Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X6 Ultrabase teardown

X60/X61 series specific matters only.
Post Reply
Message
Author
nachetb
Posts: 44
Joined: Sun Aug 23, 2020 3:23 am
Location: Madrid, Spain

X6 Ultrabase teardown

#1 Post by nachetb » Tue Oct 27, 2020 3:54 am

Hey guys. Im having issues with an ultrabase I bought for my x61. The latch for releasing the laptop doesnt fully close, which causes the docking system to not work properly and cause different issues while I try to use it. I was gonna tear it apart and try to figure out whats wrong but I decided to ask you first, since theres not many ultrabase repair info online. Have any of you guys had a similar problem with this or other ultrabase? thanks

atagunov
Senior Member
Senior Member
Posts: 630
Joined: Thu Apr 02, 2020 3:11 pm
Location: London, UK

Re: X6 Ultrabase teardown

#2 Post by atagunov » Tue Oct 27, 2020 7:14 am

I did tear down 4337 dock once - in order to remove the grill at left-far-from-me corner. There is a theory that it partially blocks the vents on X220/T520 and besides you got to remove that if you want to also dock an X230T there. I followed some video on youtube. I was able to take it apart and put it back together. I'm unhappy with the result btw, X220/T520 have become much harder to dock :) Perhaps I should have cut out half of the grill to allow better air flow but kept the other half to allow me to place X220/T520 into them easily. So I'm using my other unmodified 4337 now. I'm not sure if this helps you at all though..
X220, 2 *T520

xelonakias
Posts: 19
Joined: Wed Oct 14, 2020 2:39 am
Location: Athens, Greece

Re: X6 Ultrabase teardown

#3 Post by xelonakias » Tue Oct 27, 2020 10:43 am

nachetb wrote:
Tue Oct 27, 2020 3:54 am
Hey guys. Im having issues with an ultrabase I bought for my x61. The latch for releasing the laptop doesnt fully close, which causes the docking system to not work properly and cause different issues while I try to use it. I was gonna tear it apart and try to figure out whats wrong but I decided to ask you first, since theres not many ultrabase repair info online. Have any of you guys had a similar problem with this or other ultrabase? thanks
Never had this issue, but the latch-lever operates as a pusher, while there is a return spring. Check the return spring that should return the lever to the start position, if it has gone awry it could be the source of your blocking.
Good luck and remember take pics to see how things were while you opened it!

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “Thinkpad X60/X61 Series incl. Tablets”

Who is online

Users browsing this forum: Bing [Bot] and 16 guests