Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Mavericks 10.9 on a T61(p)

OS-X on ThinkPads
Post Reply
Message
Author
Madara-san
Freshman Member
Posts: 65
Joined: Sun Sep 15, 2013 1:38 pm
Location: Budapest, Hungary

Mavericks 10.9 on a T61(p)

#1 Post by Madara-san » Wed Oct 23, 2013 7:22 am

Working on a stable build... when I done with that, I'll write a guide for you guys :wink:

If anyone had a success please post your results here.
ThinkPad T61p - C2D T9300 - Quadro FX 570m - 4GB DDR2-667 - Mac OS X 10.9.1

chamillion
Posts: 2
Joined: Tue Sep 24, 2013 4:12 pm
Location: phoenix, az

Re: Mavericks 10.9 on a T61(p)

#2 Post by chamillion » Thu Nov 07, 2013 11:21 am

I have already accomplished what can be done at this point. Here is the progress - http://www.insanelymac.com/forum/topic/ ... type-7659/

Madara-san
Freshman Member
Posts: 65
Joined: Sun Sep 15, 2013 1:38 pm
Location: Budapest, Hungary

Re: Mavericks 10.9 on a T61(p)

#3 Post by Madara-san » Sat Nov 09, 2013 4:08 am

Ah I see, that you got success on a T61-intel. Here's my files for T61-nvidia and T61p. Just use it with myhack and everything should work fine. ;)

http://www.2shared.com/file/9aHh219C/Extra.html

If anyone got question, feel free to ask me about it. :)
ThinkPad T61p - C2D T9300 - Quadro FX 570m - 4GB DDR2-667 - Mac OS X 10.9.1

Eric Giles
Junior Member
Junior Member
Posts: 464
Joined: Mon Aug 30, 2004 3:36 pm
Location: Waynesboro, MS
Contact:

Re: Mavericks 10.9 on a T61(p)

#4 Post by Eric Giles » Mon Nov 11, 2013 12:28 am

Madara-san...

I just wanted to say thank you for your post and the files-I downloaded Mavericks 10.9 and installed it to a 8GB USB flash drive using the latest myhack 3.3.1, then added your files to the flash drive. I am using a 15.4" T61 6459-CTO with Nvidia NVS140M, 1680x1050 resolution, T8100 CPU, etc. Everything is working perfectly! Graphics performance is excellent, touchpad and trackpoint work perfectly, Bluetooth works, the stock Thinkpad/Atheros AR5212 wifi is working with a patched kext and the device ID added, and most importantly-sleep is working with no issues. Under System Information, the graphics adapter does show as a Nvidia Quadro FX570M (like your T61p), but it doesn't affect anything-it still works perfectly.

I can highly recommend Mavericks 10.9 on a Nvidia T61 using the files provided by Madara-san. It is just about the best Hackintosh setup I have used.
I lost count...

Madara-san
Freshman Member
Posts: 65
Joined: Sun Sep 15, 2013 1:38 pm
Location: Budapest, Hungary

Re: Mavericks 10.9 on a T61(p)

#5 Post by Madara-san » Mon Nov 11, 2013 3:35 am

I'm happy for your succes :) and also thanks for the feedback :wink:

If you want to change your graphics card's name, you have to edit your DSDT with MacIASL. Open /Extra/DSDT.aml and search for the string "Quadro". Now you will able to edit "Nvidia Quadro FX 570M" with "Nvidia Quadro NVS140m" and save the DSDT.aml :)
ThinkPad T61p - C2D T9300 - Quadro FX 570m - 4GB DDR2-667 - Mac OS X 10.9.1

vivison
Posts: 3
Joined: Mon Jun 07, 2010 3:01 pm
Location: garden grove, ca

Re: Mavericks 10.9 on a T61(p)

#6 Post by vivison » Mon Nov 25, 2013 10:40 pm

Thanks for your Extra. My T61 type-7663 works perfectly except for wifi. I wonder if you also have the Intel 4956AGN wifi card. I used Rosewill RNX-MiniN2 USB for wifi instead.

Eric Giles
Junior Member
Junior Member
Posts: 464
Joined: Mon Aug 30, 2004 3:36 pm
Location: Waynesboro, MS
Contact:

Re: Mavericks 10.9 on a T61(p)

#7 Post by Eric Giles » Tue Nov 26, 2013 9:24 am

vivison wrote:Thanks for your Extra. My T61 type-7663 works perfectly except for wifi. I wonder if you also have the Intel 4956AGN wifi card. I used Rosewill RNX-MiniN2 USB for wifi instead.
Intel based wifi cards do not work in OS X. Your best bet is to purchase an atheros or Broadcom based wifi card that is known to work with Mac OS X, then install the Middleton BIOS on your T61 so that the card will work without being rejected by the T61. The solution that Madara-san recommended to me was the Atheros AR5BXB92 AR9280, which I currently use-although for some reason I still cannot connect to an encrypted, password protected wifi access point. You may be better off buying an original branded Apple Airport Extreme mini PCI-e card.
I lost count...

tofu
Posts: 7
Joined: Fri Jun 06, 2008 1:12 pm
Location: Los angeles, California

Re: Mavericks 10.9 on a T61(p)

#8 Post by tofu » Tue Nov 26, 2013 10:47 am

Hi Madara-san,

Thank you for your files. I was able to install Mavericks on my Thinkpad T61P (nvidia 570) with Middleton BIOS. GFX acceleration works. Sound works. At the moment, using a Wireless USB adapter - running via a third party application. It works very well!

It feels very much like a mac, except for gestures and such.

I have a question about sleep. It seems that for you and another person, Eric Giles, that sleep is working.That is currently not working for me. Was there anything special that has to be done in the BIOS? I would like to note that OS X is running off the HDD in the Ultrabay.

Also, another question: in the post install scripts, MyHack asks to remove some Ktexts. Was it recommended to remove all three? I removed the first two and left the third one installed. Could this be why sleep isn't working?
Thinkpad T61 14.1" Widescreen / 2.4 Ghz 3 MB L2 Cache / 800 Mhz FSB / 100 GB 7200 RPM / Nvidia Quadro NVS 140M / 2 GB RAM / Windows XP / Arch Linux / Mac OS X Leopard

Leopard: No ethernet / No sound / No accelerated graphics

Madara-san
Freshman Member
Posts: 65
Joined: Sun Sep 15, 2013 1:38 pm
Location: Budapest, Hungary

Re: Mavericks 10.9 on a T61(p)

#9 Post by Madara-san » Wed Nov 27, 2013 5:20 am

Eric: Hmm, that's strange why you can't connect to encrypted networks... Did you tried a reinstall after you installed the AR5BXB92? Because it works just fine with the HP/Compaq one and no kext modifications.

tofu: Yes, sleep is working well with these kexts and almost default bios configuration (tomorrow I'll write down my bios settings). And about the 3 kexts, I removed the first one (ApplePolicyControl.kext), and leaved the 2 other. What happens if you put your laptop to sleep, or closing the lid? Kernel panic? Black screen?
ThinkPad T61p - C2D T9300 - Quadro FX 570m - 4GB DDR2-667 - Mac OS X 10.9.1

vivison
Posts: 3
Joined: Mon Jun 07, 2010 3:01 pm
Location: garden grove, ca

Re: Mavericks 10.9 on a T61(p)

#10 Post by vivison » Wed Nov 27, 2013 3:12 pm

I installed AR5BXB6 PCI-e wifi card but it was not recognized at all. I also tried AtherosFix.kext, IO8022Family.kext, and airportd that I used OK in 10.8.5 but it would not work either. Do I need to modify DSDT some how?

Madara-san
Freshman Member
Posts: 65
Joined: Sun Sep 15, 2013 1:38 pm
Location: Budapest, Hungary

Re: Mavericks 10.9 on a T61(p)

#11 Post by Madara-san » Wed Nov 27, 2013 3:47 pm

Sorry but I don't know why is that not works for you... In the DSDT there's nothing modified about wireless, and it's working perfect with my atheros, and on an another T61p with a dell broadcom. Is it recognized in the Mavericks installer? Did it worked in 10.8.5 without any modification?
ThinkPad T61p - C2D T9300 - Quadro FX 570m - 4GB DDR2-667 - Mac OS X 10.9.1

vivison
Posts: 3
Joined: Mon Jun 07, 2010 3:01 pm
Location: garden grove, ca

Re: Mavericks 10.9 on a T61(p)

#12 Post by vivison » Wed Nov 27, 2013 4:24 pm

Thanks for your reply. I installed Mavericks with your Extra on my T61 with an Intel wifi. Since Intel card does not work, I replace it with the Atheros. That wifi card work in my T60 + niresh ML + some kexts from internet. Anyway, I am more than happy with your install + USB wifi.

Eric Giles
Junior Member
Junior Member
Posts: 464
Joined: Mon Aug 30, 2004 3:36 pm
Location: Waynesboro, MS
Contact:

Re: Mavericks 10.9 on a T61(p)

#13 Post by Eric Giles » Wed Nov 27, 2013 11:22 pm

Madara-san wrote:Eric: Hmm, that's strange why you can't connect to encrypted networks... Did you tried a reinstall after you installed the AR5BXB92? Because it works just fine with the HP/Compaq one and no kext modifications.
I haven't tried a reinstall yet. In order to get the original Thinkpad Atheros based card to work, I installed atheros.kext, then added the device ID of that card to that kext-it then recognized it, but would only connect to an open wifi network. When I received the Atheros card model that you use, I removed that kext and installed the original kext for 10.9-that didn't allow the card to be recognized. When I added my downloaded atheros.kext back, the new card was detected but still have the same issue.

I should probably just reinstall from scratch, but the setup I have works so well otherwise that I hate to mess with it! I do have a spare T61p coming in next week, so I may use it as a test to see if I can get it working there.
I lost count...

bwaldow
Freshman Member
Posts: 91
Joined: Tue Sep 28, 2004 7:59 pm
Location: Perth, Australia

Re: Mavericks 10.9 on a T61(p)

#14 Post by bwaldow » Sat Nov 30, 2013 6:30 pm

Hello,

Reading this I'm thinking of running Mavericks, and I have some questions, please.

I have a 4:3 T60/61 Frankenpad with Intel graphics only. One approach is to get a T61 4:3 motherboard with the NVidia graphics. Another approach is to get a 15.4" T61 with NVidia.
  • I understand the Intel graphics won't work with Mavericks, or not well - am I mistaken?
    Does the Trackpoint work (as a mouse, perhaps)?
    There are T61s with 1920x1200 panels - would I get that native resolution?
    There are MacBook Pros and T61s with 1680x1050 panels - would I get that native resolution?
    Does anyone have a working modem? (not important, but interesting)
    Does anyone have working Bluetooth?
    Can you mention anything that does not work?
Any overall comment on usability of me upgrading my 4:3 motherboard to one with NVidia vs. getting a wide-screen thinkpad?
Frankenpad 0: T60/1 2.5Ghz Penryn C2D w/15" UXGA LED backlit LCD & Intel GPU
Frankenpad 1: T60/1 2.6Ghz Penryn C2D w/15" UXGA LED backlit LCD & NVS140M GPU
X61 Tablet 1.6Ghz SXGA (7769-A67)
T42 14" SXGA (2378-XXQ)

tofu
Posts: 7
Joined: Fri Jun 06, 2008 1:12 pm
Location: Los angeles, California

Re: Mavericks 10.9 on a T61(p)

#15 Post by tofu » Sun Dec 01, 2013 2:39 am

Madara-san wrote:tofu: Yes, sleep is working well with these kexts and almost default bios configuration (tomorrow I'll write down my bios settings). And about the 3 kexts, I removed the first one (ApplePolicyControl.kext), and leaved the 2 other. What happens if you put your laptop to sleep, or closing the lid? Kernel panic? Black screen?
If I put it to sleep or close the lid, things happen.

A weird sound beeps, and then the computer looks like its getting ready for sleep, but never goes into sleep mode. The fan is blowing, and the sleep icon blinks on and off. I can't do anything at this point, and resort to hard shutting it down.

@ the 3 ktext, I believe I removed the first two, and left the third. I left the one that talked about how some nvidia settings might cause slowdowns. I'll try installing again in the near future with close settings as you.

For the bios, the only thing I changed was USB always on. I changed it to off and I still can't get sleep to work.

In other news, I tried using the Thinkpad T61p on the dock. Works really well.
Thinkpad T61 14.1" Widescreen / 2.4 Ghz 3 MB L2 Cache / 800 Mhz FSB / 100 GB 7200 RPM / Nvidia Quadro NVS 140M / 2 GB RAM / Windows XP / Arch Linux / Mac OS X Leopard

Leopard: No ethernet / No sound / No accelerated graphics

tofu
Posts: 7
Joined: Fri Jun 06, 2008 1:12 pm
Location: Los angeles, California

Re: Mavericks 10.9 on a T61(p)

#16 Post by tofu » Sun Dec 01, 2013 2:48 am

bwaldow wrote:Hello,

Reading this I'm thinking of running Mavericks, and I have some questions, please.

I have a 4:3 T60/61 Frankenpad with Intel graphics only. One approach is to get a T61 4:3 motherboard with the NVidia graphics. Another approach is to get a 15.4" T61 with NVidia.
  • I understand the Intel graphics won't work with Mavericks, or not well - am I mistaken?
    (1)Does the Trackpoint work (as a mouse, perhaps)?
    (2)There are T61s with 1920x1200 panels - would I get that native resolution?
    (3)There are MacBook Pros and T61s with 1680x1050 panels - would I get that native resolution?
    (4)Does anyone have a working modem? (not important, but interesting)
    (5)Does anyone have working Bluetooth?
    (6)Can you mention anything that does not work?
Any overall comment on usability of me upgrading my 4:3 motherboard to one with NVidia vs. getting a wide-screen thinkpad?
(1) With Madara-san's addon, the Trackpoint does work. You can hold the middle button and it'll scroll up or down as you move up or down on the Trackpoint. I haven't figured out how to reverse the scroll though...

Two finger scroll works here in OSX.


(2) I have a T61p with the 1920x1200 resolution (15"). It looks really nice with OS X 10.9, with the Nvidia Quadro FX 570m to power it. At that resolution, with that distance, you can say its even "retina"

(3) I think you can get whatever native resolution screen your monitor supports.
(5) Bluetooth, I have not tried the internal one. But in the worst case, you can buy a USB adapter for it. BT 4.0. IOGEAR Bluetooth 4.0 USB Micro Adapter (GBU521) - this particular one works. (I've used it in 10.8, not yet in 10.9, but I assume it should work, seeing that in 10.9, it was prompting me to connect my BT keyboard). (amazon http://www.amazon.com/gp/product/B007GF ... UTF8&psc=1)

(6) I would recommend getting one with Nvidia. They seem to work OOB on 10.8 and 10.9.

I haven't tested Microphone yet, nor have I tested Serial port, parallel ports and all those legacy things. But I could not get sleep to work. Two others have gotten sleep to work. I don't know whats different.
Thinkpad T61 14.1" Widescreen / 2.4 Ghz 3 MB L2 Cache / 800 Mhz FSB / 100 GB 7200 RPM / Nvidia Quadro NVS 140M / 2 GB RAM / Windows XP / Arch Linux / Mac OS X Leopard

Leopard: No ethernet / No sound / No accelerated graphics

Madara-san
Freshman Member
Posts: 65
Joined: Sun Sep 15, 2013 1:38 pm
Location: Budapest, Hungary

Re: Mavericks 10.9 on a T61(p)

#17 Post by Madara-san » Thu Dec 05, 2013 7:34 pm

bwaldow:

For me, everything works, even VGA out and dual display mode, firewire and fingerprint reader hardware. Still, for mavericks we need a good fingerprint software because the old upek software not working. I'm just curious: do you want to use the modem? What for? :) BTW, never tried that, but if you want to use, I can do some research :D

Just get an nvidia model. If you have an intel, you just get stuck with 10.7.5

tofu:

So the moon blinks 'forever'. That "weird sound beep" is also present for me, then the moon blinks and a few seconds later it goes to sleep. I have an idea for you: please remove the nvram*******.plist from the /Extra folder, then reboot. Also, do you use the latest middleton bios, right?
ThinkPad T61p - C2D T9300 - Quadro FX 570m - 4GB DDR2-667 - Mac OS X 10.9.1

bwaldow
Freshman Member
Posts: 91
Joined: Tue Sep 28, 2004 7:59 pm
Location: Perth, Australia

Re: Mavericks 10.9 on a T61(p)

#18 Post by bwaldow » Fri Dec 06, 2013 3:00 am

Madara-san wrote:bwaldow:

For me, everything works, even VGA out and dual display mode, firewire and fingerprint reader hardware.
Thanks. That's reassuring.

I have a Hackintosh now - an HP ProBook 4540s which works very well, but is unwieldy, is another laptop, and only works well with 8G RAM. And the display panel isn't so good.

As you can read in my signature, I have 2 Frankenpads, both with lovely IPS LED backlight high-resolution displays, and if I could have known Mavericks would work so well on them, I would not have bought the ProBook. Now I know, and I think it better to move in that direction and sell the ProBook.
Madara-san wrote:I'm just curious: do you want to use the modem? What for? :) BTW, never tried that, but if you want to use, I can do some research :D
I don't have a use for it - in fact, in order to make my Frankenpads, I had to remove the modem from the donating T61 motherboards (the frame won't allow the connectors to line up).

But there was a question of replacing the motherboard on one of my Frankenpads, or purchasing a wide-screen T61p with 1680x1050 or 1920x1200 panel - which would have an intact modem. Knowing about this was interesting and might have swayed my choice.
Madara-san wrote:Just get an nvidia model. If you have an intel, you just get stuck with 10.7.5
So I do, and I am negotiating with Tuus about getting an NVidia 140M to replace the Merom Intel board. The 570 is attractive, but he says none of the 570 boards have the 'fixed' NVidia chips, and also he does not have one.

The ProBook relies on an Intel HD4000, and its discrete AMD 6770 (or such) must be disabled as there is no support for it in OS X. So, even the 140M will be faster.

However, there is a T61p with 1680x1050 panel and 570M for sale locally now, so talk me into it quick before I order from Tuus. But I know I'll be ok with a replacement board in what I have now if there's no substantial advantage.
Frankenpad 0: T60/1 2.5Ghz Penryn C2D w/15" UXGA LED backlit LCD & Intel GPU
Frankenpad 1: T60/1 2.6Ghz Penryn C2D w/15" UXGA LED backlit LCD & NVS140M GPU
X61 Tablet 1.6Ghz SXGA (7769-A67)
T42 14" SXGA (2378-XXQ)

bwaldow
Freshman Member
Posts: 91
Joined: Tue Sep 28, 2004 7:59 pm
Location: Perth, Australia

Re: Mavericks 10.9 on a T61(p)

#19 Post by bwaldow » Fri Dec 06, 2013 6:06 am

Madara-san wrote:everything works, even VGA out and dual display mode, firewire and fingerprint reader hardware
Does the CardBus slot, or the ExpressCard slot, or the 4in1 card reader work for anyone under OS X?
Frankenpad 0: T60/1 2.5Ghz Penryn C2D w/15" UXGA LED backlit LCD & Intel GPU
Frankenpad 1: T60/1 2.6Ghz Penryn C2D w/15" UXGA LED backlit LCD & NVS140M GPU
X61 Tablet 1.6Ghz SXGA (7769-A67)
T42 14" SXGA (2378-XXQ)

Eric Giles
Junior Member
Junior Member
Posts: 464
Joined: Mon Aug 30, 2004 3:36 pm
Location: Waynesboro, MS
Contact:

Re: Mavericks 10.9 on a T61(p)

#20 Post by Eric Giles » Fri Dec 06, 2013 10:31 am

I received a 15.4" T61p the other day and swapped in the SSD with 10.9 Mavericks that I had been using in my 15.4" T61 with NVS140M graphics. I now have the same issue as others with sleep-it makes the two beeps, goes into sleep mode, then wakes up-only to repeat the process. I sometimes cannot get the unit to respond after one of these cycles, so I have to force power off the laptop and then turn it back on.

Everything else seems to work just fine. I updated the BIOS on the T61p to the Middleton BIOS, which is also what my T61 was running. The wireless is the stock Thinkpad Atheros AR5212 card (which I had in my T61 with no issues related to sleep). Besides the upgraded video system, the only other notable difference between the two systems is the CPU. I am still running the original Mermom T7500 CPU in the T61p, but I was using a Penryn T9300 (and before that a T8300) in the T61. I am wondering if that may be the reason I am not able to enter sleep mode properly?

I did delete all the nvram plist files as was mentioned in an earlier post, but this didn't help. If anyone has any suggestions I would appreciate it!
I lost count...

bwaldow
Freshman Member
Posts: 91
Joined: Tue Sep 28, 2004 7:59 pm
Location: Perth, Australia

Re: Mavericks 10.9 on a T61(p)

#21 Post by bwaldow » Fri Dec 06, 2013 10:13 pm

Eric Giles wrote:Ibut I was using a Penryn T9300 (and before that a T8300) in the T61
... a question.

Is the motherboard in the (working properly) T61 a Merom board which can use a Penryn CPU because of the Middleton BIOS, or does the T61 have a native Penryn motherboard?

If the T61 has a Merom board, you can put the Penryn CPU into the T61p, which presumably has a Merom board, and find out.

I admit it's a pain and I'm not requesting that you do, rather I'm just pointing out that you can find out.

However, if the T61 has a Penryn board, then we at least have a better idea of the questions: is the difference the CPU or the motherboard?
Frankenpad 0: T60/1 2.5Ghz Penryn C2D w/15" UXGA LED backlit LCD & Intel GPU
Frankenpad 1: T60/1 2.6Ghz Penryn C2D w/15" UXGA LED backlit LCD & NVS140M GPU
X61 Tablet 1.6Ghz SXGA (7769-A67)
T42 14" SXGA (2378-XXQ)

Eric Giles
Junior Member
Junior Member
Posts: 464
Joined: Mon Aug 30, 2004 3:36 pm
Location: Waynesboro, MS
Contact:

Re: Mavericks 10.9 on a T61(p)

#22 Post by Eric Giles » Fri Dec 06, 2013 10:32 pm

bwaldow wrote:
Eric Giles wrote:Ibut I was using a Penryn T9300 (and before that a T8300) in the T61
... a question.

Is the motherboard in the (working properly) T61 a Merom board which can use a Penryn CPU because of the Middleton BIOS, or does the T61 have a native Penryn motherboard?

If the T61 has a Merom board, you can put the Penryn CPU into the T61p, which presumably has a Merom board, and find out.

I admit it's a pain and I'm not requesting that you do, rather I'm just pointing out that you can find out.

However, if the T61 has a Penryn board, then we at least have a better idea of the questions: is the difference the CPU or the motherboard?
The T61 was originally configured with the T8300, so it is a Penryn board that I flashed with the Middleton BIOS before I ever installed Mavericks. I am most likely going to install the T9300 into the T61p and then see what happens. I may do that this evening, and will post back with my results soon. If that doesn't work, I very well may try a clean install of Mavericks on the T61p and see if that makes a difference.
I lost count...

topan
Posts: 9
Joined: Thu Aug 22, 2013 10:28 pm
Location: Bandung, Indonesia.

Re: Mavericks 10.9 on a T61(p)

#23 Post by topan » Wed Dec 11, 2013 2:29 pm

Madara-san wrote:Just get an nvidia model. If you have an intel, you just get stuck with 10.7.5
Hi, Madara San. I'm looking for guidance of installing mavericks on thinkpad X61. I have a fully working Lion installation on my X61. As quoted, did you mean that my X61 is not capable to run Mavericks since it has only intel integrated graphics accelerator? Are there any solutions for it? Please give me your advice or hint. Except the VGA, AFAIK, X61 and T61 have the same components.
I'm actually satisfied with the performance of Lion in my X61, but I really want to upgrade to Mavericks. :?

Madara-san
Freshman Member
Posts: 65
Joined: Sun Sep 15, 2013 1:38 pm
Location: Budapest, Hungary

Re: Mavericks 10.9 on a T61(p)

#24 Post by Madara-san » Fri Dec 13, 2013 6:12 pm

Hi!

Sorry, but you cannot... :( Intel graphics only can use VESA mode in Mavericks, so you will not get any hardware acceleration. Stay with Lion, it's the only one solution.

Update: I've upgraded my T61p with a C2D T9300 CPU and an 1920x1200 screen. Works flawlessly, really awesome :D and BTW, sleep works still. Also tried an another T61p with a T8300 and sleep worked on that machine too! Default Mavericks installation with myhack + my extra folder. Middleton bios.

BIOS settings: all default, only modification is enable hardware virtualization (and the boot order).
ThinkPad T61p - C2D T9300 - Quadro FX 570m - 4GB DDR2-667 - Mac OS X 10.9.1

Eric Giles
Junior Member
Junior Member
Posts: 464
Joined: Mon Aug 30, 2004 3:36 pm
Location: Waynesboro, MS
Contact:

Re: Mavericks 10.9 on a T61(p)

#25 Post by Eric Giles » Fri Dec 13, 2013 11:44 pm

I took a spare hard drive and did a fresh install of Mavericks on the T61p, using Madara-san's files again. Everything works fine, except sleep -all Middleton BIOS settings were the same as the T61, but it tries to sleep and then wakes up.

I then took a 14.1" non-widescreen T61 with T8300 CPU, NVS140M, and Middleton BIOS and swapped in each of the Maverick hard drives. Same results-everything works but sleep. It seems the only T61 I can get to sleep properly is the T61 15.4" with T9300, NVS140M, and Middleton BIOS. Still no idea what could be different that would cause the issue...
I lost count...

bwaldow
Freshman Member
Posts: 91
Joined: Tue Sep 28, 2004 7:59 pm
Location: Perth, Australia

Re: Mavericks 10.9 on a T61(p)

#26 Post by bwaldow » Sat Dec 14, 2013 3:53 am

Eric Giles wrote:I took a spare hard drive and did a fresh install of Mavericks on the T61p, using Madara-san's files again. Everything works fine, except sleep -all Middleton BIOS settings were the same as the T61, but it tries to sleep and then wakes up.
I'm new at this too (Hackintosh). Is there a log file for sleep, or entries in the general log that happen around the time you try to sleep the machine that would be of interest?

I'll be getting parts this coming week to put an NVidia motherboard into my own Frankenpad to try these files (I'll sacrifice the Merom). I'll see which luck I get, but I'll be able to investigate at least.

My board will be a native Penryn with a 140m.
Frankenpad 0: T60/1 2.5Ghz Penryn C2D w/15" UXGA LED backlit LCD & Intel GPU
Frankenpad 1: T60/1 2.6Ghz Penryn C2D w/15" UXGA LED backlit LCD & NVS140M GPU
X61 Tablet 1.6Ghz SXGA (7769-A67)
T42 14" SXGA (2378-XXQ)

bwaldow
Freshman Member
Posts: 91
Joined: Tue Sep 28, 2004 7:59 pm
Location: Perth, Australia

Re: Mavericks 10.9 on a T61(p)

#27 Post by bwaldow » Sat Dec 14, 2013 6:35 am

Eric Giles wrote:Everything works fine, except sleep -all Middleton BIOS settings were the same as the T61, but it tries to sleep and then wakes up.
The maintenance manual doesn't list '2 short beeps' for any symptom.

Things to try to isolate the issue (maybe - I would start with all of these and if it makes a difference add back):
Remove the wifi adapter
Remove one of the RAM modules
Remove the Ultrabay drive

Also:
Remove the battery (on mains power)
Remove the mains power (on battery)

I know that with a 6 cell battery in place one of the ACPI sensor outputs is fixed at 50C readout regardless of actual temperature, so it may have other unintended effects which the software might trip over (and after all, any bug is an unintended effect).

My HP ProBook 4540s Hackintosh runs at 99%+ idle with 16G RAM under Mavericks, but the CPU goes to over 30% under Linux or Windows. No idea why, but it suggests minimizing the RAM as a useful diagnostic - don't know why, but know it can make a big difference in the system.
Frankenpad 0: T60/1 2.5Ghz Penryn C2D w/15" UXGA LED backlit LCD & Intel GPU
Frankenpad 1: T60/1 2.6Ghz Penryn C2D w/15" UXGA LED backlit LCD & NVS140M GPU
X61 Tablet 1.6Ghz SXGA (7769-A67)
T42 14" SXGA (2378-XXQ)

Madara-san
Freshman Member
Posts: 65
Joined: Sun Sep 15, 2013 1:38 pm
Location: Budapest, Hungary

Re: Mavericks 10.9 on a T61(p)

#28 Post by Madara-san » Sun Dec 15, 2013 1:55 pm

And what if you try it without DSDT (or DSDT=no command)?

For me, it sleeps without DSDT too!

Also, for wake reason, I recommend to follow this article: http://reviews.cnet.com/8301-13727_7-57 ... s-in-os-x/
ThinkPad T61p - C2D T9300 - Quadro FX 570m - 4GB DDR2-667 - Mac OS X 10.9.1

Madara-san
Freshman Member
Posts: 65
Joined: Sun Sep 15, 2013 1:38 pm
Location: Budapest, Hungary

Re: Mavericks 10.9 on a T61(p)

#29 Post by Madara-san » Tue Dec 17, 2013 1:07 pm

Good news: new VoodooHDA: https://dl.dropboxusercontent.com/u/290 ... A.kext.zip

Microphone works even after sleep, and absolutely no distortion!

Also I'm working on a new / better DSDT, so stay tuned! :D
ThinkPad T61p - C2D T9300 - Quadro FX 570m - 4GB DDR2-667 - Mac OS X 10.9.1

topan
Posts: 9
Joined: Thu Aug 22, 2013 10:28 pm
Location: Bandung, Indonesia.

Re: Mavericks 10.9 on a T61(p)

#30 Post by topan » Thu Dec 19, 2013 10:55 am

Madara-san wrote:Hi!

Sorry, but you cannot... :( Intel graphics only can use VESA mode in Mavericks, so you will not get any hardware acceleration. Stay with Lion, it's the only one solution.
What about T60p with ATI Mobility FireGL V5200 and T7200 processor? Will it run mavericks? :?

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “OS-X Questions”

Who is online

Users browsing this forum: No registered users and 3 guests