Page 1 of 1

10.8.4 successfully installed on T60P

Posted: Mon Jul 21, 2014 8:34 pm
by SimplyRyan ... 7a4f71.png

They said it couldn't be done!!! But after I successfully upgraded my daughter's late 2006 iMac5,1 to Mountain Lion 10.8.4 using HackerWayne's MLPostFactor as seen here I got to thinking that maybe there was some hope for these aging ThinkPads yet. I'll do my best to break down exactly what I did to get Mountain Lion up and running on my ThinkPad T60P.

The trick to getting this all up and running was to be as minimally invasive with the hacks and tweaks that you use, because Mountain Lion Post Factor (MLPF) is already an extensive collection of hacks, tweaks and modified drivers that are aimed at getting Mountain Lion to run on real legacy Macs that have been obsoleted, provided they meet the minimum hardware requirements (64 bit capable processor and at least 2GB RAM). Since I already had to make those upgrades to get Lion running on my T60P, I was ready to go.

Anyway, so here is the basic rundown of what you have to do:

1) starting from your fully functional 10.7.5 install, acquire the "Install Mountain Lion" app and MountainLionPostFactor and the latest Multibeast (5.5.5 at the time of writing) for Mountain Lion.

2) create two more hard drive partitions, each a BARE MINIMUM of 8GB, one called "Install", the other called "ML" (as per HackerWayne's instructions... technically you can call them whatever you want). I managed to install Mountain Lion on an 8GB partition and it is NOT happy. from first boot, it was squawking at me about the startup disk being full, blah, blah, blah...

3) Making sure that the Mountain Lion app is in /Applications, run MLPF, pointing it at the "Install" partition. This is basically doing the exact same thing that XMove from TonyMacx86 does. After it completes, (keeping in mind that this IS a Hackintosh), run multibeast on the "Install" partition, selecting ONLY the bare minimum kexts needed to get the system working (JMicron36x_ATA, ElliotForceLegacyRTC, EvoReboot, FakeSMC, NullCPUPowerManagement PS/2 Keyboard/Mice and AppleACPIPlatformRollback (10.6.8). You'll also need to install VoodoTSCSync if you don't want to have to boot with cpus=1.

4) Reboot and select the new "Install" partition at the Chameleon boot loader. If your computer fails to boot up the first time, it's probably because of tweaks that you made to your org.chameleon.Boot.plist on your working 10.7.5 partition. Temporarily, rename /Extra/org.chameleon.Boot.plist to /Extra/org.chameleon.Boot.bak and proceed with installing 10.9.4 to the new "ML" partition.

5) after successful installation, as per HackerWayne's instructions, under the Utilities menu select "MLPostFactor" and install it on the "ML" partition.

6) reboot back into your functional 10.7.5 partition and install all of the same kexts you installed on the "Install" partition. You will also need to make whatever modifications to your Graphics, WiFi, etc. kexts. For my graphics card (V5250 FireGL) I had to install the AppleACPIPlatForm.kext from 10.6.8 (I think) and add 0x71C41002 to both the ATIRadeonX1600.kext and ATI1600Controller.kext. If you have a different graphics card, you are on your own.

7) Reboot into the new "ML" partition. If it won't boot, double check that you have disabled the org.chameleon.Boot.plist on your main 10.7.5 partition. If you have and it STILL isn't booting, repair disk permissions on the ML partition. If that doesn't work, boot with -v -f.

You can reuse your smbios.plist and dsdt.aml from your 10.7.5 partition. You will need to keep the modifications to the Boot.plist to a minimum and make changes one at a time. If you used any EFI strings, they are not going to work anymore and will probably prevent your computer from booting ML successfully.

Enjoy Mountain Lion!!!

I'm still in the process of sorting out what works and what doesn't. So far I have not gotten the App store working, but all of the hardware that worked in Lion works, including QE/CI!

***EDIT 7/22/14***

After quite a bit of fooling around with getting things working, I've completely given up on trying to use my Atheros AR5925 card anymore. No matter what I did, it just wouldn't play nice. It would work one boot, and then the next reboot the system would say "No Wifi Hardware installed", or I'd have constant self assigned IP problems. I switched back to using a Dell BCM4311 that I rebranded as an Apple Airport card and is supported out of the box. Back on Snow Leopard all it took was a DSDT edit to get the Atheros card working. With Lion things got trickier, but using a specific version of the AirportAtheros40.kext with ID number injection PLUS the DSDT edits it worked reliably. But on Mountain Lion the Atheros card was just unreliable. The "Apple" branded Dell 4311 card works flawlessly though.

I was able to get the Synaptics Touchpad functions (two finger scrolling, tap click, etc.) AND the touchpoint (which hasn't worked since using the ThinkpadUltranav.kext on 10.6) working by installing the latest build of Rehabman's Voodoo PS2 controller and the controller daemon. Interestingly enough, it works flawlessly, but until you get past the login screen you have to use the touchpoint. Weird, but whatever. It works.

Bluetooth works out of the box, but I have to turn it on manually (hit funciton+F5) to enable it.

The gigabit ethernet was detected out of the box.

The ATI V5250 FireGL graphics work using the same mods that were required on Lion (0x71C41002 ID injection into ATIRadeonX1000 and ATI1600Controller) and EVOEnabler with the custom EDID injected. Every once in a while I do get some artifacting, but it's easily remedied by setting a hot corner to put the display to sleep and waking it up. But I'm sure everyone already knows how to get their V5250 working. For those of you with ATI X1300 or ATI X1400 graphics, I'd venture to guess that if you weren't able to get QE/CI working on Lion, it's not going to work on Mountain Lion. But don't let me rain on your parade. Go and try for yourself.

Both my SSD and 500GB HD in the UltraBay work. I haven't tried swapping out the ultra bay for a DVD drive to test because I have them set up as a Fusion Drive (sort of... They're set up in a software RAID0 which pretty much amounts to the same thing)

The App Store, iCloud and Messages all work fine using the standard fix for "Device could not be recognized" (new Serial number built using champlist or other software, delete network locations, EFI string for ethernet using EFI Studio injected into Boot.plist)

Audio works just as it always has using VoodooHDA and VoodooHDA prefPane

My ExpressCard/34 21-in-1 MultiCard reader works out of the box (at least with SD cards and Memory Stick Pro Duo). In the past I vaguely remember having to patch some kext in order to get it to mount SD cards... Maybe I'm remembering a Hackintosh long since past...

Sleep! ...Does not work. nor will it ever. Same problem as always; even with a properly compiled and modded DSDT, the computer will go to sleep but will not be able to wake up.

I think that is everything. If I missed anything, please let me know.

Re: 10.8.4 successfully installed on T60P

Posted: Tue Jul 22, 2014 7:07 am
by Madara-san
Nice work, these old beasts are still very usable. :) Sleep also works for you?

Re: 10.8.4 successfully installed on T60P

Posted: Tue Jul 22, 2014 8:39 am
by SimplyRyan
No, as usual sleep does not work on this laptop. Never has and never will.

Re: 10.8.4 successfully installed on T60P

Posted: Wed Aug 06, 2014 3:39 am
by lukerus
You did nice work, but I'm still confused about your graphics card. You wrote, that you have FireGL V5250, but you are injecting 71C4, tha belongs to V5200. On Lenovo's website there is also ATI V5200 mentioned at your laptop. I have ATI V5250 (71D4) and I found it impossible to install later OSX than 10.6.8.
I would just like to correct you and tell everybody, that ATI V5250 doesn't work under OS X ML. The reason is ATIRadeonX1000 causing kernel panic even with patched binary. So the resolution works, but QE/CI doesn't.

Re: 10.8.4 successfully installed on T60P

Posted: Thu Aug 07, 2014 3:18 am
by lukerus
One more thing... I noticed, that you are using ATIRadeonX1600. That looks like a modified kext. Could you, please upload the kext, or at least the Info.plist ? Tanks a lot.

Re: 10.8.4 successfully installed on T60P

Posted: Fri Aug 29, 2014 7:20 am
by downlord
Stumbled upon this very interesting thread, Great Work!
hopefully I can be as successfull as you installing 10.8. , on my T60P.
I'm successfully running 10.6.8 but now some apps are any more supported, and I was trying to get further.
As the poster before me I was unable to solve the V5250. It's a difficult beast, very close to V5200 but then someway different.

OP, are you running a V5200 or a V5250 video card? Are you using a modded ATIRadeonX1600 kext or you just added the ID to the Plist?
Is there a possibility using the working 10.6.8 kexts in 10.8?
Thank you for clarifying this.

Re: 10.8.4 successfully installed on T60P

Posted: Sat Aug 30, 2014 3:39 pm
by lukerus
downlord wrote: Is there a possibility using the working 10.6.8 kexts in 10.8?
I tried it under 10.7. ATIRadeonX1000 loads up just fine (without KP), but the OpenGL and OpenCL frameworks seems they aren't loaded, because there is no QE/CI.

Re: 10.8.4 successfully installed on T60P

Posted: Fri Jun 26, 2015 8:30 pm
by SimplyRyan
2015 update!!!

I've completely abandoned all things TonyMac. I've come to realize like many other members of the hackintosh community that TonyMac, for all the "help" they bring to the community are nothing but a bunch of profiteering hacks who take credit for the work of others in order to make a quick buck off of the lazy/cheap hacker who wants the Mac experience without the hefty price tag, nor the technical aptitude it takes to get a decent working hackintosh running. Sure, providing "on rails" build guidelines makes it easy, but thats because you're essentially building a Mac with off the shelf parts. That kind of flies in the face of what the hackintosh scene is actually about: opening OSX to the PC market at large.

But I digress...

A few months back I started using a newer laptop than my trusty old T60P, a Lenovo T410 with nVidia graphics. I had to switch to Clover to get the stubborn NVS3100M to work on Mavericks and beyond. After learning the ropes of UEFI bootloaders, I quickly was able to switch to Clover and completely ditch the legacy bootloaders (Chameleon and Chimera).

I'm happy to report that I was able to start all the way back on 10.6.3 retail DVD with Clover as the bootloader, using nothing but voodooPS2, FakeSMC and NullCPUPowerManagement. Using (once again) MLPostFactor to create a "recovery" partition from which to install my modified Mountain Lion image, using all the same old hacks and kexts, I have successfully been able to install 10.8.4 (but no higher, due to graphics incompatibility) completely devoid of ANY SIGN of TonyMacX86 software. And the result has been a much more stable system with far less graphics glitches, and without having to jump through hoops to connect to iCloud or the app store.