Page 1 of 1

xcode for 10.9.1?

Posted: Wed Sep 24, 2014 6:02 pm
by bwaldow
Hello,

Frankenpad 1 in my signature runs Mavericks 10.9.1. I haven't upgraded beyond that as later T61 Thinkpads lose sleep/wake beyond that. I have patched against the SSL bug, and I'd prefer to stay with what I have.

Apple will let me into the store, but the latest Xcode requires 10.9.4 and won't install. I'd like to start practicing Swift coding.

Can anyone offer a way for me to get an earlier Xcode 6 that runs with 10.9.1? The link in Apple's developer pages shows me earlier versions of Xcode, but only 5.x versions which pre-date Swift.

Thanks,
Bret

Re: xcode for 10.9.1?

Posted: Thu Oct 02, 2014 9:34 pm
by JaavrOS
Why don't you make another partition with 10.9.4 on it, or boot off an external drive to run 10.9.4? Then you could practice X-Code there, and still have your old partition with 10.9.1 for everyday use with working sleep.