Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Yosemite 10.10 on X230

OS-X on ThinkPads
Post Reply
Posts: 7
Joined: Sun Jan 25, 2015 12:13 pm
Location: Dublin, Ireland

Yosemite 10.10 on X230

#1 Post by gdemonta » Sun Jan 25, 2015 12:43 pm

I have successfully installed Yosemite on my x230 using clover with UEFI method.
I have followed this tutorial to create a USB key and then install on fresh HDD:
replace mavericks with Yosemite and add the following modifications:

Step 3:
Just to explain: it will create a hidden partition on your USB key called EFI, where the clover directory will be created and the files needed to boot the USB key copied. To unhide it in order to copy the necessary kext, you need to mount it using EFI mounter v2

Then you can copy the following kext in EFI/CLOVER/KEXTS/Other:
https://bitbucket.org/RehabMan/os-x-fak ... /downloads
Appleintel1000e (ethernet)
http://www.mediafire.com/download/bxfjd ... ra-usb.zip
http://hackintosh.zone/hackintosh-downl ... -versions/
AppleSmartBatteryManager and VoodooBattery (To have the battery indicator working (useful for a laptop!))
http://www.hackintoshosx.com/files/down ... oobattery/
Voodoops2controller (to make the tracepoint
https://bitbucket.org/RehabMan/os-x-voo ... /downloads

skip step 4

step 5:
"copy mavericks to usb" use the following command instead of the one written:

sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/CloverBoot --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --no interaction

then follow the process until the end:

Then you'll have to install clover on your hard drive so that you don't need your USB key to boot.
To do so do again step 3 "Install Clover to USB or HDD"
but this time, select your freshly installed hard drive.
You'll also have to copy the same kexts as in step 3.
You'll also have to create a config.plist. I'll put the details. It's necessary to have the brightness slider.

what's working:
HD4000 graphics
Mini displayPort
Sound with VoodoHDA (but doesn't detect when you plug a headset, I have to manually select headset on the sound properties)
Brighntess slider by pressing Fn+k and Fn+P
Speedstep with the following KEXT
All the USB Port in USB 2.0 mode in bios
External express card wifi with Linksys WEC600N should work out of the box but I haven't received it yet.

What doesn't work
The chip is a BCM20702A0 21e6 0a5c (I have tried everything...)
Sound with AppleHDA
the chip is a Realtec ALC269VC
audio device: 8086 1e20
codec id: 10eC0269
USB 3.0
genericUSBXHCI doesn't work for me
internal wifi (impossible because unsupported wificard and impossible replace except by unsoldering the bios!)
SD Card Reader

I have tried voodooSDHC but no luck
If you need more information, please ask! if you can help me to make bluetooth work, any help would be greatly appreciated
Last edited by gdemonta on Tue Aug 18, 2015 3:03 pm, edited 1 time in total.

Posts: 18
Joined: Tue Feb 03, 2015 3:11 pm
Location: Minsk, Belarus

Re: Yosemite 10.10 on X230

#2 Post by kollya » Tue Feb 03, 2015 4:54 pm

great stuff man!

I used to have hacintoshes, but then switched to VMWare VMs (there're ready to use images), no troubles at all.
ThinkPad W520 4284-CT4, 15.6" FullHD LED, i7-2720QM, 32GB RAM, 512GB Crucial MX100, 1TB HDD WD Blue, 2GB NVIDIA Quadro 2000M, WLAN Intel 7260 802.11ac Wi-Fi & Bluetooth, WWAN Gobi 3000 HSPDA+, 4x USB 3.0, DVD-RW in a USB box, patched BIOS v1.42. ThinkPad Mini Dock Plus Series 3 with USB 3.0

Posts: 1
Joined: Wed Mar 25, 2015 2:50 am
Location: Singapore

Re: Yosemite 10.10 on X230

#3 Post by nabisco » Wed Mar 25, 2015 2:53 am

I followed the instructions here -> http://www.hackintoshosx.com/files/file ... hda-patch/ to get my audio working.

Posts: 1
Joined: Fri May 08, 2015 6:42 am
Location: Münster, Germany

Re: Yosemite 10.10 on X230

#4 Post by malso » Fri May 08, 2015 6:44 am


did you received external wifi card meanwhile and can you say if it is working or not?

Posts: 7
Joined: Sun Jan 25, 2015 12:13 pm
Location: Dublin, Ireland

Re: Yosemite 10.10 on X230

#5 Post by gdemonta » Wed May 13, 2015 4:20 am

I confirm the wifi card is working. But don't unplug it while your laptop is on, it won't thank you for it....

Posts: 1
Joined: Fri Mar 03, 2017 10:19 am
Location: San Salvador, El salvador

Re: Yosemite 10.10 on X230

#6 Post by jrab66 » Fri Mar 03, 2017 10:21 am

gdemonta wrote:Hi,
I confirm the wifi card is working. But don't unplug it while your laptop is on, it won't thank you for it....
Hi gdemonta can you guide or post how you do to make a yosemite or capitan install in a x230, today a purchase one, because of the price.

Greetings from el salvador lml

Post Reply
  • Similar Topics
    Last post

Return to “OS-X Questions”

Who is online

Users browsing this forum: No registered users and 30 guests