Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

OSX on W500

OS-X on ThinkPads
Post Reply
Message
Author
sixstyle
Posts: 4
Joined: Fri Oct 24, 2008 12:00 pm
Location: Hamilton, Bermuda

OSX on W500

#1 Post by sixstyle » Tue Oct 28, 2008 3:54 pm

Does anyone have OSX running on the W500?

Could I get some tips?

thanks.
W500 - 2.53Ghz - 4gig - Server 2008

SmoothRunnings
Posts: 14
Joined: Mon Mar 16, 2009 1:47 pm
Location: Toronto, ON, CA

Re: OSX on W500

#2 Post by SmoothRunnings » Mon Jun 22, 2009 5:58 pm

sixstyle wrote:Does anyone have OSX running on the W500?

Could I get some tips?

thanks.
Pray!

I have the W500, you will have to decide if you want to run your hard drive in compatibility mode or in AHCI mode, if you want to run it in AHCI mode you will only be able to use Kalyway as I have found it's the only OSX86 with the Intel AHCI driver, the others use the compatible driver from Intel.

I have yet to find a driver for the ATI FireGL V5700 that is downloadable from the inet. I have found someone who has it but I can't seem to contact them or request they repost the link as their old one is broken. I have looked elsewhere and not found it anywhere.

The 5300 AGN wireless card doesn't work :(

I have yet to get my audio, and nic working.

Luckly for me I bought a 2nd hard drive to install OSX86 onto so I can always go back to my Vista. :-)

Andrew

chopped
Posts: 12
Joined: Sun Dec 28, 2008 11:31 pm
Location: Houston, Texas

Re: OSX on W500

#3 Post by chopped » Wed Jul 08, 2009 6:08 pm

look for my T500 thread a several topics below, the procedure should be the same.


if you have a x4500 you are in luck, a new driver has come out that will give you resolution change, qe/ci is not supported but there is hope.

NIC and Audio work for me, i think the w500 should have the same type of components. you just have to look around for the right kext, i would post the link but its an attachment at insanelymac. all you need to do is search for Conexant HD Smart Audio 221 kext , and intel82566mm.kext for the NIC.

SmoothRunnings
Posts: 14
Joined: Mon Mar 16, 2009 1:47 pm
Location: Toronto, ON, CA

Re: OSX on W500

#4 Post by SmoothRunnings » Thu Jul 09, 2009 5:59 am

chopped wrote:look for my T500 thread a several topics below, the procedure should be the same.


if you have a x4500 you are in luck, a new driver has come out that will give you resolution change, qe/ci is not supported but there is hope.

NIC and Audio work for me, i think the w500 should have the same type of components. you just have to look around for the right kext, i would post the link but its an attachment at insanelymac. all you need to do is search for Conexant HD Smart Audio 221 kext , and intel82566mm.kext for the NIC.
I am not sure what the normal intel chipset for the video is if I remove the discrete mode in the bios, I can not seem to find it anywhere... Unless you mean the chipset? I think I mention above it's a GM45 chips which I don't know if that means it's an x4500??

The weird thing about insanelymac is their website doesn't work on my PC (or IE7) but it does work on Mac OSX! :)

chopped
Posts: 12
Joined: Sun Dec 28, 2008 11:31 pm
Location: Houston, Texas

Re: OSX on W500

#5 Post by chopped » Thu Jul 09, 2009 2:35 pm

if i remember correctly all w500 come with hybrid graphics, after going into bios and selecting displays, you will have the option to chose what graphics chip to use. select the integrated graphics, the integrated graphics card should be the x4500.

crashnburn
ThinkPadder
ThinkPadder
Posts: 1643
Joined: Sat Apr 22, 2006 4:26 pm
Location: TX, USA & Bombay, India

Re: OSX on W500

#6 Post by crashnburn » Tue Apr 06, 2010 1:47 pm

Curious to know if this ever worked?
T61 8892-02U: 14.1"SXGA+/2.2C2D/4G/XP|Adv Mini Dock|30" Gateway XHD3000 WQXGA via Dual-link DVI
X61T 7767-96U: 12.1"SXGA+/1.6C2D/3G/Vista|Ultrabase
W510 4319-2PU: 15.6"FHD/i7-720QM/4G/Win7Pro64 (for dad)
T43 1875-DLU: 14.1"XGA/1.7PM-740/1G/XP (Old)

Fusion
Sophomore Member
Posts: 128
Joined: Thu Dec 21, 2006 9:34 pm
Location: Czech Republic

Re: OSX on W500

#7 Post by Fusion » Wed May 18, 2016 3:01 pm

Six years later, anyone have any success stories on W500s?
Seems like 10.10 could work. I have an Intel T9600 Core2Duo and Radeon HD 3650.
Any info is much appreciated.
ThinkPad X220, i7-2640m, 16GB RAM, 120GB Kingston SSD, Intel HD3000, 12.5" WQHD, MacOS Sierra 10.13.2
ThinkPad W500 4063-VA4 CD2 Penryn 2,80GHz, 4GB RAM, 320GB HDD, 15.4" WUXGA, FireGL V5700, Win7u
ThinkPad R60 9461-DXG P-CD2 1,83GHz, 2GB 667MHz, 100GB HDD, ATI X1400@512MB, XP2 Pro

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “OS-X Questions”

Who is online

Users browsing this forum: No registered users and 8 guests