Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Lion Mac OS X 10.7 on Thinkpad X61

OS-X on ThinkPads
Message
Author
jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#301 Post by jzhang18 » Mon Dec 03, 2012 10:07 am

jzhang18 wrote:Thanks a lot, skdsam.
I will compare your kexts with my x61 (10.7.3). on this coming weekends, I will try your steps on my x61. hopefully I can do it successfully. (keep my fingers crossed)
Yes, I made it. I use skdsam KEXTS on desktop.
These are the steps:
1. Download Lion Combo Update 10.7.5
2. Download skdsam's desktop-kexts, unzip and put them on dekstop.
3.Run Combo Update 10.7.5, do not click "restart" button.
4.Run KextBeast. it will install all kexts on the dekstop.
5.Run DiskUtil to repair disk permission.
6.Click "restart" button to reboot.

special thing for my machine. I need to delete AirPortAtheros40.kext inside of io80211family.kext everytime when I did an update. (keep only AirPortAtheros21.kext).

comparing with my previous 10.7.3, booting time became a little bit longer. mouse sometime seems a little sluggish. overall I am pretty happy with it.

thanks skdsam again .
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

skdsam
Posts: 5
Joined: Mon Nov 26, 2012 11:13 am
Location: London, England

Re: Lion Mac OS X 10.7 on Thinkpad X61

#302 Post by skdsam » Mon Dec 03, 2012 4:36 pm

Glad it went ok! , did you remove sleepEnabler.kext if you was using it? Also did you have any issue with not showing correct CPU due to the bios speed step option if not set to max performance ?

Cheers

jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#303 Post by jzhang18 » Tue Dec 04, 2012 3:40 pm

skdsam wrote:Glad it went ok! , did you remove sleepEnabler.kext if you was using it? Also did you have any issue with not showing correct CPU due to the bios speed step option if not set to max performance
I did not use SleepEnabler.kext in 10.7.3, but sleeping seems working for me in 10.7.3 I have not test it in 10.7.5
I always use SMmaximalclock =2400 SMmemtype= 19 SMmemspeed =677 in SMBIOS.plist
So it shows 2.4Ghz for CPU (T8300) correctly. (actual speed is also 2.4Ghz, I saw it in geekbench)
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

fikumiku
Posts: 1
Joined: Wed Dec 05, 2012 8:41 am
Location: Vienna, Austria

Re: Lion Mac OS X 10.7 on Thinkpad X61

#304 Post by fikumiku » Wed Dec 05, 2012 8:50 am

Hello,

thanks for this great discussion.

does anyone know if there is a way to get firewire working in osx 10.7.x / thinkpad x61(s) ?

best regards,
fikumiku

jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#305 Post by jzhang18 » Wed Dec 05, 2012 9:43 am

fikumiku wrote:does anyone know if there is a way to get firewire working in osx 10.7.x / thinkpad x61(s) ?
IEEE1394 works. But it does not support plug and play. when I connected my old Canon Z75 Camcorder via FireWire with my x61. it won't show up in profiler. after I reboot 10.7.3, I can see Canon Z75 connected in Profiler. I can download video from it.
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

phrugal
Posts: 2
Joined: Sat Dec 08, 2012 11:08 pm
Location: canton, Mi

Re: Lion Mac OS X 10.7 on Thinkpad X61

#306 Post by phrugal » Sat Dec 08, 2012 11:17 pm

Hello, Not sure were to post this, but first Thanks to all in this post, as I have followed the OP and other posting to get my X61 almost perfect. The only problem that I have is the sluggish mouse every once and a while. Seems to be when kernel_task is in the process window, the mouse stutters and then when kernel_task is complete the mouse is fine. This is just a second or two and happens about every 3 to 5 seconds. I have tried changing the smbios file, but no luck. Does anyone have any ideas? should I change/remove and kexts?

belvederewrx
Posts: 6
Joined: Wed Dec 21, 2011 9:09 pm
Location: Saint Louis, MO

Re: Lion Mac OS X 10.7 on Thinkpad X61

#307 Post by belvederewrx » Tue Dec 18, 2012 10:15 pm

phrugal wrote:Hello, Not sure were to post this, but first Thanks to all in this post, as I have followed the OP and other posting to get my X61 almost perfect. The only problem that I have is the sluggish mouse every once and a while. Seems to be when kernel_task is in the process window, the mouse stutters and then when kernel_task is complete the mouse is fine. This is just a second or two and happens about every 3 to 5 seconds. I have tried changing the smbios file, but no luck. Does anyone have any ideas? should I change/remove and kexts?
I had this same issue, it's been awhile but IIRC, make sure you use the entire SLE directory in the OP. I thought at one point I had discovered it was the GMAX3100 driver, but I can't say that with 100% certainty.

phrugal
Posts: 2
Joined: Sat Dec 08, 2012 11:08 pm
Location: canton, Mi

Re: Lion Mac OS X 10.7 on Thinkpad X61

#308 Post by phrugal » Sun Dec 23, 2012 8:31 am

I had this same issue, it's been awhile but IIRC, make sure you use the entire SLE directory in the OP. I thought at one point I had discovered it was the GMAX3100 driver, but I can't say that with 100% certainty.[/quote]

THANK YOU! That was it. I had to move the gma3100 .kext i had in the SLE folder to the trash and then copy the one in the OP to the SLE folder.

granty
Posts: 1
Joined: Tue Jan 22, 2013 1:56 pm
Location: Arnold, Nottinghamshire, UK

Re: Lion Mac OS X 10.7 on Thinkpad X61

#309 Post by granty » Tue Jan 22, 2013 6:30 pm

Hi guys,

Not my first Hackintosh but im struggling with this one.

Got everything done but I don't have full QE/CI on the build (no translucent menu bar, jagged graphics on dock when scrolling through)

I've rebuilt the image a few times using different means and still same result.

There doesn't seem to be anyone in this thread having issues.

I can only assume it's because i'm using 64bit - but my understanding is in 32bit the graphics card is natively supported unlike 64bit so why the need for the Kext in the SLE pack...plus no where does it specify to boot to 32bit so I'm really confused.

skdsam
Posts: 5
Joined: Mon Nov 26, 2012 11:13 am
Location: London, England

Re: Lion Mac OS X 10.7 on Thinkpad X61

#310 Post by skdsam » Wed Jan 23, 2013 8:31 am

Yes it is because of this try booting into 32bit mode and it should work ok , you need the Kext for the 64bit version of intel graphics but I don't think that you will have quartz working either.

Cheers

dragonknight
Posts: 18
Joined: Fri Jan 09, 2009 6:55 am
Location: Hanoi, VietNam

Re: Lion Mac OS X 10.7 on Thinkpad X61

#311 Post by dragonknight » Tue Jan 29, 2013 12:35 am

Hello guys, I know it has been quite a while, but can anyone post the kext files and the DSDT posted by Pedrone (in page 6) to fix brightness? Thanks a lot in advance. If you can't post it anywhere, can you please send it to me via email (dragonknight.tan@gmail.com) and I will make it available for everybody. Thanks in advance.
T60p 2007-8JU

X61 7675-4KU

jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#312 Post by jzhang18 » Wed May 08, 2013 10:20 am

Really want to rollback to 10.7.3 after I use 10.7.5 for a while.
The latest 10.7.5 is working, but sluggish sometime, it seems some background process make CPU busy, but I really cannot find out what it is.
When I move my mouse cursor, I feel dramatically difference between 10.7.3 and 10.7.5.

Anyone has suggestion with the same issue?

-Jack
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

xorti
Posts: 4
Joined: Thu Jul 18, 2013 6:47 am
Location: London, UK

Re: Lion Mac OS X 10.7 on Thinkpad X61

#313 Post by xorti » Thu Jul 18, 2013 6:52 am

Hi all, wondering if some one can clarify some points from the manual from the first page:

1) Move Original Lion image to a 8GB USB Flash (Do I have to copy image to flash drive using DriveUtil?)
2) Install Chameleon 2.0 RC5 r1496 (so it just run installer and select new flash drive?)
3) Copy /Extra folder from installed 10.6.7 (included below in this post) to Flash (as I understood this one? -> /Extra: http://www.mediafire.com/?j7zln8r9lr57un9 also if there is a newer version with all latest fixes and patches ?)

mjsmith
Posts: 3
Joined: Thu Jul 18, 2013 2:56 pm
Location: Rohnert Park, CA

Re: Lion Mac OS X 10.7 on Thinkpad X61

#314 Post by mjsmith » Thu Jul 18, 2013 3:12 pm

Pedrone wrote:
Anastasius wrote: On my X3100, 1024x768 everything absolutely works including OpenGL & QE/CI, except brightness control
I have an x61 7674 (middleton bios because i use SSD) and I am running Lion 10.7.2 11C74. Everything is working including brightness. At first it was uneven ( the left or right part of the screen didn't change brightness correctly) but after a patch on the x3100 kext or in dsdt (don't remember i did it a few month ago) it works perfectly. I change brightness with the two keys above F11 and F12 and i can lower the brightness just like a real macbook.
If you are interested i can upload my kext and dsdt...

EDIT: of course QE\CI work

Sorry for the bad english
Pedrone wrote:http://www.mediafire.com/download.php?vz91zy2faukok95

Tell me if it works..
Can someone reupload this? I recently reinstalled OSX and the dsdt from the first post never worked properly for me with the brightness controls but his did. Thanks a bunch.

xorti
Posts: 4
Joined: Thu Jul 18, 2013 6:47 am
Location: London, UK

Re: Lion Mac OS X 10.7 on Thinkpad X61

#315 Post by xorti » Fri Jul 19, 2013 4:41 am

mjsmith wrote:
Pedrone wrote:http://www.mediafire.com/download.php?vz91zy2faukok95
Tell me if it works..
Can someone reupload this? I recently reinstalled OSX and the dsdt from the first post never worked properly for me with the brightness controls but his did. Thanks a bunch.
Have you tried to PM this guy and also when you get it can you please post it here and have you tried this kext (http://www.mediafire.com/?28i3vdq86off90n)?

mjsmith
Posts: 3
Joined: Thu Jul 18, 2013 2:56 pm
Location: Rohnert Park, CA

Re: Lion Mac OS X 10.7 on Thinkpad X61

#316 Post by mjsmith » Fri Jul 19, 2013 10:16 am

xorti wrote: Have you tried to PM this guy and also when you get it can you please post it here and have you tried this kext (http://www.mediafire.com/?28i3vdq86off90n)?
With Anastasius's dsdt the brightness control is uneven and I have no audio. I'm running dsdt free where everything works reasonably well but the geekbench score is about 1200 instead of 2200. I'll give him a PM about that dsdt. That failing I'll try that kext.

Has anyone been able to increase the vram from 144mb to 384mb? It looks like something you might be able to change in the dsdt but I'm not sure.

xorti
Posts: 4
Joined: Thu Jul 18, 2013 6:47 am
Location: London, UK

Re: Lion Mac OS X 10.7 on Thinkpad X61

#317 Post by xorti » Mon Jul 22, 2013 3:32 am

I have used extras from this tutorial (http://claptop.com/2013/02/osx-lion-on- ... -thinkpad/) also created ssdt files, update chameleon to use them and using no lag kext from (http://www.mediafire.com/?28i3vdq86off90n)
lag has gone but brightness does not work.
mjsmith wrote:
xorti wrote: Have you tried to PM this guy and also when you get it can you please post it here and have you tried this kext (http://www.mediafire.com/?28i3vdq86off90n)?
With Anastasius's dsdt the brightness control is uneven and I have no audio. I'm running dsdt free where everything works reasonably well but the geekbench score is about 1200 instead of 2200. I'll give him a PM about that dsdt. That failing I'll try that kext.

Has anyone been able to increase the vram from 144mb to 384mb? It looks like something you might be able to change in the dsdt but I'm not sure.

xorti
Posts: 4
Joined: Thu Jul 18, 2013 6:47 am
Location: London, UK

Re: Lion Mac OS X 10.7 on Thinkpad X61

#318 Post by xorti » Mon Jul 22, 2013 3:33 pm

ok, so I have managed to enable brightness control with this kext (http://www.mediafire.com/?m8eb1yf723li97e) hope this helps, also sleep working, quite cool

mjsmith
Posts: 3
Joined: Thu Jul 18, 2013 2:56 pm
Location: Rohnert Park, CA

Re: Lion Mac OS X 10.7 on Thinkpad X61

#319 Post by mjsmith » Thu Jul 25, 2013 12:38 pm

Redid parts of this with those kext's you listed. Running very well including brightness control (geekbench 2359). Brightness works and audio works again after removing voodoohda. Sleep doesn't work but i'll look into that more in a few days.

Is your option to disable bluetooth greyed out? You can't disable it using the fn keys and the hw switch disables both right.

Thanks a bunch.

bwaldow
Freshman Member
Posts: 91
Joined: Tue Sep 28, 2004 7:59 pm
Location: Perth, Australia

Re: Lion Mac OS X 10.7 on Thinkpad X61

#320 Post by bwaldow » Thu Aug 29, 2013 9:38 pm

Hello,

I would like to get an X61 tablet or T60/1 Frankenpad (or both) working with OSX. I have tried the steps listed here, and run into problems.

Before anything else, if you think that Mountain Lion is as reliable as Lion on these machines, please point me to a resource for that. Otherwise, I am new to Hackintoshes, and I am stopped at the first steps:
Anastasius wrote:My installation steps
1) Move Original Lion image to a 8GB USB Flash
2) Install Chameleon 2.0 RC5 r1496 (you need exactly this version or Chimera - read below) to that Flash (it can be installed from .pkg)
What does "Move Original Lion image..." mean?

I purchased and downloaded Lion to a partly working VirtualBox Lion session. I found the downloaded package, opened it, and discovered an InstallESD.dmg file within.

I plugged in an 8G USB flash drive, and used Disk Utility - Restore to write the InstallESD.dmg file to the flash drive. I received the 'Could not restore - error - 206' message on completion, but Googling suggests that this is spurious, and then I run 'Repair Disk' on the drive.

When I remove and replug the drive I see files and receive no error messages.

I then tried to use the Chimera package to install Chimera to the drive, with apparent success - no problems are mentioned, everything proceeds as the directions seem to suggest.

I have repeated these steps with a partly working X61 tablet running iATKOS Lion.

But the candidate Thinkpad will not boot from the flash drive.

Can you provide more details for these steps, please? What am I missing?

Thanks,
Bret
Frankenpad 0: T60/1 2.5Ghz Penryn C2D w/15" UXGA LED backlit LCD & Intel GPU
Frankenpad 1: T60/1 2.6Ghz Penryn C2D w/15" UXGA LED backlit LCD & NVS140M GPU
X61 Tablet 1.6Ghz SXGA (7769-A67)
T42 14" SXGA (2378-XXQ)

RedRott
Posts: 1
Joined: Sun Sep 08, 2013 8:23 am
Location: Novi Sad, Serbia

Re: Lion Mac OS X 10.7 on Thinkpad X61

#321 Post by RedRott » Thu Sep 12, 2013 6:22 pm

Hello guys.. I read all 11 pages and figure out that all informations becomes a not useful if you don't set right steps at begging!? :idea:

Because i am totally beginner with make Hackintosh a use all tutorials from A - Z , i realized some things but not enough to make miracle in terminal.

I use this tutorial to make Lion (http://claptop.com/2013/02/osx-lion-on- ... -thinkpad/) Got freezing random, sleep, SD card,FireWire doesn't work!

Then i use this tutorial (http://blog.slor.net/2013/08/installing ... enovo.html) I update system to 10.7.5 and everything work, except SLEEP, SD CARD, FireWire. i need to use sleep & firewire

I have X61 7673 model (2.19 C2D, Intel GMA X3100 144 MB, 4GB ram, 500 GB sata 1 ) i have old version of BIOS but i get update to latest.

My point is that is need right steps, right DSDT, kexts and help from you to set up small Lion to work. I always have (brightness, special key,sound, graphic, fingerprints,bluetooth,iCloud) smoothly doing job.

SLEEP, FireWire,Card reader - NEVER! :(
1. sleep - when enter sleep mode, after wake up they boot from bios (i try all terminal commands, AppleRTD.kext fix, sleep enabler) i don't have battery, just power supply!

Tnx

ps> i read all and download almost everything from this 11 pages of topic.

chrufru
Posts: 2
Joined: Mon Jan 20, 2014 12:11 am
Location: Frankfurt, Hessen, Germany

Re: Lion Mac OS X 10.7 on Thinkpad X61

#322 Post by chrufru » Mon Jan 20, 2014 1:16 am

Hello Thinkpad-Forum Members,

i'm on an working Hackintosh X Modell Tablet. Everything is working now, regardless to the great Forum here and on other site's. Thank's a lot.

Ultranav/ Keyboard and Audio is working. Bluetooth/ Wifi (Atheros) works like a charm. Used my own patched DSDT extracted from Windows.

Due the issues with not working Video's and QE/CI i have found an solution to get my unsupported X4500MHD Graphics Chip working. Yes right, it isn't the X3100 Chip. Thought i dosn't post it here, the Model is a X200T. 8)
So, i'm on the wrong Thread but, there are no Tutorial for the X200 Model's since Apple has never build / release Graphics Drivers.

I can't use the arch=i368 Kernel flag, to use the patched x3100 and X4500 Drivers. I also used the Quarz Debug app to get the QE Software Acceleration.

My Problem now: I (must) used the 64bit TabletEnabler.kext. The 32bit Version worked for me. But now with the Graphics Fix, i'm on 64bit and the TabletEnabler.kext won't boot. I never get it work.

Is there a Member that used a 64bit kext Enabler on X61? Help to determine my Problem, please.

Thx

WillAdams
Posts: 38
Joined: Wed Jan 01, 2014 3:48 pm
Location: Mechanicsburg, Pa

Re: Lion Mac OS X 10.7 on Thinkpad X61

#323 Post by WillAdams » Tue Jan 21, 2014 9:53 am

Can't help you w/ the 64 bit Tablet Enabler, but I'd be curious as to any information you could share on how you got the 32 bit working.
K/MIA - GRiDcase III plus, NEC UltraLite, Toshiba T1200xe, Sharp PC-6220, NCR-3125 (donated to the Smithsonian), Fujitsu Point PT-510, Stylistic ST-2300, LT C-500
Ret. - ThinkPad 755c w/ Dock
AD - ST-4110, ST-4121 (current machine), ThinkPad X61 Tablet (setting up OS X 10.6)

PREngineer
Posts: 1
Joined: Mon Feb 03, 2014 3:07 am
Location: Guaynabo, PR

Re: Lion Mac OS X 10.7 on Thinkpad X61

#324 Post by PREngineer » Mon Feb 03, 2014 3:17 am

I've read the whole thread and tried everything here.

Unfortunately, the Tablet doesn't work on my X61-7767 Laptop.

Has anyone found a way to fix this issue?

I'm running Lion 10.7.5.

I tried putting my SSDT.aml and its companion files in EXTRA… it did nothing.

I really need to have the Tablet function working for College.

I'd appreciate any help.

Thanks.

Here's a picture of my Table Magic. It never shows the Serial0 port.

Image

Image
According to windows my wacom and pen are WACF004

jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#325 Post by jzhang18 » Mon Feb 10, 2014 2:13 pm

I updated the Chameleon 2.2 boot loader for Intel T7x00, T8x00, T9x00, those with 800Mhz front bus C2D CPU.
Now it corrected the wrong calculation from original boot loader source code.

You do not need to injected any cosmetic values for CPU and FSB in smbios.plist.

It will show you the correct FSB frequency and CPU frequency from Chameleon boot loader.

http://forum.thinkpads.com/viewtopic.ph ... &start=120
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

hackintoshmalang
Posts: 1
Joined: Fri Jun 03, 2016 4:01 am
Location: Jakarta, Indonesia

Re: Lion Mac OS X 10.7 on Thinkpad X61

#326 Post by hackintoshmalang » Fri Jun 03, 2016 4:18 am

Please somebody help me..my X61 Tablet running Lion, have this display problem...
http://i1036.photobucket.com/albums/a44 ... mqkyyx.jpg

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “OS-X Questions”

Who is online

Users browsing this forum: No registered users and 4 guests