Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Lion Mac OS X 10.7 on Thinkpad X61

OS-X on ThinkPads
Message
Author
jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#241 Post by jzhang18 » Fri May 11, 2012 2:53 pm

Yes, using UniBeast is the easiest way.
Please make sure, after first installation, you need also install all kexts from Anastasius' post including his DSDT and Chimera loader.
I use Lion 10.7.0 and UniBeast to make the bootable 8GB USB stick.
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

slungu
Posts: 2
Joined: Fri May 18, 2012 3:34 am
Location: Aschaffenburg, Germany

Re: Lion Mac OS X 10.7 on Thinkpad X61

#242 Post by slungu » Fri May 18, 2012 10:56 am

Should the install of OS-X to a T61 be similar to X61 ? It looks to me like the basic components similar are. I am having a T61 with Intel graphics and wated to know if the tips I read from you guys would apply to my laptop.

Regards, Stefan

victor.vhv
Posts: 26
Joined: Thu Nov 10, 2011 11:56 am
Location: Valparaíso, Chile (traveling through SA)

Re: Lion Mac OS X 10.7 on Thinkpad X61

#243 Post by victor.vhv » Thu May 24, 2012 8:51 pm

As promised, attached this message are my SSDT tables (extracted from a X61T_7763-CTO with a 1400x1050 pixels screen).

https://www.dropbox.com/s/56avfbgmxmd68 ... 63-CTO.zip

I hope it helps someone, I will be testing my reinstall and see how things go :-)
Thinkpad X61 Tablet 7763-CTO 4GB RAM
Processor: 1.79 Ghz Intel C2D
Graphics: Intel GMA 965 (0x8086, 0x2a02), 1400x1050
WI-FI: Apple Airport Extreme (0x168C, 0x0024 - Atheros 5416 4.0)
Disk: SAMSUNG 640GB HM641JI GPT
OS:Mac OS X Lion 10.7.3 (11D46), Chameleon r1664, tri-boot Ubuntu+W7

victor.vhv
Posts: 26
Joined: Thu Nov 10, 2011 11:56 am
Location: Valparaíso, Chile (traveling through SA)

Re: Lion Mac OS X 10.7 on Thinkpad X61

#244 Post by victor.vhv » Fri May 25, 2012 2:06 am

Is anyone using 10.7.4?

I did the upgrade, but it was a mess (and then tried to reinstall, but can't get the graphics working without booting in SAFE_MODE with -x).
Thinkpad X61 Tablet 7763-CTO 4GB RAM
Processor: 1.79 Ghz Intel C2D
Graphics: Intel GMA 965 (0x8086, 0x2a02), 1400x1050
WI-FI: Apple Airport Extreme (0x168C, 0x0024 - Atheros 5416 4.0)
Disk: SAMSUNG 640GB HM641JI GPT
OS:Mac OS X Lion 10.7.3 (11D46), Chameleon r1664, tri-boot Ubuntu+W7

jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#245 Post by jzhang18 » Fri May 25, 2012 10:15 pm

victor.vhv wrote:Is anyone using 10.7.4?
I found this link-- http://bbs.pcbeta.com/viewthread-1019104-1-1.html

I translated some part of the post into English as following
"It is updated to 10.7.4 successfully, before doing it, just open S/L/E/AppleGraphicsControl.kext/Contents/PlugIns directory. when you see ApplePolicyControl.kext during installing 10.7.4, delete it immediately. otherwise, it will crash. Then you need to delete S/L/E/AppleACPIPlatform.kext before rebooting the machine.

I follow it, no luck.
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

crashnburn
ThinkPadder
ThinkPadder
Posts: 1643
Joined: Sat Apr 22, 2006 4:26 pm
Location: TX, USA & Bombay, India

Re: Lion Mac OS X 10.7 on Thinkpad X61

#246 Post by crashnburn » Sat Jun 02, 2012 10:45 pm

After a long delay with a lot of things, and my last experiments with iPC OSX 86..

I think I want to finally go with a Mac OS X install on the X61T.

Would you recommend SL or Lion ..AT THIS MOMENT.. for a (and which 10.X.Y version)
- More "stable" and "complete" hardware support?
- More stable/ efficient/ faster system?

Thoughts?
T61 8892-02U: 14.1"SXGA+/2.2C2D/4G/XP|Adv Mini Dock|30" Gateway XHD3000 WQXGA via Dual-link DVI
X61T 7767-96U: 12.1"SXGA+/1.6C2D/3G/Vista|Ultrabase
W510 4319-2PU: 15.6"FHD/i7-720QM/4G/Win7Pro64 (for dad)
T43 1875-DLU: 14.1"XGA/1.7PM-740/1G/XP (Old)

victor.vhv
Posts: 26
Joined: Thu Nov 10, 2011 11:56 am
Location: Valparaíso, Chile (traveling through SA)

Re: Lion Mac OS X 10.7 on Thinkpad X61

#247 Post by victor.vhv » Sun Jun 03, 2012 2:59 am

crashnburn wrote:After a long delay with a lot of things, and my last experiments with iPC OSX 86..

I think I want to finally go with a Mac OS X install on the X61T.

Would you recommend SL or Lion ..AT THIS MOMENT.. for a (and which 10.X.Y version)
- More "stable" and "complete" hardware support?
- More stable/ efficient/ faster system?

Thoughts?
Hi, I am using Lion 10.7.3, by far I have now the most stable install, using ssdt's collected from windows. Upgrading to 10.7.4 gives me some trouble, so I'll wait for the moment. I install from the app store's OSX Installer, directly with versión 10.7.3 (no combo upgrades, etc).

For the bootloader I use the latest Chameleon, Chimera gives me troubles as well...
Thinkpad X61 Tablet 7763-CTO 4GB RAM
Processor: 1.79 Ghz Intel C2D
Graphics: Intel GMA 965 (0x8086, 0x2a02), 1400x1050
WI-FI: Apple Airport Extreme (0x168C, 0x0024 - Atheros 5416 4.0)
Disk: SAMSUNG 640GB HM641JI GPT
OS:Mac OS X Lion 10.7.3 (11D46), Chameleon r1664, tri-boot Ubuntu+W7

jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#248 Post by jzhang18 » Mon Jun 04, 2012 6:43 am

victor.vhv wrote:For the bootloader I use the latest Chameleon, Chimera gives me troubles as well...
What's the problem of Chimera? more details I would like to know.
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

victor.vhv
Posts: 26
Joined: Thu Nov 10, 2011 11:56 am
Location: Valparaíso, Chile (traveling through SA)

Re: Lion Mac OS X 10.7 on Thinkpad X61

#249 Post by victor.vhv » Mon Jun 04, 2012 7:02 am

jzhang18 wrote:What's the problem of Chimera? more details I would like to know.
I have a strange problem with it, I mentioned it earlier in this thread. Some kexts won't load properly with chimera as a bootloader. I will try again and give some more details, the last time I checked, I still had the same problem.
Thinkpad X61 Tablet 7763-CTO 4GB RAM
Processor: 1.79 Ghz Intel C2D
Graphics: Intel GMA 965 (0x8086, 0x2a02), 1400x1050
WI-FI: Apple Airport Extreme (0x168C, 0x0024 - Atheros 5416 4.0)
Disk: SAMSUNG 640GB HM641JI GPT
OS:Mac OS X Lion 10.7.3 (11D46), Chameleon r1664, tri-boot Ubuntu+W7

bynce
Posts: 9
Joined: Tue May 15, 2012 9:29 pm

Re: Lion Mac OS X 10.7 on Thinkpad X61

#250 Post by bynce » Thu Jun 07, 2012 4:06 am

Anastasius hi:
My english is very pool . I hope you understand . haha .
my X61; T7300 2.5G X3100 .

bluetooth not work.i found your x61 bluetooth ok.
i need your X61 BIOS version file . i update BIOS to .2.22..i think version ..mybe dsdt error..

sorry . english very pool .

china macos bbs: http://bbs.pcbeta.com/ .

Anastasius
Sophomore Member
Posts: 140
Joined: Fri Feb 29, 2008 2:16 am
Location: Moscow, Russia

Re: Lion Mac OS X 10.7 on Thinkpad X61

#251 Post by Anastasius » Sun Jun 10, 2012 8:42 am

bynce
I use a standard BIOS from Lenovo v 1.25. You can download it here:
http://support.lenovo.com/en_US/downloads/default.page?
Just type in your model and it will give you the right BIOS.

As about DSDT - you can download it from my previous post. Please note that you may need a different DSDT or you may need to patch it, as my configuration is Lenovo X61 tablet 7767.
What kind of problems do you have?

victor.vhv
I successfully updated to 10.7.4. Just put IOPlatformPluginFamily.kext from my 10.7.2 installation. Everything worked. It was on my test configuration though and I didn't have time to update my main config to 10.7.4 and test it thoroughly
Mac OS X 10.6.7, 10.6.8 and 10.7.2 Lion on X61 7767 tablet.

const
Posts: 1
Joined: Sun Jun 10, 2012 2:04 pm
Location: Athens, Greece

Re: Lion Mac OS X 10.7 on Thinkpad X61

#252 Post by const » Sun Jun 10, 2012 2:30 pm

I just registered here and firstly i would like to thank you all for this wealth of info and files,
these files helped me in finally succeeding in getting my x61t work with osx!! :banana:

the biggest problem i had was the WACF004 device. i could not get it to work.
because i thought (as my dsdt) that it was a WACF008...
(and everywhere i looked the files where for WACF008)
  • 1. sudo ioreg -lx > ioreg-tablet.txt

    2. then, within the file i searched for "wac" and found that in the dsdt it was somewhere around/within the Device (DTR)

    3. going to the DSDT i found that within that device, there is a Method (_HID, ... )

    that looks something like that

    Code: Select all

                        Method (_HID, 0, NotSerialized)
                        {
                            If (DATD)
                            {
                                Return (0x08F0235C)
                            }
                            Else
                            {
                                Return (0x04F0235C)
                            }
                        }
    
    4. looking at it i realized that all you have to do, is to swap the first Return (0x08F0235C) with the second Return (0x04F0235C) (and possibly vice versa) so you make it look like this :

    Code: Select all

                        Method (_HID, 0, NotSerialized)
                        {
                            If (DATD)
                            {
                                Return (0x04F0235C)
                            }
                            Else
                            {
                                Return (0x08F0235C)
                            }
                        }
    
change WACF008 to WACF004 in TabletEnabler, Apple16X50Serial, LegacyX60T (or LegacyX61T) and configure TabletMagic and that is all. you are ready to go.

on a sidenote, because i have seen this opinion around and it can be very confusing:

screen size does NOT matter.

WACF004 is on mine and i have 1400x1050.
so wrong is the analogy
WACF004 --> 1024x768
WACF008 --> 1400x1050

i have added this information to the wiki, along with files.

*if i have made any mistakes, please be gentle, it's not my native tongue!

jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#253 Post by jzhang18 » Sun Jun 10, 2012 9:37 pm

Anastasius wrote:I successfully updated to 10.7.4. Just put IOPlatformPluginFamily.kext from my 10.7.2 installation. Everything worked. It was on my test configuration though and I didn't have time to update my main config to 10.7.4 and test it thoroughly
I have no luck to update to 10.7.4. even by replacing IOPlatformPluginFamily.kext. I use external HD (10.7.3), download 10.7.4 combo update, applying it, before rebooting, replace IOPlatformPluginFamily.kext with the one you put in SLE.zip from your first post. hanging on spinning Apple logo.

What is wrong with my steps? Please advise, appreciated.
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

chopped_pork
Posts: 1
Joined: Tue Jun 12, 2012 6:34 am
Location: london, uk

Re: Lion Mac OS X 10.7 on Thinkpad X61

#254 Post by chopped_pork » Tue Jun 12, 2012 7:00 am

hiya,

i've been struggling with getting osx on my x61 for the past three days with not much success - i guess i must be missing something obvious so i figured i'm gonna ask for help. here's what i did so far:

first attempt was unibeast (10.7.2 lion from the app store) on external drive (guid) - both keyboard and trackpoint were working during the installation but not after the reboot, i've copied the kexts from the first post using linux to where they should be and got stuck on a "hfs_lock: locking against myself!" kernel panic.

second attempt was unibeast on my internal drive which is mbr so not much luck - i've tried replacing OSInstall manually but that resulted in my unibeast stick not booting at all so gave that up pretty quickly.

next up - myHack (internal MBR SSD again). installer boots fine, no trackpoint but keyboard works. the installer would hang for ages (not freeze, the system was responsive but nothing would happen for minutes on after choosing the generic Extra package and removing the one problematic apple kext it suggests removing). the install seemed to be complete though - i could reboot into osx but again - no keyboard (nor mouse this time). copying Anastasius' kexts resulted in the hfs_lock kernel panic again.

ultimately i decided to just try and follow Anastasius' guide. reimaged my usb stick with a vanilla 10.7.2 app store image, installed the latest chameleon on it and added the Extra bundle. kernel panic within a second or two "Unable to find a driver for this platform: ACPI (...)". I've tried adding the SLE kexts to the extra dir, same thing.

any ideas what i might be doing wrong? i don't mind installing osx on the external drive so that i don't have to replace OSInstall - i can always just reimage it to my internal drive partition later and chameleon is gonna be happy to boot that from what i understand.

for clarification - by no keyboard after install i mean the furthest i got was the post-apple logo prompt to connect a keyboard.

vampyrex13
Posts: 2
Joined: Tue Jun 12, 2012 3:25 pm
Location: Owings Mills, Maryland

Re: Lion Mac OS X 10.7 on Thinkpad X61

#255 Post by vampyrex13 » Tue Jun 12, 2012 3:29 pm

Does anyone running my X61-7675 DSDT have issues with Lion rebooting when waking up from sleep? I've removed all my Kexts except for my PS2 keyboard/mouse and have also tried using Voodoo kext replacements. The only thing different from my Snow Leopard setup is that I had to patch the AppleRTC as per the the OP.

bynce
Posts: 9
Joined: Tue May 15, 2012 9:29 pm

Re: Lion Mac OS X 10.7 on Thinkpad X61

#256 Post by bynce » Thu Jun 14, 2012 2:02 am

Thank you!!!
my computer ThinkPad X61 (7673-4NG)
T7300(2GHz), 2.5GB RAM, 80GB 5400rpm HD, 12.1in 1024x768 LCD, Intel X3100, Intel 802.11agn(n-disabled), Bluetooth, Modem, 1Gb Ethernet, Secure chip, Fingerprint reader, 8c Li-Ion.
I try edit dsdt . the computer can not work. use software DSDTSE DSDTFixer (auto fix).
Reference :http://forum.thinkpads.com/viewtopic.php?f=32&t=85344.

now I use RALINk Wlan . but can not run airport. only 4$. MAC OS drive http://www.ralinktech.com/en/index.php

Computer hard disk protection. Vibration will be sound.How to remove it?... :cry:

ready install Mac OS X Mountain Lion .. go go go !! :banana:

Thank you your Information....

bynce
Posts: 9
Joined: Tue May 15, 2012 9:29 pm

Re: Lion Mac OS X 10.7 on Thinkpad X61

#257 Post by bynce » Mon Jun 18, 2012 9:06 pm

I have Original dsdt
mac os dsdtse :http://www.mediafire.com/?9bthc8rplzr9veq
win everest :http://www.mediafire.com/?se8fdg2zyx7tq9j

Different:http://www.mediafire.com/i/?phhkvsb77qp5l8k
only 1 Different
DefinitionBlock ("./dsdt.aml", "DSDT", 1, "LENOVO", "TP-7V ", 0x00002220)
DefinitionBlock ("dsdt.aml", "DSDT", 1, "LENOVO", "TP-7V ", 0x00002220)

How to modify the DSDT? please help.Thank you !!!

bynce
Posts: 9
Joined: Tue May 15, 2012 9:29 pm

Re: Lion Mac OS X 10.7 on Thinkpad X61

#258 Post by bynce » Tue Jun 19, 2012 1:08 am

:banana: sound ok!!!!
DSDT very different... :roll:

yuchia
Posts: 2
Joined: Sat Jun 23, 2012 2:07 am
Location: Santa Barbara, CA

Re: Lion Mac OS X 10.7 on Thinkpad X61

#259 Post by yuchia » Sat Jun 23, 2012 2:17 am

Hi Jzhang18,

I couldn't boot from the USB drive created using UniBeast. Can you elaborate the process to install the kexts into the USB drive? I tried to copy them but it didn't let me do it.

Thank you,
Joseph
jzhang18 wrote:Yes, using UniBeast is the easiest way.
Please make sure, after first installation, you need also install all kexts from Anastasius' post including his DSDT and Chimera loader.
I use Lion 10.7.0 and UniBeast to make the bootable 8GB USB stick.

jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#260 Post by jzhang18 » Sun Jun 24, 2012 9:20 pm

yuchia wrote:I couldn't boot from the USB drive created using UniBeast. Can you elaborate the process to install the kexts into the USB drive? I tried to copy them but it didn't let me do it.
UniBeast is a genius product from TonyMacX86.com. You just need to follow the instruction from the link http://tonymacx86.blogspot.com/2011/10/ ... using.html.
For me, I use Patriot XT 8GB thumb drive. I have a working hackintosh desktop (MB: GA-P55-USB3, Graphics card: Evga 9800GT 1GB, RAM: 16GB, CPU: Intel i5 750) .
I follow the instruction from above link. made a bootable Lion thumb drive easily.
For x61 laptop, I change the boot device sequence in bios. Make sure the USB thumb drive is listed before my internal hard drive.
During the installation, I use an USB mouse because the trackpoint will not work. Keyboard works, after installation, with additional driver (kext file), trackpoint works. All kext files are attached in the first post of this forum.
What else I forgot to mention, please feel free to ask me. I am very glad if some of my experience can help others.
thanks,
- Jack
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

Radioguy
ThinkPadder
ThinkPadder
Posts: 1101
Joined: Fri Feb 29, 2008 2:45 pm
Location: Brooklyn, New York

Re: Lion Mac OS X 10.7 on Thinkpad X61

#261 Post by Radioguy » Sun Jun 24, 2012 11:51 pm

Has anyone created DSDT's for a T61 with an X3100? (I'm still not having luck)
  • T61 - 6465CTO - T9500 - 15.4" LG WSXGA+ - 8GB OCZ- 120GB EVO 850 SSD - X3100 - Win 8.1 Pro 64-bit
    X301 - 2774W8Q - U9400 - 13.3" BOEHYDIS WXGA - 8GB Elpida - 128GB C400 mSATA SSD - 4500MHD - Win 10 Pro 64-Bit

yuchia
Posts: 2
Joined: Sat Jun 23, 2012 2:07 am
Location: Santa Barbara, CA

Re: Lion Mac OS X 10.7 on Thinkpad X61

#262 Post by yuchia » Wed Jun 27, 2012 12:26 am

Hi Jack,

I followed the instruction and finished step 2 to create a bootable USB drive. In step 3, you are supposed to boot on the USB drive. I was able to see screen to select the "USB" drive, but then I got kernel panic. I wasn't able to boot out of the USB drive.

Were you be able to boot from your USB drive without any customed kexts? I have X61s and my lion is 10.7.4.

Thank you,
Joseph
jzhang18 wrote: UniBeast is a genius product from TonyMacX86.com. You just need to follow the instruction from the link http://tonymacx86.blogspot.com/2011/10/ ... using.html.
- Jack

bynce
Posts: 9
Joined: Tue May 15, 2012 9:29 pm

Re: Lion Mac OS X 10.7 on Thinkpad X61

#263 Post by bynce » Tue Jul 03, 2012 1:23 am

Tragedy !!!my money.
update BIOS..update update . my X61 dead .Maintenance costs: 300RMB :cry: :cry: :cry: :cry: :cry: :cry:
now my x61 ok . Updated several BIOS.. :lol: :lol:


BT ok. Windows XP system use FN+F5 turn on .

now system :mac os lion .

How to turn off vibration sensor? :cry: .

thank you !!!




edit :
ai !! My bt turn off . today .my x61 CMOS have problem..

jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#264 Post by jzhang18 » Tue Jul 03, 2012 2:20 pm

yuchia wrote: I followed the instruction and finished step 2 to create a bootable USB drive. In step 3, you are supposed to boot on the USB drive. I was able to see screen to select the "USB" drive, but then I got kernel panic. I wasn't able to boot out of the USB drive.
Joseph,
Did you use 10.7.0 Lion? I am not sure other versions (10.7.1, 10.7.2, 10.7.3 or 10.7.4) will work. I just use 10.7.0, no other kexts.

-Jack
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

sleepyTP
Posts: 7
Joined: Mon Mar 05, 2012 11:53 am

Re: Lion Mac OS X 10.7 on Thinkpad X61

#265 Post by sleepyTP » Fri Jul 06, 2012 9:50 am

Has anyone been able to get the ripple effect in Dashboard on 10.7.3? I seem to have at least partial QE/CI enabled, tranlucent menu bar etc. But the most annoying thing is that some windows get stuck as they are drawn, alomost mini-windows stuck in the background and random freezes. I am using a macbook 3,1 in SMB BIOS. I also have used the frame buffer from the original post. Any ideas? I am booting into 32 bit mode as well.

jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#266 Post by jzhang18 » Fri Jul 13, 2012 9:33 am

sleepyTP wrote:Has anyone been able to get the ripple effect in Dashboard on 10.7.3?
I did not see any problem with that on my x61 tablet and x61, both running 10.7.3
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

Kai_Def
Posts: 1
Joined: Fri Jul 13, 2012 1:39 pm
Location: Manchester UK

Re: Lion Mac OS X 10.7 on Thinkpad X61

#267 Post by Kai_Def » Fri Jul 13, 2012 1:53 pm

Hi guys,

first off many thanks for this great thread & input :P

This is my first Hackint0sh & I'm running successfully 10.7.3 on my x61 (regular/non tablet).
I am pretty happy with albeit some bugs/crashes.

I largely used tatsuikeda advice from his blog:
http://www.tumblr.com/tagged/thinkpad-x ... 1331155856

2 things i would like to continue working on:

1) I have no sound
2) youtube /video playback

both not working at this stage - any thoughts :?:

Kind regards
Kai

belvederewrx
Posts: 6
Joined: Wed Dec 21, 2011 9:09 pm
Location: Saint Louis, MO

Re: Lion Mac OS X 10.7 on Thinkpad X61

#268 Post by belvederewrx » Sun Jul 22, 2012 11:14 am

Hey everyone, I've resurrected my old X61 (7675) and have successfully gotten Lion working. Everything is pretty much fully functional thanks to this thread.

I have one issue that doesn't quite make sense though. Does anyone else use an ultrabay? I noticed that out of the ultrabay, performance is much slower. I thought I was just imagining things at first, but running geekbench confirmed my suspicions as it scores nearly 3 times higher in the dock.

Would this be a power management issue, or is there a kext or configuration that needs to be made out of the dock? Thanks guys, and I appreciate all of your help!

Edit: After looking at the proc speed on battery and on A/C I realized it was being under clocked on battery. I assume this is whatever hardware functionality used by the C2D series since this shouldn't be occurring in software. I guess since it's hardware initiated there's no way around it.

Anastasius
Sophomore Member
Posts: 140
Joined: Fri Feb 29, 2008 2:16 am
Location: Moscow, Russia

Re: Lion Mac OS X 10.7 on Thinkpad X61

#269 Post by Anastasius » Tue Jul 24, 2012 8:22 pm

I added new SD Card drivers (Ricoh) to the original post. They are more stable for me
Mac OS X 10.6.7, 10.6.8 and 10.7.2 Lion on X61 7767 tablet.

jzhang18
Sophomore Member
Posts: 187
Joined: Mon Jan 10, 2011 10:37 am
Location: New York, NY

Re: Lion Mac OS X 10.7 on Thinkpad X61

#270 Post by jzhang18 » Wed Jul 25, 2012 8:26 pm

Anastasius wrote:I added new SD Card drivers (Ricoh) to the original post. They are more stable for me

Where is your kext file? I cannot find it in your latest zip files.

-Jack
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “OS-X Questions”

Who is online

Users browsing this forum: No registered users and 4 guests