Page 1 of 1

X220 Wifi (Intel Ultimate-N 6300) + Debian Wheezy 7

Posted: Tue Jun 04, 2013 8:12 am
by min0me
Hello,

hopefully i can find some debian users on here that can help...

I just picked up a new Thinkpad X220 last week and im trying to make it my first laptop with Debian.
I upgrade the wifi from the thinkpad wifi card that comes as standard to a Intel Ultimate-N 6300
The connection remains stable when connected to a access point, but the preformence is very poor, it typically hovers between 1-5mb and the thoughput tends to be around 55kbs.
It very noticable when browsing the internet as there is a pause before the page begins to load and any pictures take their time.

The access points in question are a Technicolor (Thompson) TG587v2 and some Linksys WRT160N routers running DDWRT (office and home)
while i dont have any apples to apples to compare too, i do have oranges and even some bananas that run fast and have good coverage.
I have notebooks and netbooks running intel wireless 5100 that run very well (running some other OS), android devices, even a Nokia N9.
because the N9 has no problems i dont think its the access points.
A Toshiba NB200 netbook has graced my presence, with an Atheros based card and after installed Squeeze it seamed to work fine too (its an orange apple, wrong debian with wrong wificard)

I am running WPA2 Personal TKIP+AES normally, but i have tried WPA2 Personal AES, WPA Personal TKIP+AES... and all other combos except WEP

If anyone can point me in the right direction i would be most greate full.

While its not strickly nessessory, but if someone fancys cherry topping.
I do have a mute button for the microphone that doesnt work along with the light that it has in the centre. i have read about patching kernels (i dont fancy building a new kernel) and/or making scripts, but i cannot seam to get the button to output anything to detect to make a script.
The camara i belive has a little light when it is active, which would be cool to activate when the camara is on but that is at the bottom of the list.


thank you!

Re: X220 Wifi (Intel Ultimate-N 6300) + Debian Wheezy 7

Posted: Thu Jun 06, 2013 5:05 pm
by crazeazn
from what ive read the 6300 (3x3) maybe missing the appropriate antennaes?

Re: X220 Wifi (Intel Ultimate-N 6300) + Debian Wheezy 7

Posted: Mon Jun 17, 2013 6:18 am
by rzl
I run debian 7 on my x220 as the only operating system.

Everything work fine and out of the box. Internet connection is good too.

I'd say: test speed for lan-to-lan connection, then take some internet speed test.
Maybe it's just your internet slow.