Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Upgrading X220/X230 to FHD 1080p

X200, X201, X220 (including equivalent tablet models) and X300, X301 series specific matters only.
Message
Author
TeroS
Posts: 6
Joined: Wed Jan 24, 2018 2:47 pm
Location: Tampere, Finland

Re: Upgrading X220/X230 to FHD 1080p

#1051 Post by TeroS » Sun Sep 30, 2018 5:47 am

Obviously brightness adjustment works: https://www.youtube.com/watch?v=9b_dJzbXf7A

I have the mod installed with LG-panel, Win 10 with dummy display. So what do I need to change to get the brightness to work?

Dynamicmetaflow
Posts: 10
Joined: Wed Aug 29, 2018 6:55 pm
Location: Boston, MA

Re: Upgrading X220/X230 to FHD 1080p

#1052 Post by Dynamicmetaflow » Sun Sep 30, 2018 4:29 pm

thrilleratplay wrote:
Mon Sep 03, 2018 7:58 am
That would be awesome. I cannot find it in the patches from the past week on review.coreboot.org. If someone a link it it can they post it here? I would like to help test that once it is available.
Has there been any updates about this patch being made available and or released? I've looked around at review.coreboot.org and the mailing list and haven't found any updates.

nitrocaster
Senior Member
Senior Member
Posts: 566
Joined: Fri Mar 04, 2016 8:38 am
Location: Moscow, Russia
Contact:

Re: Upgrading X220/X230 to FHD 1080p

#1053 Post by nitrocaster » Mon Oct 01, 2018 8:07 am

I suggest you to ask lynxislazus.
Want to buy X220/X230 FHD mod kit? Read this before sending me a PM!
T25 | X230: i7-3520M | 16GB RAM | 512GB M.2 Micron M600 | LG LP125WF2-SPB4 FHD IPS | 9c Li-Ion | Win8.1 Pro 64

nitrocaster
Senior Member
Senior Member
Posts: 566
Joined: Fri Mar 04, 2016 8:38 am
Location: Moscow, Russia
Contact:

Re: Upgrading X220/X230 to FHD 1080p

#1054 Post by nitrocaster » Mon Oct 01, 2018 8:46 am

qwertyxxx wrote:
Fri Sep 28, 2018 12:14 pm
Hello everyone, I was just installing mod and everything went well and lcd worked until I cut corners. After that, panel was doing this https://imgur.com/cyEPIFj
Cut went through metal. I am guessing I killed pcb of panel, right? I was using snips for cutting metal. Do you recommend other tool for my next atempt when I get next lcd? I am a bit sad now because I was really excited for 1080p experience. Any other advise for cutting lcd? Thanks for mod nitrocaster btw.
That is indeed very sad because you killed the LCD itself. Snips is the right tool to do this, but you have to be careful to not destroy the LCD. You can see in the pictures from the installation guide that cut does not go through metal frame. It doesn't really matter if you're careful enough though - the key point is to not bend the PCB or mounting bracket as you cut. I do this by laying the display on my left hand forearm and holding the snips in my right hand.
Want to buy X220/X230 FHD mod kit? Read this before sending me a PM!
T25 | X230: i7-3520M | 16GB RAM | 512GB M.2 Micron M600 | LG LP125WF2-SPB4 FHD IPS | 9c Li-Ion | Win8.1 Pro 64

qwertyxxx
Posts: 2
Joined: Fri Sep 28, 2018 11:50 am
Location: Pilsen, Czech Republic

Re: Upgrading X220/X230 to FHD 1080p

#1055 Post by qwertyxxx » Mon Oct 01, 2018 1:02 pm

nitrocaster wrote:
Mon Oct 01, 2018 8:46 am
qwertyxxx wrote:
Fri Sep 28, 2018 12:14 pm
Hello everyone, I was just installing mod and everything went well and lcd worked until I cut corners. After that, panel was doing this https://imgur.com/cyEPIFj
Cut went through metal. I am guessing I killed pcb of panel, right? I was using snips for cutting metal. Do you recommend other tool for my next atempt when I get next lcd? I am a bit sad now because I was really excited for 1080p experience. Any other advise for cutting lcd? Thanks for mod nitrocaster btw.
That is indeed very sad because you killed the LCD itself. Snips is the right tool to do this, but you have to be careful to not destroy the LCD. You can see in the pictures from the installation guide that cut does not go through metal frame. It doesn't really matter if you're careful enough though - the key point is to not bend the PCB or mounting bracket as you cut. I do this by laying the display on my left hand forearm and holding the snips in my right hand.
Thank you for answer and advice. I will be more careful next time.

phonics
Posts: 5
Joined: Wed Feb 28, 2018 12:58 am
Location: Raleigh, NC, USA

Re: Upgrading X220/X230 to FHD 1080p

#1056 Post by phonics » Mon Oct 01, 2018 5:44 pm

Dynamicmetaflow wrote:
Sun Sep 30, 2018 4:29 pm
thrilleratplay wrote:
Mon Sep 03, 2018 7:58 am


That would be awesome. I cannot find it in the patches from the past week on review.coreboot.org. If someone a link it it can they post it here? I would like to help test that once it is available.
Has there been any updates about this patch being made available and or released? I've looked around at review.coreboot.org and the mailing list and haven't found any updates.
You can achieve this yourself by changing

Code: Select all

select GFX_GMA_INTERNAL_IS_LVDS
to

Code: Select all

select GFX_GMA_INTERNAL_IS_EDP
in src/mainboard/lenovo/[x220 or x230]/Kconfig and selecting libgfxinit in coreboot config.

Dynamicmetaflow
Posts: 10
Joined: Wed Aug 29, 2018 6:55 pm
Location: Boston, MA

Re: Upgrading X220/X230 to FHD 1080p

#1057 Post by Dynamicmetaflow » Wed Oct 03, 2018 7:24 pm

phonics wrote:
Mon Oct 01, 2018 5:44 pm
Dynamicmetaflow wrote:
Sun Sep 30, 2018 4:29 pm


Has there been any updates about this patch being made available and or released? I've looked around at review.coreboot.org and the mailing list and haven't found any updates.
You can achieve this yourself by changing

Code: Select all

select GFX_GMA_INTERNAL_IS_LVDS
to

Code: Select all

select GFX_GMA_INTERNAL_IS_EDP
in src/mainboard/lenovo/[x220 or x230]/Kconfig and selecting libgfxinit in coreboot config.
Thank you for the information. I've made the change you have mentioned in your prior comment. Sometimes I'm able to see SeaBios and it boots correctly to the desktop other times it doesn't and I get a black screen.

What is your coreboot config that you use when you run:

make nconfig

In addition, was wondering if you Phonics or anyone has a guide/tutorial for patching i915 or a driver in general? I've looked online and haven't found a tutorial that I found accessible. I have a basic understanding of GNU/Linux but I haven't applied a patch before.

dwhacks
Posts: 9
Joined: Fri Oct 05, 2018 12:57 am
Location: Grand Forks, Canada

Re: Upgrading X220/X230 to FHD 1080p

#1058 Post by dwhacks » Fri Oct 05, 2018 1:11 am

Well after waiting for my turn for quite some time I finally made it on the list! I got my Mod kit super fast, I was surprised when I got it in the mail. The display took a little longer, but not too long, I got it today! I ordered a BOE display from the ebay seller.

ANYWAY, I've got it all installed and its been acting a bit strange. I have Coreboot on my x220 and I read there may be a patch ? Has anyone tried it? I'm a coreboot noob.

So here's what works and whats weird:

Windows: shows seabios->grub->windows. No blank screens, nothing wrong, works greats (this was unexpected)
Linux (Mint) is strange. I get Seabios -> grub -> Blank screen (but I am able to control the backlight). Eventually I was able to get the FHD panel to work by plugging in a VGA monitor and removing it. It only seems to work on "extended" mode. If I make it mirror the dumby display then it goes blank.

Any ideas whats up? (Its a bit annoying losing my pointer out the side of the screen) Or should I try updating my coreboot bios?

Other then that, display is AWESOME!! you're the man Nitrocaster

phonics
Posts: 5
Joined: Wed Feb 28, 2018 12:58 am
Location: Raleigh, NC, USA

Re: Upgrading X220/X230 to FHD 1080p

#1059 Post by phonics » Fri Oct 05, 2018 9:55 pm

Dynamicmetaflow wrote:
Wed Oct 03, 2018 7:24 pm
What is your coreboot config that you use when you run:

make nconfig

In addition, was wondering if you Phonics or anyone has a guide/tutorial for patching i915 or a driver in general? I've looked online and haven't found a tutorial that I found accessible. I have a basic understanding of GNU/Linux but I haven't applied a patch before.
Here's my config for coreboot, I use GRUB as my primary payload but SeaBios works as well in FHD
How you patch kernel modules depends a lot on your distro. For most, the procedure is like this: fetch the kernel, patch the driver (cd path/to/kernel/src/ && patch -p1 < path/to/i915.patch), build the module then copy the .ko to the running kernel's module directory in /lib/modules. Look up how to build a single in-tree module, just replace names with i915 and patch before running make. You should be able to adapt this for your distro
dwhacks wrote:
Fri Oct 05, 2018 1:11 am
Linux (Mint) is strange. I get Seabios -> grub -> Blank screen (but I am able to control the backlight). Eventually I was able to get the FHD panel to work by plugging in a VGA monitor and removing it. It only seems to work on "extended" mode.
Sounds like you need the i915 Linux patch as well, a "phantom" display will exist until you patch the driver.

dwhacks
Posts: 9
Joined: Fri Oct 05, 2018 12:57 am
Location: Grand Forks, Canada

Re: Upgrading X220/X230 to FHD 1080p

#1060 Post by dwhacks » Sat Oct 06, 2018 12:51 pm

Seems like the x230 is getting some coreboot love:
https://review.coreboot.org/c/coreboot/+/28950

Mine is still shotty. I've built coreboot every which way. Either I see the bios and grub and its blank until I plug in an external monitor via VGA or I dont see the bios/grub and I get to my login screen.
Heck, I don't even think my windows works anymore, which I believe is part of the VGA bios in coreboot. I seem to have lost the coreboot.rom I was using originally as well... great.

thrilleratplay
Posts: 12
Joined: Wed Sep 20, 2017 8:03 am
Location: Albany, NY, USA

Re: Upgrading X220/X230 to FHD 1080p

#1061 Post by thrilleratplay » Sun Oct 07, 2018 10:23 am

dwhacks wrote:
Sat Oct 06, 2018 12:51 pm
Seems like the x230 is getting some coreboot love:
https://review.coreboot.org/c/coreboot/+/28950

Mine is still shotty. I've built coreboot every which way. Either I see the bios and grub and its blank until I plug in an external monitor via VGA or I dont see the bios/grub and I get to my login screen.
Heck, I don't even think my windows works anymore, which I believe is part of the VGA bios in coreboot. I seem to have lost the coreboot.rom I was using originally as well... great.
I am testing this. The VBT updates seem to correct some scaling issues but the brightness does not change with the fn-f8/f9 keys. I am talking to Hellsenburg but maybe wished I knew that he doesn't own a Lenovo before doing this * wince * .

As for your build, still have a stockbios copy or your current a copy of coreboot to parse the blobs out of, try https://github.com/Thrilleratplay/coreb ... er-scripts with the provided x230 config.

kai
Freshman Member
Posts: 56
Joined: Sun Jul 18, 2004 11:11 am

Re: Upgrading X220/X230 to FHD 1080p

#1062 Post by kai » Sun Oct 07, 2018 11:02 am

I've finally installed my mod that I received quite a long time ago.

It was slightly tricky but it seems to be working well.

I'm having one small issue though and that is when I am using a dock (ultrabase 3 I think?), I'm seeing some random small glitching of the display. It's very minor and quite intermittent. When not plugged into the dock, the display is solid and working well.

Anyone else faced the same issue and know what it might be?

Thanks

Dynamicmetaflow
Posts: 10
Joined: Wed Aug 29, 2018 6:55 pm
Location: Boston, MA

Re: Upgrading X220/X230 to FHD 1080p

#1063 Post by Dynamicmetaflow » Sun Oct 07, 2018 11:31 am

phonics wrote:
Fri Oct 05, 2018 9:55 pm
Dynamicmetaflow wrote:
Wed Oct 03, 2018 7:24 pm
What is your coreboot config that you use when you run:

make nconfig

In addition, was wondering if you Phonics or anyone has a guide/tutorial for patching i915 or a driver in general? I've looked online and haven't found a tutorial that I found accessible. I have a basic understanding of GNU/Linux but I haven't applied a patch before.
Here's my config for coreboot, I use GRUB as my primary payload but SeaBios works as well in FHD
How you patch kernel modules depends a lot on your distro. For most, the procedure is like this: fetch the kernel, patch the driver (cd path/to/kernel/src/ && patch -p1 < path/to/i915.patch), build the module then copy the .ko to the running kernel's module directory in /lib/modules. Look up how to build a single in-tree module, just replace names with i915 and patch before running make. You should be able to adapt this for your distro
dwhacks wrote:
Fri Oct 05, 2018 1:11 am
Linux (Mint) is strange. I get Seabios -> grub -> Blank screen (but I am able to control the backlight). Eventually I was able to get the FHD panel to work by plugging in a VGA monitor and removing it. It only seems to work on "extended" mode.
Sounds like you need the i915 Linux patch as well, a "phantom" display will exist until you patch the driver.
Thanks for your config and support. I have not patched the kernel yet but I was able to apply the coreboot patch from https://review.coreboot.org/c/coreboot/+/28950

When booting the screen is black and I'm unable to see SeaBios I am then able to see lightdm and login.

After applying the patch what I did notice is that when I run xrandr I can see eDP-1 as the primary monitor and there is no phantom display.

Here is the link to the coreboot config i used. https://pastebin.com/y0TNS8na

xrandr output

Code: Select all

$ uname -r                                  
4.18.5-041805-generic
$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 276mm x 155mm
   1920x1080     60.00*+  59.97    59.96    59.93    48.00  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1440x900      59.89  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1360x768      59.80    59.96  
   1280x800      59.99    59.97    59.81    59.91  
   1152x864      60.00  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   800x512       60.17  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   720x450       59.89  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   680x384       59.80    59.96  
   640x400       59.88    59.98  
   576x432       60.06  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
VGA-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)

From what I was able to test, what's currently not working is:
- Brightness controls
- Suspend

If anyone has any suggestions of how to fix the issues above I would greatly appreciate it.

dwhacks
Posts: 9
Joined: Fri Oct 05, 2018 12:57 am
Location: Grand Forks, Canada

Re: Upgrading X220/X230 to FHD 1080p

#1064 Post by dwhacks » Sun Oct 07, 2018 12:12 pm

thrilleratplay wrote:
Sun Oct 07, 2018 10:23 am


As for your build, still have a stockbios copy or your current a copy of coreboot to parse the blobs out of, try https://github.com/Thrilleratplay/coreb ... er-scripts with the provided x230 config.

I have an x220, or I would have tried the x230 coreboot update. I do have all my blobs and the stock bios. Does that script extract the vga bios blob? I believe the vga bios blob is needed for windows, and I'd like to get windows to run so I can use it a few times a year to tune my car.

thrilleratplay
Posts: 12
Joined: Wed Sep 20, 2017 8:03 am
Location: Albany, NY, USA

Re: Upgrading X220/X230 to FHD 1080p

#1065 Post by thrilleratplay » Sun Oct 07, 2018 12:32 pm

dwhacks wrote:
Sun Oct 07, 2018 12:12 pm

I have an x220, or I would have tried the x230 coreboot update. I do have all my blobs and the stock bios. Does that script extract the vga bios blob? I believe the vga bios blob is needed for windows, and I'd like to get windows to run so I can use it a few times a year to tune my car.
Ah, there is a X220 config in the project as well. I do not think the vga blob is needed for anything other than a boot image but cannot confirm; I only run Linux. Seeing you already have issue issues with the booting with the VGA, you can try it would. Those scripts also require Docker.

dwhacks
Posts: 9
Joined: Fri Oct 05, 2018 12:57 am
Location: Grand Forks, Canada

Re: Upgrading X220/X230 to FHD 1080p

#1066 Post by dwhacks » Sun Oct 07, 2018 4:46 pm

thrilleratplay wrote:
Sun Oct 07, 2018 12:32 pm
dwhacks wrote:
Sun Oct 07, 2018 12:12 pm

I have an x220, or I would have tried the x230 coreboot update. I do have all my blobs and the stock bios. Does that script extract the vga bios blob? I believe the vga bios blob is needed for windows, and I'd like to get windows to run so I can use it a few times a year to tune my car.
Ah, there is a X220 config in the project as well. I do not think the vga blob is needed for anything other than a boot image but cannot confirm; I only run Linux. Seeing you already have issue issues with the booting with the VGA, you can try it would. Those scripts also require Docker.
I ended up flashing the stock bios again. Windows now boots, and everything works as it should, but mint still boots to a blank screen. If I put it to sleep (fn-f4) then wake it up, sometimes I get mint on my FHD screen and can log in.

I'm all out of ideas, maybe nitrocaster has some?

EDIT:

With the stock bios, the screen is blank after boot, but if I put it to sleep and then wake it up the screen works..... :roll:

kai
Freshman Member
Posts: 56
Joined: Sun Jul 18, 2004 11:11 am

Re: Upgrading X220/X230 to FHD 1080p

#1067 Post by kai » Wed Oct 10, 2018 2:28 am

kai wrote:
Sun Oct 07, 2018 11:02 am
I've finally installed my mod that I received quite a long time ago.

It was slightly tricky but it seems to be working well.

I'm having one small issue though and that is when I am using a dock (ultrabase 3 I think?), I'm seeing some random small glitching of the display. It's very minor and quite intermittent. When not plugged into the dock, the display is solid and working well.

Anyone else faced the same issue and know what it might be?

Thanks
To offer a little bit of closure on this, I happen to have two docks - one at home and one in the office. When I put it into the office one, while it does glitch it is much less apparent and much less frequent. In fact I barely notice it at all. I think I'll put it down to the dock at home doing something funny or maybe I'll look at cleaning the contacts underneath. The setups are pretty much identical with identical connections, etc.

Gnark
Posts: 3
Joined: Fri Jun 08, 2018 7:06 am
Location: Paris, France

Re: Upgrading X220/X230 to FHD 1080p

#1068 Post by Gnark » Sun Oct 14, 2018 4:13 pm

Привет Павел,

I have received the module last months ago (rev.5), I mounted the module with the help of a pro (too difficult with cheap tools to reach good temperature & senswire is a type of SMD ceramic capacitor 0603 : 1.6mm x 0.8 mm ... ).
After installation, I have check : the LCD screen was good. So before cut & remount everything, I managed the LVDS & eDP cable connection.
But nothing on new screen & ... after a remount, nothing on old LCD screen :eek:
Yes now, old LCD produce black screen definitively with battery or A/C.
Fortunately I have only one working display with the displayport>hdmi of my dock ultrabase3. But I'm thinking to buy an other laptop ... :oops:


To be honest :
  • I tried several times : I inserted wrongly the LVDS cable ... & I tried to pull horizontally on eDP cable routing but not pull up ...
  • Furthermore, I received an other LP125WF4 (SP) B1 display, but the vendor said it's the new & same model that LP125WF2(SP)(B4), & model is deprecated :/
  • Bios/EFI is unavalaible so I used powershell or hta by lenovo in order to check & force set display numerical etc. But still nothing
  • a friend of mine put too much solder on sense wire capacitor. This necessitated cleaning the sense wire capacitor, it had to have a hot shot or could be damaged, I don't know, but I have checked there are no solder bridge with adjacent capacitor
  • I thought about putting kapton between the module and the mainboard ..
Would you have some tips, please ... ? :bow: :oops:
  • why ???
  • How to test with my multimeter in order to find the problem ?
  • How else could I test the sens wire capacitor with my multimeter
  • Is it useful, possible and feasible to replace the sens wire capacitor ?
  • How to check if my stock old LCD is still alive ?
Thanks in advance ...
X230 i7

9R
Posts: 4
Joined: Tue Oct 16, 2018 4:40 am
Location: Munich, BY Germany

Re: Upgrading X220/X230 to FHD 1080p

#1069 Post by 9R » Tue Oct 16, 2018 5:41 am

Dynamicmetaflow wrote:
Sun Oct 07, 2018 11:31 am

Thanks for your config and support. I have not patched the kernel yet but I was able to apply the coreboot patch from https://review.coreboot.org/c/coreboot/+/28950

From what I was able to test, what's currently not working is:
- Brightness controls
- Suspend

If anyone has any suggestions of how to fix the issues above I would greatly appreciate it.
I have been using coreboot with the modified vbt for a couple weeks without any regressions. Brightness control (Fn+F8/F9) and suspend work as expected.
All parts of the boot process and desktop are displayed on the fhd panel and there is no lvds-phantom output.
I running an unpatched default kernel from arch (currently 14.18.14) and use the native libgfxinit in coreboot without binary blobs from the lenovo bios.

Here's the output of make defconfig from my coreboot for reference:

Code: Select all

CONFIG_USE_OPTION_TABLE=y
CONFIG_TIMESTAMPS_ON_CONSOLE=y
CONFIG_USE_BLOBS=y
CONFIG_VENDOR_LENOVO=y
CONFIG_CBFS_SIZE=0x400000
CONFIG_INTEL_GMA_VBT_FILE="src/mainboard/$(MAINBOARDDIR)/data.edp.vbt"
CONFIG_BOARD_LENOVO_X230=y
CONFIG_DRIVERS_PS2_KEYBOARD=y
CONFIG_PCIEXP_L1_SUB_STATE=y
CONFIG_PCIEXP_CLK_PM=y
CONFIG_SEABIOS_PS2_TIMEOUT=2000
CONFIG_H8_SUPPORT_BT_ON_WIFI=y
CONFIG_MAINBOARD_USE_LIBGFXINIT=y
CONFIG_GENERIC_LINEAR_FRAMEBUFFER=y
CONFIG_MRC_SETTINGS_PROTECT=y
CONFIG_DEFAULT_CONSOLE_LOGLEVEL_8=y
CONFIG_SEABIOS_MASTER=y
CONFIG_COREINFO_SECONDARY_PAYLOAD=y
CONFIG_MEMTEST_SECONDARY_PAYLOAD=y
CONFIG_NVRAMCUI_SECONDARY_PAYLOAD=y
CONFIG_TINT_SECONDARY_PAYLOAD=y

nitrocaster
Senior Member
Senior Member
Posts: 566
Joined: Fri Mar 04, 2016 8:38 am
Location: Moscow, Russia
Contact:

Re: Upgrading X220/X230 to FHD 1080p

#1070 Post by nitrocaster » Tue Oct 16, 2018 7:01 am

This is awesome. You folks did an amazing job.
Want to buy X220/X230 FHD mod kit? Read this before sending me a PM!
T25 | X230: i7-3520M | 16GB RAM | 512GB M.2 Micron M600 | LG LP125WF2-SPB4 FHD IPS | 9c Li-Ion | Win8.1 Pro 64

nitrocaster
Senior Member
Senior Member
Posts: 566
Joined: Fri Mar 04, 2016 8:38 am
Location: Moscow, Russia
Contact:

Re: Upgrading X220/X230 to FHD 1080p

#1071 Post by nitrocaster » Tue Oct 16, 2018 7:06 am

Gnark wrote:
Sun Oct 14, 2018 4:13 pm
Привет Павел,

I have received the module last months ago (rev.5), I mounted the module with the help of a pro (too difficult with cheap tools to reach good temperature & senswire is a type of SMD ceramic capacitor 0603 : 1.6mm x 0.8 mm ... ).
After installation, I have check : the LCD screen was good. So before cut & remount everything, I managed the LVDS & eDP cable connection.
But nothing on new screen & ... after a remount, nothing on old LCD screen :eek:
Yes now, old LCD produce black screen definitively with battery or A/C.
Fortunately I have only one working display with the displayport>hdmi of my dock ultrabase3. But I'm thinking to buy an other laptop ... :oops:


To be honest :
  • I tried several times : I inserted wrongly the LVDS cable ... & I tried to pull horizontally on eDP cable routing but not pull up ...
  • Furthermore, I received an other LP125WF4 (SP) B1 display, but the vendor said it's the new & same model that LP125WF2(SP)(B4), & model is deprecated :/
  • Bios/EFI is unavalaible so I used powershell or hta by lenovo in order to check & force set display numerical etc. But still nothing
  • a friend of mine put too much solder on sense wire capacitor. This necessitated cleaning the sense wire capacitor, it had to have a hot shot or could be damaged, I don't know, but I have checked there are no solder bridge with adjacent capacitor
  • I thought about putting kapton between the module and the mainboard ..
Would you have some tips, please ... ? :bow: :oops:
  • why ???
  • How to test with my multimeter in order to find the problem ?
  • How else could I test the sens wire capacitor with my multimeter
  • Is it useful, possible and feasible to replace the sens wire capacitor ?
  • How to check if my stock old LCD is still alive ?
Thanks in advance ...
Are you getting no image or no backlight? Those are two different issues.
Want to buy X220/X230 FHD mod kit? Read this before sending me a PM!
T25 | X230: i7-3520M | 16GB RAM | 512GB M.2 Micron M600 | LG LP125WF2-SPB4 FHD IPS | 9c Li-Ion | Win8.1 Pro 64

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 19512
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: Upgrading X220/X230 to FHD 1080p

#1072 Post by RealBlackStuff » Tue Oct 16, 2018 7:22 am

Gnark wrote:
Sun Oct 14, 2018 4:13 pm
  • How else could I test the sens wire capacitor with my multimeter
The sense wire is soldered to one side of capacitor C137, which goes to dock-connector DOCKB_DP3N.
C137 is SCD1U10V2KX-4GP
See page 38 from the X230 schematics.
If you lose/blow/destroy C137 and/or you do not use the dock, it is enough if you solder the sense wire to the lower (farthest away from dock) spot of where that C137 was.

Gnark
Posts: 3
Joined: Fri Jun 08, 2018 7:06 am
Location: Paris, France

Re: Upgrading X220/X230 to FHD 1080p

#1073 Post by Gnark » Tue Oct 16, 2018 7:40 am

nitrocaster wrote:
Tue Oct 16, 2018 7:06 am


Are you getting no image or no backlight? Those are two different issues.
Thanks, only no image, backlight near webcam is ok and light keyboard ok too
X230 i7

dwhacks
Posts: 9
Joined: Fri Oct 05, 2018 12:57 am
Location: Grand Forks, Canada

Re: Upgrading X220/X230 to FHD 1080p

#1074 Post by dwhacks » Tue Oct 16, 2018 10:52 am

9R wrote:
Tue Oct 16, 2018 5:41 am

I have been using coreboot with the modified vbt for a couple weeks without any regressions. Brightness control (Fn+F8/F9) and suspend work as expected.
All parts of the boot process and desktop are displayed on the fhd panel and there is no lvds-phantom output.
I running an unpatched default kernel from arch (currently 14.18.14) and use the native libgfxinit in coreboot without binary blobs from the lenovo bios.

Here's the output of make defconfig from my coreboot for reference:

Code: Select all

CONFIG_USE_OPTION_TABLE=y
CONFIG_TIMESTAMPS_ON_CONSOLE=y
CONFIG_USE_BLOBS=y
CONFIG_VENDOR_LENOVO=y
CONFIG_CBFS_SIZE=0x400000
CONFIG_INTEL_GMA_VBT_FILE="src/mainboard/$(MAINBOARDDIR)/data.edp.vbt"
CONFIG_BOARD_LENOVO_X230=y
CONFIG_DRIVERS_PS2_KEYBOARD=y
CONFIG_PCIEXP_L1_SUB_STATE=y
CONFIG_PCIEXP_CLK_PM=y
CONFIG_SEABIOS_PS2_TIMEOUT=2000
CONFIG_H8_SUPPORT_BT_ON_WIFI=y
CONFIG_MAINBOARD_USE_LIBGFXINIT=y
CONFIG_GENERIC_LINEAR_FRAMEBUFFER=y
CONFIG_MRC_SETTINGS_PROTECT=y
CONFIG_DEFAULT_CONSOLE_LOGLEVEL_8=y
CONFIG_SEABIOS_MASTER=y
CONFIG_COREINFO_SECONDARY_PAYLOAD=y
CONFIG_MEMTEST_SECONDARY_PAYLOAD=y
CONFIG_NVRAMCUI_SECONDARY_PAYLOAD=y
CONFIG_TINT_SECONDARY_PAYLOAD=y
Any chance someone could apply this to the x220 ? I have no idea hot to modify the VBT or I would try and copy it

1101
Posts: 1
Joined: Mon Nov 13, 2017 2:50 pm
Location: Moscow, Russia

Re: Upgrading X220/X230 to FHD 1080p

#1075 Post by 1101 » Tue Oct 16, 2018 2:42 pm

Got black screen on BIOS, cannot see any menus and Grub, but after boot - everything works fine.

Someone in this thread said that it's the problem with 10K resistor below "b" letter, looks like i don't have it either.

Image


Should i just bridge it?

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 19512
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: Upgrading X220/X230 to FHD 1080p

#1076 Post by RealBlackStuff » Tue Oct 16, 2018 3:17 pm

Not sure if that is SMD 0603 or 0402 size.
You might find one on another faulty motherboard.
Use a magnifier and some tweezers, a very fine-tipped soldering iron and some flux.

Dynamicmetaflow
Posts: 10
Joined: Wed Aug 29, 2018 6:55 pm
Location: Boston, MA

Re: Upgrading X220/X230 to FHD 1080p

#1077 Post by Dynamicmetaflow » Tue Oct 16, 2018 7:24 pm

9R wrote:
Tue Oct 16, 2018 5:41 am
Dynamicmetaflow wrote:
Sun Oct 07, 2018 11:31 am

Thanks for your config and support. I have not patched the kernel yet but I was able to apply the coreboot patch from https://review.coreboot.org/c/coreboot/+/28950

From what I was able to test, what's currently not working is:
- Brightness controls
- Suspend

If anyone has any suggestions of how to fix the issues above I would greatly appreciate it.
I have been using coreboot with the modified vbt for a couple weeks without any regressions. Brightness control (Fn+F8/F9) and suspend work as expected.
All parts of the boot process and desktop are displayed on the fhd panel and there is no lvds-phantom output.
I running an unpatched default kernel from arch (currently 14.18.14) and use the native libgfxinit in coreboot without binary blobs from the lenovo bios.

Here's the output of make defconfig from my coreboot for reference:

Code: Select all

CONFIG_USE_OPTION_TABLE=y
CONFIG_TIMESTAMPS_ON_CONSOLE=y
CONFIG_USE_BLOBS=y
CONFIG_VENDOR_LENOVO=y
CONFIG_CBFS_SIZE=0x400000
CONFIG_INTEL_GMA_VBT_FILE="src/mainboard/$(MAINBOARDDIR)/data.edp.vbt"
CONFIG_BOARD_LENOVO_X230=y
CONFIG_DRIVERS_PS2_KEYBOARD=y
CONFIG_PCIEXP_L1_SUB_STATE=y
CONFIG_PCIEXP_CLK_PM=y
CONFIG_SEABIOS_PS2_TIMEOUT=2000
CONFIG_H8_SUPPORT_BT_ON_WIFI=y
CONFIG_MAINBOARD_USE_LIBGFXINIT=y
CONFIG_GENERIC_LINEAR_FRAMEBUFFER=y
CONFIG_MRC_SETTINGS_PROTECT=y
CONFIG_DEFAULT_CONSOLE_LOGLEVEL_8=y
CONFIG_SEABIOS_MASTER=y
CONFIG_COREINFO_SECONDARY_PAYLOAD=y
CONFIG_MEMTEST_SECONDARY_PAYLOAD=y
CONFIG_NVRAMCUI_SECONDARY_PAYLOAD=y
CONFIG_TINT_SECONDARY_PAYLOAD=y
Thank you for your post and config! I'm glad to hear you got it working! Out of curiosity any problems with suspend and or using a dock (Lenovo Mini Dock Plus, Ultrabase docking station)?

I'm going to try again sometime this week and will report back.

thrilleratplay
Posts: 12
Joined: Wed Sep 20, 2017 8:03 am
Location: Albany, NY, USA

Re: Upgrading X220/X230 to FHD 1080p

#1078 Post by thrilleratplay » Fri Oct 19, 2018 1:47 pm

Warning to US screen purchasers:
Do not by from dvdsuper999 on ebay

I ordered a replacement LP125WF2-SPB4 screen and did not want to wait for it to be shipped from China. I received a LP125WF4-SPB1, which have the same mounts and a 30pin eDP connector but does not work with nitrocaster's board (I think it has to do with the LP125WF4-SPB1 not being dual channel eDP). I was told it was compatible, I just replayed with no it isn't.

Wanted to warn others. Order from Win0win.
Last edited by thrilleratplay on Fri Oct 19, 2018 2:08 pm, edited 1 time in total.

9R
Posts: 4
Joined: Tue Oct 16, 2018 4:40 am
Location: Munich, BY Germany

Re: Upgrading X220/X230 to FHD 1080p

#1079 Post by 9R » Fri Oct 19, 2018 1:57 pm

Dynamicmetaflow wrote:
Tue Oct 16, 2018 7:24 pm

Out of curiosity any problems with suspend and or using a dock (Lenovo Mini Dock Plus, Ultrabase docking station)?
Suspend works without any problems. I have not used any docks in a while but I can test with an Ultrabase3 next week.

Dynamicmetaflow
Posts: 10
Joined: Wed Aug 29, 2018 6:55 pm
Location: Boston, MA

Re: Upgrading X220/X230 to FHD 1080p

#1080 Post by Dynamicmetaflow » Sat Oct 20, 2018 2:34 pm

9R wrote:
Fri Oct 19, 2018 1:57 pm
Dynamicmetaflow wrote:
Tue Oct 16, 2018 7:24 pm

Out of curiosity any problems with suspend and or using a dock (Lenovo Mini Dock Plus, Ultrabase docking station)?
Suspend works without any problems. I have not used any docks in a while but I can test with an Ultrabase3 next week.
Thank you for the confirmation that suspend works! Would you or anyone else who has successfully flashed their X230 with Coreboot be willing to share their generated .rom file?

I've tried multiple different configurations and have not had a successful flash for the X230 where everything is functional.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X200/201/220 and X300/301 Series”

Who is online

Users browsing this forum: No registered users and 10 guests