Verifying VT-x (Intel virtualisation technology)

X200, X201, X220 (including equivalent tablet models) and X300, X301 series specific matters only.
Post Reply
Message
Author
maja_ldm
Posts: 2
Joined: Thu Jul 13, 2017 12:57 am
Location: Ferrara, Italy

Verifying VT-x (Intel virtualisation technology)

#1 Post by maja_ldm » Thu Jul 13, 2017 1:09 am

I have a X201 with the i5 M560 and I need to use the AVD emulator of Android Studio which requires VT-x virtualisation to be activated. I checked the BIOS and Intel TXT and Intel AMT are both disabled, virtualisation and VM-d are both enabled, but Android Studio keeps reporting that VT-x is not activated (as a general check I could launch a Virtual Box machine).

How can I check if VT-x is indeed enabled on my laptop?

RealBlackStuff
Admin
Admin
Posts: 18186
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA USA
Contact:

Re: Verifying VT-x (Intel virtualisation technology)

#2 Post by RealBlackStuff » Thu Jul 13, 2017 5:43 am

Welcome to the Forum.
Check in your BIOS/Security if you have a Virtualization option.
If not, you can't use VT-x.
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

jdrou
Senior Member
Senior Member
Posts: 600
Joined: Tue Feb 10, 2009 6:15 pm
Location: Madison Heights, MI

Re: Verifying VT-x (Intel virtualisation technology)

#3 Post by jdrou » Thu Jul 13, 2017 5:06 pm

If running Windows 8 Pro or later you may also need to disable Hyper-V.
Current Thinkpads:
X31, X40, X61T, X61, X201, X220 (i7 IPS), W520 (2720QM/2000M/FHD), T440p (i7-4800MQ/GF730GT/FHD)
Dells: Latitude C840, Precision M70, Precision M4400, M6400 (WUXGA), M6600, M6700
Daily driver: Dell XPS 13 w/Kaby Lake+Iris Pro+TB3

maja_ldm
Posts: 2
Joined: Thu Jul 13, 2017 12:57 am
Location: Ferrara, Italy

Re: Verifying VT-x (Intel virtualisation technology)

#4 Post by maja_ldm » Fri Jul 14, 2017 6:41 pm

RealBlackStuff wrote:
Thu Jul 13, 2017 5:43 am
Check in your BIOS/Security if you have a Virtualization option.
In the BIOS I have Virtualization and VT-d, both are enabled.
jdrou wrote:
Thu Jul 13, 2017 5:06 pm
If running Windows 8 Pro or later you may also need to disable Hyper-V.
I use Windows 10 Pro, Hyper-V is disabled.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X200/201/220 and X300/301 Series”

Who is online

Users browsing this forum: rkawakami and 8 guests