Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

Misssing X220 Tablet Mouse buttons

X200, X201, X220 (including equivalent tablet models) and X300, X301 series specific matters only.
Post Reply
Message
Author
X-Man
Posts: 48
Joined: Sat Jan 23, 2010 8:05 am
Location: London, UK

Misssing X220 Tablet Mouse buttons

#1 Post by X-Man » Sat Jan 06, 2018 5:05 pm

Have been suffering from intermittent BSODs so decided somewhat off the cuff to do a Win 10 refresh.

That problem now seems to have gone, but I am horrified to see that my mouse buttons have stopped working.

Further Lenovo appear to withdrawn Win 10 support since I last tinkered with the configuration and deleted all sorts of drivers!

Any ideas?

Many thanks!!
Active: X220 Tablet (i5-2520M, Multitouch) | T530 (i7-3720QM, 1920x1080)
Retired: 2x X31 (1.6/1.7 GHz) | T60p (Core Duo 2.2Ghz, 1600x1200 IPS) | 2x X61T (1.6/1.8GHz)

RealBlackStuff
Admin
Admin
Posts: 18661
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: Misssing X220 Tablet Mouse buttons

#2 Post by RealBlackStuff » Sun Jan 07, 2018 2:24 am

All here: https://pcsupport.lenovo.com/jp/en/prod ... /downloads
They may shortly be transferring (or started already) all the drivers etc. to the EOL portal: https://download.lenovo.com/eol/index.html
Wait a few days, then try there.
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Boardroom for Parts, Mods and Other Services.

X-Man
Posts: 48
Joined: Sat Jan 23, 2010 8:05 am
Location: London, UK

Re: Misssing X220 Tablet Mouse buttons

#3 Post by X-Man » Sun Jan 07, 2018 4:13 am

Thanks so much RBS.

In the meantime first of all the right button came back. Then the middle. . .

Then I popped the lid and reseated the ultranav ribbon that was last out when I reapplied thermal paste 9 months ago, and hey presto; everything working fine with the native Win 10 drivers!

Must have been what was causing the BSODs earlier, but strange that it wasn't working at all following the clean reinstall. Anyway that was somewhat needed so all good.

Many thanks!
Active: X220 Tablet (i5-2520M, Multitouch) | T530 (i7-3720QM, 1920x1080)
Retired: 2x X31 (1.6/1.7 GHz) | T60p (Core Duo 2.2Ghz, 1600x1200 IPS) | 2x X61T (1.6/1.8GHz)

X-Man
Posts: 48
Joined: Sat Jan 23, 2010 8:05 am
Location: London, UK

Re: Misssing X220 Tablet Mouse buttons

#4 Post by X-Man » Sun Jan 07, 2018 3:45 pm

So setting up the machine later today, the left mouse button has gone again.

I assume this must be hardware problem.

According to the service manual I need a 04W2188.

But an eBay text search reveals various FRUs that all look similar. Does anybody know if they are all interchangeable as long as they are for some flavour of X220?

Many thanks!
Active: X220 Tablet (i5-2520M, Multitouch) | T530 (i7-3720QM, 1920x1080)
Retired: 2x X31 (1.6/1.7 GHz) | T60p (Core Duo 2.2Ghz, 1600x1200 IPS) | 2x X61T (1.6/1.8GHz)

RealBlackStuff
Admin
Admin
Posts: 18661
Joined: Mon Sep 18, 2006 5:17 am
Location: Mt. Cobb, PA
Contact:

Re: Misssing X220 Tablet Mouse buttons

#5 Post by RealBlackStuff » Mon Jan 08, 2018 1:58 am

Wrong.
The mouse buttons are part of the keyboard, not of the palmrest.
Look for a new KB with UK-English layout, preferably made by NMB, FRU 45N2240

X-Man
Posts: 48
Joined: Sat Jan 23, 2010 8:05 am
Location: London, UK

Re: Misssing X220 Tablet Mouse buttons

#6 Post by X-Man » Mon Jan 08, 2018 2:58 am

RealBlackStuff wrote:
Mon Jan 08, 2018 1:58 am
Wrong.
The mouse buttons are part of the keyboard, not of the palmrest.
Doh!

The problem was, however, due to the palm rest.

I am an old school Toshiba user and strictly stick to the nipple and buttons.

However, something had been nagging me about the trackpad and I have intermittently been stabbing for button presses without any joy.

Whether I had pressed too hard or had failed to seat the whole thing properly last time out, it looks like the assembly had somehow stuck on a permanent down press, which must have somehow screwed up the click handling from the regular buttons.

Anyway it is now reseated properly with all the clicks working as intended for a net expenditiure of £/$ 0:-

Again thanks very much for all you help, RBS.
Active: X220 Tablet (i5-2520M, Multitouch) | T530 (i7-3720QM, 1920x1080)
Retired: 2x X31 (1.6/1.7 GHz) | T60p (Core Duo 2.2Ghz, 1600x1200 IPS) | 2x X61T (1.6/1.8GHz)

X-Man
Posts: 48
Joined: Sat Jan 23, 2010 8:05 am
Location: London, UK

Re: Misssing X220 Tablet Mouse buttons

#7 Post by X-Man » Mon Jan 08, 2018 3:31 am

And just to add a footnote the final result of this little exercise is that the machine is now lightning fast.

Whether that is because of the clean install of Win 10 or significantly fewer mouse click interrupts hitting the CPU I can not say, but I am delighted with the outcome!

Thanks again!
Active: X220 Tablet (i5-2520M, Multitouch) | T530 (i7-3720QM, 1920x1080)
Retired: 2x X31 (1.6/1.7 GHz) | T60p (Core Duo 2.2Ghz, 1600x1200 IPS) | 2x X61T (1.6/1.8GHz)

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X200/201/220 and X300/301 Series”

Who is online

Users browsing this forum: No registered users and 6 guests