Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

[SOLVED] X301 BIOS update won't boot

X200, X201, X220 (including equivalent tablet models) and X300, X301 series specific matters only.
Post Reply
Message
Author
PierU
Posts: 30
Joined: Sun Jan 20, 2019 5:28 pm
Location: Paris, France

[SOLVED] X301 BIOS update won't boot

#1 Post by PierU » Mon Jan 21, 2019 6:11 pm

Hi,

I'm trying to update the BIOS on a X301. I got the update file on the Lenovo here : https://support.lenovo.com/fr/fr/downloads/migr-70466

It's an ISO file that is said to be bootable. So I transfer it on a USB drive with the unix "dd" command (this usually works fine for Linux bootable ISO files) :
dd if=xxx.iso of=/dev/disk3
(disk3 is the USB drive on a Mac here)

But then it won't boot on the X301... What am I doing wrong ? Do I need to burn a CD ?

Thanks
Last edited by PierU on Tue Jan 22, 2019 4:24 pm, edited 1 time in total.
X60s - Intel x25 80GB SSD - Xubuntu 16.04LTS
X301 - Kingston 120GB mSATA SSD + 1.8" adapter - Xubuntu 18.04LTS

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20022
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Ireland
Contact:

Re: X301 BIOS update won't boot

#2 Post by RealBlackStuff » Mon Jan 21, 2019 9:57 pm

That dd command is plain copying, you need an iso-burning program, like ImgBurn.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!

PierU
Posts: 30
Joined: Sun Jan 20, 2019 5:28 pm
Location: Paris, France

Re: X301 BIOS update won't boot

#3 Post by PierU » Tue Jan 22, 2019 3:06 am

RealBlackStuff wrote:
Mon Jan 21, 2019 9:57 pm
That dd command is plain copying, you need an iso-burning program, like ImgBurn.
Maybe, but I did exactly the same 3 days ago with the bootable ISO image of xubuntu 18.04 (just "dd" to the USB drive), and it worked...
X60s - Intel x25 80GB SSD - Xubuntu 16.04LTS
X301 - Kingston 120GB mSATA SSD + 1.8" adapter - Xubuntu 18.04LTS

PierU
Posts: 30
Joined: Sun Jan 20, 2019 5:28 pm
Location: Paris, France

Re: X301 BIOS update won't boot

#4 Post by PierU » Tue Jan 22, 2019 3:20 am

This ISO image looks weird, actually : I've finally burnt it to a CD with an appropriate tool, I can mount the CD, and it appears to be empty... its size is reported to be 39Mo (like the ISO file) but it contains no file at all. It is the same story when I "dd" it to the USB drive (I can mount it and it is empty) or if I mount directly the ISO image...

Where can I find another place to download the up-to-date BIOS ?
X60s - Intel x25 80GB SSD - Xubuntu 16.04LTS
X301 - Kingston 120GB mSATA SSD + 1.8" adapter - Xubuntu 18.04LTS

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20022
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Ireland
Contact:

Re: X301 BIOS update won't boot

#5 Post by RealBlackStuff » Tue Jan 22, 2019 4:53 am

https://download.lenovo.com/eol/index.html
Select Laptops & Tablets/Thinkpad X Series/Thinkpad X301/BIOS update bootable CD (3.16)

PierU
Posts: 30
Joined: Sun Jan 20, 2019 5:28 pm
Location: Paris, France

Re: X301 BIOS update won't boot

#6 Post by PierU » Tue Jan 22, 2019 6:38 am

Thanks, will try this one this evening...

About "dd" : if the output of dd is the device itself (/dev/disk3) and not a file on the mounted file system of the drive, then it is supposed to be equivalent to burning the image.
X60s - Intel x25 80GB SSD - Xubuntu 16.04LTS
X301 - Kingston 120GB mSATA SSD + 1.8" adapter - Xubuntu 18.04LTS

as.nielo
Posts: 48
Joined: Sat Sep 30, 2017 1:46 pm
Location: EU

Re: X301 BIOS update won't boot

#7 Post by as.nielo » Tue Jan 22, 2019 7:40 am

you need to convert the image with el torito first. easier way is to burn downloaded image on cd and boot from it.


Sent from my iPad using Tapatalk

PierU
Posts: 30
Joined: Sun Jan 20, 2019 5:28 pm
Location: Paris, France

Re: X301 BIOS update won't boot

#8 Post by PierU » Tue Jan 22, 2019 8:35 am

as.nielo wrote:
Tue Jan 22, 2019 7:40 am
easier way is to burn downloaded image on cd and boot from it.
did that and it didn't work (see my post above : posting.php?mode=quote&f=43&p=829172#pr829163 )
X60s - Intel x25 80GB SSD - Xubuntu 16.04LTS
X301 - Kingston 120GB mSATA SSD + 1.8" adapter - Xubuntu 18.04LTS

PierU
Posts: 30
Joined: Sun Jan 20, 2019 5:28 pm
Location: Paris, France

Re: X301 BIOS update won't boot

#9 Post by PierU » Tue Jan 22, 2019 8:44 am

RealBlackStuff wrote:
Tue Jan 22, 2019 4:53 am
https://download.lenovo.com/eol/index.html
Select Laptops & Tablets/Thinkpad X Series/Thinkpad X301/BIOS update bootable CD (3.16)
Same issue : the downloaded image appear to be empty :-(
X60s - Intel x25 80GB SSD - Xubuntu 16.04LTS
X301 - Kingston 120GB mSATA SSD + 1.8" adapter - Xubuntu 18.04LTS

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20022
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Ireland
Contact:

Re: X301 BIOS update won't boot

#10 Post by RealBlackStuff » Tue Jan 22, 2019 9:19 am

The download is 6euj42uc.iso with size 38.252 KB
It is identical in size and content to the copy I downloaded in 2014.
I strongly suggest to find a Windows machine with ImgBurn and burn a CD.
Did you set BIOS to first boot from that USB-slot? Or press F12?
Maybe the X301 USB-port(s) is/are defect?

PierU
Posts: 30
Joined: Sun Jan 20, 2019 5:28 pm
Location: Paris, France

Re: X301 BIOS update won't boot

#11 Post by PierU » Tue Jan 22, 2019 9:40 am

RealBlackStuff wrote:
Tue Jan 22, 2019 9:19 am
The download is 6euj42uc.iso with size 38.252 KB
It is identical in size and content to the copy I downloaded in 2014.
I strongly suggest to find a Windows machine with ImgBurn and burn a CD.
Yes, the ISO file siez in indeed 38.2MB. But whatever the method used it looks empty, and I tried :
- mount the ISO file directly in W10 : the virtual drive looks empty
- mount the ISO file directly in macOS : the virtual drive looks empty
- "burn" a USB drive with "dd" : the create volume looks empty
- burn a CD using the built-in macOS utility : once mounted the CD looks empty

When I mean "empty" I really mean empty, it's not just that it doesn't boot... All of them are reported to be 38.2MB

I can try imgburn as well, but what is the reason why it would work better ?
Did you set BIOS to first boot from that USB-slot? Or press F12?
Maybe the X301 USB-port(s) is/are defect?
They are fine. 3 days ago I have booted on a USB drive (created with "dd") to install xubuntu, and yesterday I could boot on a FreeDos USB Drive (created with Rufus, to try flashing the SSD firmware).
X60s - Intel x25 80GB SSD - Xubuntu 16.04LTS
X301 - Kingston 120GB mSATA SSD + 1.8" adapter - Xubuntu 18.04LTS

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20022
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Ireland
Contact:

Re: X301 BIOS update won't boot

#12 Post by RealBlackStuff » Tue Jan 22, 2019 10:07 am

The point here is: looks deceive!
If you open the ISO with e.g. 7z, you find [BOOT] directory, doubleclick it to find Boot-Harddisk.img
Doubleclick that to find 0.fat with size 38 780 728.
ISO CDs normally only LOOK empty.
Maybe your CD drive is defective?

PierU
Posts: 30
Joined: Sun Jan 20, 2019 5:28 pm
Location: Paris, France

Re: X301 BIOS update won't boot

#13 Post by PierU » Tue Jan 22, 2019 11:43 am

OK, with 7zip I can ideed see that the ISO image is not empty, with the [BOOT] folder. Still, the fact is that neither a flash drive nor a burnt CD with this image will boot... Will try again this evening.

Usually the ISO images I use do not look empty. For instance the xubuntu ISO image mounted mounted in W10 :
https://i.imgur.com/s5FrEXu.png

So I guess that these are different kinds of ISO images...
X60s - Intel x25 80GB SSD - Xubuntu 16.04LTS
X301 - Kingston 120GB mSATA SSD + 1.8" adapter - Xubuntu 18.04LTS

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20022
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Ireland
Contact:

Re: X301 BIOS update won't boot

#14 Post by RealBlackStuff » Tue Jan 22, 2019 11:58 am

In BIOS is Security/BIOS-update/Flashing ENabled?

After this I give up.
But if interested, I'll sell you another X301 (2776-3CU) where everything works!

as.nielo
Posts: 48
Joined: Sat Sep 30, 2017 1:46 pm
Location: EU

Re: X301 BIOS update won't boot

#15 Post by as.nielo » Tue Jan 22, 2019 12:25 pm

Why don't you just try to boot from this "empty" disc?

PierU
Posts: 30
Joined: Sun Jan 20, 2019 5:28 pm
Location: Paris, France

Re: X301 BIOS update won't boot

#16 Post by PierU » Tue Jan 22, 2019 4:23 pm

Good news : after a new failed attempt with the USB drive, I could boot with the CD and update the firmware !

As my first attempt with the CD failed yesterday, I then tried to boot the same CD several times and it seems that there's a problem with either the CD or the CD drive, as it fails booting one out of 3 times... So : for some reason this image cannot boot on a USB drive, and my CD or CD drive is not fully working... But I could update the firmware, so problem solved !

Thanks !
X60s - Intel x25 80GB SSD - Xubuntu 16.04LTS
X301 - Kingston 120GB mSATA SSD + 1.8" adapter - Xubuntu 18.04LTS

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X200/201/220 and X300/301 Series”

Who is online

Users browsing this forum: No registered users and 9 guests