Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X220 issues with clean Win10 install

X200, X201, X220 (including equivalent tablet models) and X300, X301 series specific matters only.
Post Reply
Message
Author
StarGehzer
Freshman Member
Posts: 50
Joined: Sat Aug 22, 2009 9:00 pm
Location: Toronto Ontario Canada

X220 issues with clean Win10 install

#1 Post by StarGehzer » Fri Mar 08, 2019 4:13 pm

I've just installed a new ssd & installed Win10 onto it. This is my first experience with Windows 10. The install seems to have worked just fine.
But... I'm having some driver? issues.
From the pcsupport.lenovo.com site I installed & ran the auto update & now it says all drivers are installed.
I'm having 2 problems right now.
1st. I have no settings available for my trackpoint. I can't adjust the speed of the mouse &, more importantly, I can't make a center click of a link on a web page open a new tab. Are there special drivers for this or is the ability to 'setup' the trackpoint gone?
2nd. I'm having an issue with the fingerprint reader. I can use it to 'start' the computer, but then I have to use it a 2nd time to sign into windows. Can I make it so 1 fingerprint scan does both?

I've just begun working on this so I have no doubt I'll have other questions soon. Is there a posting somewhere that is a guide to windows 10 on a thinkpad designed for Win7 pro (an X220).
Thanks for any tips or pointers..
Over the years... 760XL, X31, X220, & a 2nd X220

GomJabbar
Moderator
Moderator
Posts: 9872
Joined: Tue Jun 07, 2005 6:57 am

Re: X220 issues with clean Win10 install

#2 Post by GomJabbar » Sat Mar 16, 2019 7:02 pm

Have you run Windows Update to see if Windows offers the drivers you need?
DKB

StarGehzer
Freshman Member
Posts: 50
Joined: Sat Aug 22, 2009 9:00 pm
Location: Toronto Ontario Canada

Re: X220 issues with clean Win10 install

#3 Post by StarGehzer » Sat Mar 16, 2019 11:25 pm

GomJabbar wrote:
Sat Mar 16, 2019 7:02 pm
Have you run Windows Update to see if Windows offers the drivers you need?
Thanks for looking.
Yes, I've used the Windows Update, rebooted, & repeated until it insisted I had all the updates.
I've also double checked the pcsupport.lenovo.com site & it also says everything is good.

Does nobody else running an X220 have the same issues? (i5 processor in my machine)
Does anyone with an X220 have the ability to center click to open web pages in a new tab? If so, what mouse driver are you using?
Over the years... 760XL, X31, X220, & a 2nd X220

RealBlackStuff
Admin Emeritus
Admin Emeritus
Posts: 20214
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire
Contact:

Re: X220 issues with clean Win10 install

#4 Post by RealBlackStuff » Sun Mar 17, 2019 5:25 am

Did you install this Synaptics driver? https://support.lenovo.com/us/en/downloads/ds103454
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.

StarGehzer
Freshman Member
Posts: 50
Joined: Sat Aug 22, 2009 9:00 pm
Location: Toronto Ontario Canada

Re: X220 issues with clean Win10 install

#5 Post by StarGehzer » Mon Mar 18, 2019 9:43 am

RealBlackStuff wrote:
Sun Mar 17, 2019 5:25 am
Did you install this Synaptics driver? https://support.lenovo.com/us/en/downloads/ds103454
Thanks for offering an idea.
Yes, this was the first driver I installed.
When this is installed the mouse properties have a setting where I can select 'scroll' or 'center click', but it doesn't make any difference, both scroll.
Image

I noticed that when I use the center click button the 'scroll' pointer on the screen is a rectangle. Image
When I was running Win7 the scroll pointer was a circle with an arrow inside & the 'center click open in new tab' worked well.
I think I read somewhere that one of them was the Microsoft driver & the other was the Lenovo driver.

Any thoughts? Suggestions?

EDIT:
I just plugged in a wired, optical mouse to see if it made any difference.
The wired mouse works properly (or, at least the way I want). Using it, if I click a link it opens in a new window, if I click where there is no link, it scrolls.
When it scrolls with the wired mouse, the icon is the Circle version, like this.. Image
How do I get this using the Trackpoint??
Over the years... 760XL, X31, X220, & a 2nd X220

dr_st
Moderator
Moderator
Posts: 8016
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: X220 issues with clean Win10 install

#6 Post by dr_st » Mon Mar 18, 2019 10:30 am

StarGehzer wrote:
Mon Mar 18, 2019 9:43 am
Yes, this was the first driver I installed.
When this is installed the mouse properties have a setting where I can select 'scroll' or 'center click', but it doesn't make any difference, both scroll.
Just to be super-certain (sorry for asking something so obvious), you did click 'apply' after selecting 'scrolling', right?

Because I just tested this behavior with the latest Synaptics driver that Win10 installed (19.3.4.219 from 31/Oct/2018) and I get correct behavior (both in the cursor appearance and the functionality).

Granted, it's not on an X220; I don't have an X220 running Win10 to check. There may be some weird incompatibility between the Win10 driver and the older trackpoint of X220...
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

StarGehzer
Freshman Member
Posts: 50
Joined: Sat Aug 22, 2009 9:00 pm
Location: Toronto Ontario Canada

Re: X220 issues with clean Win10 install

#7 Post by StarGehzer » Mon Mar 18, 2019 10:53 am

dr_st wrote:
Mon Mar 18, 2019 10:30 am
StarGehzer wrote:
Mon Mar 18, 2019 9:43 am
Yes, this was the first driver I installed.
When this is installed the mouse properties have a setting where I can select 'scroll' or 'center click', but it doesn't make any difference, both scroll.
Just to be super-certain (sorry for asking something so obvious), you did click 'apply' after selecting 'scrolling', right?
Thanks for thinking of that.
Yes, I did 'apply', & I also did a reboot.

I've also experimented with enabling & disabling the trackpad in the BIOS, but it made no difference.
Over the years... 760XL, X31, X220, & a 2nd X220

dr_st
Moderator
Moderator
Posts: 8016
Joined: Sat Oct 29, 2005 6:20 am
Location: Israel

Re: X220 issues with clean Win10 install

#8 Post by dr_st » Mon Mar 18, 2019 10:56 am

I would experiment with different versions of the Synaptics driver as well as uninstalling it completely. Middle button should be the default functionality when no vendor-specific driver is installed. At least I think it used to be.
Thinkpad 25 (20K7), X1 Carbon (20HQ), Yoga 14 (20FY), T430s (IPS FHD + Classic Keyboard), X220 4291-4BG
X61 7673-V2V, T60 2007-QPG, T42 2373-F7G, X32 (IPS Screen), A31p w/ Ultrabay Numpad, A21m 2628-GXU

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X200/201/220 and X300/301 Series”

Who is online

Users browsing this forum: No registered users and 33 guests