Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X220 Recovery Stuck

X200, X201, X220 (including equivalent tablet models) and X300, X301 series specific matters only.
Post Reply
Posts: 2
Joined: Thu Sep 26, 2019 5:51 am
Location: Whitmore Lake, Michigan

X220 Recovery Stuck

#1 Post by colin.frank5 » Thu Sep 26, 2019 1:57 pm

Hello, everyone.

Yesterday I got an X220, and I downloaded the recovery discs. I put them on USB drives.
The recovery process works normally until I confirm "Yes" to deleting all the data on the hard drive.
Then it says "Preparing the hard disk...", and then it stalls. There is no hard disk activity.
I let this run for about an hour before I stopped. I have tried multiple times, but with no success.
How can I fix this? Is there a BIOS setting I'm missing?

Posts: 34
Joined: Sun Oct 01, 2006 7:05 am

Re: X220 Recovery Stuck

#2 Post by 31336 » Thu Sep 26, 2019 3:25 pm

Just a guess but could it be that the Windows Setup (or some ThinkPad-specific partitioning tool) expects to find an MBR disk and you have a GPT one?

You should be able to press Shift-F10 to open the console to be able to investigate the problem further. Normally you could check the logs, in particular the file \Windows\Panther\setupact.log, but this might be somewhat too early for them to appear.

The only BIOS option that would make a big difference here is whether you are booting in UEFI mode or not.
701C (The Butterfly) · 360CSE · 370C · T20 · T42 · T60 · X31 · X220 ⨯ 2

Posts: 2
Joined: Thu Sep 26, 2019 5:51 am
Location: Whitmore Lake, Michigan

Re: X220 Recovery Stuck

#3 Post by colin.frank5 » Thu Sep 26, 2019 4:59 pm

Shift+F10 doesn't work, but the hard disk does say MBR. Couldn't find any logs.
Really confused on this one... :?

Admin Emeritus
Admin Emeritus
Posts: 21193
Joined: Mon Sep 18, 2006 5:17 am
Location: Dublin, Éire

Re: X220 Recovery Stuck

#4 Post by RealBlackStuff » Thu Sep 26, 2019 11:59 pm

Insert your USB drive (or is it stick?)
Check BIOS/Startup and check
Boot Priority sequence:
1 USB HDD (should show the USB drive)
2 ATAPI HDD0 (should show your HDD/SSD)
Rest whatever...
Now check and/or set
- UEFI/Legacy Boot to "Both"
- Boot priority to "Legacy"
- Boot Device List F12 to "Enabled"
Press F10 to save and restart installation.
Lovely day for a Guinness! (the Real Black Stuff). And pigs CAN fly!
Check out The Boardroom for Parts, Mods and Other Services.
Covid-19: Mask it or casket.

Posts: 5873
Joined: Thu Apr 29, 2004 6:49 am
Location: Toronto, Canada

Re: X220 Recovery Stuck

#5 Post by jdhurst » Fri Sep 27, 2019 7:14 am

I have an X230 here and it needs the Dock attached to reinstall the operating system. It may be the same for your X220.

Posts: 1
Joined: Sun Nov 17, 2019 10:40 pm
Location: user declined, email admin to appeal

Re: X220 Recovery Stuck

#6 Post by akesai » Sun Nov 17, 2019 10:43 pm

you have to use cdrom to load the product recovery (R.R)
boot from usb cant work,i've tried before

Post Reply
  • Similar Topics
    Last post

Return to “ThinkPad X200/201/220 and X300/301 Series”

Who is online

Users browsing this forum: No registered users and 15 guests