Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

T420 NVidia Drivers

T400/T410/T420 and T500/T510/T520 Series
Post Reply
Message
Author
NickSteel
Posts: 2
Joined: Fri Jun 18, 2021 6:06 pm
Location: Hattiesburg, MS

T420 NVidia Drivers

#1 Post by NickSteel » Fri Jun 18, 2021 7:01 pm

Have tried everything I can find, but none are compatible. Sometimes NVidia shows up as hidden in Device Manager, shows up with a warning symbol or doesn't show at all.
T420 w/ 1600x900 NVIDIA NVS 4200M
Windows 10 64 Pro


Help

https://imgur.com/GcHgsPW

https://imgur.com/tycvAT7

fissionpowered
Posts: 18
Joined: Fri Jun 18, 2021 9:12 pm
Location: Washington, DC

Re: T420 NVidia Drivers

#2 Post by fissionpowered » Fri Jun 18, 2021 11:42 pm

Have you tried the drivers from nvidia's website?

Current version appears to be 390 (392.65 to be exact, from https://www.nvidia.com/Download/driverR ... 4210/en-us). My T420 is running 392.37, which I just downloaded from nvidia's website a while ago.

If you're using this version, have you tried completely uninstalling the driver/software package and then reinstalling? DDU can be very handy for these sorts of issues: https://www.guru3d.com/files-details/di ... nload.html

NickSteel
Posts: 2
Joined: Fri Jun 18, 2021 6:06 pm
Location: Hattiesburg, MS

Re: T420 NVidia Drivers

#3 Post by NickSteel » Sat Jun 19, 2021 7:24 am

Have you tried the drivers from nvidia's website?

Current version appears to be 390 (392.65 to be exact, from https://www.nvidia.com/Download/driverR ... 4210/en-us). My T420 is running 392.37, which I just downloaded from nvidia's website a while ago.

If you're using this version, have you tried completely uninstalling the driver/software package and then reinstalling? DDU can be very handy for these sorts of issues: https://www.guru3d.com/files-details/di ... nload.html
Ran DDU and the driver you listed. It did install, but it still only appears as hidden. BIOS is set to NVIDIA Default. I may have a hardware problem?

https://imgur.com/s857HHE

fissionpowered
Posts: 18
Joined: Fri Jun 18, 2021 9:12 pm
Location: Washington, DC

Re: T420 NVidia Drivers

#4 Post by fissionpowered » Sat Jun 19, 2021 8:48 am

Yeah, that's very weird. It should appear operational so long as it's not completely disabled.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad T400/T410/T420 and T500/T510/T520 Series”

Who is online

Users browsing this forum: No registered users and 51 guests